467,864 Members | 1,900 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,864 developers. It's quick & easy.

enterprise library logging creates errors

JV
I added enterprise library logging to an application using a custom event
log. It works but it generates error entries in the Application log as
well. Apparently it's trying to create some sort of counters and failing.
I have so far found nothing to explain this.

Error examples:

Failed to create instances of performance counter 'Client: # of Logs
Written/Sec' - The requested Performance Counter is not a custom counter, it
has to be initialized as ReadOnly..

Failed to create instances of performance counter 'Distributor: # of Logs
Distributed/Sec' - The requested Performance Counter is not a custom
counter, it has to be initialized as ReadOnly..

Failed to create instances of performance counter '# of Exceptions
Handled/Sec' - The requested Performance Counter is not a custom counter, it
has to be initialized as ReadOnly..
Nov 17 '05 #1
  • viewed: 8149
Share:
4 Replies

Did you run the "Install Services" script from the Enterprise Library
folder on the Start Menu ?
In article <ee**************@TK2MSFTNGP09.phx.gbl>,
jo**********@goisc.com says...
I added enterprise library logging to an application using a custom event
log. It works but it generates error entries in the Application log as
well. Apparently it's trying to create some sort of counters and failing.
I have so far found nothing to explain this.

Error examples:

Failed to create instances of performance counter 'Client: # of Logs
Written/Sec' - The requested Performance Counter is not a custom counter, it
has to be initialized as ReadOnly..

Failed to create instances of performance counter 'Distributor: # of Logs
Distributed/Sec' - The requested Performance Counter is not a custom
counter, it has to be initialized as ReadOnly..

Failed to create instances of performance counter '# of Exceptions
Handled/Sec' - The requested Performance Counter is not a custom counter, it
has to be initialized as ReadOnly..


--
************************************************** **************
Tapio Kulmala

"Those are my principles. If you don't like them I have others."

- Groucho Marx
************************************************** **************
Nov 17 '05 #2
JV
To be honest, I don't recall. Is this something that would be necessary to
deploy on servers where the logging is being used?

"Tapio Kulmala" <ta******@hotmail.com> wrote >
Did you run the "Install Services" script from the Enterprise Library
folder on the Start Menu ?

Nov 17 '05 #3
Yes.

Don't ask why.

In article <uo**************@TK2MSFTNGP12.phx.gbl>,
jo**********@goisc.com says...
To be honest, I don't recall. Is this something that would be necessary to
deploy on servers where the logging is being used?

Nov 17 '05 #4
JV
Thanks for pointing this out. I'm annoyed that I got this far down the road
without the EL documentation clearly stating that this step would be needed
just to do simple logging to the Event Log. I could have written something
simpler and lower overhead.

I probably will yank the enterprise library after all, since running this
BAT file did not fix the problem we are having.
Nov 17 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by Jonathan Crawford | last post: by
reply views Thread by =?Utf-8?B?U2hyaWthbnQgTW9yZQ==?= | last post: by
1 post views Thread by arunairs | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.