By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,899 Members | 1,350 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,899 IT Pros & Developers. It's quick & easy.

Web Control Display problem

P: n/a
Hi,

I have just started developing web application using C#/ASP.Net and I am
have a
problem.

I have generated a web form (using .NET 2003) with various buttons, labels,
drop-downs etc ( just to see what they would look like on screen) but when I
run it in Explorer the various controls are not where the are in the design
form.

Explorer has all the current updates and everything is running under Windows
2K.

Has anyone come across this problem or know what I am doing wrong?
Best Regards

Gary Coutts
Nov 16 '05 #1
Share this Question
Share on Google+
11 Replies


P: n/a
I do not think ASP.NET is registered with IIS server, probably because you
installed
IIS after .NET framework?
Try running this from the command line(Start->Run->cmd):
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_regiis.exe -i

--
Regards,
Dennis JD Myrén
Oslo Kodebureau
"Gary Coutts" <ga****@btopenworld.com> wrote in message
news:d0**********@titan.btinternet.com...
Hi,

I have just started developing web application using C#/ASP.Net and I am
have a
problem.

I have generated a web form (using .NET 2003) with various buttons,
labels,
drop-downs etc ( just to see what they would look like on screen) but when
I
run it in Explorer the various controls are not where the are in the
design
form.

Explorer has all the current updates and everything is running under
Windows
2K.

Has anyone come across this problem or know what I am doing wrong?
Best Regards

Gary Coutts

Nov 16 '05 #2

P: n/a
Gary,

You have sent this message yesterday to the newsgroup general.

After some questions from Dennis you have showed the page you where using.

However, in that was only one button, while you where talking in your
question about more controls.

Where was that button placed when you was running it and where had you
expected it?

Cor
Nov 16 '05 #3

P: n/a
Cor,

It was me who asked Gary to create this page with one button, because we
needed no more than
that to demonstrate the problem.

--
Regards,
Dennis JD Myrén
Oslo Kodebureau
"Cor Ligthert" <no************@planet.nl> wrote in message
news:ec****************@TK2MSFTNGP12.phx.gbl...
Gary,

You have sent this message yesterday to the newsgroup general.

After some questions from Dennis you have showed the page you where using.

However, in that was only one button, while you where talking in your
question about more controls.

Where was that button placed when you was running it and where had you
expected it?

Cor

Nov 16 '05 #4

P: n/a
Dennis,

I checked it and saw that I misunderstood that part, however Gary did not
tell if that page had the same effects, otherwise we could have done that
ourselfs as well (You did not ask it, however that is for me obvious).

Sorry for my misstake, however the problem stays the same.

Cor
Nov 16 '05 #5

P: n/a
Cor,

The HTML source indicates that this page had same effect, because the server
tag is left unprocessed.
Here is a few people who also have had this problem(scroll down):
http://www.experts-exchange.com/Web/..._20835609.html

I think that this is the solution.

--
Regards,
Dennis JD Myrén
Oslo Kodebureau
"Cor Ligthert" <no************@planet.nl> wrote in message
news:uY***************@TK2MSFTNGP15.phx.gbl...
Dennis,

I checked it and saw that I misunderstood that part, however Gary did not
tell if that page had the same effects, otherwise we could have done that
ourselfs as well (You did not ask it, however that is for me obvious).

Sorry for my misstake, however the problem stays the same.

Cor

Nov 16 '05 #6

P: n/a
Cor/Dennis,

I have noticed that fonts are bigger, for labels and radio button text,
when displayed using Explorer than when displayed in the .NET design view.

Normal buttons seem to be uneffected.

Gary

"Cor Ligthert" <no************@planet.nl> wrote in message
news:ec****************@TK2MSFTNGP12.phx.gbl...
Gary,

You have sent this message yesterday to the newsgroup general.

After some questions from Dennis you have showed the page you where using.

However, in that was only one button, while you where talking in your
question about more controls.

Where was that button placed when you was running it and where had you
expected it?

Cor

Nov 16 '05 #7

P: n/a
Gary,
I have noticed that fonts are bigger, for labels and radio button text,
when displayed using Explorer than when displayed in the .NET design view.


That can be just a setting of IE.
Every user can set his own preferences in IE.
The controls are in a way all normal HTML controls with some additiion.

What you can do is when you have showed it in IE do a right click and than
see what code is generated with "see sourcecode", than it explains maybe
something more for you.

Cor
Nov 16 '05 #8

P: n/a
Gary,

That is just a browser preference setting.
Use View-Text Size(present in any browser) to adjust the text size to meet
your preferences.

Did you try the
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_regiis.exe -i

You should really read this(scroll down)
http://www.experts-exchange.com/Web/..._20835609.html

--
Regards,
Dennis JD Myrén
Oslo Kodebureau
"Gary Coutts" <ga****@btopenworld.com> wrote in message
news:d0**********@hercules.btinternet.com...
Cor/Dennis,

I have noticed that fonts are bigger, for labels and radio button text,
when displayed using Explorer than when displayed in the .NET design view.

Normal buttons seem to be uneffected.

Gary

"Cor Ligthert" <no************@planet.nl> wrote in message
news:ec****************@TK2MSFTNGP12.phx.gbl...
Gary,

You have sent this message yesterday to the newsgroup general.

After some questions from Dennis you have showed the page you where
using.

However, in that was only one button, while you where talking in your
question about more controls.

Where was that button placed when you was running it and where had you
expected it?

Cor


Nov 16 '05 #9

P: n/a
Cor

I reset Explorer to Factory Defaults when I first had this problem and the
problem still exits.

Cheers

Gary

"Cor Ligthert" <no************@planet.nl> wrote in message
news:%2******************@TK2MSFTNGP14.phx.gbl...
Gary,
I have noticed that fonts are bigger, for labels and radio button text,
when displayed using Explorer than when displayed in the .NET design
view.
That can be just a setting of IE.
Every user can set his own preferences in IE.
The controls are in a way all normal HTML controls with some additiion.

What you can do is when you have showed it in IE do a right click and than
see what code is generated with "see sourcecode", than it explains maybe
something more for you.

Cor

Nov 16 '05 #10

P: n/a
Gary,

Why do you have this problem and others not. Did you take that source from
your browser, had a look for it and showed it than again in your browser?

However you said the button had not the problem, did you tried a new page,
set a label on it, with text and tried what was the result.

(Maybe it is something in the standard CSV file).

Cor
Nov 16 '05 #11

P: n/a
Hi Dennis/Cor,

I did try it.

"C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspn et_regiis.exe -i"

I used the View-Text Size and set the text size to the same as the size in
design mode and it all displays correctly. I assumed that the font size
would be set to the size set in design mode not the one set by Explorer. Is
there away to protect against this, as if a user sets the text size to a
different value it will alter how the page will be displayed.

Thanks for all your help.

Cheers

Gary


"Dennis Myrén" <de****@oslokb.no> wrote in message
news:uB****************@tk2msftngp13.phx.gbl...
Gary,

That is just a browser preference setting.
Use View-Text Size(present in any browser) to adjust the text size to meet
your preferences.

Did you try the
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspne t_regiis.exe -i

You should really read this(scroll down)
http://www.experts-exchange.com/Web/..._20835609.html

--
Regards,
Dennis JD Myrén
Oslo Kodebureau
"Gary Coutts" <ga****@btopenworld.com> wrote in message
news:d0**********@hercules.btinternet.com...
Cor/Dennis,

I have noticed that fonts are bigger, for labels and radio button text,
when displayed using Explorer than when displayed in the .NET design view.
Normal buttons seem to be uneffected.

Gary

"Cor Ligthert" <no************@planet.nl> wrote in message
news:ec****************@TK2MSFTNGP12.phx.gbl...
Gary,

You have sent this message yesterday to the newsgroup general.

After some questions from Dennis you have showed the page you where
using.

However, in that was only one button, while you where talking in your
question about more controls.

Where was that button placed when you was running it and where had you
expected it?

Cor



Nov 16 '05 #12

This discussion thread is closed

Replies have been disabled for this discussion.