By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,670 Members | 1,563 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,670 IT Pros & Developers. It's quick & easy.

Install C# Explorer Band

P: n/a
Hi,

I actually sent this to microsoft.public.dotnet.general first, but decided
there may be people here that may know better (this list certainly sees more
traffic). Apologies to those that may receive this twice.

I have a project that is both an explorer band and a BHO. I'm using WISE to
take a snapshot of the system after I do a "regasm" followed by a "regasm
/codebase". Running this on a system gets it all set up, but unfortunately,
the installer (which needs to work system-wide, so anything in %APPDATA% and
HKCU are ignored) doesn't seem to set things up properly when I run on a
different system. The BHO works fine, but the explorer band part doesn't
register correctly. Running "regasm" and then "regasm /codebase" on the new
system after the install makes it work.

It seems to me that something is being installed for the local user that I
would rather install globally. There is no entry for .NET in Documents and
Settings\All Users, so I'm not sure where to put things. I had tried using
gacutil, but that seems to break the system (the explorer band comes up
blank -- looks like it disposes itself immediately).

Any help would be greatly appreciated.

Thanks,
Kevin

Nov 16 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.