By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,424 Members | 1,351 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,424 IT Pros & Developers. It's quick & easy.

C# compiler on the command line?

P: n/a
I just installed the SDK, but when I typed csc /help on the command line
(from the C: directory), it said 'csc' wasn't a recognized command. Why
didn't that work? Do I need to be in a different directory?
Nov 16 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
"John Salerno" wrote:
I just installed the SDK, but when I typed csc /help on the command line
(from the C: directory), it said 'csc' wasn't a recognized command. Why
didn't that work? Do I need to be in a different directory?


Command prompt uses the PATH environment variable to locate programs. Add
the directory containing the compiler to you path and you should be fine. On
my machine, the compiler is here:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322
Nov 16 '05 #2

P: n/a
MarkT [developmentor] wrote:
"John Salerno" wrote:
I just installed the SDK, but when I typed csc /help on the command line
(from the C: directory), it said 'csc' wasn't a recognized command. Why
didn't that work? Do I need to be in a different directory?

Command prompt uses the PATH environment variable to locate programs. Add
the directory containing the compiler to you path and you should be fine. On
my machine, the compiler is here:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322


Thanks. I guess I need to do a little more reading up on the command
line first.
Nov 16 '05 #3

P: n/a
you have to either type the full path where you installed the sdk in or you
have to add the path to your sdk to your PATH environment variable.

"John Salerno" <jo******@NOSPAMgmail.com> schrieb im Newsbeitrag
news:q5********************@rcn.net...
I just installed the SDK, but when I typed csc /help on the command line
(from the C: directory), it said 'csc' wasn't a recognized command. Why
didn't that work? Do I need to be in a different directory?

Nov 16 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.