By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,948 Members | 1,570 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,948 IT Pros & Developers. It's quick & easy.

Alcatel - TAPI - C# Driver hangs

P: n/a

Hello,

I am days into this problem and I cant make heads or tails of it.

Please post suggestions, I dont care how crazy they sound.

Scenario:
I have a TAPI C# application. (TAPI 3.0)

Driver is an Alcatel TAPI Service Provider v. 5.0.46.003 with an Alcatel
PBX unit.

The application will never initalize unless I run the Pimphony application
FIRST (which ships with the application)

If I try to initalize the appplication without the Pimphony application
started, it will never initalize. If I then try to start Pimphony, it will
never start. Only when I re-boot will Pimphony start again.

Even if you dont use the Alcatel brand and have encountered a similar
problem, please let me know..

I cant understand why this just wont work. Please help.
Nov 16 '05 #1
Share this Question
Share on Google+
11 Replies


P: n/a
Well, I'd suggest getting a copy of the MS TAPI Browser and testing to
see if it can open the line(s) involved. If it fails then you know it
is something funky on the Alcatel side.

I'm not really following what the role of "Pimphony" is...

Also, is the application yours? If so, are you opening the lines with
OWNER as well as MONITOR privileges?
--
Grant Schenck
Grant Schenck Software
sc******@optonline.net
http://grantschenck.tripod.com

"BizTalk Architect" <bi***************@gmail.com> wrote in message
news:41***********************@diablo.nl.easynet.n et...

Hello,

I am days into this problem and I cant make heads or tails of it.

Please post suggestions, I dont care how crazy they sound.

Scenario:
I have a TAPI C# application. (TAPI 3.0)

Driver is an Alcatel TAPI Service Provider v. 5.0.46.003 with an Alcatel PBX unit.

The application will never initalize unless I run the Pimphony application FIRST (which ships with the application)

If I try to initalize the appplication without the Pimphony application started, it will never initalize. If I then try to start Pimphony, it will never start. Only when I re-boot will Pimphony start again.

Even if you dont use the Alcatel brand and have encountered a similar problem, please let me know..

I cant understand why this just wont work. Please help.

Nov 16 '05 #2

P: n/a

"Grant Schenck" <sc******@optonline.net> wrote in message
news:Ob**************@TK2MSFTNGP09.phx.gbl...
Well, I'd suggest getting a copy of the MS TAPI Browser and testing to
see if it can open the line(s) involved. If it fails then you know it
is something funky on the Alcatel side.

I'm not really following what the role of "Pimphony" is...

Also, is the application yours? If so, are you opening the lines with
OWNER as well as MONITOR privileges?
--
Grant Schenck
Grant Schenck Software
sc******@optonline.net
http://grantschenck.tripod.com

"BizTalk Architect" <bi***************@gmail.com> wrote in message
news:41***********************@diablo.nl.easynet.n et...

Hello,

I am days into this problem and I cant make heads or tails of it.

Please post suggestions, I dont care how crazy they sound.

Scenario:
I have a TAPI C# application. (TAPI 3.0)

Driver is an Alcatel TAPI Service Provider v. 5.0.46.003 with an

Alcatel
PBX unit.

The application will never initalize unless I run the Pimphony

application
FIRST (which ships with the application)

If I try to initalize the appplication without the Pimphony

application
started, it will never initalize. If I then try to start Pimphony,

it will
never start. Only when I re-boot will Pimphony start again.

Even if you dont use the Alcatel brand and have encountered a

similar
problem, please let me know..

I cant understand why this just wont work. Please help.



Grant,

I already have the TAPI browser, which works correctly. I didnt mention it
so as not to add any
more complexity to the scenario. Basically the same is true for the TAPI
Browser as for "Pimphony". Pimphony is a little client app that came with
the PBX. I lets you make calls and answer them, et al from a pc across the
network. It sort of seems like these apps are able to get TAPI going, but
not C#....
Nov 16 '05 #3

P: n/a
"BizTalk Architect" <bi***************@gmail.com> schrieb im Newsbeitrag
news:41***********************@diablo.nl.easynet.n et...
I have a TAPI C# application. (TAPI 3.0)

Driver is an Alcatel TAPI Service Provider v. 5.0.46.003 with an Alcatel
PBX unit.

The application will never initalize unless I run the Pimphony application
FIRST (which ships with the application)

If I try to initalize the appplication without the Pimphony application
started, it will never initalize. If I then try to start Pimphony, it will
never start. Only when I re-boot will Pimphony start again.

Even if you dont use the Alcatel brand and have encountered a similar
problem, please let me know..


What do you mean exactly by "it will never initalize"?
What HRESULT do you get from ITTAPI::Initialize()?
Please post the relevant code for review.

Regarding TAPI and .NET see KB article "841712 - Telephony Application
Programming Interface (TAPI) functionality is not supported from managed code"
See my TAPI and TSPI FAQ:

Q: Are there any KB articles on TAPI available ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Are_ there_7

Q: Are there any .NET wrappers for TAPI2 available ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Are_ there_4

--
Best Regards
Andreas Marschall
Microsoft MVP for TAPI / Windows SDK
TAPI / TSP Developer and Tester
http://www.I-B-A-M.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm
* Please post all messages and replies to the newsgroup so all may
* benefit from the discussion. Private mail is usually not replied to.
* This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 16 '05 #4

P: n/a

"Andreas Marschall [MVP TAPI]" <An***************@I-B-A-M.de> wrote in
message news:eO**************@TK2MSFTNGP09.phx.gbl...
"BizTalk Architect" <bi***************@gmail.com> schrieb im Newsbeitrag
news:41***********************@diablo.nl.easynet.n et...
I have a TAPI C# application. (TAPI 3.0)

Driver is an Alcatel TAPI Service Provider v. 5.0.46.003 with an Alcatel
PBX unit.

The application will never initalize unless I run the Pimphony
application
FIRST (which ships with the application)

If I try to initalize the appplication without the Pimphony application
started, it will never initalize. If I then try to start Pimphony, it
will
never start. Only when I re-boot will Pimphony start again.

Even if you dont use the Alcatel brand and have encountered a similar
problem, please let me know..


What do you mean exactly by "it will never initalize"?
What HRESULT do you get from ITTAPI::Initialize()?
Please post the relevant code for review.

Regarding TAPI and .NET see KB article "841712 - Telephony Application
Programming Interface (TAPI) functionality is not supported from managed
code"
See my TAPI and TSPI FAQ:

Q: Are there any KB articles on TAPI available ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Are_ there_7

Q: Are there any .NET wrappers for TAPI2 available ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Are_ there_4

--
Best Regards
Andreas Marschall
Microsoft MVP for TAPI / Windows SDK
TAPI / TSP Developer and Tester
http://www.I-B-A-M.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm
* Please post all messages and replies to the newsgroup so all may
* benefit from the discussion. Private mail is usually not replied to.
* This posting is provided "AS IS" with no warranties, and confers no
rights.

Thanks for the reply.

After some further investigation, I have determined the code is stopping
when "RegisterCallNotifications" talkes place.
// connect the event to the handler on the object and store the token
received

gCallNotificationToken =
parentObject.gTapi.RegisterCallNotifications(gAddr ess, true, true,
objMediaSupport.MediaTypes, 0);
//gCallNotificationToken =
parentObject.gTapi.RegisterCallNotifications(gAddr ess, true, false,
objMediaSupport.MediaTypes, 0);

I tried setting fOwner to false and it had no effect....

Any ideas?

Thanks again....
Nov 16 '05 #5

P: n/a
"BizTalk Architect" <bi***************@gmail.com> schrieb im Newsbeitrag
news:41***********************@diablo.nl.easynet.n et...
After some further investigation, I have determined the code is stopping
when "RegisterCallNotifications" talkes place.
// connect the event to the handler on the object and store the token
received

gCallNotificationToken =
parentObject.gTapi.RegisterCallNotifications(gAddr ess, true, true,
objMediaSupport.MediaTypes, 0);
//gCallNotificationToken =
parentObject.gTapi.RegisterCallNotifications(gAddr ess, true, false,
objMediaSupport.MediaTypes, 0);

I tried setting fOwner to false and it had no effect....


What MediaTypes are you using?
What about providing a lCallbackInstance?
From MSDN: "Callback instance to be used by the TAPI 3 DLL. Can be the
gulAdvise value returned by IConnectionPoint::Advise during registration of
the ITTAPIEventNotification outgoing interface."

Can you reproduce this with TAPI Browser TB3x ?
If so, please post a TB3x log.
See my TAPI and TSPI FAQ:

Q: Where can I download TAPI Browser ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Wher e_can

Q: Is there a user guide available for TAPI Browser TB3x ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Is_t here_2

--
Best Regards
Andreas Marschall
Microsoft MVP for TAPI / Windows SDK
TAPI / TSP Developer and Tester
http://www.I-B-A-M.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm
* Please post all messages and replies to the newsgroup so all may
* benefit from the discussion. Private mail is usually not replied to.
* This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 16 '05 #6

P: n/a

"Andreas Marschall [MVP TAPI]" <An***************@I-B-A-M.de> wrote in
message news:uF**************@TK2MSFTNGP12.phx.gbl...
"BizTalk Architect" <bi***************@gmail.com> schrieb im Newsbeitrag
news:41***********************@diablo.nl.easynet.n et...
After some further investigation, I have determined the code is stopping
when "RegisterCallNotifications" talkes place.
// connect the event to the handler on the object and store the token
received

gCallNotificationToken =
parentObject.gTapi.RegisterCallNotifications(gAddr ess, true, true,
objMediaSupport.MediaTypes, 0);
//gCallNotificationToken =
parentObject.gTapi.RegisterCallNotifications(gAddr ess, true, false,
objMediaSupport.MediaTypes, 0);

I tried setting fOwner to false and it had no effect....


What MediaTypes are you using?
What about providing a lCallbackInstance?
From MSDN: "Callback instance to be used by the TAPI 3 DLL. Can be the
gulAdvise value returned by IConnectionPoint::Advise during registration
of
the ITTAPIEventNotification outgoing interface."

Can you reproduce this with TAPI Browser TB3x ?
If so, please post a TB3x log.
See my TAPI and TSPI FAQ:

Q: Where can I download TAPI Browser ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Wher e_can

Q: Is there a user guide available for TAPI Browser TB3x ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Is_t here_2

--
Best Regards
Andreas Marschall
Microsoft MVP for TAPI / Windows SDK
TAPI / TSP Developer and Tester
http://www.I-B-A-M.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm
* Please post all messages and replies to the newsgroup so all may
* benefit from the discussion. Private mail is usually not replied to.
* This posting is provided "AS IS" with no warranties, and confers no
rights.


Hello again, and thank you.

Media type is TAPIMEDIATYPE_AUDIO

No I cannot reproduce this behavior on the Tapi browser. It works normally.

I tried an lCallbackInstance = 1 which had no effect -- is there another
value I can place here? I read the MS page you sent but I cant determine
whether I need those values or not.


Nov 16 '05 #7

P: n/a

"Andreas Marschall [MVP TAPI]" <An***************@I-B-A-M.de> wrote in
message news:uF**************@TK2MSFTNGP12.phx.gbl...
"BizTalk Architect" <bi***************@gmail.com> schrieb im Newsbeitrag
news:41***********************@diablo.nl.easynet.n et...
After some further investigation, I have determined the code is stopping
when "RegisterCallNotifications" talkes place.
// connect the event to the handler on the object and store the token
received

gCallNotificationToken =
parentObject.gTapi.RegisterCallNotifications(gAddr ess, true, true,
objMediaSupport.MediaTypes, 0);
//gCallNotificationToken =
parentObject.gTapi.RegisterCallNotifications(gAddr ess, true, false,
objMediaSupport.MediaTypes, 0);

I tried setting fOwner to false and it had no effect....


What MediaTypes are you using?
What about providing a lCallbackInstance?
From MSDN: "Callback instance to be used by the TAPI 3 DLL. Can be the
gulAdvise value returned by IConnectionPoint::Advise during registration
of
the ITTAPIEventNotification outgoing interface."

Can you reproduce this with TAPI Browser TB3x ?
If so, please post a TB3x log.
See my TAPI and TSPI FAQ:

Q: Where can I download TAPI Browser ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Wher e_can

Q: Is there a user guide available for TAPI Browser TB3x ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Is_t here_2

--
Best Regards
Andreas Marschall
Microsoft MVP for TAPI / Windows SDK
TAPI / TSP Developer and Tester
http://www.I-B-A-M.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm
* Please post all messages and replies to the newsgroup so all may
* benefit from the discussion. Private mail is usually not replied to.
* This posting is provided "AS IS" with no warranties, and confers no
rights.

Well, now the confusion grows....

What has worked in the past is no working....

Here is the log from the TAPI Browser:
ITTAPI_6.Initialize returned hr = 0x00000000
ITTAPI_6.get_Addresses returned hr = 0x00000000

VARIANT* pVariant = ITCollection2_3

ITCollection2_3.get_Item

long Index : 8 (0x00000008)

returned hr = 0x00000000

VARIANT* pVariant = ITAddress2_3

ITTAPI_6.RegisterCallNotifications

ITAddress* pAddress : ITAddress2_3

VARIANT_BOOL fMonitor : 0

VARIANT_BOOL fOwner : 1

long lMediaTypes : 8 (0x00000008)

long lCallbackInstance : 0 (0x00000000)

returned hr = 0x8000ffff

E_UNEXPECTED ($8000FFFF) Catastrophic failure

source (null) description (null)

ITTAPI_6.RegisterCallNotifications

ITAddress* pAddress : ITAddress2_3

VARIANT_BOOL fMonitor : 0

VARIANT_BOOL fOwner : 1

long lMediaTypes : 8 (0x00000008)

long lCallbackInstance : 1 (0x00000001)

returned hr = 0x8000ffff

E_UNEXPECTED ($8000FFFF) Catastrophic failure

source (null) description (null)

ITTAPI_6.put_EventFilter

long plFilterMask : 30 (0x0000001e)

returned hr = 0x00000000

ITTAPI_6.RegisterCallNotifications

ITAddress* pAddress : ITAddress2_3

VARIANT_BOOL fMonitor : 0

VARIANT_BOOL fOwner : 1

long lMediaTypes : 8 (0x00000008)

long lCallbackInstance : 0 (0x00000000)

returned hr = 0x8000ffff

E_UNEXPECTED ($8000FFFF) Catastrophic failure

source (null) description (null)

Nov 16 '05 #8

P: n/a
"BizTalk Architect" <bi***************@gmail.com> schrieb im Newsbeitrag
news:41***********************@diablo.nl.easynet.n et...
Well, now the confusion grows....
What has worked in the past is no working....
Here is the log from the TAPI Browser:

ITTAPI_6.RegisterCallNotifications
ITAddress* pAddress : ITAddress2_3
VARIANT_BOOL fMonitor : 0
VARIANT_BOOL fOwner : 1
long lMediaTypes : 8 (0x00000008)
long lCallbackInstance : 0 (0x00000000)

returned hr = 0x8000ffff
E_UNEXPECTED ($8000FFFF) Catastrophic failure
source (null) description (null)


What happens if you use fMonitor = true ?
What happens if you use lCallbackInstance retrieved by ::Advise() from
ITTAPI_6 ?
See my TAPI and TSPI FAQ:
Q: Is there a user guide available for TAPI Browser TB3x ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Is_t here_2

--
Best Regards
Andreas Marschall
Microsoft MVP for TAPI / Windows SDK
TAPI / TSP Developer and Tester
http://www.I-B-A-M.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm
* Please post all messages and replies to the newsgroup so all may
* benefit from the discussion. Private mail is usually not replied to.
* This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 16 '05 #9

P: n/a

What happens if you use fMonitor = true ?
Same thing happens, it hangs forever trying to create the call notifications

What happens if you use lCallbackInstance retrieved by ::Advise() from
ITTAPI_6 ?


I am not sure what you mean by "::Advise() " or how to impliment it.

Can you explain this a bit?

Thank you !

Isaac Ferreira
Nov 16 '05 #10

P: n/a
"BizTalk Architect" <bi***************@gmail.com> wrote in message
news:41***********************@diablo.nl.easynet.n et...
What happens if you use lCallbackInstance retrieved by ::Advise() from
ITTAPI_6 ?


I am not sure what you mean by "::Advise() " or how to impliment it.


Isaac,
as I already suggested:
See my TAPI and TSPI FAQ:
Q: Is there a user guide available for TAPI Browser TB3x ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Is_t here_2

--
Best Regards
Andreas Marschall
Microsoft MVP for TAPI / Windows SDK
TAPI / TSP Developer and Tester
http://www.I-B-A-M.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm
* Please post all messages and replies to the newsgroup so all may
* benefit from the discussion. Private mail is usually not replied to.
* This posting is provided "AS IS" with no warranties, and confers no
rights.


Nov 16 '05 #11

P: n/a

"Andreas Marschall [MVP TAPI]" <An***************@I-B-A-M.de> wrote in
message news:OF**************@TK2MSFTNGP11.phx.gbl...
"BizTalk Architect" <bi***************@gmail.com> wrote in message
news:41***********************@diablo.nl.easynet.n et...
What happens if you use lCallbackInstance retrieved by ::Advise() from
ITTAPI_6 ?
I am not sure what you mean by "::Advise() " or how to impliment it.


Isaac,
as I already suggested:
See my TAPI and TSPI FAQ:
Q: Is there a user guide available for TAPI Browser TB3x ?
http://www.i-b-a-m.de/Andreas_Marschall's_TAPI_and_TSPI_FAQ.htm#_Q:_Is_t here_2

Andreas,

Thank you, and I didnt mention, your FAQ was very helpful.

I gave up. I grabbed a server, installed w2k, vs.net 2003 and I dont have
any more problems.

I wish I could put a finger on my problem for the public info, but I cant.

Thanks again.

Nov 16 '05 #12

This discussion thread is closed

Replies have been disabled for this discussion.