By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,836 Members | 2,018 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,836 IT Pros & Developers. It's quick & easy.

Access is denied - dll error

P: n/a
Uma
Hi

We have developed a C# Class Library dll which raises a error
intermittently. We get error Access is denied looked at the google
newsgroups etc., It all points to "Remove the Indexing service to specific
directory". But, Indexing service is not running in the machine.

What could be the problem ? anyone any idea... When I did deep investigation
using filemon utility ==> I found that .net is copying all dll's to some
sort of temp directory before execution and it is reading the file from temp
directory and access is denied.

Thanks


Nov 16 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
"Uma" <um*@tesco.net> wrote in message news:%2***************@TK2MSFTNGP09.phx.gbl...
Hi

We have developed a C# Class Library dll which raises a error
intermittently. We get error Access is denied looked at the google
newsgroups etc., It all points to "Remove the Indexing service to specific
directory". But, Indexing service is not running in the machine.

What could be the problem ? anyone any idea... When I did deep investigation
using filemon utility ==> I found that .net is copying all dll's to some
sort of temp directory before execution and it is reading the file from temp
directory and access is denied.


If you are talking about an ASP.NET application, you need to grant Full Control permissions to the system user (ASPNET for IIS 5.0, Network Service for IIS 6.0) to the "%System Root%\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files" folder.

You'll have to use the Advanced button and uncheck the "Inherited" checkbox. Just select Copy from the pop-up nag box and make sure the account has Full Control.

- carl
Nov 16 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.