469,917 Members | 1,937 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,917 developers. It's quick & easy.

windows service

Hi

I'm just playing with Visual Studio 2003 trying to write simple windows
service. I've created user service, installer and msi package, my cool
service appeared in MMC service list. But when I try to start it following
message appears:

What's wrong?

P.S. Working uder Windows 2003 Server.
Nov 16 '05 #1
3 4001
Sorry, message is:
Application popup: JIT Debugging : JIT Debugging failed with the following
error: Access is denied.

JIT Debugging was initiated by the user account 'NT AUTHORITY\NETWORK
SERVICE'.

Check the documentation index for 'Just-in-time debugging, errors' for more
information.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
"Ivan G." <iv************@hotmail.com> wrote in message
news:Oo*************@TK2MSFTNGP11.phx.gbl...
Hi

I'm just playing with Visual Studio 2003 trying to write simple windows
service. I've created user service, installer and msi package, my cool
service appeared in MMC service list. But when I try to start it following
message appears:

What's wrong?

P.S. Working uder Windows 2003 Server.

Nov 16 '05 #2
Are you calling System.Diagnostics.Debugger.Break() in your code? That
seems like the most likely cause of your error. To access the debugger like
that the user you are running your service under must be in the Debuggers
group. Try running the service under your account (which I assume is in the
debugger group) and see if you still have the same problem.

--
Jared Parson [MSFT]
ja******@online.microsoft.com

This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm

"Ivan G." <iv************@hotmail.com> wrote in message
news:uT*************@TK2MSFTNGP10.phx.gbl...
Sorry, message is:
Application popup: JIT Debugging : JIT Debugging failed with the following
error: Access is denied.

JIT Debugging was initiated by the user account 'NT AUTHORITY\NETWORK
SERVICE'.

Check the documentation index for 'Just-in-time debugging, errors' for
more
information.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
"Ivan G." <iv************@hotmail.com> wrote in message
news:Oo*************@TK2MSFTNGP11.phx.gbl...
Hi

I'm just playing with Visual Studio 2003 trying to write simple windows
service. I've created user service, installer and msi package, my cool
service appeared in MMC service list. But when I try to start it
following
message appears:

What's wrong?

P.S. Working uder Windows 2003 Server.


Nov 16 '05 #3
Thanks, you're right!

I've created new user with debugging previledges and run service under it,
now it works.

"Jared Parsons [MSFT]" <ja******@online.microsoft.com> wrote in message
news:#8**************@TK2MSFTNGP12.phx.gbl...
Are you calling System.Diagnostics.Debugger.Break() in your code? That
seems like the most likely cause of your error. To access the debugger like that the user you are running your service under must be in the Debuggers
group. Try running the service under your account (which I assume is in the debugger group) and see if you still have the same problem.

--
Jared Parson [MSFT]
ja******@online.microsoft.com

This posting is provided "AS IS" with no warranties, and confers no rights. Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm

"Ivan G." <iv************@hotmail.com> wrote in message
news:uT*************@TK2MSFTNGP10.phx.gbl...
Sorry, message is:
Application popup: JIT Debugging : JIT Debugging failed with the following error: Access is denied.

JIT Debugging was initiated by the user account 'NT AUTHORITY\NETWORK
SERVICE'.

Check the documentation index for 'Just-in-time debugging, errors' for
more
information.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
"Ivan G." <iv************@hotmail.com> wrote in message
news:Oo*************@TK2MSFTNGP11.phx.gbl...
Hi

I'm just playing with Visual Studio 2003 trying to write simple windows
service. I've created user service, installer and msi package, my cool
service appeared in MMC service list. But when I try to start it
following
message appears:

What's wrong?

P.S. Working uder Windows 2003 Server.



Nov 16 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

11 posts views Thread by Michael Riggio | last post: by
1 post views Thread by Artur Kowalski | last post: by
9 posts views Thread by SP | last post: by
1 post views Thread by Scott Davies | last post: by
reply views Thread by Scott Davies | last post: by
3 posts views Thread by Doug Bailey | last post: by
4 posts views Thread by tshad | last post: by
5 posts views Thread by dm3281 | last post: by
1 post views Thread by =?Utf-8?B?TWFuanJlZSBHYXJn?= | last post: by
1 post views Thread by Waqarahmed | last post: by
reply views Thread by Salome Sato | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.