By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,916 Members | 1,068 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,916 IT Pros & Developers. It's quick & easy.

HELP Connection error on Release mode

P: n/a
I have no idea what is going on. I have a Login screen where someone types
in their login information and this populates a datagrid based off of the
login. Works great in debug and test through VS, however, when I change to
release and put it out on the web it fails giving me the following error
message

The underlying connection was closed. Could not establish a trust
relationship with the remote server.
How on earth do I fix this? I read a little on it and it says that you
usually get this when using SSL but I am not using SSL.
Nov 16 '05 #1
Share this Question
Share on Google+
10 Replies


P: n/a
Brian,

Is this an ASP.NET application, or is this an EXE that is downloaded
from the web? If it is an EXE that is downloaded from the web, then the exe
runs with a reduced permission set, which definitely restricts network
access (considering that it is from the internet zone).

You will have to download the EXE to your machine, or you will have to
set the permissions for the EXE in the .NET configuration manager in order
to grant rights to that EXE.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:Ox**************@TK2MSFTNGP10.phx.gbl...
I have no idea what is going on. I have a Login screen where someone types in their login information and this populates a datagrid based off of the
login. Works great in debug and test through VS, however, when I change to release and put it out on the web it fails giving me the following error
message

The underlying connection was closed. Could not establish a trust
relationship with the remote server.
How on earth do I fix this? I read a little on it and it says that you
usually get this when using SSL but I am not using SSL.

Nov 16 '05 #2

P: n/a
This is an ASP.NET application. I am using the installer program to deploy
though. I built one other ASP.NET application the same way and it works
fine, different database server though than this one.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:Oa**************@tk2msftngp13.phx.gbl...
Brian,

Is this an ASP.NET application, or is this an EXE that is downloaded
from the web? If it is an EXE that is downloaded from the web, then the exe runs with a reduced permission set, which definitely restricts network
access (considering that it is from the internet zone).

You will have to download the EXE to your machine, or you will have to
set the permissions for the EXE in the .NET configuration manager in order
to grant rights to that EXE.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:Ox**************@TK2MSFTNGP10.phx.gbl...
I have no idea what is going on. I have a Login screen where someone

types
in their login information and this populates a datagrid based off of the login. Works great in debug and test through VS, however, when I change

to
release and put it out on the web it fails giving me the following error
message

The underlying connection was closed. Could not establish a trust
relationship with the remote server.
How on earth do I fix this? I read a little on it and it says that you
usually get this when using SSL but I am not using SSL.


Nov 16 '05 #3

P: n/a
Brian,

Is the database on the machine that IIS is on or is it on another
machine? If it is on the local machine, is the database configured to allow
the user account that is accessing it? Most likely, this is the ASPNET
account, which is local to the machine that IIS is running on. If the
database is on another machine, then you need to change the account (for the
duration of the database access) to an account that has access to the
network and the database.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:O5**************@TK2MSFTNGP12.phx.gbl...
This is an ASP.NET application. I am using the installer program to deploy
though. I built one other ASP.NET application the same way and it works
fine, different database server though than this one.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in message news:Oa**************@tk2msftngp13.phx.gbl...
Brian,

Is this an ASP.NET application, or is this an EXE that is downloaded
from the web? If it is an EXE that is downloaded from the web, then the

exe
runs with a reduced permission set, which definitely restricts network
access (considering that it is from the internet zone).

You will have to download the EXE to your machine, or you will have to
set the permissions for the EXE in the .NET configuration manager in order to grant rights to that EXE.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:Ox**************@TK2MSFTNGP10.phx.gbl...
I have no idea what is going on. I have a Login screen where someone

types
in their login information and this populates a datagrid based off of the login. Works great in debug and test through VS, however, when I change to
release and put it out on the web it fails giving me the following

error message

The underlying connection was closed. Could not establish a trust
relationship with the remote server.
How on earth do I fix this? I read a little on it and it says that you usually get this when using SSL but I am not using SSL.



Nov 16 '05 #4

P: n/a
The database is on another machine (same as with my other application that
works fine) I am not sure what you mean by changing the account to an
account that has access to the network. I thought that this was already
established within the webconfig file in the connection string. My
development computer is setup fairly identical to the test server, and it
runs perfectly fine on my computer.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:uv**************@TK2MSFTNGP10.phx.gbl...
Brian,

Is the database on the machine that IIS is on or is it on another
machine? If it is on the local machine, is the database configured to allow the user account that is accessing it? Most likely, this is the ASPNET
account, which is local to the machine that IIS is running on. If the
database is on another machine, then you need to change the account (for the duration of the database access) to an account that has access to the
network and the database.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:O5**************@TK2MSFTNGP12.phx.gbl...
This is an ASP.NET application. I am using the installer program to deploy
though. I built one other ASP.NET application the same way and it works
fine, different database server though than this one.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:Oa**************@tk2msftngp13.phx.gbl...
Brian,

Is this an ASP.NET application, or is this an EXE that is downloaded from the web? If it is an EXE that is downloaded from the web, then the
exe
runs with a reduced permission set, which definitely restricts network
access (considering that it is from the internet zone).

You will have to download the EXE to your machine, or you will hav
e to set the permissions for the EXE in the .NET configuration manager in order to grant rights to that EXE.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:Ox**************@TK2MSFTNGP10.phx.gbl...
> I have no idea what is going on. I have a Login screen where
someone types
> in their login information and this populates a datagrid based off

of the
> login. Works great in debug and test through VS, however, when I

change to
> release and put it out on the web it fails giving me the following error > message
>
> The underlying connection was closed. Could not establish a trust
> relationship with the remote server.
>
>
> How on earth do I fix this? I read a little on it and it says that you > usually get this when using SSL but I am not using SSL.
>
>



Nov 16 '05 #5

P: n/a
Brian,

The connection string only has the credientials. However, ASP.NET runs
locally using ASPNET, which can't access the network. If the page runs
under an account that can't access the network, then it can't even get to
the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:uq**************@TK2MSFTNGP12.phx.gbl...
The database is on another machine (same as with my other application that
works fine) I am not sure what you mean by changing the account to an
account that has access to the network. I thought that this was already
established within the webconfig file in the connection string. My
development computer is setup fairly identical to the test server, and it
runs perfectly fine on my computer.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in message news:uv**************@TK2MSFTNGP10.phx.gbl...
Brian,

Is the database on the machine that IIS is on or is it on another
machine? If it is on the local machine, is the database configured to allow
the user account that is accessing it? Most likely, this is the ASPNET
account, which is local to the machine that IIS is running on. If the
database is on another machine, then you need to change the account (for

the
duration of the database access) to an account that has access to the
network and the database.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:O5**************@TK2MSFTNGP12.phx.gbl...
This is an ASP.NET application. I am using the installer program to deploy though. I built one other ASP.NET application the same way and it works fine, different database server though than this one.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote
in
message news:Oa**************@tk2msftngp13.phx.gbl...
> Brian,
>
> Is this an ASP.NET application, or is this an EXE that is downloaded > from the web? If it is an EXE that is downloaded from the web, then the exe
> runs with a reduced permission set, which definitely restricts
network > access (considering that it is from the internet zone).
>
> You will have to download the EXE to your machine, or you will
hav e
to
> set the permissions for the EXE in the .NET configuration manager in

order
> to grant rights to that EXE.
>
> Hope this helps.
>
>
> --
> - Nicholas Paldino [.NET/C# MVP]
> - mv*@spam.guard.caspershouse.com
>
> "Brian Conway" <Br**********@qwest.com> wrote in message
> news:Ox**************@TK2MSFTNGP10.phx.gbl...
> > I have no idea what is going on. I have a Login screen where

someone > types
> > in their login information and this populates a datagrid based off of the
> > login. Works great in debug and test through VS, however, when I

change
> to
> > release and put it out on the web it fails giving me the following

error
> > message
> >
> > The underlying connection was closed. Could not establish a trust
> > relationship with the remote server.
> >
> >
> > How on earth do I fix this? I read a little on it and it says

that you
> > usually get this when using SSL but I am not using SSL.
> >
> >
>
>



Nov 16 '05 #6

P: n/a
I would assume that the account can, since my other application accesses a
database not on that server and is located elsewhere on the network. How do
I try to check and see if this is the problem and how do I resolve it?

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:u$**************@TK2MSFTNGP10.phx.gbl...
Brian,

The connection string only has the credientials. However, ASP.NET runs locally using ASPNET, which can't access the network. If the page runs
under an account that can't access the network, then it can't even get to
the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:uq**************@TK2MSFTNGP12.phx.gbl...
The database is on another machine (same as with my other application that
works fine) I am not sure what you mean by changing the account to an
account that has access to the network. I thought that this was already
established within the webconfig file in the connection string. My
development computer is setup fairly identical to the test server, and it runs perfectly fine on my computer.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote

in
message news:uv**************@TK2MSFTNGP10.phx.gbl...
Brian,

Is the database on the machine that IIS is on or is it on another
machine? If it is on the local machine, is the database configured to

allow
the user account that is accessing it? Most likely, this is the ASPNET account, which is local to the machine that IIS is running on. If the
database is on another machine, then you need to change the account (for
the
duration of the database access) to an account that has access to the
network and the database.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:O5**************@TK2MSFTNGP12.phx.gbl...
> This is an ASP.NET application. I am using the installer program to

deploy
> though. I built one other ASP.NET application the same way and it works > fine, different database server though than this one.
>
>
>
> "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
> message news:Oa**************@tk2msftngp13.phx.gbl...
> > Brian,
> >
> > Is this an ASP.NET application, or is this an EXE that is

downloaded
> > from the web? If it is an EXE that is downloaded from the web,
then the
> exe
> > runs with a reduced permission set, which definitely restricts network > > access (considering that it is from the internet zone).
> >
> > You will have to download the EXE to your machine, or you will hav
e
to
> > set the permissions for the EXE in the .NET configuration manager

in order
> > to grant rights to that EXE.
> >
> > Hope this helps.
> >
> >
> > --
> > - Nicholas Paldino [.NET/C# MVP]
> > - mv*@spam.guard.caspershouse.com
> >
> > "Brian Conway" <Br**********@qwest.com> wrote in message
> > news:Ox**************@TK2MSFTNGP10.phx.gbl...
> > > I have no idea what is going on. I have a Login screen where

someone
> > types
> > > in their login information and this populates a datagrid based off of
> the
> > > login. Works great in debug and test through VS, however, when

I change
> > to
> > > release and put it out on the web it fails giving me the following error
> > > message
> > >
> > > The underlying connection was closed. Could not establish a trust > > > relationship with the remote server.
> > >
> > >
> > > How on earth do I fix this? I read a little on it and it says

that you
> > > usually get this when using SSL but I am not using SSL.
> > >
> > >
> >
> >
>
>



Nov 16 '05 #7

P: n/a
Brian,

Is your other application configured differently? I would imagine that
this is the case. Can you post the web.config file for your current app?

You can test this by changing the account that the app runs under by
setting the <identity> element and setting the impersonate attribute to a
value of "true". This will allow you to specify an account which can access
the network (through the username and password attributes).
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:Od**************@tk2msftngp13.phx.gbl...
I would assume that the account can, since my other application accesses a
database not on that server and is located elsewhere on the network. How do I try to check and see if this is the problem and how do I resolve it?

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in message news:u$**************@TK2MSFTNGP10.phx.gbl...
Brian,

The connection string only has the credientials. However, ASP.NET runs
locally using ASPNET, which can't access the network. If the page runs
under an account that can't access the network, then it can't even get to
the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:uq**************@TK2MSFTNGP12.phx.gbl...
The database is on another machine (same as with my other application that works fine) I am not sure what you mean by changing the account to an
account that has access to the network. I thought that this was already established within the webconfig file in the connection string. My
development computer is setup fairly identical to the test server, and it runs perfectly fine on my computer.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:uv**************@TK2MSFTNGP10.phx.gbl...
> Brian,
>
> Is the database on the machine that IIS is on or is it on
another > machine? If it is on the local machine, is the database configured to allow
> the user account that is accessing it? Most likely, this is the ASPNET > account, which is local to the machine that IIS is running on. If the > database is on another machine, then you need to change the account (for the
> duration of the database access) to an account that has access to the > network and the database.
>
>
> --
> - Nicholas Paldino [.NET/C# MVP]
> - mv*@spam.guard.caspershouse.com
>
> "Brian Conway" <Br**********@qwest.com> wrote in message
> news:O5**************@TK2MSFTNGP12.phx.gbl...
> > This is an ASP.NET application. I am using the installer program to deploy
> > though. I built one other ASP.NET application the same way and it

works
> > fine, different database server though than this one.
> >
> >
> >
> > "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com>

wrote
> in
> > message news:Oa**************@tk2msftngp13.phx.gbl...
> > > Brian,
> > >
> > > Is this an ASP.NET application, or is this an EXE that is
downloaded
> > > from the web? If it is an EXE that is downloaded from the web, then the
> > exe
> > > runs with a reduced permission set, which definitely restricts

network
> > > access (considering that it is from the internet zone).
> > >
> > > You will have to download the EXE to your machine, or you
will hav
e
> to
> > > set the permissions for the EXE in the .NET configuration

manager in > order
> > > to grant rights to that EXE.
> > >
> > > Hope this helps.
> > >
> > >
> > > --
> > > - Nicholas Paldino [.NET/C# MVP]
> > > - mv*@spam.guard.caspershouse.com
> > >
> > > "Brian Conway" <Br**********@qwest.com> wrote in message
> > > news:Ox**************@TK2MSFTNGP10.phx.gbl...
> > > > I have no idea what is going on. I have a Login screen where
someone
> > > types
> > > > in their login information and this populates a datagrid based off of
> > the
> > > > login. Works great in debug and test through VS, however,
when
I > change
> > > to
> > > > release and put it out on the web it fails giving me the following > error
> > > > message
> > > >
> > > > The underlying connection was closed. Could not establish a trust > > > > relationship with the remote server.
> > > >
> > > >
> > > > How on earth do I fix this? I read a little on it and it says

that
> you
> > > > usually get this when using SSL but I am not using SSL.
> > > >
> > > >
> > >
> > >
> >
> >
>
>



Nov 16 '05 #8

P: n/a
This is the web config for the one that does not work, below this one is the
web config for the one that does work.

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<appSettings>

<add key="FleetConnectionString" value="Data
Source=fletws01;Password=upgrade;User ID=fleet;provider=OraOLEDB.Oracle.1"/>

</appSettings>

<system.web>

<!-- DYNAMIC DEBUG COMPILATION

Set compilation debug="true" to enable ASPX debugging. Otherwise, setting
this value to

false will improve runtime performance of this application.

Set compilation debug="true" to insert debugging symbols (.pdb information)

into the compiled page. Because this creates a larger file that executes

more slowly, you should set this value to true only when debugging and to

false at all other times. For more information, refer to the documentation
about

debugging ASP.NET files.

-->

<compilation

defaultLanguage="c#"

debug="true"

/>

<!-- CUSTOM ERROR MESSAGES

Set customErrors mode="On" or "RemoteOnly" to enable custom error messages,
"Off" to disable.

Add <error> tags for each of the errors you want to handle.

"On" Always display custom (friendly) messages.

"Off" Always display detailed ASP.NET error information.

"RemoteOnly" Display custom (friendly) messages only to users not running

on the local Web server. This setting is recommended for security purposes,
so

that you do not display application detail information to remote clients.

-->

<customErrors

mode="RemoteOnly"

/>

<!-- AUTHENTICATION

This section sets the authentication policies of the application. Possible
modes are "Windows",

"Forms", "Passport" and "None"

"None" No authentication is performed.

"Windows" IIS performs authentication (Basic, Digest, or Integrated Windows)
according to

its settings for the application. Anonymous access must be disabled in IIS.

"Forms" You provide a custom form (Web page) for users to enter their
credentials, and then

you authenticate them in your application. A user credential token is stored
in a cookie.

"Passport" Authentication is performed via a centralized authentication
service provided

by Microsoft that offers a single logon and core profile services for member
sites.

-->

<authentication mode="Windows" />

<!-- AUTHORIZATION

This section sets the authorization policies of the application. You can
allow or deny access

to application resources by user or role. Wildcards: "*" mean everyone, "?"
means anonymous

(unauthenticated) users.

-->

<authorization>

<allow users="*" /> <!-- Allow all users -->

<!-- <allow users="[comma separated list of users]"

roles="[comma separated list of roles]"/>

<deny users="[comma separated list of users]"

roles="[comma separated list of roles]"/>

-->

</authorization>

<!-- APPLICATION-LEVEL TRACE LOGGING

Application-level tracing enables trace log output for every page within an
application.

Set trace enabled="true" to enable application trace logging. If
pageOutput="true", the

trace information will be displayed at the bottom of each page. Otherwise,
you can view the

application trace log by browsing the "trace.axd" page from your web
application

root.

-->

<trace

enabled="false"

requestLimit="10"

pageOutput="false"

traceMode="SortByTime"

localOnly="true"

/>

<!-- SESSION STATE SETTINGS

By default ASP.NET uses cookies to identify which requests belong to a
particular session.

If cookies are not available, a session can be tracked by adding a session
identifier to the URL.

To disable cookies, set sessionState cookieless="true".

-->

<sessionState

mode="InProc"

stateConnectionString="tcpip=127.0.0.1:42424"

sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"

cookieless="false"

timeout="20"

/>

<!-- GLOBALIZATION

This section sets the globalization settings of the application.

-->

<globalization

requestEncoding="utf-8"

responseEncoding="utf-8"

/>
</system.web>

</configuration>

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<This is for the one that does work

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<appSettings>

<add key="ConferenceConnectionString" value="Data
Source=ntdrp001.world;Password=conf00;User
ID=conference;provider=OraOLEDB.Oracle.1"/>

</appSettings>

<system.web>

<!-- DYNAMIC DEBUG COMPILATION

Set compilation debug="true" to enable ASPX debugging. Otherwise, setting
this value to

false will improve runtime performance of this application.

Set compilation debug="true" to insert debugging symbols (.pdb information)

into the compiled page. Because this creates a larger file that executes

more slowly, you should set this value to true only when debugging and to

false at all other times. For more information, refer to the documentation
about

debugging ASP.NET files.

-->

<compilation

defaultLanguage="c#"

debug="true"

/>

<!-- CUSTOM ERROR MESSAGES

Set customErrors mode="On" or "RemoteOnly" to enable custom error messages,
"Off" to disable.

Add <error> tags for each of the errors you want to handle.

"On" Always display custom (friendly) messages.

"Off" Always display detailed ASP.NET error information.

"RemoteOnly" Display custom (friendly) messages only to users not running

on the local Web server. This setting is recommended for security purposes,
so

that you do not display application detail information to remote clients.

-->

<customErrors

mode="RemoteOnly"

/>

<!-- AUTHENTICATION

This section sets the authentication policies of the application. Possible
modes are "Windows",

"Forms", "Passport" and "None"

"None" No authentication is performed.

"Windows" IIS performs authentication (Basic, Digest, or Integrated Windows)
according to

its settings for the application. Anonymous access must be disabled in IIS.

"Forms" You provide a custom form (Web page) for users to enter their
credentials, and then

you authenticate them in your application. A user credential token is stored
in a cookie.

"Passport" Authentication is performed via a centralized authentication
service provided

by Microsoft that offers a single logon and core profile services for member
sites.

-->

<authentication mode="Windows" />

<!-- AUTHORIZATION

This section sets the authorization policies of the application. You can
allow or deny access

to application resources by user or role. Wildcards: "*" mean everyone, "?"
means anonymous

(unauthenticated) users.

-->

<authorization>

<allow users="*" /> <!-- Allow all users -->

<!-- <allow users="[comma separated list of users]"

roles="[comma separated list of roles]"/>

<deny users="[comma separated list of users]"

roles="[comma separated list of roles]"/>

-->

</authorization>

<!-- APPLICATION-LEVEL TRACE LOGGING

Application-level tracing enables trace log output for every page within an
application.

Set trace enabled="true" to enable application trace logging. If
pageOutput="true", the

trace information will be displayed at the bottom of each page. Otherwise,
you can view the

application trace log by browsing the "trace.axd" page from your web
application

root.

-->

<trace

enabled="false"

requestLimit="10"

pageOutput="false"

traceMode="SortByTime"

localOnly="true"

/>

<!-- SESSION STATE SETTINGS

By default ASP.NET uses cookies to identify which requests belong to a
particular session.

If cookies are not available, a session can be tracked by adding a session
identifier to the URL.

To disable cookies, set sessionState cookieless="true".

-->

<sessionState

mode="InProc"

stateConnectionString="tcpip=127.0.0.1:42424"

sqlConnectionString="data source=127.0.0.1;Trusted_Connection=yes"

cookieless="false"

timeout="20"

/>

<!-- GLOBALIZATION

This section sets the globalization settings of the application.

-->

<globalization

requestEncoding="utf-8"

responseEncoding="utf-8"

/>
</system.web>

</configuration>

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:u9**************@TK2MSFTNGP11.phx.gbl...
Brian,

Is your other application configured differently? I would imagine that this is the case. Can you post the web.config file for your current app?

You can test this by changing the account that the app runs under by
setting the <identity> element and setting the impersonate attribute to a
value of "true". This will allow you to specify an account which can access the network (through the username and password attributes).
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:Od**************@tk2msftngp13.phx.gbl...
I would assume that the account can, since my other application accesses a
database not on that server and is located elsewhere on the network. How
do
I try to check and see if this is the problem and how do I resolve it?

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:u$**************@TK2MSFTNGP10.phx.gbl...
Brian,

The connection string only has the credientials. However, ASP.NET

runs
locally using ASPNET, which can't access the network. If the page runs under an account that can't access the network, then it can't even get

to the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:uq**************@TK2MSFTNGP12.phx.gbl...
> The database is on another machine (same as with my other application that
> works fine) I am not sure what you mean by changing the account to
an > account that has access to the network. I thought that this was already > established within the webconfig file in the connection string. My
> development computer is setup fairly identical to the test server, and it
> runs perfectly fine on my computer.
>
> "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
> message news:uv**************@TK2MSFTNGP10.phx.gbl...
> > Brian,
> >
> > Is the database on the machine that IIS is on or is it on another > > machine? If it is on the local machine, is the database
configured to > allow
> > the user account that is accessing it? Most likely, this is the

ASPNET
> > account, which is local to the machine that IIS is running on. If the > > database is on another machine, then you need to change the
account
(for
> the
> > duration of the database access) to an account that has access to the > > network and the database.
> >
> >
> > --
> > - Nicholas Paldino [.NET/C# MVP]
> > - mv*@spam.guard.caspershouse.com
> >
> > "Brian Conway" <Br**********@qwest.com> wrote in message
> > news:O5**************@TK2MSFTNGP12.phx.gbl...
> > > This is an ASP.NET application. I am using the installer program to > deploy
> > > though. I built one other ASP.NET application the same way and
it works
> > > fine, different database server though than this one.
> > >
> > >
> > >
> > > "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote
> > in
> > > message news:Oa**************@tk2msftngp13.phx.gbl...
> > > > Brian,
> > > >
> > > > Is this an ASP.NET application, or is this an EXE that is
> downloaded
> > > > from the web? If it is an EXE that is downloaded from the web, then
> the
> > > exe
> > > > runs with a reduced permission set, which definitely restricts
network
> > > > access (considering that it is from the internet zone).
> > > >
> > > > You will have to download the EXE to your machine, or you will hav
> e
> > to
> > > > set the permissions for the EXE in the .NET configuration

manager
in
> > order
> > > > to grant rights to that EXE.
> > > >
> > > > Hope this helps.
> > > >
> > > >
> > > > --
> > > > - Nicholas Paldino [.NET/C# MVP]
> > > > - mv*@spam.guard.caspershouse.com
> > > >
> > > > "Brian Conway" <Br**********@qwest.com> wrote in message
> > > > news:Ox**************@TK2MSFTNGP10.phx.gbl...
> > > > > I have no idea what is going on. I have a Login screen

where > someone
> > > > types
> > > > > in their login information and this populates a datagrid based off
> of
> > > the
> > > > > login. Works great in debug and test through VS, however,

when
I
> > change
> > > > to
> > > > > release and put it out on the web it fails giving me the

following
> > error
> > > > > message
> > > > >
> > > > > The underlying connection was closed. Could not establish a

trust
> > > > > relationship with the remote server.
> > > > >
> > > > >
> > > > > How on earth do I fix this? I read a little on it and it

says that
> > you
> > > > > usually get this when using SSL but I am not using SSL.
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>



Nov 16 '05 #9

P: n/a
I tried this string after the authorization section in the webconfig file

<identity impersonate="true" userName="edqa" password="admin40!"/>

and it still returned the same error message.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:u9**************@TK2MSFTNGP11.phx.gbl...
Brian,

Is your other application configured differently? I would imagine that this is the case. Can you post the web.config file for your current app?

You can test this by changing the account that the app runs under by
setting the <identity> element and setting the impersonate attribute to a
value of "true". This will allow you to specify an account which can access the network (through the username and password attributes).
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:Od**************@tk2msftngp13.phx.gbl...
I would assume that the account can, since my other application accesses a
database not on that server and is located elsewhere on the network. How
do
I try to check and see if this is the problem and how do I resolve it?

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:u$**************@TK2MSFTNGP10.phx.gbl...
Brian,

The connection string only has the credientials. However, ASP.NET

runs
locally using ASPNET, which can't access the network. If the page runs under an account that can't access the network, then it can't even get

to the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:uq**************@TK2MSFTNGP12.phx.gbl...
> The database is on another machine (same as with my other application that
> works fine) I am not sure what you mean by changing the account to
an > account that has access to the network. I thought that this was already > established within the webconfig file in the connection string. My
> development computer is setup fairly identical to the test server, and it
> runs perfectly fine on my computer.
>
> "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
> message news:uv**************@TK2MSFTNGP10.phx.gbl...
> > Brian,
> >
> > Is the database on the machine that IIS is on or is it on another > > machine? If it is on the local machine, is the database
configured to > allow
> > the user account that is accessing it? Most likely, this is the

ASPNET
> > account, which is local to the machine that IIS is running on. If the > > database is on another machine, then you need to change the
account
(for
> the
> > duration of the database access) to an account that has access to the > > network and the database.
> >
> >
> > --
> > - Nicholas Paldino [.NET/C# MVP]
> > - mv*@spam.guard.caspershouse.com
> >
> > "Brian Conway" <Br**********@qwest.com> wrote in message
> > news:O5**************@TK2MSFTNGP12.phx.gbl...
> > > This is an ASP.NET application. I am using the installer program to > deploy
> > > though. I built one other ASP.NET application the same way and
it works
> > > fine, different database server though than this one.
> > >
> > >
> > >
> > > "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote
> > in
> > > message news:Oa**************@tk2msftngp13.phx.gbl...
> > > > Brian,
> > > >
> > > > Is this an ASP.NET application, or is this an EXE that is
> downloaded
> > > > from the web? If it is an EXE that is downloaded from the web, then
> the
> > > exe
> > > > runs with a reduced permission set, which definitely restricts
network
> > > > access (considering that it is from the internet zone).
> > > >
> > > > You will have to download the EXE to your machine, or you will hav
> e
> > to
> > > > set the permissions for the EXE in the .NET configuration

manager
in
> > order
> > > > to grant rights to that EXE.
> > > >
> > > > Hope this helps.
> > > >
> > > >
> > > > --
> > > > - Nicholas Paldino [.NET/C# MVP]
> > > > - mv*@spam.guard.caspershouse.com
> > > >
> > > > "Brian Conway" <Br**********@qwest.com> wrote in message
> > > > news:Ox**************@TK2MSFTNGP10.phx.gbl...
> > > > > I have no idea what is going on. I have a Login screen

where > someone
> > > > types
> > > > > in their login information and this populates a datagrid based off
> of
> > > the
> > > > > login. Works great in debug and test through VS, however,

when
I
> > change
> > > > to
> > > > > release and put it out on the web it fails giving me the

following
> > error
> > > > > message
> > > > >
> > > > > The underlying connection was closed. Could not establish a

trust
> > > > > relationship with the remote server.
> > > > >
> > > > >
> > > > > How on earth do I fix this? I read a little on it and it

says that
> > you
> > > > > usually get this when using SSL but I am not using SSL.
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>



Nov 16 '05 #10

P: n/a
Tracked it down to the webservice that I am using requires HTTPS. I have
gone through the walk through on installing the certificate, however, it
does not stay in the system, once you leave IE and go back in it will ask
for the certificate again. How do I get this installed permanently.
"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:u9**************@TK2MSFTNGP11.phx.gbl...
Brian,

Is your other application configured differently? I would imagine that this is the case. Can you post the web.config file for your current app?

You can test this by changing the account that the app runs under by
setting the <identity> element and setting the impersonate attribute to a
value of "true". This will allow you to specify an account which can access the network (through the username and password attributes).
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:Od**************@tk2msftngp13.phx.gbl...
I would assume that the account can, since my other application accesses a
database not on that server and is located elsewhere on the network. How
do
I try to check and see if this is the problem and how do I resolve it?

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:u$**************@TK2MSFTNGP10.phx.gbl...
Brian,

The connection string only has the credientials. However, ASP.NET

runs
locally using ASPNET, which can't access the network. If the page runs under an account that can't access the network, then it can't even get

to the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Brian Conway" <Br**********@qwest.com> wrote in message
news:uq**************@TK2MSFTNGP12.phx.gbl...
> The database is on another machine (same as with my other application that
> works fine) I am not sure what you mean by changing the account to
an > account that has access to the network. I thought that this was already > established within the webconfig file in the connection string. My
> development computer is setup fairly identical to the test server, and it
> runs perfectly fine on my computer.
>
> "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
> message news:uv**************@TK2MSFTNGP10.phx.gbl...
> > Brian,
> >
> > Is the database on the machine that IIS is on or is it on another > > machine? If it is on the local machine, is the database
configured to > allow
> > the user account that is accessing it? Most likely, this is the

ASPNET
> > account, which is local to the machine that IIS is running on. If the > > database is on another machine, then you need to change the
account
(for
> the
> > duration of the database access) to an account that has access to the > > network and the database.
> >
> >
> > --
> > - Nicholas Paldino [.NET/C# MVP]
> > - mv*@spam.guard.caspershouse.com
> >
> > "Brian Conway" <Br**********@qwest.com> wrote in message
> > news:O5**************@TK2MSFTNGP12.phx.gbl...
> > > This is an ASP.NET application. I am using the installer program to > deploy
> > > though. I built one other ASP.NET application the same way and
it works
> > > fine, different database server though than this one.
> > >
> > >
> > >
> > > "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote
> > in
> > > message news:Oa**************@tk2msftngp13.phx.gbl...
> > > > Brian,
> > > >
> > > > Is this an ASP.NET application, or is this an EXE that is
> downloaded
> > > > from the web? If it is an EXE that is downloaded from the web, then
> the
> > > exe
> > > > runs with a reduced permission set, which definitely restricts
network
> > > > access (considering that it is from the internet zone).
> > > >
> > > > You will have to download the EXE to your machine, or you will hav
> e
> > to
> > > > set the permissions for the EXE in the .NET configuration

manager
in
> > order
> > > > to grant rights to that EXE.
> > > >
> > > > Hope this helps.
> > > >
> > > >
> > > > --
> > > > - Nicholas Paldino [.NET/C# MVP]
> > > > - mv*@spam.guard.caspershouse.com
> > > >
> > > > "Brian Conway" <Br**********@qwest.com> wrote in message
> > > > news:Ox**************@TK2MSFTNGP10.phx.gbl...
> > > > > I have no idea what is going on. I have a Login screen

where > someone
> > > > types
> > > > > in their login information and this populates a datagrid based off
> of
> > > the
> > > > > login. Works great in debug and test through VS, however,

when
I
> > change
> > > > to
> > > > > release and put it out on the web it fails giving me the

following
> > error
> > > > > message
> > > > >
> > > > > The underlying connection was closed. Could not establish a

trust
> > > > > relationship with the remote server.
> > > > >
> > > > >
> > > > > How on earth do I fix this? I read a little on it and it

says that
> > you
> > > > > usually get this when using SSL but I am not using SSL.
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>



Nov 16 '05 #11

This discussion thread is closed

Replies have been disabled for this discussion.