By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,089 Members | 2,301 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,089 IT Pros & Developers. It's quick & easy.

Problem changing Cursor property in a ListView control

P: n/a
Hi
I would to display a Cursors.WaitCursor on a ListView control, so I tried

listView.Cursor = Cursors.WaitCursor

but it doesn't work at all, I see always the default cursor. The same thing happens if I set the WaitCursor in the properties window. The strange thing is that with other controls, like buttons or the treeview, it does work. The only control for which I can't change the cursor is the ListView: it does not work even if I set the current cursor property with the line

Cursor.Current = Cursors.WaitCursor

Any ideas? Is it a bug of the ListView control? Must I set some other properties of the ListView control to change the cursor

Best regards
Riccardo
Nov 16 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
riccardo,

based on this link http://www.google.de/groups?
threadm=bfmk3l%24gla2q%241%40ID-25595.news.uni-
berlin.de , it is a known bug.

HTH,

gani
http://thedeveloperscorner.com.ph

-----Original Message-----
Hi,
I would to display a Cursors.WaitCursor on a ListView control, so I tried:
listView.Cursor = Cursors.WaitCursor;

but it doesn't work at all, I see always the default cursor. The same thing happens if I set the WaitCursor in
the properties window. The strange thing is that with
other controls, like buttons or the treeview, it does
work. The only control for which I can't change the
cursor is the ListView: it does not work even if I set
the current cursor property with the line:
Cursor.Current = Cursors.WaitCursor;

Any ideas? Is it a bug of the ListView control? Must I set some other properties of the ListView control to
change the cursor?
Best regards,
Riccardo
.

Nov 16 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.