By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,647 Members | 1,178 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,647 IT Pros & Developers. It's quick & easy.

Problems with httpHandlers --> Help me please

P: n/a
Hi,

I want to protected all files in my website, so I try to use httpHandlers, I put this in my WEB.CONFIG (at the end of page), but I can't protected the files type MDB, CSB, can someone help me? :

<httpHandlers>

<add verb="*" path="*.mdb" type="System.Web.HttpForbiddenHandler" />

<add verb="*" path="*.csv" type="System.Web.HttpForbiddenHandler" />

</httpHandlers>

I see this example in http://support.microsoft.com/default...b;EN-US;815152

Nov 15 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Luis
1) Please use plain text format if possible when posting
2) You may want to try posting to the asp.net forum instead of C#

3) In order for your handlers to ever have an effect, the file extensions in
question must be mapped to ASP.NET in IIS's configuration. By default, IIS
asks ASP.NET to handle only .aspx, ascx, asax, asmx, ashx, .cs, .vb,
possibly a few more. In IIS6.0, it's possible to construct a wildcard
mapping that will map all requests to ASP.NET. In IIS5.0, you'll have to do
it the hard way.

Read this link for much more information:
http://aspnet.4guysfromrolla.com/articles/020404-1.aspx

"Luis" <ll*@telefonica.net> wrote in message
news:ua****************@tk2msftngp13.phx.gbl...
Hi,

I want to protected all files in my website, so I try to use httpHandlers, I
put this in my WEB.CONFIG (at the end of page), but I can't protected the
files type MDB, CSB, can someone help me? :

<httpHandlers>
<add verb="*" path="*.mdb" type="System.Web.HttpForbiddenHandler" />
<add verb="*" path="*.csv" type="System.Web.HttpForbiddenHandler" />
</httpHandlers>

I see this example in
http://support.microsoft.com/default...b;EN-US;815152
Nov 15 '05 #2

P: n/a
Thanks and sorry...
Luis

"Philip Rieck" <st***@mckraken.com> escribió en el mensaje
news:uH****************@TK2MSFTNGP12.phx.gbl...
Luis
1) Please use plain text format if possible when posting
2) You may want to try posting to the asp.net forum instead of C#

3) In order for your handlers to ever have an effect, the file extensions in question must be mapped to ASP.NET in IIS's configuration. By default, IIS asks ASP.NET to handle only .aspx, ascx, asax, asmx, ashx, .cs, .vb,
possibly a few more. In IIS6.0, it's possible to construct a wildcard
mapping that will map all requests to ASP.NET. In IIS5.0, you'll have to do it the hard way.

Read this link for much more information:
http://aspnet.4guysfromrolla.com/articles/020404-1.aspx

"Luis" <ll*@telefonica.net> wrote in message
news:ua****************@tk2msftngp13.phx.gbl...
Hi,

I want to protected all files in my website, so I try to use httpHandlers, I put this in my WEB.CONFIG (at the end of page), but I can't protected the
files type MDB, CSB, can someone help me? :

<httpHandlers>
<add verb="*" path="*.mdb" type="System.Web.HttpForbiddenHandler" />
<add verb="*" path="*.csv" type="System.Web.HttpForbiddenHandler" />
</httpHandlers>

I see this example in
http://support.microsoft.com/default...b;EN-US;815152

Nov 15 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.