By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,710 Members | 1,613 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,710 IT Pros & Developers. It's quick & easy.

<location>+webconfig+IIS?

P: n/a
when i used <location> tag as follow;
</system.web>
<location path="members" allowOverride="false">
<system.web>
<authentication mode="Forms">
<forms loginUrl="./default.aspx"></forms>
</authentication>
<authorization>
<deny users="?" />
</authorization>
</system.web>
</location>
<appSettings>
i faced with folloving error
Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS.

Source Error:

Line 44: <location path="members" allowOverride="false">
Line 45: <system.web>
Line 46: <authentication mode="Forms">
Line 47: <forms loginUrl="./default.aspx"></forms>
Line 48: </authentication>
Source File: c:\inetpub\wwwroot\KKTCEMLAK\web.config Line: 46

thanks in advance for any help or idea
Nov 15 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I have had success in putting the authentication information at the
top and then separating the <location/authorization/allow/deny> stuff
under that, in a separate <location> location. That works for me
anyways.

"Cantekin Guneser" <ca*************@hotmail.com> wrote in message news:<ek**************@tk2msftngp13.phx.gbl>...
when i used <location> tag as follow;
</system.web>
<location path="members" allowOverride="false">
<system.web>
<authentication mode="Forms">
<forms loginUrl="./default.aspx"></forms>
</authentication>
<authorization>
<deny users="?" />
</authorization>
</system.web>
</location>
<appSettings>
i faced with folloving error
Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS.

Source Error:

Line 44: <location path="members" allowOverride="false">
Line 45: <system.web>
Line 46: <authentication mode="Forms">
Line 47: <forms loginUrl="./default.aspx"></forms>
Line 48: </authentication>
Source File: c:\inetpub\wwwroot\KKTCEMLAK\web.config Line: 46

thanks in advance for any help or idea

Nov 15 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.