By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,971 Members | 907 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,971 IT Pros & Developers. It's quick & easy.

problems with WebReferences in VS2003

P: n/a
When I try to create a new C# Web Reference in Visual Studio 2003, I get an
error message "The proxy settings on this computer are not configured
correctly for web discovery. ..." This web reference is to a service on my
machine - http://localhost/... - so I don't know why any proxy configuration
should be necessary.

Doing the same thing in Visual Studio 2002 works fine (i.e., no error about
"proxy settings"). However, when I update the project to 2003, and then try
to update the web reference I get "Child nodes are not allowed.
(c:\...\v1.1.4322\Config\machine.config line 3253). I've looked at my
machine.config, the lines in question are just
<webServices>
<protocols>
<add name="HttpSoap1.2">
</add>
<add name="HttpSoap">
</add>

I'm not real sure where things went wrong nor how to fix it. Neither Google
nor MSDN searches turn up much of anything.

Thanks,
Dan
Nov 15 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a

Hi Dan,

I think your problem related to "Troubleshooting Add Web Reference Issues"
situation2, VSDisco (dynamic discovery) is turned off default, you should
turn it on through .config file. For more information, please refer to the
article(situation2 ) below:
http://support.microsoft.com/?kbid=307303

Hope this helps,

Best regards,
Jeffrey Tan
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

--------------------
| From: "Dan Smith" <J_************@HoTMaiL.com>
| Subject: problems with WebReferences in VS2003
| Date: Thu, 23 Oct 2003 15:11:33 -0400
| Lines: 25
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| Message-ID: <#i**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.languages.csharp
| NNTP-Posting-Host: adeskout.autodesk.com 198.102.112.18
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.csharp:193618
| X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
|
| When I try to create a new C# Web Reference in Visual Studio 2003, I get
an
| error message "The proxy settings on this computer are not configured
| correctly for web discovery. ..." This web reference is to a service on
my
| machine - http://localhost/... - so I don't know why any proxy
configuration
| should be necessary.
|
| Doing the same thing in Visual Studio 2002 works fine (i.e., no error
about
| "proxy settings"). However, when I update the project to 2003, and then
try
| to update the web reference I get "Child nodes are not allowed.
| (c:\...\v1.1.4322\Config\machine.config line 3253). I've looked at my
| machine.config, the lines in question are just
| <webServices>
| <protocols>
| <add name="HttpSoap1.2">
| </add>
| <add name="HttpSoap">
| </add>
|
| I'm not real sure where things went wrong nor how to fix it. Neither
Google
| nor MSDN searches turn up much of anything.
|
| Thanks,
| Dan
|
|
|

Nov 15 '05 #2

P: n/a
I've uncommented the "vsdisco" line in machine.config for 1.0 and added it
for 1.1. Things are still exactly the same: web references works fine in
VS2002, but can't update in 2003 after converting project; can't create a
new web reference in 2003.

Dan

""Jeffrey Tan[MSFT]"" <v-*****@online.microsoft.com> wrote in message
news:4r**************@cpmsftngxa06.phx.gbl...

Hi Dan,

I think your problem related to "Troubleshooting Add Web Reference Issues"
situation2, VSDisco (dynamic discovery) is turned off default, you should
turn it on through .config file. For more information, please refer to the
article(situation2 ) below:
http://support.microsoft.com/?kbid=307303

Hope this helps,

Best regards,
Jeffrey Tan
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

--------------------
| From: "Dan Smith" <J_************@HoTMaiL.com>
| Subject: problems with WebReferences in VS2003
| Date: Thu, 23 Oct 2003 15:11:33 -0400
| Lines: 25
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| Message-ID: <#i**************@TK2MSFTNGP12.phx.gbl>
| Newsgroups: microsoft.public.dotnet.languages.csharp
| NNTP-Posting-Host: adeskout.autodesk.com 198.102.112.18
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.csharp:193618 | X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
|
| When I try to create a new C# Web Reference in Visual Studio 2003, I get
an
| error message "The proxy settings on this computer are not configured
| correctly for web discovery. ..." This web reference is to a service on
my
| machine - http://localhost/... - so I don't know why any proxy
configuration
| should be necessary.
|
| Doing the same thing in Visual Studio 2002 works fine (i.e., no error
about
| "proxy settings"). However, when I update the project to 2003, and then
try
| to update the web reference I get "Child nodes are not allowed.
| (c:\...\v1.1.4322\Config\machine.config line 3253). I've looked at my
| machine.config, the lines in question are just
| <webServices>
| <protocols>
| <add name="HttpSoap1.2">
| </add>
| <add name="HttpSoap">
| </add>
|
| I'm not real sure where things went wrong nor how to fix it. Neither
Google
| nor MSDN searches turn up much of anything.
|
| Thanks,
| Dan
|
|
|

Nov 15 '05 #3

P: n/a

Hi Dan,

I think you can first try to access your web service through IE to ensure
that your web service is available.
If it is available through IE, you can try to use "http://url.asmx?wsdl" to
save the wsdl file and directly refer this wsdl file.

I think you also can try to set up a new project to do the same things as
your problem project.
Does this error still generate in new project?

For more, you can try another way of enable discovery Web service in the
article below:
http://msdn.microsoft.com/library/de...us/cpguide/htm
l/cpconenablingdiscoveryforwebservice.asp

Best regards,
Jeffrey Tan
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

--------------------
| From: "Dan Smith" <J_************@HoTMaiL.com>
| References: <#i**************@TK2MSFTNGP12.phx.gbl>
<4r**************@cpmsftngxa06.phx.gbl>
| Subject: Re: problems with WebReferences in VS2003
| Date: Fri, 24 Oct 2003 09:27:21 -0400
| Lines: 78
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| Message-ID: <#9**************@TK2MSFTNGP09.phx.gbl>
| Newsgroups: microsoft.public.dotnet.languages.csharp
| NNTP-Posting-Host: adeskout.autodesk.com 198.102.112.18
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.csharp:193804
| X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
|
| I've uncommented the "vsdisco" line in machine.config for 1.0 and added it
| for 1.1. Things are still exactly the same: web references works fine in
| VS2002, but can't update in 2003 after converting project; can't create a
| new web reference in 2003.
|
| Dan
|
| ""Jeffrey Tan[MSFT]"" <v-*****@online.microsoft.com> wrote in message
| news:4r**************@cpmsftngxa06.phx.gbl...
| >
| > Hi Dan,
| >
| > I think your problem related to "Troubleshooting Add Web Reference
Issues"
| > situation2, VSDisco (dynamic discovery) is turned off default, you
should
| > turn it on through .config file. For more information, please refer to
the
| > article(situation2 ) below:
| > http://support.microsoft.com/?kbid=307303
| >
| > Hope this helps,
| >
| > Best regards,
| > Jeffrey Tan
| > Microsoft Online Partner Support
| > Get Secure! - www.microsoft.com/security
| > This posting is provided "as is" with no warranties and confers no
rights.
| >
| > --------------------
| > | From: "Dan Smith" <J_************@HoTMaiL.com>
| > | Subject: problems with WebReferences in VS2003
| > | Date: Thu, 23 Oct 2003 15:11:33 -0400
| > | Lines: 25
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| > | Message-ID: <#i**************@TK2MSFTNGP12.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.languages.csharp
| > | NNTP-Posting-Host: adeskout.autodesk.com 198.102.112.18
| > | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
| > | Xref: cpmsftngxa06.phx.gbl
| microsoft.public.dotnet.languages.csharp:193618
| > | X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
| > |
| > | When I try to create a new C# Web Reference in Visual Studio 2003, I
get
| > an
| > | error message "The proxy settings on this computer are not configured
| > | correctly for web discovery. ..." This web reference is to a service
on
| > my
| > | machine - http://localhost/... - so I don't know why any proxy
| > configuration
| > | should be necessary.
| > |
| > | Doing the same thing in Visual Studio 2002 works fine (i.e., no error
| > about
| > | "proxy settings"). However, when I update the project to 2003, and
then
| > try
| > | to update the web reference I get "Child nodes are not allowed.
| > | (c:\...\v1.1.4322\Config\machine.config line 3253). I've looked at my
| > | machine.config, the lines in question are just
| > | <webServices>
| > | <protocols>
| > | <add name="HttpSoap1.2">
| > | </add>
| > | <add name="HttpSoap">
| > | </add>
| > |
| > | I'm not real sure where things went wrong nor how to fix it. Neither
| > Google
| > | nor MSDN searches turn up much of anything.
| > |
| > | Thanks,
| > | Dan
| > |
| > |
| > |
| >
|
|
|

Nov 15 '05 #4

P: n/a
Getting the WSDL through IE worked fine, and this already was a simple test
case.

Anyway, I removed and then (re)installed .NET 1.1 and VS2003; things are
working fine now.

Dan

""Jeffrey Tan[MSFT]"" <v-*****@online.microsoft.com> wrote in message
news:03**************@cpmsftngxa06.phx.gbl...

Hi Dan,

I think you can first try to access your web service through IE to ensure
that your web service is available.
If it is available through IE, you can try to use "http://url.asmx?wsdl" to save the wsdl file and directly refer this wsdl file.

I think you also can try to set up a new project to do the same things as
your problem project.
Does this error still generate in new project?

For more, you can try another way of enable discovery Web service in the
article below:
http://msdn.microsoft.com/library/de...us/cpguide/htm l/cpconenablingdiscoveryforwebservice.asp

Best regards,
Jeffrey Tan
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

--------------------
| From: "Dan Smith" <J_************@HoTMaiL.com>
| References: <#i**************@TK2MSFTNGP12.phx.gbl>
<4r**************@cpmsftngxa06.phx.gbl>
| Subject: Re: problems with WebReferences in VS2003
| Date: Fri, 24 Oct 2003 09:27:21 -0400
| Lines: 78
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| Message-ID: <#9**************@TK2MSFTNGP09.phx.gbl>
| Newsgroups: microsoft.public.dotnet.languages.csharp
| NNTP-Posting-Host: adeskout.autodesk.com 198.102.112.18
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.csharp:193804 | X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
|
| I've uncommented the "vsdisco" line in machine.config for 1.0 and added it | for 1.1. Things are still exactly the same: web references works fine in | VS2002, but can't update in 2003 after converting project; can't create a | new web reference in 2003.
|
| Dan
|
| ""Jeffrey Tan[MSFT]"" <v-*****@online.microsoft.com> wrote in message
| news:4r**************@cpmsftngxa06.phx.gbl...
| >
| > Hi Dan,
| >
| > I think your problem related to "Troubleshooting Add Web Reference
Issues"
| > situation2, VSDisco (dynamic discovery) is turned off default, you
should
| > turn it on through .config file. For more information, please refer to
the
| > article(situation2 ) below:
| > http://support.microsoft.com/?kbid=307303
| >
| > Hope this helps,
| >
| > Best regards,
| > Jeffrey Tan
| > Microsoft Online Partner Support
| > Get Secure! - www.microsoft.com/security
| > This posting is provided "as is" with no warranties and confers no
rights.
| >
| > --------------------
| > | From: "Dan Smith" <J_************@HoTMaiL.com>
| > | Subject: problems with WebReferences in VS2003
| > | Date: Thu, 23 Oct 2003 15:11:33 -0400
| > | Lines: 25
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| > | Message-ID: <#i**************@TK2MSFTNGP12.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.languages.csharp
| > | NNTP-Posting-Host: adeskout.autodesk.com 198.102.112.18
| > | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
| > | Xref: cpmsftngxa06.phx.gbl
| microsoft.public.dotnet.languages.csharp:193618
| > | X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
| > |
| > | When I try to create a new C# Web Reference in Visual Studio 2003, I
get
| > an
| > | error message "The proxy settings on this computer are not configured | > | correctly for web discovery. ..." This web reference is to a service on
| > my
| > | machine - http://localhost/... - so I don't know why any proxy
| > configuration
| > | should be necessary.
| > |
| > | Doing the same thing in Visual Studio 2002 works fine (i.e., no error | > about
| > | "proxy settings"). However, when I update the project to 2003, and
then
| > try
| > | to update the web reference I get "Child nodes are not allowed.
| > | (c:\...\v1.1.4322\Config\machine.config line 3253). I've looked at my | > | machine.config, the lines in question are just
| > | <webServices>
| > | <protocols>
| > | <add name="HttpSoap1.2">
| > | </add>
| > | <add name="HttpSoap">
| > | </add>
| > |
| > | I'm not real sure where things went wrong nor how to fix it. Neither | > Google
| > | nor MSDN searches turn up much of anything.
| > |
| > | Thanks,
| > | Dan
| > |
| > |
| > |
| >
|
|
|

Nov 15 '05 #5

P: n/a

Hi Dan,

I am glad it finally works fine.
I think it must be something wrong with part component of your previous
.Net Framework.
If you still have any question, please feel free to let me know, I am glad
to work with you.

Best regards,
Jeffrey Tan
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

--------------------
| From: "Dan Smith" <J_************@HoTMaiL.com>
| References: <#i**************@TK2MSFTNGP12.phx.gbl>
<4r**************@cpmsftngxa06.phx.gbl>
<#9**************@TK2MSFTNGP09.phx.gbl>
<03**************@cpmsftngxa06.phx.gbl>
| Subject: Re: problems with WebReferences in VS2003
| Date: Sat, 25 Oct 2003 15:24:35 -0400
| Lines: 151
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| Message-ID: <Oz**************@TK2MSFTNGP09.phx.gbl>
| Newsgroups: microsoft.public.dotnet.languages.csharp
| NNTP-Posting-Host: adeskout.autodesk.com 198.102.112.18
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.csharp:194049
| X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
|
| Getting the WSDL through IE worked fine, and this already was a simple
test
| case.
|
| Anyway, I removed and then (re)installed .NET 1.1 and VS2003; things are
| working fine now.
|
| Dan
|
| ""Jeffrey Tan[MSFT]"" <v-*****@online.microsoft.com> wrote in message
| news:03**************@cpmsftngxa06.phx.gbl...
| >
| > Hi Dan,
| >
| > I think you can first try to access your web service through IE to
ensure
| > that your web service is available.
| > If it is available through IE, you can try to use "http://url.asmx?wsdl"
| to
| > save the wsdl file and directly refer this wsdl file.
| >
| > I think you also can try to set up a new project to do the same things
as
| > your problem project.
| > Does this error still generate in new project?
| >
| > For more, you can try another way of enable discovery Web service in the
| > article below:
| >
|
http://msdn.microsoft.com/library/de...us/cpguide/htm
| > l/cpconenablingdiscoveryforwebservice.asp
| >
| > Best regards,
| > Jeffrey Tan
| > Microsoft Online Partner Support
| > Get Secure! - www.microsoft.com/security
| > This posting is provided "as is" with no warranties and confers no
rights.
| >
| > --------------------
| > | From: "Dan Smith" <J_************@HoTMaiL.com>
| > | References: <#i**************@TK2MSFTNGP12.phx.gbl>
| > <4r**************@cpmsftngxa06.phx.gbl>
| > | Subject: Re: problems with WebReferences in VS2003
| > | Date: Fri, 24 Oct 2003 09:27:21 -0400
| > | Lines: 78
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| > | Message-ID: <#9**************@TK2MSFTNGP09.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.languages.csharp
| > | NNTP-Posting-Host: adeskout.autodesk.com 198.102.112.18
| > | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
| > | Xref: cpmsftngxa06.phx.gbl
| microsoft.public.dotnet.languages.csharp:193804
| > | X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
| > |
| > | I've uncommented the "vsdisco" line in machine.config for 1.0 and
added
| it
| > | for 1.1. Things are still exactly the same: web references works fine
| in
| > | VS2002, but can't update in 2003 after converting project; can't
create
| a
| > | new web reference in 2003.
| > |
| > | Dan
| > |
| > | ""Jeffrey Tan[MSFT]"" <v-*****@online.microsoft.com> wrote in message
| > | news:4r**************@cpmsftngxa06.phx.gbl...
| > | >
| > | > Hi Dan,
| > | >
| > | > I think your problem related to "Troubleshooting Add Web Reference
| > Issues"
| > | > situation2, VSDisco (dynamic discovery) is turned off default, you
| > should
| > | > turn it on through .config file. For more information, please refer
to
| > the
| > | > article(situation2 ) below:
| > | > http://support.microsoft.com/?kbid=307303
| > | >
| > | > Hope this helps,
| > | >
| > | > Best regards,
| > | > Jeffrey Tan
| > | > Microsoft Online Partner Support
| > | > Get Secure! - www.microsoft.com/security
| > | > This posting is provided "as is" with no warranties and confers no
| > rights.
| > | >
| > | > --------------------
| > | > | From: "Dan Smith" <J_************@HoTMaiL.com>
| > | > | Subject: problems with WebReferences in VS2003
| > | > | Date: Thu, 23 Oct 2003 15:11:33 -0400
| > | > | Lines: 25
| > | > | X-Priority: 3
| > | > | X-MSMail-Priority: Normal
| > | > | X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| > | > | Message-ID: <#i**************@TK2MSFTNGP12.phx.gbl>
| > | > | Newsgroups: microsoft.public.dotnet.languages.csharp
| > | > | NNTP-Posting-Host: adeskout.autodesk.com 198.102.112.18
| > | > | Path:
cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP12.phx.gbl
| > | > | Xref: cpmsftngxa06.phx.gbl
| > | microsoft.public.dotnet.languages.csharp:193618
| > | > | X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
| > | > |
| > | > | When I try to create a new C# Web Reference in Visual Studio
2003, I
| > get
| > | > an
| > | > | error message "The proxy settings on this computer are not
| configured
| > | > | correctly for web discovery. ..." This web reference is to a
| service
| > on
| > | > my
| > | > | machine - http://localhost/... - so I don't know why any proxy
| > | > configuration
| > | > | should be necessary.
| > | > |
| > | > | Doing the same thing in Visual Studio 2002 works fine (i.e., no
| error
| > | > about
| > | > | "proxy settings"). However, when I update the project to 2003,
and
| > then
| > | > try
| > | > | to update the web reference I get "Child nodes are not allowed.
| > | > | (c:\...\v1.1.4322\Config\machine.config line 3253). I've looked
at
| my
| > | > | machine.config, the lines in question are just
| > | > | <webServices>
| > | > | <protocols>
| > | > | <add name="HttpSoap1.2">
| > | > | </add>
| > | > | <add name="HttpSoap">
| > | > | </add>
| > | > |
| > | > | I'm not real sure where things went wrong nor how to fix it.
| Neither
| > | > Google
| > | > | nor MSDN searches turn up much of anything.
| > | > |
| > | > | Thanks,
| > | > | Dan
| > | > |
| > | > |
| > | > |
| > | >
| > |
| > |
| > |
| >
|
|
|

Nov 15 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.