By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,664 Members | 1,705 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,664 IT Pros & Developers. It's quick & easy.

datetimepicker

P: n/a
L.S.

in my application I changed the current culture with the following
code:

CultureInfo newCulture = new CultureInfo("nl-nl");
newCulture.DateTimeFormat.DayNames = new string[]
{"Sunday","Monday", "Tuesday", "Wednesday", "Thursday", "Friday",
"Saturday"} ;
//newCulture.DateTimeFormat.AbbreviatedDayNames

Thread.CurrentThread.CurrentCulture = newCulture;
Thread.CurrentThread.CurrentUICulture = newCulture;

but my datetimepicker still displays the days of the week with the
settings of my computer (which are dutch). How can I change these
settings??
I cannot find an appropriate help on this.

Erald
Nov 15 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Try setting these as the first instruction in the Main

Then Application.Run(new MainForm());
Hope this helps

Dan Cimpoiesu

"Erald Kulk" <er***@delta-travel.nl> wrote in message
news:d9**************************@posting.google.c om...
L.S.

in my application I changed the current culture with the following
code:

CultureInfo newCulture = new CultureInfo("nl-nl");
newCulture.DateTimeFormat.DayNames = new string[]
{"Sunday","Monday", "Tuesday", "Wednesday", "Thursday", "Friday",
"Saturday"} ;
//newCulture.DateTimeFormat.AbbreviatedDayNames

Thread.CurrentThread.CurrentCulture = newCulture;
Thread.CurrentThread.CurrentUICulture = newCulture;

but my datetimepicker still displays the days of the week with the
settings of my computer (which are dutch). How can I change these
settings??
I cannot find an appropriate help on this.

Erald

Nov 15 '05 #2

P: n/a
Dan Cimpoiesu,

thanks for trying. But it doesn't work.

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 15 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.