By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,463 Members | 2,954 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,463 IT Pros & Developers. It's quick & easy.

Compiler problems

P: n/a
I compile my project. No errors. Then I hit my page and I get an

Error in Application "/"

[No relevant source lines]

I change nothing and recompile. Works fine. If I compile twice in a row,
still get the error. I have to compile, hit the page, compile again.
Every single time. It is driving me batty. Anyone know the solution for
this?

-Cam

Nov 15 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Hi,

I know very little about visual studio, and you've told us even less of your
situation (hit the page? sorry not too familiar with asp.net).

I'll have a guess anyway -> try doing rebuild all instead of compile.

Just a complete shot in the dark.

Pete

cameron wrote:
I compile my project. No errors. Then I hit my page and I get an

Error in Application "/"

[No relevant source lines]

I change nothing and recompile. Works fine. If I compile twice in a
row, still get the error. I have to compile, hit the page, compile
again. Every single time. It is driving me batty. Anyone know the
solution for this?

-Cam

Nov 15 '05 #2

P: n/a
Hit the page == load the page up in the web browser

I have tried doing builds and rebuilds. Same issue.

-Cam

Nov 15 '05 #3

P: n/a

Hi Cameron,

Does it work now?
If it still does not work, please feel free to let me know.

Best regards,
Jeffrey Tan
Microsoft Online Partner Support
Get Secure! - www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

--------------------
| X-Tomcat-ID: 137089916
| References: <3F**************@appdepot.com>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: v-*****@online.microsoft.com (Jeffrey Tan[MSFT])
| Organization: Microsoft
| Date: Fri, 29 Aug 2003 07:22:03 GMT
| Subject: RE: Compiler problems
| X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
| Message-ID: <IN**************@cpmsftngxa06.phx.gbl>
| Newsgroups: microsoft.public.dotnet.languages.csharp
| Lines: 124
| Path: cpmsftngxa06.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.dotnet.languages.csharp:180539
| NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
|
|
| Hi Cameron,
|
| These access denied errors were cause because the aspnet_wp.exe was not
| running
| under the correct context.
|
| Here are the steps to fix this:
|
|
|
| Steps to develop using a remote file share located on a different computer
|
| 1) On the remote computer
|
| a) Create a share on the remote computer
|
| b) Make sure that the .NET Framework has been installed on the remote
| computer
|
| c) Give the ASP.NET developer full NTFS control to this directory
|
| 2) On the development box
|
| a) Make sure that IIS is installed
|
| b) Open Internet Information Services Manager
|
| i) Click Start
|
| ii) Select Run
|
| iii) Type inetmgr
|
| iv) Press Enter
|
| c) Point the Default Web Site to use the remote file share
|
| i) Right Click the Default Web Site
|
| ii) Select Properties
|
| iii) Select the Home Directory Tab
|
| iv) Under "When connecting to this resource, the content should
| come
| from? " Select a share located on another computer?
| v) Type the path to the remote share (i.e.
| <\\somecomputername\somesharename>)
|
| vi) If prompted, supply the connect as information
|
| (1) For the username you should use DomainName\UserName
|
| (2) For the password, you should use this users domain
| password
|
| vii) If you did not get prompted, select the Connect As button
and
| provide the required information.
|
| d) Make sure that Visual Studio .NET and the .NET Framework are
installed.
|
| e) Add the ASP.NET developer to both the VS Developers and Debugger
Users
| groups
|
| f) Open the machine.config file from the C:\<window
| directory>\Microsoft.NET\Framework\v1.0.3705\CONFI G
|
| i) Find the <processModel> element; make sure that this is not
the
| commented out section
|
| ii) Set the username="DomainName\UserName"
|
| iii) Set the password="DomainNamePassword"
|
| g) Reset IIS
|
| i) Click Start
|
| ii) Select Run
|
| iii) Type iisreset
|
| iv) Press Enter
|
| h) If you have made changes to the .NET Framework code security or if
you
| are unsure, run the following
|
| i) Click Start
|
| ii) Select Run
|
| iii) Type caspol -machine -recover
|
| iv) Press Enter
|
| i) Open the Microsoft .NET Framework Configuration tool
|
| i) Click Start
|
| ii) Go to Settings
|
| iii) Select Control Panel
|
| iv) Double click Administrative Tools
|
| v) Double click on the Microsoft .NET Framework Configuration
icon
|
| j) Create a new code group
|
| i) Expand Runtime Security Policy
|
| ii) Expand Machine
|
| iii) Expand All_Code
|
| iv) Right Click LocalIntranet_Zone
|
| v) Select New
|
| vi) In the Create Code Group window
|
| (1) Give the code group a name, click Next
|
| (2) From Choose the condition type? select URL
|
| (3) For the URL, type <file://machinename/sharename/*>;
| Click Next
|
| (4) Select Use existing permission set and select
| FullTrust; Click Next
|
| (5) Click Finish
|
| k) Reset IIS
|
| i) Click Start
|
| ii) Select Run
|
| iii) Type iisreset
|
| iv) Press Enter
|
|
|
| You should now be able to create and debug applications on your local
| machine
|
| Hope this helps.
|
| Best regards,
| Jeffrey Tan
| Microsoft Online Partner Support
| Get Secure! - www.microsoft.com/security
| This posting is provided "as is" with no warranties and confers no rights.
|
| --------------------
| | Message-ID: <3F**************@appdepot.com>
| | Date: Thu, 28 Aug 2003 14:39:05 -0600
| | From: cameron <ca****************@appdepot.com>
| | User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0)
| Gecko/20020530
| | X-Accept-Language: en-us, en
| | MIME-Version: 1.0
| | Subject: Compiler problems
| | Content-Type: text/plain; charset=us-ascii; format=flowed
| | Content-Transfer-Encoding: 7bit
| | Newsgroups:
|
microsoft.public.dotnet.languages.csharp,microsoft .public.dotnet.framework.a
| spnet
| | NNTP-Posting-Host: hsdbrg64-201-211-159.sasknet.sk.ca 64.201.211.159
| | Lines: 1
| | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
| | Xref: cpmsftngxa06.phx.gbl
| microsoft.public.dotnet.framework.aspnet:172442
| microsoft.public.dotnet.languages.csharp:180391
| | X-Tomcat-NG: microsoft.public.dotnet.languages.csharp
| |
| | I compile my project. No errors. Then I hit my page and I get an
| |
| | Error in Application "/"
| |
| | [No relevant source lines]
| |
| | I change nothing and recompile. Works fine. If I compile twice in a
row,
| | still get the error. I have to compile, hit the page, compile again.
| | Every single time. It is driving me batty. Anyone know the solution for
| | this?
| |
| | -Cam
| |
| |
|
|

Nov 15 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.