By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,811 Members | 785 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,811 IT Pros & Developers. It's quick & easy.

customerrors tag doesnt works

P: n/a
Hi,

i am delevoping an ASP.NET website which worked well on my old web host and
now working on localhost but now it doesnt works on my new host. i have new
registered and ftp the files that work on previous host. now it shows the
classic runtime eror page which explains how to enable customerrors tag.
the problem is my website is configured to show my custom error page. what
is the problem? why the customerors tag doesnt work?
my Web.Config file is:

<?xml version="1.0"?>
<configuration>
<appSettings>
</appSettings>
<connectionStrings>
<add name=..../>
</connectionStrings>
<system.web>
<authentication mode="Forms">
<forms name..../>
</authentication>
<authorization>
<allow users="*"/>
</authorization>
<customErrors mode="RemoteOnly" defaultRedirect="YapimAsamasinda.htm">
<error statusCode="403" redirect="YapimAsamasinda.htm"/>
<error statusCode="404" redirect="YapimAsamasinda.htm"/>
</customErrors>
<compilation debug="true">
<assemblies>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=B03F5F7F11D50A3A"/>
</assemblies>
</compilation>
</system.web>
</configuration>

the site is shown as:

Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrorstag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrorstag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrorsconfiguration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
Sep 3 '08 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Tahir wrote:
Hi,

i am delevoping an ASP.NET website which worked well on my old web host
and now working on localhost but now it doesnt works on my new host. i
have new registered and ftp the files that work on previous host. now
it shows the classic runtime eror page which explains how to enable
customerrors tag. the problem is my website is configured to show my
custom error page. what is the problem? why the customerors tag doesnt
work?
my Web.Config file is:

<?xml version="1.0"?>
<configuration>
<appSettings>
</appSettings>
<connectionStrings>
<add name=..../>
</connectionStrings>
<system.web>
<authentication mode="Forms">
<forms name..../>
</authentication>
<authorization>
<allow users="*"/>
</authorization>
<customErrors mode="RemoteOnly" defaultRedirect="YapimAsamasinda.htm">
Try with mode="Off" so that you see the actual error message. That may
help to find out what the main problem is.
Use an url relative to the root instead of an url relative to the
current folder:

~/YapimAsamasinda.htm

That way you get redirected to the same page even if the error occurs in
a page in a subfolder.
<error statusCode="403" redirect="YapimAsamasinda.htm"/>
<error statusCode="404" redirect="YapimAsamasinda.htm"/>
</customErrors>
<compilation debug="true">
<assemblies>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=B03F5F7F11D50A3A"/>
</assemblies>
</compilation>
</system.web>
</configuration>

the site is shown as:

Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons). It
could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrorstag within a
"web.config" configuration file located in the root directory of the
current web application. This <customErrorstag should then have its
"mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the
application's <customErrorsconfiguration tag to point to a custom
error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>


--
Göran Andersson
_____
http://www.guffa.com
Sep 3 '08 #2

P: n/a
"Göran Andersson" <gu***@guffa.comwrote in message
news:%2****************@TK2MSFTNGP06.phx.gbl...
Use an url relative to the root instead of an url relative to the current
folder:

~/YapimAsamasinda.htm

That way you get redirected to the same page even if the error occurs in a
page in a subfolder.
I suspect that's the problem i.e. the error is occurring on a page in a
subfolder, and the top-level error message is that the error page can't be
found...
--
Mark Rae
ASP.NET MVP
http://www.markrae.net

Sep 3 '08 #3

P: n/a
ok, i found that the error was my site isnot configured as .NET 2.0
application >:(
thanks for replies.
"Tahir" <ku*********@gmail.com>, iletisinde şunu yazdı,
news:97**********************************@microsof t.com...
Hi,

i am delevoping an ASP.NET website which worked well on my old web host
and now working on localhost but now it doesnt works on my new host. i
have new registered and ftp the files that work on previous host. now it
shows the classic runtime eror page which explains how to enable
customerrors tag. the problem is my website is configured to show my
custom error page. what is the problem? why the customerors tag doesnt
work?
my Web.Config file is:

<?xml version="1.0"?>
<configuration>
<appSettings>
</appSettings>
<connectionStrings>
<add name=..../>
</connectionStrings>
<system.web>
<authentication mode="Forms">
<forms name..../>
</authentication>
<authorization>
<allow users="*"/>
</authorization>
<customErrors mode="RemoteOnly" defaultRedirect="YapimAsamasinda.htm">
<error statusCode="403" redirect="YapimAsamasinda.htm"/>
<error statusCode="404" redirect="YapimAsamasinda.htm"/>
</customErrors>
<compilation debug="true">
<assemblies>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=B03F5F7F11D50A3A"/>
</assemblies>
</compilation>
</system.web>
</configuration>

the site is shown as:

Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons). It
could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrorstag within a
"web.config" configuration file located in the root directory of the
current web application. This <customErrorstag should then have its
"mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the
application's <customErrorsconfiguration tag to point to a custom error
page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"
defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Sep 4 '08 #4

This discussion thread is closed

Replies have been disabled for this discussion.