By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,741 Members | 2,033 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,741 IT Pros & Developers. It's quick & easy.

Sessions seem to time out too soon

P: n/a
Hi all,

In a private Web Application (VS2008 VB.NET) the users were complaining that
the default session time was too short, because if they stop for a phone
call or any distraction, they get logged out of what they were doing. I
tried to increase the Timeout to 90 minutes. I just now walked away from my
computer for about 20 minutes and I came back to find out my session had
timed out.

Here is part of the Web.config that I thought would extend the session
timeout.

<sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424"
sqlCommandTimeout="180" cookieName="PC.NET_SessionId" timeout="90"/>

There is only one web.config file in the root of the site.

What am I doing wrong?

Thanks for any help...
Aug 28 '08 #1
Share this Question
Share on Google+
3 Replies


P: n/a
"John Kotuby" <jk*******@comcast.netwrote in message
news:ur**************@TK2MSFTNGP05.phx.gbl...
Hi all,

In a private Web Application (VS2008 VB.NET) the users were complaining
that
the default session time was too short, because if they stop for a phone
call or any distraction, they get logged out of what they were doing. I
tried to increase the Timeout to 90 minutes. I just now walked away from
my
computer for about 20 minutes and I came back to find out my session had
timed out.

Here is part of the Web.config that I thought would extend the session
timeout.

<sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424"
sqlCommandTimeout="180" cookieName="PC.NET_SessionId" timeout="90"/>

There is only one web.config file in the root of the site.

What am I doing wrong?

The worker process will also have a idle timeout set in the application pool
settings. It defaults to 20 minutes.
Hence if all users end on the phone all at the same time for 20 minutes then
despite the session timeout still having some time left the whole app will
have been torn down.

In reality this situation only really happens in testing, however since it
doesn't make sense to a have idle pool timeout less than the maximum session
timeout set for apps that run in it you should change it.
--
Anthony Jones - MVP ASP/ASP.NET
Aug 28 '08 #2

P: n/a
Thank you Anthony,

This did happen during testing.

However, at some loactions where the application is deployed on a local
Intranet it's entirely possible that at times there might be only one user
who will then experience a timeout at 20 minutes. Now I just have to find
out where to change the idle pool timeout.

"Anthony Jones" <An*@yadayadayada.comwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
"John Kotuby" <jk*******@comcast.netwrote in message
news:ur**************@TK2MSFTNGP05.phx.gbl...
>Hi all,

In a private Web Application (VS2008 VB.NET) the users were complaining
that
>the default session time was too short, because if they stop for a phone
call or any distraction, they get logged out of what they were doing. I
tried to increase the Timeout to 90 minutes. I just now walked away from
my
>computer for about 20 minutes and I came back to find out my session had
timed out.

Here is part of the Web.config that I thought would extend the session
timeout.

<sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424"
sqlCommandTimeout="180" cookieName="PC.NET_SessionId" timeout="90"/>

There is only one web.config file in the root of the site.

What am I doing wrong?


The worker process will also have a idle timeout set in the application
pool
settings. It defaults to 20 minutes.
Hence if all users end on the phone all at the same time for 20 minutes
then
despite the session timeout still having some time left the whole app will
have been torn down.

In reality this situation only really happens in testing, however since it
doesn't make sense to a have idle pool timeout less than the maximum
session
timeout set for apps that run in it you should change it.
--
Anthony Jones - MVP ASP/ASP.NET


Aug 28 '08 #3

P: n/a
"John Kotuby" <jk*******@comcast.netwrote in message
news:uz**************@TK2MSFTNGP02.phx.gbl...
Thank you Anthony,

This did happen during testing.

However, at some loactions where the application is deployed on a local
Intranet it's entirely possible that at times there might be only one user
who will then experience a timeout at 20 minutes. Now I just have to find
out where to change the idle pool timeout.
In IIS7 select the App pool in the tree pane and click Advanced Settings...
In the Process Model category you will see Idle Time-out

In IIS6 open properties dialog on App Pool on Performance Tab there is an
Idle timeout box.


--
Anthony Jones - MVP ASP/ASP.NET

Aug 28 '08 #4

This discussion thread is closed

Replies have been disabled for this discussion.