By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,712 Members | 1,421 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,712 IT Pros & Developers. It's quick & easy.

another ASP.net AJAX Extensions - Scriptmanager.axd 404

P: n/a
Yan
Hi,

I'm apparently far from being the 1st one to meet this error... My
asp.net ajax page requires ScriptManager.axd but gets a 404.

following a lot of "This is how I solved it" posts, I :
- checked my web.config (copied below)
- re-installed the ajax.net extensions
- ran aspnet_regiis my application

the application runs perfectly OK on my dev machine.

The thing is, my dev machine runs on Vista (IIS7) and the web server
is a 2003 (IIS6). Could it be the source of the problem ? Then, any
solution around ?

---------------------------------- web.config
----------------------------------
<?xml version="1.0"?>
<!--
Note: As an alternative to hand editing this file you can use the
web admin tool to configure settings for your application. Use
the Website->Asp.Net Configuration option in Visual Studio.
A full list of settings and comments can be found in
machine.config.comments usually located in
\Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
<configSections>
<sectionGroup name="system.web.extensions"
type="System.Web.Configuration.SystemWebExtensions SectionGroup,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35">
<sectionGroup name="scripting"
type="System.Web.Configuration.ScriptingSectionGro up,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35">
<section name="scriptResourceHandler"
type="System.Web.Configuration.ScriptingScriptReso urceHandlerSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="MachineToApplication"/>
<sectionGroup name="webServices"
type="System.Web.Configuration.ScriptingWebService sSectionGroup,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35">
<section name="jsonSerialization"
type="System.Web.Configuration.ScriptingJsonSerial izationSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="Everywhere" />
<section name="profileService"
type="System.Web.Configuration.ScriptingProfileSer viceSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="MachineToApplication" />
<section name="authenticationService"
type="System.Web.Configuration.ScriptingAuthentica tionServiceSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="MachineToApplication" />
</sectionGroup>
</sectionGroup>
</sectionGroup>
</configSections>
<appSettings>
</appSettings>
<connectionStrings/>
<system.web>
<!--

Set compilation debug="true" to insert debugging
symbols into the compiled page. Because this
affects performance, set this value to true only
during development.

Visual Basic options:
Set strict="true" to disallow all data type conversions
where data loss can occur.
Set explicit="true" to force declaration of all variables.
-->
<compilation debug="true" strict="false" explicit="true">
<assemblies>
<add assembly="System.Management, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Windows.Forms, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Runtime.Serialization.Formatters. Soap,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
<add assembly="System.Web.Extensions, Version=1.0.61025.0,
Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
</assemblies>
</compilation>
<httpHandlers>
<remove verb="*" path="*.asmx"/>
<add verb="*" path="*.asmx" validate="false"
type="System.Web.Script.Services.ScriptHandlerFact ory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
<add verb="*" path="*_AppService.axd" validate="false"
type="System.Web.Script.Services.ScriptHandlerFact ory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
<add verb="GET,HEAD" path="ScriptResource.axd"
type="System.Web.Handlers.ScriptResourceHandler,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" validate="false"/>
</httpHandlers>
<httpModules>
<add name="ScriptModule" type="System.Web.Handlers.ScriptModule,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
</httpModules>
<pages>
<namespaces>
<clear/>
<add namespace="System"/>
<add namespace="System.Collections"/>
<add namespace="System.Collections.Specialized"/>
<add namespace="System.Configuration"/>
<add namespace="System.Text"/>
<add namespace="System.Text.RegularExpressions"/>
<add namespace="System.Web"/>
<add namespace="System.Web.Caching"/>
<add namespace="System.Web.SessionState"/>
<add namespace="System.Web.Security"/>
<add namespace="System.Web.Profile"/>
<add namespace="System.Web.UI"/>
<add namespace="System.Web.UI.WebControls"/>
<add namespace="System.Web.UI.WebControls.WebParts"/>
<add namespace="System.Web.UI.HtmlControls"/>
</namespaces>
<controls>
<add tagPrefix="asp" namespace="System.Web.UI"
assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
</controls>

</pages>
<!--
The <authenticationsection enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Windows"/>
<!--
The <customErrorssection enables configuration
of what to do if/when an unhandled error occurs
during the execution of a request. Specifically,
it enables developers to configure html error pages
to be displayed in place of a error stack trace.

<customErrors mode="RemoteOnly"
defaultRedirect="GenericErrorPage.htm">
<error statusCode="403" redirect="NoAccess.htm" />
<error statusCode="404" redirect="FileNotFound.htm" />
</customErrors>
-->
</system.web>
<system.web.extensions>
<scripting>
<webServices>
<!-- Uncomment this line to customize maxJsonLength and add a
custom converter -->
<!--
<jsonSerialization maxJsonLength="500">
<converters>
<add name="ConvertMe"
type="Acme.SubAcme.ConvertMeTypeConverter"/>
</converters>
</jsonSerialization>
-->
<!-- Uncomment this line to enable the authentication service.
Include requireSSL="true" if appropriate. -->
<!--
<authenticationService enabled="true" requireSSL = "true|
false"/>
-->

<!-- Uncomment these lines to enable the profile service. To
allow profile properties to be retrieved
and modified in ASP.NET AJAX applications, you need to add
each property name to the readAccessProperties and
writeAccessProperties attributes. -->
<!--
<profileService enabled="true"

readAccessProperties="propertyname1,propertyname2"

writeAccessProperties="propertyname1,propertyname2 " />
-->
</webServices>
<!--
<scriptResourceHandler enableCompression="true"
enableCaching="true" />
-->
</scripting>
</system.web.extensions>

<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<add name="ScriptModule" preCondition="integratedMode"
type="System.Web.Handlers.ScriptModule, System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/
>
</modules>
<handlers>
<remove name="WebServiceHandlerFactory-Integrated" />
<add name="ScriptHandlerFactory" verb="*" path="*.asmx"
preCondition="integratedMode"
type="System.Web.Script.Services.ScriptHandlerFact ory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
<add name="ScriptHandlerFactoryAppServices" verb="*"
path="*_AppService.axd" preCondition="integratedMode"
type="System.Web.Script.Services.ScriptHandlerFact ory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
<add name="ScriptResource" preCondition="integratedMode"
verb="GET,HEAD" path="ScriptResource.axd"
type="System.Web.Handlers.ScriptResourceHandler,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" />
</handlers>
</system.webServer>
</configuration>
Aug 15 '08 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Yan
I just removed the application from the web server and re-created
it... and I now works.
I restarted IIS several times, but it apparently wasn't enough to
reload the config... At leat everything isOK, I won't commplain :)

Yan.

On 15 août, 15:31, Yan <yan.cornei...@gmail.comwrote:
Hi,

I'm apparently far from being the 1st one to meet this error... My
asp.net ajax page requires *ScriptManager.axd but gets a 404.

following a lot of "This is how I solved it" posts, I :
- checked my web.config (copied below)
- re-installed the ajax.net extensions
- ran aspnet_regiis my application

the application runs perfectly OK on my dev machine.

The thing is, my dev machine runs on Vista (IIS7) and the web server
is a 2003 (IIS6). Could it be the source of the problem ? Then, any
solution around ?

---------------------------------- web.config
----------------------------------
<?xml version="1.0"?>
<!--
* * Note: As an alternative to hand editing this file you can use the
* * web admin tool to configure settings for your application. Use
* * the Website->Asp.Net Configuration option in Visual Studio.
* * A full list of settings and comments can be found in
* * machine.config.comments usually located in
* * \Windows\Microsoft.Net\Framework\v2.x\Config
-->
<configuration>
* <configSections>
* * <sectionGroup name="system.web.extensions"
type="System.Web.Configuration.SystemWebExtensions SectionGroup,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35">
* * * <sectionGroup name="scripting"
type="System.Web.Configuration.ScriptingSectionGro up,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35">
* * * * * <section name="scriptResourceHandler"
type="System.Web.Configuration.ScriptingScriptReso urceHandlerSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="MachineToApplication"/>
* * * * <sectionGroup name="webServices"
type="System.Web.Configuration.ScriptingWebService sSectionGroup,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35">
* * * * * <section name="jsonSerialization"
type="System.Web.Configuration.ScriptingJsonSerial izationSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="Everywhere" />
* * * * * <section name="profileService"
type="System.Web.Configuration.ScriptingProfileSer viceSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="MachineToApplication" />
* * * * * <section name="authenticationService"
type="System.Web.Configuration.ScriptingAuthentica tionServiceSection,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" requirePermission="false"
allowDefinition="MachineToApplication" />
* * * * </sectionGroup>
* * * </sectionGroup>
* * </sectionGroup>
* </configSections>
* * * * <appSettings>
* * * * </appSettings>
* * * * <connectionStrings/>
* * * * <system.web>
* * * * * * * * <!--

* * * * * * Set compilation debug="true" to insert debugging
* * * * * * symbols into the compiled page. Because this
* * * * * * affects performance, set this value to true only
* * * * * * during development.

* * * * * * Visual Basic options:
* * * * * * Set strict="true" to disallow all data type conversions
* * * * * * where data loss can occur.
* * * * * * Set explicit="true" to force declaration of allvariables.
* * * * -->
* * * * * * * * <compilation debug="true" strict="false" explicit="true">
* * * * * * * * * * * * <assemblies>
* * * * * * * * * * * * * * * * <add assembly="System.Management, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
* * * * * * * * * * * * * * * * <add assembly="System.Windows.Forms, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
* * * * * * * * * * * * * * * * <add assembly="System.Design, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=B03F5F7F11D50A3A"/>
* * * * * * * * * * * * * * * * <add assembly="System.Runtime.Serialization.Formatters. Soap,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
* * * * * * * * * * * * * * * * <add assembly="System.Web.Extensions, Version=1.0.61025.0,
Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
* * * * * * * * * * * * </assemblies>
* * * * * * * * </compilation>
* * * * * * * * <httpHandlers>
* * * * * * * * * * * * <remove verb="*" path="*.asmx"/>
* * * * * * * * * * * * <add verb="*" path="*..asmx" validate="false"
type="System.Web.Script.Services.ScriptHandlerFact ory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
* * * * * * * * * * * * <add verb="*" path="*_AppService.axd" validate="false"
type="System.Web.Script.Services.ScriptHandlerFact ory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
* * * * * * * * * * * * <add verb="GET,HEAD" path="ScriptResource.axd"
type="System.Web.Handlers.ScriptResourceHandler,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" validate="false"/>
* * * * * * * * </httpHandlers>
* * * * * * * * <httpModules>
* * * * * * * * * * * * <add name="ScriptModule" type="System.Web.Handlers.ScriptModule,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
* * * * * * * * </httpModules>
* * * * * * * * <pages>
* * * * * * * * * * * * <namespaces>
* * * * * * * * * * * * * * * * <clear/>
* * * * * * * * * * * * * * * * <add namespace="System"/>
* * * * * * * * * * * * * * * * <add namespace="System.Collections"/>
* * * * * * * * * * * * * * * * <add namespace="System.Collections.Specialized"/>
* * * * * * * * * * * * * * * * <add namespace="System.Configuration"/>
* * * * * * * * * * * * * * * * <add namespace="System.Text"/>
* * * * * * * * * * * * * * * * <add namespace="System.Text.RegularExpressions"/>
* * * * * * * * * * * * * * * * <add namespace="System.Web"/>
* * * * * * * * * * * * * * * * <add namespace="System.Web.Caching"/>
* * * * * * * * * * * * * * * * <add namespace="System.Web.SessionState"/>
* * * * * * * * * * * * * * * * <add namespace="System.Web.Security"/>
* * * * * * * * * * * * * * * * <add namespace="System.Web.Profile"/>
* * * * * * * * * * * * * * * * <add namespace="System.Web.UI"/>
* * * * * * * * * * * * * * * * <add namespace="System.Web.UI.WebControls"/>
* * * * * * * * * * * * * * * * <add namespace="System.Web.UI.WebControls.WebParts"/>
* * * * * * * * * * * * * * * * <add namespace="System.Web.UI.HtmlControls"/>
* * * * * * * * * * * * </namespaces>
* * * <controls>
* * * * <add tagPrefix="asp" namespace="System.Web.UI"
assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
* * * </controls>

* * * * * * * * </pages>
* * * * * * * * <!--
* * * * * * The <authenticationsection enables configuration
* * * * * * of the security authentication mode used by
* * * * * * ASP.NET to identify an incoming user.
* * * * -->
* * * * * * * * <authentication mode="Windows"/>
* * * * * * * * <!--
* * * * * * The <customErrorssection enables configuration
* * * * * * of what to do if/when an unhandled error occurs
* * * * * * during the execution of a request. Specifically,
* * * * * * it enables developers to configure html error pages
* * * * * * to be displayed in place of a error stack trace.

* * * * <customErrors mode="RemoteOnly"
defaultRedirect="GenericErrorPage.htm">
* * * * * * <error statusCode="403" redirect="NoAccess.htm" />
* * * * * * <error statusCode="404" redirect="FileNotFound.htm" />
* * * * </customErrors>
* * * * -->
* * * * </system.web>
* <system.web.extensions>
* * <scripting>
* * * <webServices>
* * * <!-- Uncomment this line to customize maxJsonLength and add a
custom converter -->
* * * <!--
* * * <jsonSerialization maxJsonLength="500">
* * * * <converters>
* * * * * <add name="ConvertMe"
type="Acme.SubAcme.ConvertMeTypeConverter"/>
* * * * </converters>
* * * </jsonSerialization>
* * * -->
* * * <!-- Uncomment this line to enable the authentication service..
Include requireSSL="true" if appropriate. -->
* * * <!--
* * * * <authenticationService enabled="true" requireSSL = "true|
false"/>
* * * -->

* * * <!-- Uncomment these lines to enable the profile service. To
allow profile properties to be retrieved
* * * * * *and modified in ASP.NET AJAX applications, you need to add
each property name to the readAccessProperties and
* * * * * *writeAccessProperties attributes. -->
* * * <!--
* * * <profileService enabled="true"

readAccessProperties="propertyname1,propertyname2"

writeAccessProperties="propertyname1,propertyname2 " />
* * * -->
* * * </webServices>
* * * <!--
* * * <scriptResourceHandler enableCompression="true"
enableCaching="true" />
* * * -->
* * </scripting>
* </system.web.extensions>

* <system.webServer>
* * <validation validateIntegratedModeConfiguration="false"/>
* * <modules>
* * * <add name="ScriptModule" preCondition="integratedMode"
type="System.Web.Handlers.ScriptModule, System.Web.Extensions,
Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/

* * </modules>
* * <handlers>
* * * <remove name="WebServiceHandlerFactory-Integrated" />
* * * <add name="ScriptHandlerFactory" verb="*" path="*.asmx"
preCondition="integratedMode"
* * * * * *type="System.Web.Script.Services.ScriptHandlerFac tory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
* * * <add name="ScriptHandlerFactoryAppServices" verb="*"
path="*_AppService.axd" preCondition="integratedMode"
* * * * * *type="System.Web.Script.Services.ScriptHandlerFac tory,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35"/>
* * * <add name="ScriptResource" preCondition="integratedMode"
verb="GET,HEAD" path="ScriptResource.axd"
type="System.Web.Handlers.ScriptResourceHandler,
System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,
PublicKeyToken=31bf3856ad364e35" />
* * </handlers>
* </system.webServer>
</configuration>
Aug 15 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.