By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,584 Members | 1,065 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,584 IT Pros & Developers. It's quick & easy.

VS2008 HTTP 403 Help!!

P: n/a
I've been away from ASPNET - I open up a new Web app in VS2008 and go into
properties and select to use IIS instead of the personal web server. Then
I run in debug mode and it says I have to set the Debug= True in the
Web.config which I do. Then try to run it again and it says I must enable
integrated security which I do. I then try to run it again and get the HTTP
403 error - " This error (HTTP 403 Forbidden) means that Internet Explorer
was able to connect to the website, but it does not have permission to view
the webpage."

What have I got to do to get around this to debug a simple ASPNET app?

TIA
Harry
Jul 8 '08 #1
Share this Question
Share on Google+
16 Replies


P: n/a
Is your ASP.NET application running as an IIS application ?
Does the account ASP.NET runs as, have read permissions to the app's physical directory ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:ec**************@TK2MSFTNGP03.phx.gbl...
I've been away from ASPNET - I open up a new Web app in VS2008 and go into properties and select to use IIS instead of
the personal web server. Then I run in debug mode and it says I have to set the Debug= True in the Web.config which I
do. Then try to run it again and it says I must enable integrated security which I do. I then try to run it again and
get the HTTP 403 error - " This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the
website, but it does not have permission to view the webpage."

What have I got to do to get around this to debug a simple ASPNET app?

TIA
Harry

Jul 8 '08 #2

P: n/a
Those were the first things I checked. Yes.
It creates a virtual directory in the project properties. When I go into IIS
I see it as a web app.

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:er**************@TK2MSFTNGP02.phx.gbl...
Is your ASP.NET application running as an IIS application ?
Does the account ASP.NET runs as, have read permissions to the app's
physical directory ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:ec**************@TK2MSFTNGP03.phx.gbl...
>I've been away from ASPNET - I open up a new Web app in VS2008 and go
into properties and select to use IIS instead of the personal web server.
Then I run in debug mode and it says I have to set the Debug= True in the
Web.config which I do. Then try to run it again and it says I must enable
integrated security which I do. I then try to run it again and get the
HTTP 403 error - " This error (HTTP 403 Forbidden) means that Internet
Explorer was able to connect to the website, but it does not have
permission to view the webpage."

What have I got to do to get around this to debug a simple ASPNET app?

TIA
Harry


Jul 8 '08 #3

P: n/a
And I've given full rights on the directory where the web app actual files
reside...
"Harry Simpson" <hs*******@phgt.netwrote in message
news:ep**************@TK2MSFTNGP02.phx.gbl...
Those were the first things I checked. Yes.
It creates a virtual directory in the project properties. When I go into
IIS I see it as a web app.

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:er**************@TK2MSFTNGP02.phx.gbl...
>Is your ASP.NET application running as an IIS application ?
Does the account ASP.NET runs as, have read permissions to the app's
physical directory ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:ec**************@TK2MSFTNGP03.phx.gbl...
>>I've been away from ASPNET - I open up a new Web app in VS2008 and go
into properties and select to use IIS instead of the personal web
server. Then I run in debug mode and it says I have to set the Debug=
True in the Web.config which I do. Then try to run it again and it says
I must enable integrated security which I do. I then try to run it
again and get the HTTP 403 error - " This error (HTTP 403 Forbidden)
means that Internet Explorer was able to connect to the website, but it
does not have permission to view the webpage."

What have I got to do to get around this to debug a simple ASPNET app?

TIA
Harry



Jul 8 '08 #4

P: n/a
re:
!And I've given full rights on the directory where the web app actual files reside...

To which account did you give rights to ?
Which OS are you running VS 2008 on ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP02.phx.gbl...
And I've given full rights on the directory where the web app actual files reside...
"Harry Simpson" <hs*******@phgt.netwrote in message news:ep**************@TK2MSFTNGP02.phx.gbl...
>Those were the first things I checked. Yes.
It creates a virtual directory in the project properties. When I go into IIS I see it as a web app.

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:er**************@TK2MSFTNGP02.phx.gbl...
>>Is your ASP.NET application running as an IIS application ?
Does the account ASP.NET runs as, have read permissions to the app's physical directory ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:ec**************@TK2MSFTNGP03.phx.gbl...
I've been away from ASPNET - I open up a new Web app in VS2008 and go into properties and select to use IIS instead
of the personal web server. Then I run in debug mode and it says I have to set the Debug= True in the Web.config
which I do. Then try to run it again and it says I must enable integrated security which I do. I then try to run
it again and get the HTTP 403 error - " This error (HTTP 403 Forbidden) means that Internet Explorer was able to
connect to the website, but it does not have permission to view the webpage."

What have I got to do to get around this to debug a simple ASPNET app?

TIA
Harry



Jul 8 '08 #5

P: n/a
Thanks for hanging in here with me on this one Juan!

I'm running XP SP3

Gave the aspnet_wp account (PHG\ASPNET) full accesss to the directory where
the web app files are physically located.

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:u4**************@TK2MSFTNGP05.phx.gbl...
re:
!And I've given full rights on the directory where the web app actual
files reside...

To which account did you give rights to ?
Which OS are you running VS 2008 on ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
>And I've given full rights on the directory where the web app actual
files reside...
"Harry Simpson" <hs*******@phgt.netwrote in message
news:ep**************@TK2MSFTNGP02.phx.gbl...
>>Those were the first things I checked. Yes.
It creates a virtual directory in the project properties. When I go into
IIS I see it as a web app.

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:er**************@TK2MSFTNGP02.phx.gbl...
Is your ASP.NET application running as an IIS application ?
Does the account ASP.NET runs as, have read permissions to the app's
physical directory ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:ec**************@TK2MSFTNGP03.phx.gbl...
I've been away from ASPNET - I open up a new Web app in VS2008 and go
into properties and select to use IIS instead of the personal web
server. Then I run in debug mode and it says I have to set the Debug=
True in the Web.config which I do. Then try to run it again and it
says I must enable integrated security which I do. I then try to run
it again and get the HTTP 403 error - " This error (HTTP 403
Forbidden) means that Internet Explorer was able to connect to the
website, but it does not have permission to view the webpage."
>
What have I got to do to get around this to debug a simple ASPNET app?
>
TIA
Harry
>




Jul 8 '08 #6

P: n/a
If I'm not mistaken, the account which should be given access rights to any physical directory
which holds ASP.NET files for Windows XP is the MachineName\ASPNET account.

Please save the following code as "identity.aspx" :
-------------------------------------------------------------------------
<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = "ASP.NET is running as the account : " & tmp
End Sub
</script>
<html>
<head>
<title>What account is ASP.NET running as ?</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
-----------------

Save it to the wwwroot directory, and run it as :

http://localhost/identity.aspx

You can click that link after you save the file to the wwwroot directory.
Then, please post back the results you got.

I think you will get back "YourMachineName\ASPNET",
unless you have changed the account by configuring an account to impersonate.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:uj**************@TK2MSFTNGP03.phx.gbl...
Thanks for hanging in here with me on this one Juan!

I'm running XP SP3

Gave the aspnet_wp account (PHG\ASPNET) full accesss to the directory where the web app files are physically located.

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:u4**************@TK2MSFTNGP05.phx.gbl...
>re:
!And I've given full rights on the directory where the web app actual files reside...

To which account did you give rights to ?
Which OS are you running VS 2008 on ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP02.phx.gbl...
>>And I've given full rights on the directory where the web app actual files reside...
"Harry Simpson" <hs*******@phgt.netwrote in message news:ep**************@TK2MSFTNGP02.phx.gbl...
Those were the first things I checked. Yes.
It creates a virtual directory in the project properties. When I go into IIS I see it as a web app.

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:er**************@TK2MSFTNGP02.phx.gbl...
Is your ASP.NET application running as an IIS application ?
Does the account ASP.NET runs as, have read permissions to the app's physical directory ?
>
>
>
>
Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:ec**************@TK2MSFTNGP03.phx.gbl...
>I've been away from ASPNET - I open up a new Web app in VS2008 and go into properties and select to use IIS
>instead of the personal web server. Then I run in debug mode and it says I have to set the Debug= True in the
>Web.config which I do. Then try to run it again and it says I must enable integrated security which I do. I then
>try to run it again and get the HTTP 403 error - " This error (HTTP 403 Forbidden) means that Internet Explorer
>was able to connect to the website, but it does not have permission to view the webpage."
>>
>What have I got to do to get around this to debug a simple ASPNET app?
>>
>TIA
>Harry
>>
>
>




Jul 9 '08 #7

P: n/a
Thanks Juan

Got
ASP.NET is running as the account : SIMPSON2\ASPNET

And the physical directory the virtual hits has full access granted to
ASP.NET Machine Account (SIMPSON2\ASPNET)

VS2008 defaults to using the personal server - which works fine - no HTTP
403 error with it. Just when I switch to IIS in VS2008 project popreties -
WEB do I run into problems
Could it be here that things a screwed up?

I set the project URL to the virtual directory
http://localhost/TestWebApp

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:u4**************@TK2MSFTNGP05.phx.gbl...
re:
!And I've given full rights on the directory where the web app actual
files reside...

To which account did you give rights to ?
Which OS are you running VS 2008 on ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
>And I've given full rights on the directory where the web app actual
files reside...
"Harry Simpson" <hs*******@phgt.netwrote in message
news:ep**************@TK2MSFTNGP02.phx.gbl...
>>Those were the first things I checked. Yes.
It creates a virtual directory in the project properties. When I go into
IIS I see it as a web app.

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:er**************@TK2MSFTNGP02.phx.gbl...
Is your ASP.NET application running as an IIS application ?
Does the account ASP.NET runs as, have read permissions to the app's
physical directory ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:ec**************@TK2MSFTNGP03.phx.gbl...
I've been away from ASPNET - I open up a new Web app in VS2008 and go
into properties and select to use IIS instead of the personal web
server. Then I run in debug mode and it says I have to set the Debug=
True in the Web.config which I do. Then try to run it again and it
says I must enable integrated security which I do. I then try to run
it again and get the HTTP 403 error - " This error (HTTP 403
Forbidden) means that Internet Explorer was able to connect to the
website, but it does not have permission to view the webpage."
>
What have I got to do to get around this to debug a simple ASPNET app?
>
TIA
Harry
>




Jul 9 '08 #8

P: n/a
re:
!Just when I switch to IIS in VS2008 project properties - WEB do I run into problems

I just reproduced what you're seeing.

I think it may be related to VS 2008 running ASP.NET apps as MachineName\Administrator,
while IIS runs them as MachineName\ASP.NET_account, in your case : MachineName\ASPNET
and in my case, MachineName\Network Service.

What I don't understand is why the MachineName\ASP.NET_account's permissions don't take hold,
even though the account is explicitly granted access permissions.

I did find a workaround for your problem which, as mentioned, I was able to reproduce.

What I did was *publish* the project to a disk-based directory.
Then, I created a virtual directory in IIS which points to the directory where the project was published to.

After that, using the option "Open web site" in VS 2008,
allowed me to open, edit and run the published project.

Also, if I open the property pages for the project,
and configure the "Use custom server" option to http://localhost/ApplicationName/,
(the same virtual directory name I created in IIS) I can also browse the project from within VS 2008 using IIS.

So, while this is a good workaround, it looks like you found a bug.
Can you file a bug report at the Connect site ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:um**************@TK2MSFTNGP02.phx.gbl...
Thanks Juan

Got
ASP.NET is running as the account : SIMPSON2\ASPNET

And the physical directory the virtual hits has full access granted to ASP.NET Machine Account (SIMPSON2\ASPNET)

VS2008 defaults to using the personal server - which works fine - no HTTP 403 error with it. Just when I switch to
IIS in VS2008 project popreties - WEB do I run into problems
Could it be here that things a screwed up?

I set the project URL to the virtual directory
http://localhost/TestWebApp

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:u4**************@TK2MSFTNGP05.phx.gbl...
>re:
!And I've given full rights on the directory where the web app actual files reside...

To which account did you give rights to ?
Which OS are you running VS 2008 on ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP02.phx.gbl...
>>And I've given full rights on the directory where the web app actual files reside...
"Harry Simpson" <hs*******@phgt.netwrote in message news:ep**************@TK2MSFTNGP02.phx.gbl...
Those were the first things I checked. Yes.
It creates a virtual directory in the project properties. When I go into IIS I see it as a web app.

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:er**************@TK2MSFTNGP02.phx.gbl...
Is your ASP.NET application running as an IIS application ?
Does the account ASP.NET runs as, have read permissions to the app's physical directory ?
>
>
>
>
Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:ec**************@TK2MSFTNGP03.phx.gbl...
>I've been away from ASPNET - I open up a new Web app in VS2008 and go into properties and select to use IIS
>instead of the personal web server. Then I run in debug mode and it says I have to set the Debug= True in the
>Web.config which I do. Then try to run it again and it says I must enable integrated security which I do. I then
>try to run it again and get the HTTP 403 error - " This error (HTTP 403 Forbidden) means that Internet Explorer
>was able to connect to the website, but it does not have permission to view the webpage."
>>
>What have I got to do to get around this to debug a simple ASPNET app?
>>
>TIA
>Harry
>>
>
>





Jul 9 '08 #9

P: n/a
Sure Juan - what's the url to the "Connect site" ?

Also now after doing this I've getting the following error on build
Error 1 It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS. D:\_VS2008 PROJECTS\TestWebApp\TestWebApp\Web.config 70

Seems like the publish took away the projects web app status.

My project now looks like "D:\_VS2008 PROJECTS\TestWebApp\

Looks like when you publish this it just reverts to using the old dev server
and not IIS
http://localhost:4788/TestWebApplication/
which does work but I want to use IIS........

what's the url to the "Connect site" ?

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:uh*************@TK2MSFTNGP04.phx.gbl...
re:
!Just when I switch to IIS in VS2008 project properties - WEB do I run
into problems

I just reproduced what you're seeing.

I think it may be related to VS 2008 running ASP.NET apps as
MachineName\Administrator,
while IIS runs them as MachineName\ASP.NET_account, in your case :
MachineName\ASPNET
and in my case, MachineName\Network Service.

What I don't understand is why the MachineName\ASP.NET_account's
permissions don't take hold,
even though the account is explicitly granted access permissions.

I did find a workaround for your problem which, as mentioned, I was able
to reproduce.

What I did was *publish* the project to a disk-based directory.
Then, I created a virtual directory in IIS which points to the directory
where the project was published to.

After that, using the option "Open web site" in VS 2008,
allowed me to open, edit and run the published project.

Also, if I open the property pages for the project,
and configure the "Use custom server" option to
http://localhost/ApplicationName/,
(the same virtual directory name I created in IIS) I can also browse the
project from within VS 2008 using IIS.

So, while this is a good workaround, it looks like you found a bug.
Can you file a bug report at the Connect site ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:um**************@TK2MSFTNGP02.phx.gbl...
>Thanks Juan

Got
ASP.NET is running as the account : SIMPSON2\ASPNET

And the physical directory the virtual hits has full access granted to
ASP.NET Machine Account (SIMPSON2\ASPNET)

VS2008 defaults to using the personal server - which works fine - no HTTP
403 error with it. Just when I switch to
IIS in VS2008 project popreties - WEB do I run into problems
Could it be here that things a screwed up?

I set the project URL to the virtual directory
http://localhost/TestWebApp

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:u4**************@TK2MSFTNGP05.phx.gbl...
>>re:
!And I've given full rights on the directory where the web app actual
files reside...

To which account did you give rights to ?
Which OS are you running VS 2008 on ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl.. .
And I've given full rights on the directory where the web app actual
files reside...
"Harry Simpson" <hs*******@phgt.netwrote in message
news:ep**************@TK2MSFTNGP02.phx.gbl...
Those were the first things I checked. Yes.
It creates a virtual directory in the project properties. When I go
into IIS I see it as a web app.
>
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:er**************@TK2MSFTNGP02.phx.gbl.. .
>Is your ASP.NET application running as an IIS application ?
>Does the account ASP.NET runs as, have read permissions to the app's
>physical directory ?
>>
>>
>>
>>
>Juan T. Llibre, asp.net MVP
>asp.net faq : http://asp.net.do/faq/
>foros de asp.net, en espaņol : http://asp.net.do/foros/
>======================================
>"Harry Simpson" <hs*******@phgt.netwrote in message
>news:ec**************@TK2MSFTNGP03.phx.gbl. ..
>>I've been away from ASPNET - I open up a new Web app in VS2008 and
>>go into properties and select to use IIS
>>instead of the personal web server. Then I run in debug mode and it
>>says I have to set the Debug= True in the
>>Web.config which I do. Then try to run it again and it says I must
>>enable integrated security which I do. I then
>>try to run it again and get the HTTP 403 error - " This error (HTTP
>>403 Forbidden) means that Internet Explorer
>>was able to connect to the website, but it does not have permission
>>to view the webpage."
>>>
>>What have I got to do to get around this to debug a simple ASPNET
>>app?
>>>
>>TIA
>>Harry
>>>
>>
>>
>
>





Jul 9 '08 #10

P: n/a
re:
!what's the url to the "Connect site" ?

http://connect.microsoft.com/

You'll need to use your Windows Live ID to sign in.
If you don't have one, create one and then sign in to Connect.

re:
Also now after doing this I've getting the following error on build
!Error 1 It is an error to use a section registered as
!allowDefinition='MachineToApplication' beyond application level.

That error is caused by a virtual directory not being configured as an application in IIS.
Check in your IIS Manager, and make sure you created a virtual directory for your app.

re:
!Looks like when you publish this it just reverts to using the old dev server
!and not IIS http://localhost:4788/TestWebApplication/
!which does work but I want to use IIS

You need to open the property pages for the project, and configure the "Use custom server"
option to http://localhost/ApplicationName/, (the same virtual directory name created in IIS)
and you will be able to browse the project from within VS 2008 using IIS.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP05.phx.gbl...
Sure Juan - what's the url to the "Connect site" ?

Also now after doing this I've getting the following error on build
Error 1 It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.
This error can be caused by a virtual directory not being configured as an application in IIS. D:\_VS2008
PROJECTS\TestWebApp\TestWebApp\Web.config 70

Seems like the publish took away the projects web app status.

My project now looks like "D:\_VS2008 PROJECTS\TestWebApp\

Looks like when you publish this it just reverts to using the old dev server and not IIS
http://localhost:4788/TestWebApplication/
which does work but I want to use IIS........

what's the url to the "Connect site" ?

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:uh*************@TK2MSFTNGP04.phx.gbl...
>re:
!Just when I switch to IIS in VS2008 project properties - WEB do I run into problems

I just reproduced what you're seeing.

I think it may be related to VS 2008 running ASP.NET apps as MachineName\Administrator,
while IIS runs them as MachineName\ASP.NET_account, in your case : MachineName\ASPNET
and in my case, MachineName\Network Service.

What I don't understand is why the MachineName\ASP.NET_account's permissions don't take hold,
even though the account is explicitly granted access permissions.

I did find a workaround for your problem which, as mentioned, I was able to reproduce.

What I did was *publish* the project to a disk-based directory.
Then, I created a virtual directory in IIS which points to the directory where the project was published to.

After that, using the option "Open web site" in VS 2008,
allowed me to open, edit and run the published project.

Also, if I open the property pages for the project,
and configure the "Use custom server" option to http://localhost/ApplicationName/,
(the same virtual directory name I created in IIS) I can also browse the project from within VS 2008 using IIS.

So, while this is a good workaround, it looks like you found a bug.
Can you file a bug report at the Connect site ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:um**************@TK2MSFTNGP02.phx.gbl...
>>Thanks Juan

Got
ASP.NET is running as the account : SIMPSON2\ASPNET

And the physical directory the virtual hits has full access granted to ASP.NET Machine Account (SIMPSON2\ASPNET)

VS2008 defaults to using the personal server - which works fine - no HTTP 403 error with it. Just when I switch to
IIS in VS2008 project popreties - WEB do I run into problems
Could it be here that things a screwed up?

I set the project URL to the virtual directory
http://localhost/TestWebApp

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:u4**************@TK2MSFTNGP05.phx.gbl...
re:
!And I've given full rights on the directory where the web app actual files reside...

To which account did you give rights to ?
Which OS are you running VS 2008 on ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP02.phx.gbl...
And I've given full rights on the directory where the web app actual files reside...
"Harry Simpson" <hs*******@phgt.netwrote in message news:ep**************@TK2MSFTNGP02.phx.gbl...
>Those were the first things I checked. Yes.
>It creates a virtual directory in the project properties. When I go into IIS I see it as a web app.
>>
>"Juan T. Llibre" <no***********@nowhere.comwrote in message news:er**************@TK2MSFTNGP02.phx.gbl...
>>Is your ASP.NET application running as an IIS application ?
>>Does the account ASP.NET runs as, have read permissions to the app's physical directory ?
>>>
>>>
>>>
>>>
>>Juan T. Llibre, asp.net MVP
>>asp.net faq : http://asp.net.do/faq/
>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>======================================
>>"Harry Simpson" <hs*******@phgt.netwrote in message news:ec**************@TK2MSFTNGP03.phx.gbl...
>>>I've been away from ASPNET - I open up a new Web app in VS2008 and go into properties and select to use IIS
>>>instead of the personal web server. Then I run in debug mode and it says I have to set the Debug= True in the
>>>Web.config which I do. Then try to run it again and it says I must enable integrated security which I do. I
>>>then
>>>try to run it again and get the HTTP 403 error - " This error (HTTP 403 Forbidden) means that Internet Explorer
>>>was able to connect to the website, but it does not have permission to view the webpage."
>>>>
>>>What have I got to do to get around this to debug a simple ASPNET app?
>>>>
>>>TIA
>>>Harry
>>>>
>>>
>>>
>>
>>
>
>





Jul 9 '08 #11

P: n/a
Thanks Juan!

I tried the workaround and could never get it to work - I'll send this to MS
and maybe somebody can help. It's amazing that we're the only two people in
the world that have ever run into this to date....

Harry
(have bug, will find....)

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:eF****************@TK2MSFTNGP05.phx.gbl...
re:
!what's the url to the "Connect site" ?

http://connect.microsoft.com/

You'll need to use your Windows Live ID to sign in.
If you don't have one, create one and then sign in to Connect.

re:
>Also now after doing this I've getting the following error on build
!Error 1 It is an error to use a section registered as
!allowDefinition='MachineToApplication' beyond application level.

That error is caused by a virtual directory not being configured as an
application in IIS.
Check in your IIS Manager, and make sure you created a virtual directory
for your app.

re:
!Looks like when you publish this it just reverts to using the old dev
server
!and not IIS http://localhost:4788/TestWebApplication/
!which does work but I want to use IIS

You need to open the property pages for the project, and configure the
"Use custom server"
option to http://localhost/ApplicationName/, (the same virtual directory
name created in IIS)
and you will be able to browse the project from within VS 2008 using IIS.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
>Sure Juan - what's the url to the "Connect site" ?

Also now after doing this I've getting the following error on build
Error 1 It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS. D:\_VS2008 PROJECTS\TestWebApp\TestWebApp\Web.config
70

Seems like the publish took away the projects web app status.

My project now looks like "D:\_VS2008 PROJECTS\TestWebApp\

Looks like when you publish this it just reverts to using the old dev
server and not IIS
http://localhost:4788/TestWebApplication/
which does work but I want to use IIS........

what's the url to the "Connect site" ?

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:uh*************@TK2MSFTNGP04.phx.gbl...
>>re:
!Just when I switch to IIS in VS2008 project properties - WEB do I run
into problems

I just reproduced what you're seeing.

I think it may be related to VS 2008 running ASP.NET apps as
MachineName\Administrator,
while IIS runs them as MachineName\ASP.NET_account, in your case :
MachineName\ASPNET
and in my case, MachineName\Network Service.

What I don't understand is why the MachineName\ASP.NET_account's
permissions don't take hold,
even though the account is explicitly granted access permissions.

I did find a workaround for your problem which, as mentioned, I was able
to reproduce.

What I did was *publish* the project to a disk-based directory.
Then, I created a virtual directory in IIS which points to the directory
where the project was published to.

After that, using the option "Open web site" in VS 2008,
allowed me to open, edit and run the published project.

Also, if I open the property pages for the project,
and configure the "Use custom server" option to
http://localhost/ApplicationName/,
(the same virtual directory name I created in IIS) I can also browse the
project from within VS 2008 using IIS.

So, while this is a good workaround, it looks like you found a bug.
Can you file a bug report at the Connect site ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:um**************@TK2MSFTNGP02.phx.gbl...
Thanks Juan

Got
ASP.NET is running as the account : SIMPSON2\ASPNET

And the physical directory the virtual hits has full access granted to
ASP.NET Machine Account (SIMPSON2\ASPNET)

VS2008 defaults to using the personal server - which works fine - no
HTTP 403 error with it. Just when I switch to
IIS in VS2008 project popreties - WEB do I run into problems
Could it be here that things a screwed up?

I set the project URL to the virtual directory
http://localhost/TestWebApp

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:u4**************@TK2MSFTNGP05.phx.gbl...
re:
!And I've given full rights on the directory where the web app
actual files reside...
>
To which account did you give rights to ?
Which OS are you running VS 2008 on ?
>
>
>
>
Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl.. .
>And I've given full rights on the directory where the web app actual
>files reside...
>"Harry Simpson" <hs*******@phgt.netwrote in message
>news:ep**************@TK2MSFTNGP02.phx.gbl. ..
>>Those were the first things I checked. Yes.
>>It creates a virtual directory in the project properties. When I go
>>into IIS I see it as a web app.
>>>
>>"Juan T. Llibre" <no***********@nowhere.comwrote in message
>>news:er**************@TK2MSFTNGP02.phx.gbl.. .
>>>Is your ASP.NET application running as an IIS application ?
>>>Does the account ASP.NET runs as, have read permissions to the
>>>app's physical directory ?
>>>>
>>>>
>>>>
>>>>
>>>Juan T. Llibre, asp.net MVP
>>>asp.net faq : http://asp.net.do/faq/
>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>======================================
>>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>>news:ec**************@TK2MSFTNGP03.phx.gbl. ..
>>>>I've been away from ASPNET - I open up a new Web app in VS2008 and
>>>>go into properties and select to use IIS
>>>>instead of the personal web server. Then I run in debug mode and
>>>>it says I have to set the Debug= True in the
>>>>Web.config which I do. Then try to run it again and it says I must
>>>>enable integrated security which I do. I then
>>>>try to run it again and get the HTTP 403 error - " This error
>>>>(HTTP 403 Forbidden) means that Internet Explorer
>>>>was able to connect to the website, but it does not have
>>>>permission to view the webpage."
>>>>>
>>>>What have I got to do to get around this to debug a simple ASPNET
>>>>app?
>>>>>
>>>>TIA
>>>>Harry
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>





Jul 10 '08 #12

P: n/a
Juan,

Case is at
http://connect.microsoft.com/VisualS...dbackID=355757
if you're interested. Ironic thing was When I was going through the routine
which had failed so many times to do the bug report, it worked! But I
cannot find a way to get these other apps to work correctly at all....

Thanks
Harry

"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP04.phx.gbl...
Thanks Juan!

I tried the workaround and could never get it to work - I'll send this to
MS and maybe somebody can help. It's amazing that we're the only two
people in the world that have ever run into this to date....

Harry
(have bug, will find....)

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:eF****************@TK2MSFTNGP05.phx.gbl...
>re:
!what's the url to the "Connect site" ?

http://connect.microsoft.com/

You'll need to use your Windows Live ID to sign in.
If you don't have one, create one and then sign in to Connect.

re:
>>Also now after doing this I've getting the following error on build
!Error 1 It is an error to use a section registered as
!allowDefinition='MachineToApplication' beyond application level.

That error is caused by a virtual directory not being configured as an
application in IIS.
Check in your IIS Manager, and make sure you created a virtual directory
for your app.

re:
!Looks like when you publish this it just reverts to using the old dev
server
!and not IIS http://localhost:4788/TestWebApplication/
!which does work but I want to use IIS

You need to open the property pages for the project, and configure the
"Use custom server"
option to http://localhost/ApplicationName/, (the same virtual directory
name created in IIS)
and you will be able to browse the project from within VS 2008 using IIS.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
>>Sure Juan - what's the url to the "Connect site" ?

Also now after doing this I've getting the following error on build
Error 1 It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS. D:\_VS2008 PROJECTS\TestWebApp\TestWebApp\Web.config
70

Seems like the publish took away the projects web app status.

My project now looks like "D:\_VS2008 PROJECTS\TestWebApp\

Looks like when you publish this it just reverts to using the old dev
server and not IIS
http://localhost:4788/TestWebApplication/
which does work but I want to use IIS........

what's the url to the "Connect site" ?

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:uh*************@TK2MSFTNGP04.phx.gbl...
re:
!Just when I switch to IIS in VS2008 project properties - WEB do I
run into problems

I just reproduced what you're seeing.

I think it may be related to VS 2008 running ASP.NET apps as
MachineName\Administrator,
while IIS runs them as MachineName\ASP.NET_account, in your case :
MachineName\ASPNET
and in my case, MachineName\Network Service.

What I don't understand is why the MachineName\ASP.NET_account's
permissions don't take hold,
even though the account is explicitly granted access permissions.

I did find a workaround for your problem which, as mentioned, I was
able to reproduce.

What I did was *publish* the project to a disk-based directory.
Then, I created a virtual directory in IIS which points to the
directory where the project was published to.

After that, using the option "Open web site" in VS 2008,
allowed me to open, edit and run the published project.

Also, if I open the property pages for the project,
and configure the "Use custom server" option to
http://localhost/ApplicationName/,
(the same virtual directory name I created in IIS) I can also browse
the project from within VS 2008 using IIS.

So, while this is a good workaround, it looks like you found a bug.
Can you file a bug report at the Connect site ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:um**************@TK2MSFTNGP02.phx.gbl...
Thanks Juan
>
Got
ASP.NET is running as the account : SIMPSON2\ASPNET
>
And the physical directory the virtual hits has full access granted to
ASP.NET Machine Account (SIMPSON2\ASPNET)
>
VS2008 defaults to using the personal server - which works fine - no
HTTP 403 error with it. Just when I switch to
IIS in VS2008 project popreties - WEB do I run into problems
Could it be here that things a screwed up?
>
I set the project URL to the virtual directory
http://localhost/TestWebApp
>
Thanks
Harry
>
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:u4**************@TK2MSFTNGP05.phx.gbl.. .
>re:
>!And I've given full rights on the directory where the web app
>actual files reside...
>>
>To which account did you give rights to ?
>Which OS are you running VS 2008 on ?
>>
>>
>>
>>
>Juan T. Llibre, asp.net MVP
>asp.net faq : http://asp.net.do/faq/
>foros de asp.net, en espaņol : http://asp.net.do/foros/
>======================================
>"Harry Simpson" <hs*******@phgt.netwrote in message
>news:%2****************@TK2MSFTNGP02.phx.gbl. ..
>>And I've given full rights on the directory where the web app actual
>>files reside...
>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>news:ep**************@TK2MSFTNGP02.phx.gbl.. .
>>>Those were the first things I checked. Yes.
>>>It creates a virtual directory in the project properties. When I go
>>>into IIS I see it as a web app.
>>>>
>>>"Juan T. Llibre" <no***********@nowhere.comwrote in message
>>>news:er**************@TK2MSFTNGP02.phx.gbl. ..
>>>>Is your ASP.NET application running as an IIS application ?
>>>>Does the account ASP.NET runs as, have read permissions to the
>>>>app's physical directory ?
>>>>>
>>>>>
>>>>>
>>>>>
>>>>Juan T. Llibre, asp.net MVP
>>>>asp.net faq : http://asp.net.do/faq/
>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>======================================
>>>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>>>news:ec**************@TK2MSFTNGP03.phx.gbl ...
>>>>>I've been away from ASPNET - I open up a new Web app in VS2008
>>>>>and go into properties and select to use IIS
>>>>>instead of the personal web server. Then I run in debug mode and
>>>>>it says I have to set the Debug= True in the
>>>>>Web.config which I do. Then try to run it again and it says I
>>>>>must enable integrated security which I do. I then
>>>>>try to run it again and get the HTTP 403 error - " This error
>>>>>(HTTP 403 Forbidden) means that Internet Explorer
>>>>>was able to connect to the website, but it does not have
>>>>>permission to view the webpage."
>>>>>>
>>>>>What have I got to do to get around this to debug a simple ASPNET
>>>>>app?
>>>>>>
>>>>>TIA
>>>>>Harry
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>





Jul 11 '08 #13

P: n/a
Thanks for following up, Harry.
That way, we will all benefit from the resolution.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:OH**************@TK2MSFTNGP05.phx.gbl...
Juan,

Case is at
http://connect.microsoft.com/VisualS...dbackID=355757
if you're interested. Ironic thing was When I was going through the routine which had failed so many times to do the
bug report, it worked! But I cannot find a way to get these other apps to work correctly at all....

Thanks
Harry

"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP04.phx.gbl...
>Thanks Juan!

I tried the workaround and could never get it to work - I'll send this to MS and maybe somebody can help. It's
amazing that we're the only two people in the world that have ever run into this to date....

Harry
(have bug, will find....)

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:eF****************@TK2MSFTNGP05.phx.gbl...
>>re:
!what's the url to the "Connect site" ?

http://connect.microsoft.com/

You'll need to use your Windows Live ID to sign in.
If you don't have one, create one and then sign in to Connect.

re:
Also now after doing this I've getting the following error on build
!Error 1 It is an error to use a section registered as
!allowDefinition='MachineToApplication' beyond application level.

That error is caused by a virtual directory not being configured as an application in IIS.
Check in your IIS Manager, and make sure you created a virtual directory for your app.

re:
!Looks like when you publish this it just reverts to using the old dev server
!and not IIS http://localhost:4788/TestWebApplication/
!which does work but I want to use IIS

You need to open the property pages for the project, and configure the "Use custom server"
option to http://localhost/ApplicationName/, (the same virtual directory name created in IIS)
and you will be able to browse the project from within VS 2008 using IIS.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP05.phx.gbl...
Sure Juan - what's the url to the "Connect site" ?

Also now after doing this I've getting the following error on build
Error 1 It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application
level. This error can be caused by a virtual directory not being configured as an application in IIS. D:\_VS2008
PROJECTS\TestWebApp\TestWebApp\Web.config 70

Seems like the publish took away the projects web app status.

My project now looks like "D:\_VS2008 PROJECTS\TestWebApp\

Looks like when you publish this it just reverts to using the old dev server and not IIS
http://localhost:4788/TestWebApplication/
which does work but I want to use IIS........

what's the url to the "Connect site" ?

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:uh*************@TK2MSFTNGP04.phx.gbl...
re:
!Just when I switch to IIS in VS2008 project properties - WEB do I run into problems
>
I just reproduced what you're seeing.
>
I think it may be related to VS 2008 running ASP.NET apps as MachineName\Administrator,
while IIS runs them as MachineName\ASP.NET_account, in your case : MachineName\ASPNET
and in my case, MachineName\Network Service.
>
What I don't understand is why the MachineName\ASP.NET_account's permissions don't take hold,
even though the account is explicitly granted access permissions.
>
I did find a workaround for your problem which, as mentioned, I was able to reproduce.
>
What I did was *publish* the project to a disk-based directory.
Then, I created a virtual directory in IIS which points to the directory where the project was published to.
>
After that, using the option "Open web site" in VS 2008,
allowed me to open, edit and run the published project.
>
Also, if I open the property pages for the project,
and configure the "Use custom server" option to http://localhost/ApplicationName/,
(the same virtual directory name I created in IIS) I can also browse the project from within VS 2008 using IIS.
>
So, while this is a good workaround, it looks like you found a bug.
Can you file a bug report at the Connect site ?
>
>
>
>
Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:um**************@TK2MSFTNGP02.phx.gbl...
>Thanks Juan
>>
>Got
>ASP.NET is running as the account : SIMPSON2\ASPNET
>>
>And the physical directory the virtual hits has full access granted to ASP.NET Machine Account (SIMPSON2\ASPNET)
>>
>VS2008 defaults to using the personal server - which works fine - no HTTP 403 error with it. Just when I switch
>to
>IIS in VS2008 project popreties - WEB do I run into problems
>Could it be here that things a screwed up?
>>
>I set the project URL to the virtual directory
>http://localhost/TestWebApp
>>
>Thanks
>Harry
>>
>"Juan T. Llibre" <no***********@nowhere.comwrote in message news:u4**************@TK2MSFTNGP05.phx.gbl...
>>re:
>>!And I've given full rights on the directory where the web app actual files reside...
>>>
>>To which account did you give rights to ?
>>Which OS are you running VS 2008 on ?
>>>
>>>
>>>
>>>
>>Juan T. Llibre, asp.net MVP
>>asp.net faq : http://asp.net.do/faq/
>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>======================================
>>"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP02.phx.gbl...
>>>And I've given full rights on the directory where the web app actual files reside...
>>>"Harry Simpson" <hs*******@phgt.netwrote in message news:ep**************@TK2MSFTNGP02.phx.gbl...
>>>>Those were the first things I checked. Yes.
>>>>It creates a virtual directory in the project properties. When I go into IIS I see it as a web app.
>>>>>
>>>>"Juan T. Llibre" <no***********@nowhere.comwrote in message news:er**************@TK2MSFTNGP02.phx.gbl...
>>>>>Is your ASP.NET application running as an IIS application ?
>>>>>Does the account ASP.NET runs as, have read permissions to the app's physical directory ?
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>Juan T. Llibre, asp.net MVP
>>>>>asp.net faq : http://asp.net.do/faq/
>>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>======================================
>>>>>"Harry Simpson" <hs*******@phgt.netwrote in message news:ec**************@TK2MSFTNGP03.phx.gbl...
>>>>>>I've been away from ASPNET - I open up a new Web app in VS2008 and go into properties and select to use IIS
>>>>>>instead of the personal web server. Then I run in debug mode and it says I have to set the Debug= True in
>>>>>>the
>>>>>>Web.config which I do. Then try to run it again and it says I must enable integrated security which I do. I
>>>>>>then
>>>>>>try to run it again and get the HTTP 403 error - " This error (HTTP 403 Forbidden) means that Internet
>>>>>>Explorer
>>>>>>was able to connect to the website, but it does not have permission to view the webpage."
>>>>>>>
>>>>>>What have I got to do to get around this to debug a simple ASPNET app?
>>>>>>>
>>>>>>TIA
>>>>>>Harry
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>
>




Jul 11 '08 #14

P: n/a
Juan,

I figured it was something simple....cause it was so hard to solve.....
Seems like the web app project does not default to the ONLY aspx in a
project during debug run. Highlighting the default.aspx before debug start
or explicitly setting Default.aspx to the start page works. Otherwise in
debug it will not search for the default or index files to run - it just
HTTP 403s.

I don't remember every having this problem before VS2008....course I've been
doing mostly smart device apps until last week or so so maybe i'm just
really rusty....

Thanks for all your help....

Harry

"Harry Simpson" <hs*******@phgt.netwrote in message
news:OH**************@TK2MSFTNGP05.phx.gbl...
Juan,

Case is at
http://connect.microsoft.com/VisualS...dbackID=355757
if you're interested. Ironic thing was When I was going through the
routine which had failed so many times to do the bug report, it worked!
But I cannot find a way to get these other apps to work correctly at
all....

Thanks
Harry

"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP04.phx.gbl...
>Thanks Juan!

I tried the workaround and could never get it to work - I'll send this to
MS and maybe somebody can help. It's amazing that we're the only two
people in the world that have ever run into this to date....

Harry
(have bug, will find....)

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:eF****************@TK2MSFTNGP05.phx.gbl...
>>re:
!what's the url to the "Connect site" ?

http://connect.microsoft.com/

You'll need to use your Windows Live ID to sign in.
If you don't have one, create one and then sign in to Connect.

re:
Also now after doing this I've getting the following error on build
!Error 1 It is an error to use a section registered as
!allowDefinition='MachineToApplication' beyond application level.

That error is caused by a virtual directory not being configured as an
application in IIS.
Check in your IIS Manager, and make sure you created a virtual directory
for your app.

re:
!Looks like when you publish this it just reverts to using the old dev
server
!and not IIS http://localhost:4788/TestWebApplication/
!which does work but I want to use IIS

You need to open the property pages for the project, and configure the
"Use custom server"
option to http://localhost/ApplicationName/, (the same virtual directory
name created in IIS)
and you will be able to browse the project from within VS 2008 using
IIS.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl.. .
Sure Juan - what's the url to the "Connect site" ?

Also now after doing this I've getting the following error on build
Error 1 It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS. D:\_VS2008
PROJECTS\TestWebApp\TestWebApp\Web.config 70

Seems like the publish took away the projects web app status.

My project now looks like "D:\_VS2008 PROJECTS\TestWebApp\

Looks like when you publish this it just reverts to using the old dev
server and not IIS
http://localhost:4788/TestWebApplication/
which does work but I want to use IIS........

what's the url to the "Connect site" ?

Thanks
Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:uh*************@TK2MSFTNGP04.phx.gbl...
re:
!Just when I switch to IIS in VS2008 project properties - WEB do I
run into problems
>
I just reproduced what you're seeing.
>
I think it may be related to VS 2008 running ASP.NET apps as
MachineName\Administrator,
while IIS runs them as MachineName\ASP.NET_account, in your case :
MachineName\ASPNET
and in my case, MachineName\Network Service.
>
What I don't understand is why the MachineName\ASP.NET_account's
permissions don't take hold,
even though the account is explicitly granted access permissions.
>
I did find a workaround for your problem which, as mentioned, I was
able to reproduce.
>
What I did was *publish* the project to a disk-based directory.
Then, I created a virtual directory in IIS which points to the
directory where the project was published to.
>
After that, using the option "Open web site" in VS 2008,
allowed me to open, edit and run the published project.
>
Also, if I open the property pages for the project,
and configure the "Use custom server" option to
http://localhost/ApplicationName/,
(the same virtual directory name I created in IIS) I can also browse
the project from within VS 2008 using IIS.
>
So, while this is a good workaround, it looks like you found a bug.
Can you file a bug report at the Connect site ?
>
>
>
>
Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:um**************@TK2MSFTNGP02.phx.gbl.. .
>Thanks Juan
>>
>Got
>ASP.NET is running as the account : SIMPSON2\ASPNET
>>
>And the physical directory the virtual hits has full access granted
>to ASP.NET Machine Account (SIMPSON2\ASPNET)
>>
>VS2008 defaults to using the personal server - which works fine - no
>HTTP 403 error with it. Just when I switch to
>IIS in VS2008 project popreties - WEB do I run into problems
>Could it be here that things a screwed up?
>>
>I set the project URL to the virtual directory
>http://localhost/TestWebApp
>>
>Thanks
>Harry
>>
>"Juan T. Llibre" <no***********@nowhere.comwrote in message
>news:u4**************@TK2MSFTNGP05.phx.gbl. ..
>>re:
>>!And I've given full rights on the directory where the web app
>>actual files reside...
>>>
>>To which account did you give rights to ?
>>Which OS are you running VS 2008 on ?
>>>
>>>
>>>
>>>
>>Juan T. Llibre, asp.net MVP
>>asp.net faq : http://asp.net.do/faq/
>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>======================================
>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>news:%2****************@TK2MSFTNGP02.phx.gbl ...
>>>And I've given full rights on the directory where the web app
>>>actual files reside...
>>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>>news:ep**************@TK2MSFTNGP02.phx.gbl. ..
>>>>Those were the first things I checked. Yes.
>>>>It creates a virtual directory in the project properties. When I
>>>>go into IIS I see it as a web app.
>>>>>
>>>>"Juan T. Llibre" <no***********@nowhere.comwrote in message
>>>>news:er**************@TK2MSFTNGP02.phx.gbl ...
>>>>>Is your ASP.NET application running as an IIS application ?
>>>>>Does the account ASP.NET runs as, have read permissions to the
>>>>>app's physical directory ?
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>Juan T. Llibre, asp.net MVP
>>>>>asp.net faq : http://asp.net.do/faq/
>>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>======================================
>>>>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>>>>news:ec**************@TK2MSFTNGP03.phx.gb l...
>>>>>>I've been away from ASPNET - I open up a new Web app in VS2008
>>>>>>and go into properties and select to use IIS
>>>>>>instead of the personal web server. Then I run in debug mode and
>>>>>>it says I have to set the Debug= True in the
>>>>>>Web.config which I do. Then try to run it again and it says I
>>>>>>must enable integrated security which I do. I then
>>>>>>try to run it again and get the HTTP 403 error - " This error
>>>>>>(HTTP 403 Forbidden) means that Internet Explorer
>>>>>>was able to connect to the website, but it does not have
>>>>>>permission to view the webpage."
>>>>>>>
>>>>>>What have I got to do to get around this to debug a simple
>>>>>>ASPNET app?
>>>>>>>
>>>>>>TIA
>>>>>>Harry
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>
>




Jul 11 '08 #15

P: n/a
re:
!the web app project does not default to the ONLY aspx in a project during debug run.

That's not exactly the bug... ;-)

re:
!Highlighting the default.aspx before debug start or explicitly setting Default.aspx to the start page works.
!Otherwise in debug it will not search for the default or index files to run - it just HTTP 403s.

That's an alleged workaround which doesn't work, not a solution to the bug.

They should fix the behavior in the next SP.
We don't need any "gotchas" in VS 2008... ;-)

I noticed the request that the bug report be closed,
and added a comment requesting that the bug report not be closed.

http://connect.microsoft.com/VisualS...dbackID=355757

I can still reproduce the problem in all its splendor... :-(

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP03.phx.gbl...
Juan,

I figured it was something simple....cause it was so hard to solve.....
Seems like the web app project does not default to the ONLY aspx in a project during debug run. Highlighting the
default.aspx before debug start or explicitly setting Default.aspx to the start page works. Otherwise in debug it will
not search for the default or index files to run - it just HTTP 403s.

I don't remember every having this problem before VS2008....course I've been doing mostly smart device apps until last
week or so so maybe i'm just really rusty....

Thanks for all your help....

Harry

"Harry Simpson" <hs*******@phgt.netwrote in message news:OH**************@TK2MSFTNGP05.phx.gbl...
>Juan,

Case is at
http://connect.microsoft.com/VisualS...dbackID=355757
if you're interested. Ironic thing was When I was going through the routine which had failed so many times to do the
bug report, it worked! But I cannot find a way to get these other apps to work correctly at all....

Thanks
Harry

"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP04.phx.gbl...
>>Thanks Juan!

I tried the workaround and could never get it to work - I'll send this to MS and maybe somebody can help. It's
amazing that we're the only two people in the world that have ever run into this to date....

Harry
(have bug, will find....)

"Juan T. Llibre" <no***********@nowhere.comwrote in message news:eF****************@TK2MSFTNGP05.phx.gbl...
re:
!what's the url to the "Connect site" ?

http://connect.microsoft.com/

You'll need to use your Windows Live ID to sign in.
If you don't have one, create one and then sign in to Connect.

re:
Also now after doing this I've getting the following error on build
!Error 1 It is an error to use a section registered as
!allowDefinition='MachineToApplication' beyond application level.

That error is caused by a virtual directory not being configured as an application in IIS.
Check in your IIS Manager, and make sure you created a virtual directory for your app.

re:
!Looks like when you publish this it just reverts to using the old dev server
!and not IIS http://localhost:4788/TestWebApplication/
!which does work but I want to use IIS

You need to open the property pages for the project, and configure the "Use custom server"
option to http://localhost/ApplicationName/, (the same virtual directory name created in IIS)
and you will be able to browse the project from within VS 2008 using IIS.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP05.phx.gbl...
Sure Juan - what's the url to the "Connect site" ?
>
Also now after doing this I've getting the following error on build
Error 1 It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application
level. This error can be caused by a virtual directory not being configured as an application in IIS. D:\_VS2008
PROJECTS\TestWebApp\TestWebApp\Web.config 70
>
Seems like the publish took away the projects web app status.
>
My project now looks like "D:\_VS2008 PROJECTS\TestWebApp\
>
Looks like when you publish this it just reverts to using the old dev server and not IIS
http://localhost:4788/TestWebApplication/
which does work but I want to use IIS........
>
what's the url to the "Connect site" ?
>
Thanks
Harry
>
"Juan T. Llibre" <no***********@nowhere.comwrote in message news:uh*************@TK2MSFTNGP04.phx.gbl...
>re:
>!Just when I switch to IIS in VS2008 project properties - WEB do I run into problems
>>
>I just reproduced what you're seeing.
>>
>I think it may be related to VS 2008 running ASP.NET apps as MachineName\Administrator,
>while IIS runs them as MachineName\ASP.NET_account, in your case : MachineName\ASPNET
>and in my case, MachineName\Network Service.
>>
>What I don't understand is why the MachineName\ASP.NET_account's permissions don't take hold,
>even though the account is explicitly granted access permissions.
>>
>I did find a workaround for your problem which, as mentioned, I was able to reproduce.
>>
>What I did was *publish* the project to a disk-based directory.
>Then, I created a virtual directory in IIS which points to the directory where the project was published to.
>>
>After that, using the option "Open web site" in VS 2008,
>allowed me to open, edit and run the published project.
>>
>Also, if I open the property pages for the project,
>and configure the "Use custom server" option to http://localhost/ApplicationName/,
>(the same virtual directory name I created in IIS) I can also browse the project from within VS 2008 using IIS.
>>
>So, while this is a good workaround, it looks like you found a bug.
>Can you file a bug report at the Connect site ?
>>
>>
>>
>>
>Juan T. Llibre, asp.net MVP
>asp.net faq : http://asp.net.do/faq/
>foros de asp.net, en espaņol : http://asp.net.do/foros/
>======================================
>"Harry Simpson" <hs*******@phgt.netwrote in message news:um**************@TK2MSFTNGP02.phx.gbl...
>>Thanks Juan
>>>
>>Got
>>ASP.NET is running as the account : SIMPSON2\ASPNET
>>>
>>And the physical directory the virtual hits has full access granted to ASP.NET Machine Account (SIMPSON2\ASPNET)
>>>
>>VS2008 defaults to using the personal server - which works fine - no HTTP 403 error with it. Just when I switch
>>to
>>IIS in VS2008 project popreties - WEB do I run into problems
>>Could it be here that things a screwed up?
>>>
>>I set the project URL to the virtual directory
>>http://localhost/TestWebApp
>>>
>>Thanks
>>Harry
>>>
>>"Juan T. Llibre" <no***********@nowhere.comwrote in message news:u4**************@TK2MSFTNGP05.phx.gbl...
>>>re:
>>>!And I've given full rights on the directory where the web app actual files reside...
>>>>
>>>To which account did you give rights to ?
>>>Which OS are you running VS 2008 on ?
>>>>
>>>>
>>>>
>>>>
>>>Juan T. Llibre, asp.net MVP
>>>asp.net faq : http://asp.net.do/faq/
>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>======================================
>>>"Harry Simpson" <hs*******@phgt.netwrote in message news:%2****************@TK2MSFTNGP02.phx.gbl...
>>>>And I've given full rights on the directory where the web app actual files reside...
>>>>"Harry Simpson" <hs*******@phgt.netwrote in message news:ep**************@TK2MSFTNGP02.phx.gbl...
>>>>>Those were the first things I checked. Yes.
>>>>>It creates a virtual directory in the project properties. When I go into IIS I see it as a web app.
>>>>>>
>>>>>"Juan T. Llibre" <no***********@nowhere.comwrote in message news:er**************@TK2MSFTNGP02.phx.gbl...
>>>>>>Is your ASP.NET application running as an IIS application ?
>>>>>>Does the account ASP.NET runs as, have read permissions to the app's physical directory ?
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>Juan T. Llibre, asp.net MVP
>>>>>>asp.net faq : http://asp.net.do/faq/
>>>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>======================================
>>>>>>"Harry Simpson" <hs*******@phgt.netwrote in message news:ec**************@TK2MSFTNGP03.phx.gbl...
>>>>>>>I've been away from ASPNET - I open up a new Web app in VS2008 and go into properties and select to use IIS
>>>>>>>instead of the personal web server. Then I run in debug mode and it says I have to set the Debug= True in
>>>>>>>the
>>>>>>>Web.config which I do. Then try to run it again and it says I must enable integrated security which I do.
>>>>>>>I then
>>>>>>>try to run it again and get the HTTP 403 error - " This error (HTTP 403 Forbidden) means that Internet
>>>>>>>Explorer
>>>>>>>was able to connect to the website, but it does not have permission to view the webpage."
>>>>>>>>
>>>>>>>What have I got to do to get around this to debug a simple ASPNET app?
>>>>>>>>
>>>>>>>TIA
>>>>>>>Harry
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>>
>
>




Jul 11 '08 #16

P: n/a
Yowsers so it IS a problem still? I thought it was just me.... ;-)

OK

I see it's still alive but no comment responding to yours....

Harry

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
re:
!the web app project does not default to the ONLY aspx in a project
during debug run.

That's not exactly the bug... ;-)

re:
!Highlighting the default.aspx before debug start or explicitly setting
Default.aspx to the start page works.
!Otherwise in debug it will not search for the default or index files to
run - it just HTTP 403s.

That's an alleged workaround which doesn't work, not a solution to the
bug.

They should fix the behavior in the next SP.
We don't need any "gotchas" in VS 2008... ;-)

I noticed the request that the bug report be closed,
and added a comment requesting that the bug report not be closed.

http://connect.microsoft.com/VisualS...dbackID=355757

I can still reproduce the problem in all its splendor... :-(

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
>Juan,

I figured it was something simple....cause it was so hard to solve.....
Seems like the web app project does not default to the ONLY aspx in a
project during debug run. Highlighting the default.aspx before debug
start or explicitly setting Default.aspx to the start page works.
Otherwise in debug it will not search for the default or index files to
run - it just HTTP 403s.

I don't remember every having this problem before VS2008....course I've
been doing mostly smart device apps until last week or so so maybe i'm
just really rusty....

Thanks for all your help....

Harry

"Harry Simpson" <hs*******@phgt.netwrote in message
news:OH**************@TK2MSFTNGP05.phx.gbl...
>>Juan,

Case is at
http://connect.microsoft.com/VisualS...dbackID=355757
if you're interested. Ironic thing was When I was going through the
routine which had failed so many times to do the bug report, it worked!
But I cannot find a way to get these other apps to work correctly at
all....

Thanks
Harry

"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP04.phx.gbl.. .
Thanks Juan!

I tried the workaround and could never get it to work - I'll send this
to MS and maybe somebody can help. It's amazing that we're the only
two people in the world that have ever run into this to date....

Harry
(have bug, will find....)

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:eF****************@TK2MSFTNGP05.phx.gbl. ..
re:
!what's the url to the "Connect site" ?
>
http://connect.microsoft.com/
>
You'll need to use your Windows Live ID to sign in.
If you don't have one, create one and then sign in to Connect.
>
re:
>Also now after doing this I've getting the following error on build
!Error 1 It is an error to use a section registered as
!allowDefinition='MachineToApplication' beyond application level.
>
That error is caused by a virtual directory not being configured as an
application in IIS.
Check in your IIS Manager, and make sure you created a virtual
directory for your app.
>
re:
!Looks like when you publish this it just reverts to using the old
dev server
!and not IIS http://localhost:4788/TestWebApplication/
!which does work but I want to use IIS
>
You need to open the property pages for the project, and configure the
"Use custom server"
option to http://localhost/ApplicationName/, (the same virtual
directory name created in IIS)
and you will be able to browse the project from within VS 2008 using
IIS.
>
>
>
>
Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
"Harry Simpson" <hs*******@phgt.netwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl.. .
>Sure Juan - what's the url to the "Connect site" ?
>>
>Also now after doing this I've getting the following error on build
>Error 1 It is an error to use a section registered as
>allowDefinition='MachineToApplication' beyond application level. This
>error can be caused by a virtual directory not being configured as an
>application in IIS. D:\_VS2008
>PROJECTS\TestWebApp\TestWebApp\Web.config 70
>>
>Seems like the publish took away the projects web app status.
>>
>My project now looks like "D:\_VS2008 PROJECTS\TestWebApp\
>>
>Looks like when you publish this it just reverts to using the old dev
>server and not IIS
>http://localhost:4788/TestWebApplication/
>which does work but I want to use IIS........
>>
>what's the url to the "Connect site" ?
>>
>Thanks
>Harry
>>
>"Juan T. Llibre" <no***********@nowhere.comwrote in message
>news:uh*************@TK2MSFTNGP04.phx.gbl.. .
>>re:
>>!Just when I switch to IIS in VS2008 project properties - WEB do I
>>run into problems
>>>
>>I just reproduced what you're seeing.
>>>
>>I think it may be related to VS 2008 running ASP.NET apps as
>>MachineName\Administrator,
>>while IIS runs them as MachineName\ASP.NET_account, in your case :
>>MachineName\ASPNET
>>and in my case, MachineName\Network Service.
>>>
>>What I don't understand is why the MachineName\ASP.NET_account's
>>permissions don't take hold,
>>even though the account is explicitly granted access permissions.
>>>
>>I did find a workaround for your problem which, as mentioned, I was
>>able to reproduce.
>>>
>>What I did was *publish* the project to a disk-based directory.
>>Then, I created a virtual directory in IIS which points to the
>>directory where the project was published to.
>>>
>>After that, using the option "Open web site" in VS 2008,
>>allowed me to open, edit and run the published project.
>>>
>>Also, if I open the property pages for the project,
>>and configure the "Use custom server" option to
>>http://localhost/ApplicationName/,
>>(the same virtual directory name I created in IIS) I can also browse
>>the project from within VS 2008 using IIS.
>>>
>>So, while this is a good workaround, it looks like you found a bug.
>>Can you file a bug report at the Connect site ?
>>>
>>>
>>>
>>>
>>Juan T. Llibre, asp.net MVP
>>asp.net faq : http://asp.net.do/faq/
>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>======================================
>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>news:um**************@TK2MSFTNGP02.phx.gbl.. .
>>>Thanks Juan
>>>>
>>>Got
>>>ASP.NET is running as the account : SIMPSON2\ASPNET
>>>>
>>>And the physical directory the virtual hits has full access granted
>>>to ASP.NET Machine Account (SIMPSON2\ASPNET)
>>>>
>>>VS2008 defaults to using the personal server - which works fine -
>>>no HTTP 403 error with it. Just when I switch to
>>>IIS in VS2008 project popreties - WEB do I run into problems
>>>Could it be here that things a screwed up?
>>>>
>>>I set the project URL to the virtual directory
>>>http://localhost/TestWebApp
>>>>
>>>Thanks
>>>Harry
>>>>
>>>"Juan T. Llibre" <no***********@nowhere.comwrote in message
>>>news:u4**************@TK2MSFTNGP05.phx.gbl. ..
>>>>re:
>>>>!And I've given full rights on the directory where the web app
>>>>actual files reside...
>>>>>
>>>>To which account did you give rights to ?
>>>>Which OS are you running VS 2008 on ?
>>>>>
>>>>>
>>>>>
>>>>>
>>>>Juan T. Llibre, asp.net MVP
>>>>asp.net faq : http://asp.net.do/faq/
>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>======================================
>>>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>>>news:%2****************@TK2MSFTNGP02.phx.g bl...
>>>>>And I've given full rights on the directory where the web app
>>>>>actual files reside...
>>>>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>>>>news:ep**************@TK2MSFTNGP02.phx.gb l...
>>>>>>Those were the first things I checked. Yes.
>>>>>>It creates a virtual directory in the project properties. When I
>>>>>>go into IIS I see it as a web app.
>>>>>>>
>>>>>>"Juan T. Llibre" <no***********@nowhere.comwrote in message
>>>>>>news:er**************@TK2MSFTNGP02.phx.g bl...
>>>>>>>Is your ASP.NET application running as an IIS application ?
>>>>>>>Does the account ASP.NET runs as, have read permissions to the
>>>>>>>app's physical directory ?
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>Juan T. Llibre, asp.net MVP
>>>>>>>asp.net faq : http://asp.net.do/faq/
>>>>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>>===================================== =
>>>>>>>"Harry Simpson" <hs*******@phgt.netwrote in message
>>>>>>>news:ec**************@TK2MSFTNGP03.phx. gbl...
>>>>>>>>I've been away from ASPNET - I open up a new Web app in VS2008
>>>>>>>>and go into properties and select to use IIS
>>>>>>>>instead of the personal web server. Then I run in debug mode
>>>>>>>>and it says I have to set the Debug= True in the
>>>>>>>>Web.config which I do. Then try to run it again and it says I
>>>>>>>>must enable integrated security which I do. I then
>>>>>>>>try to run it again and get the HTTP 403 error - " This error
>>>>>>>>(HTTP 403 Forbidden) means that Internet Explorer
>>>>>>>>was able to connect to the website, but it does not have
>>>>>>>>permission to view the webpage."
>>>>>>>>>
>>>>>>>>What have I got to do to get around this to debug a simple
>>>>>>>>ASPNET app?
>>>>>>>>>
>>>>>>>>TIA
>>>>>>>>Harry
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>>
>>
>>
>
>




Jul 14 '08 #17

This discussion thread is closed

Replies have been disabled for this discussion.