473,224 Members | 1,953 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 473,224 software developers and data experts.

IIS Virtual Directory Woes

I didn't get a resolution to this in my earlier post, so I'll try again:

System:

Windows XP Pro. (SP2) with IIS installed and running PRIOR to VS 2008 Pro.
installation.
VS 2008 Pro. (full installation).
Installations and testing is all done via an Administrator account.

If I simply create a new ASP .NET Web Application Project (WAP) on my local
file system and then go into the project properties and switch the web
server over to IIS and click the "Create Virtual Directory" button, the page
will not run and will eror out.

I can overcome this by going into IIS and turning on Integrated Windows
Authentication and adding "default.aspx" to the default document list.

My question is, why do I have to set these items up manually? ASP .NET is
correctly installed into IIS (the ASP .NET tab is present in IIS
configuration settings).

Is anyone else experiencing this? BTW-This is not an isolated incident, I
get this behavior EVERY time and on EVERY machine I try it on.
Jul 6 '08 #1
6 3487
"Scott M." <s-***@nospam.nospamwrote in message
news:Oq*************@TK2MSFTNGP04.phx.gbl...
I didn't get a resolution to this in my earlier post, so I'll try again:

System:

Windows XP Pro. (SP2) with IIS installed and running PRIOR to VS 2008 Pro.
installation.
VS 2008 Pro. (full installation).
Installations and testing is all done via an Administrator account.

If I simply create a new ASP .NET Web Application Project (WAP) on my
local
file system and then go into the project properties and switch the web
server over to IIS and click the "Create Virtual Directory" button, the
page
will not run and will eror out.

I can overcome this by going into IIS and turning on Integrated Windows
Authentication and adding "default.aspx" to the default document list.

My question is, why do I have to set these items up manually? ASP .NET is
correctly installed into IIS (the ASP .NET tab is present in IIS
configuration settings).

Is anyone else experiencing this? BTW-This is not an isolated incident, I
get this behavior EVERY time and on EVERY machine I try it on.

Since IIS 5.1 predates .NET its default documents list would not include a
default.aspx. I haven't got a vanilla XP to prove that ASP.NET would add it
to the list for you. Although it does look like you've proved that it
doesn't.

As to intergrated windows authentication that just sounds like you haven't
granted the IUSR_ account access to the folder you pointing your virtual
directory at.
--
Anthony Jones - MVP ASP/ASP.NET
Jul 6 '08 #2
Thanks Anthony, but that doesn't help me move forward on the issue.

I've just done a test. If I go into IIS Manger and create a virtual
directory there, both the default.aspx document and the Integrated Windows
Authentication are set as they should be. In addition, the site has the ASP
..NET configuration tab in the site's properties.

If I create a new ASP .NET Web Application Project from Visual Studio 2008,
and I go into the project properties and change over to IIS, rather than the
ASP .NET development server, I'm FORCED to ask VS .NET to create the virtual
directory for me and it doesn't set these two items I've mentioned.

Clearly ASP .NET is installed on IIS (and yes, I have run aspnet_regiis -i
in the past to test if that would help). And it would seem that because it
is installed, IIS is aware of default.aspx pages as it does add that to the
document list if I make the virtual directory myself.

This is a reproduceable problem that I encounter on every XP machine I try
it on.

How can nobody else be having this issue?
"Anthony Jones" <An*@yadayadayada.comwrote in message
news:Oq**************@TK2MSFTNGP04.phx.gbl...
"Scott M." <s-***@nospam.nospamwrote in message
news:Oq*************@TK2MSFTNGP04.phx.gbl...
>I didn't get a resolution to this in my earlier post, so I'll try again:

System:

Windows XP Pro. (SP2) with IIS installed and running PRIOR to VS 2008
Pro.
installation.
VS 2008 Pro. (full installation).
Installations and testing is all done via an Administrator account.

If I simply create a new ASP .NET Web Application Project (WAP) on my
local
>file system and then go into the project properties and switch the web
server over to IIS and click the "Create Virtual Directory" button, the
page
>will not run and will eror out.

I can overcome this by going into IIS and turning on Integrated Windows
Authentication and adding "default.aspx" to the default document list.

My question is, why do I have to set these items up manually? ASP .NET
is
correctly installed into IIS (the ASP .NET tab is present in IIS
configuration settings).

Is anyone else experiencing this? BTW-This is not an isolated incident,
I
get this behavior EVERY time and on EVERY machine I try it on.


Since IIS 5.1 predates .NET its default documents list would not include a
default.aspx. I haven't got a vanilla XP to prove that ASP.NET would add
it
to the list for you. Although it does look like you've proved that it
doesn't.

As to intergrated windows authentication that just sounds like you haven't
granted the IUSR_ account access to the folder you pointing your virtual
directory at.
--
Anthony Jones - MVP ASP/ASP.NET


Jul 6 '08 #3
The reason other ppl are probably not reporting is or complaining is that
they dont use it this way. Since VS2005, I dont think I have ever bothered
creating a virtual directory this way. I know that doesent help, but perhaps
it may offer some insight into your last comment.

Cheers - Rain

"Scott M." <s-***@nospam.nospamwrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
Thanks Anthony, but that doesn't help me move forward on the issue.

I've just done a test. If I go into IIS Manger and create a virtual
directory there, both the default.aspx document and the Integrated Windows
Authentication are set as they should be. In addition, the site has the
ASP .NET configuration tab in the site's properties.

If I create a new ASP .NET Web Application Project from Visual Studio
2008, and I go into the project properties and change over to IIS, rather
than the ASP .NET development server, I'm FORCED to ask VS .NET to create
the virtual directory for me and it doesn't set these two items I've
mentioned.

Clearly ASP .NET is installed on IIS (and yes, I have run aspnet_regiis -i
in the past to test if that would help). And it would seem that because
it is installed, IIS is aware of default.aspx pages as it does add that to
the document list if I make the virtual directory myself.

This is a reproduceable problem that I encounter on every XP machine I try
it on.

How can nobody else be having this issue?
"Anthony Jones" <An*@yadayadayada.comwrote in message
news:Oq**************@TK2MSFTNGP04.phx.gbl...
>"Scott M." <s-***@nospam.nospamwrote in message
news:Oq*************@TK2MSFTNGP04.phx.gbl...
>>I didn't get a resolution to this in my earlier post, so I'll try again:

System:

Windows XP Pro. (SP2) with IIS installed and running PRIOR to VS 2008
Pro.
installation.
VS 2008 Pro. (full installation).
Installations and testing is all done via an Administrator account.

If I simply create a new ASP .NET Web Application Project (WAP) on my
local
>>file system and then go into the project properties and switch the web
server over to IIS and click the "Create Virtual Directory" button, the
page
>>will not run and will eror out.

I can overcome this by going into IIS and turning on Integrated Windows
Authentication and adding "default.aspx" to the default document list.

My question is, why do I have to set these items up manually? ASP .NET
is
correctly installed into IIS (the ASP .NET tab is present in IIS
configuration settings).

Is anyone else experiencing this? BTW-This is not an isolated incident,
I
get this behavior EVERY time and on EVERY machine I try it on.


Since IIS 5.1 predates .NET its default documents list would not include
a
default.aspx. I haven't got a vanilla XP to prove that ASP.NET would add
it
to the list for you. Although it does look like you've proved that it
doesn't.

As to intergrated windows authentication that just sounds like you
haven't
granted the IUSR_ account access to the folder you pointing your virtual
directory at.
--
Anthony Jones - MVP ASP/ASP.NET



Jul 6 '08 #4
That doesn't make any sense. To use a virtual directory with VS, you MUST
create it from WITHIN Visual Studio. If you make the virtual directory
ahead of time from IIS (which creates it properly), VS will tell you that
the virtual directory could not be created, but at the same time it will
also tell you that you must create the directory, so you have no choice but
to make it via VS.

How do you setup an IIS virtual directory that Visual Studio will let you
run your WAP against?

-Scott

"Rain" <me@myplace.comwrote in message
news:ud**************@TK2MSFTNGP05.phx.gbl...
The reason other ppl are probably not reporting is or complaining is that
they dont use it this way. Since VS2005, I dont think I have ever bothered
creating a virtual directory this way. I know that doesent help, but
perhaps it may offer some insight into your last comment.

Cheers - Rain

"Scott M." <s-***@nospam.nospamwrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
>Thanks Anthony, but that doesn't help me move forward on the issue.

I've just done a test. If I go into IIS Manger and create a virtual
directory there, both the default.aspx document and the Integrated
Windows Authentication are set as they should be. In addition, the site
has the ASP .NET configuration tab in the site's properties.

If I create a new ASP .NET Web Application Project from Visual Studio
2008, and I go into the project properties and change over to IIS, rather
than the ASP .NET development server, I'm FORCED to ask VS .NET to create
the virtual directory for me and it doesn't set these two items I've
mentioned.

Clearly ASP .NET is installed on IIS (and yes, I have run
aspnet_regiis -i in the past to test if that would help). And it would
seem that because it is installed, IIS is aware of default.aspx pages as
it does add that to the document list if I make the virtual directory
myself.

This is a reproduceable problem that I encounter on every XP machine I
try it on.

How can nobody else be having this issue?
"Anthony Jones" <An*@yadayadayada.comwrote in message
news:Oq**************@TK2MSFTNGP04.phx.gbl...
>>"Scott M." <s-***@nospam.nospamwrote in message
news:Oq*************@TK2MSFTNGP04.phx.gbl...
I didn't get a resolution to this in my earlier post, so I'll try
again:

System:

Windows XP Pro. (SP2) with IIS installed and running PRIOR to VS 2008
Pro.
installation.
VS 2008 Pro. (full installation).
Installations and testing is all done via an Administrator account.

If I simply create a new ASP .NET Web Application Project (WAP) on my
local
file system and then go into the project properties and switch the web
server over to IIS and click the "Create Virtual Directory" button, the
page
will not run and will eror out.

I can overcome this by going into IIS and turning on Integrated Windows
Authentication and adding "default.aspx" to the default document list.

My question is, why do I have to set these items up manually? ASP .NET
is
correctly installed into IIS (the ASP .NET tab is present in IIS
configuration settings).

Is anyone else experiencing this? BTW-This is not an isolated
incident, I
get this behavior EVERY time and on EVERY machine I try it on.

Since IIS 5.1 predates .NET its default documents list would not include
a
default.aspx. I haven't got a vanilla XP to prove that ASP.NET would
add it
to the list for you. Although it does look like you've proved that it
doesn't.

As to intergrated windows authentication that just sounds like you
haven't
granted the IUSR_ account access to the folder you pointing your virtual
directory at.
--
Anthony Jones - MVP ASP/ASP.NET




Jul 6 '08 #5
"Scott M." <s-***@nospam.nospamwrote:
That doesn't make any sense. To use a virtual directory with VS, you MUST
create it from WITHIN Visual Studio. If you make the virtual directory
ahead of time from IIS (which creates it properly), VS will tell you that
the virtual directory could not be created, but at the same time it will
also tell you that you must create the directory, so you have no choice
but to make it via VS.

How do you setup an IIS virtual directory that Visual Studio will let you
run your WAP against?
In VS2008 on Vista, if I go to the Web tab in the project properties of a
WAP project, I can select "Use IIS Web Server" and manually enter the URL of
a virtual directory I created ahead of time. Visual Studio doesn't complain
when I save it (it works too when I run it).

If I enter an invalid URL, however, VS complains asking me if I want it to
create the virtual directory. So, my guess would be that you're not
entering a valid pre-created URL? What you enter into the Project Url box
should look something like:

http://localhost/your-virtual-directory-name

Jul 7 '08 #6
I'm not using Vista, but that shouldn't change VS's behavior.

When I am in a WAP project settings and switch over to the IIS setting, I
cannot save without being prompted to create the virtual directory. If I do
create it and it doesn't exist, it will be created, but with the two
problems I've been discussing. If I created it ahead of time, Visual Studio
won't let me create it again and yet it won't let me get out of that dialog
without creating it - so the bottom line is that you MUST create the virtual
directory within VS, leaving me with a virtual directory that is
incompletely setup.

I am very well-versed in virtual directories, so I know what I'm entering
into Visual Studio is correct.

"Ben Amada" <be********************@gmail.comwrote in message
news:3E**********************************@microsof t.com...
"Scott M." <s-***@nospam.nospamwrote:
>That doesn't make any sense. To use a virtual directory with VS, you
MUST create it from WITHIN Visual Studio. If you make the virtual
directory ahead of time from IIS (which creates it properly), VS will
tell you that the virtual directory could not be created, but at the same
time it will also tell you that you must create the directory, so you
have no choice but to make it via VS.

How do you setup an IIS virtual directory that Visual Studio will let you
run your WAP against?

In VS2008 on Vista, if I go to the Web tab in the project properties of a
WAP project, I can select "Use IIS Web Server" and manually enter the URL
of a virtual directory I created ahead of time. Visual Studio doesn't
complain when I save it (it works too when I run it).

If I enter an invalid URL, however, VS complains asking me if I want it to
create the virtual directory. So, my guess would be that you're not
entering a valid pre-created URL? What you enter into the Project Url box
should look something like:

http://localhost/your-virtual-directory-name

Jul 7 '08 #7

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

3
by: Zenobia | last post by:
I copy an application to wwwroot: wwwroot +--- myApp +--- common | +--- images | default.asp global.asa
2
by: Jeffry van de Vuurst | last post by:
Hi, (sorry for the crosspost, I wasn't sure which was the best place to put this). I was just thinking about something and wondered if any of you has some ideas about this. I'm using the...
4
by: Michelle | last post by:
I have a website with 6 virtual directories under it who dont "see" the bin/ directory in the root. If I create a /bin directory in each virtual directory and then copy my dll's in there, it...
5
by: Leszek | last post by:
Hello, Could anybody explain what's a difference between a virtual directory and an application root under IIS? I'm a little bit confused. This is mu problem: Let's assume the following...
10
by: Wm. Scott Miller | last post by:
We have a intranet site that allows one of our departments to search a set of pdfs and then look at them. Only problem is that only they and us geeks should be allowed to see the pdfs. We have it...
2
by: Danny Miller | last post by:
Hi there, I'm facing a problem that is driving me nuts. The scenario is as follows: 1) Create an empty directory structure e.g. C:\Dev1\TestWebApp 2) Map a virtual directory e.g. TestWebApp...
4
by: david | last post by:
I basically use the following code to display the directory and file names in the WWWROOT, but can not show the virtual directory. ---- Dim path As String = Server.MapPath(x) Dim di As...
6
by: David | last post by:
Hi all, Using C# .NET 1.1 I am creating a CMS type of application. So far so good. I have a templating system in place that works fantastically. I can remap non-real files and folders and get...
6
by: ManagedCoder | last post by:
Hi, My requirement is as follows: I need to set the HttpExpires (enable content expiration - set to 7 days) on a folder within a virtual directory. I have been able to set the HttpExpires...
1
isladogs
by: isladogs | last post by:
The next online meeting of the Access Europe User Group will be on Wednesday 6 Dec 2023 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). In this month's session, Mike...
0
by: VivesProcSPL | last post by:
Obviously, one of the original purposes of SQL is to make data query processing easy. The language uses many English-like terms and syntax in an effort to make it easy to learn, particularly for...
3
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 3 Jan 2024 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). For other local times, please check World Time Buddy In...
0
by: jianzs | last post by:
Introduction Cloud-native applications are conventionally identified as those designed and nurtured on cloud infrastructure. Such applications, rooted in cloud technologies, skillfully benefit from...
0
by: mar23 | last post by:
Here's the situation. I have a form called frmDiceInventory with subform called subfrmDice. The subform's control source is linked to a query called qryDiceInventory. I've been trying to pick up the...
2
by: jimatqsi | last post by:
The boss wants the word "CONFIDENTIAL" overlaying certain reports. He wants it large, slanted across the page, on every page, very light gray, outlined letters, not block letters. I thought Word Art...
2
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 7 Feb 2024 starting at 18:00 UK time (6PM UTC) and finishing at about 19:30 (7.30PM). In this month's session, the creator of the excellent VBE...
0
Git
by: egorbl4 | last post by:
Скачал я git, хотел начать настройку, а там вылезло вот это Что это? Что мне с этим делать? ...
1
by: davi5007 | last post by:
Hi, Basically, I am trying to automate a field named TraceabilityNo into a web page from an access form. I've got the serial held in the variable strSearchString. How can I get this into the...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.