472,980 Members | 2,022 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,980 software developers and data experts.

VS.NET 2008 Debug ASP.NET on VISTA with IIS7?

Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0… is "Allowed" in the ISAPI and CGI Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them to IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf

Mar 11 '08 #1
11 2657
That ":49705" port number looks more like you are hitting the VS 2008 Web
Development built in webserver, not IIS. Make sure your project is configured
to use IIS and that the /aaa/ folder is marked as an IIS application.
The resultand url would then resemble:
http://locahost/aaa/default.aspx
-- Peter
Site: http://www.eggheadcafe.com
UnBlog: http://petesbloggerama.blogspot.com
Short Urls & more: http://ittyurl.net
"Asaf" wrote:
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0… is "Allowed" in the ISAPI and CGI Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them to IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf
Mar 11 '08 #2
Hi Peter,

Thanks for your answer.
I am confused now.
I don't want to use IIS for my ASP.NET applications so why VS.NET is using
http://localhost/ ?
When creating a new website I have set it to work on "File System" so it is
going to look for localhost?
Where can I configure to use VS.NET 2008 built in web server please?

Thanks,
Asaf
"Peter Bromberg [C# MVP]" wrote:
That ":49705" port number looks more like you are hitting the VS 2008 Web
Development built in webserver, not IIS. Make sure your project is configured
to use IIS and that the /aaa/ folder is marked as an IIS application.
The resultand url would then resemble:
http://locahost/aaa/default.aspx
-- Peter
Site: http://www.eggheadcafe.com
UnBlog: http://petesbloggerama.blogspot.com
Short Urls & more: http://ittyurl.net
"Asaf" wrote:
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0… is "Allowed" in the ISAPI and CGI Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them to IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf
Mar 11 '08 #3
It looks like you hitting the internal web server in Visual studio. And not
IIS.

Also seems to be firewall/antivirus is blocking the request to
localhost:79705

Either allow it on firwall or use http and not local file system for your
project.

George.
"Asaf" <AG**@newsgroups.nospamwrote in message
news:F3**********************************@microsof t.com...
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the
message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0. is "Allowed" in the ISAPI and CGI
Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them to
IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf

Mar 11 '08 #4
If you choosing "file system" then VS starts it's own internal web server.
That is the only way to run Web applications (through web server).

And if do not want to use IIS then you doing exactly what you want to do.

The only problem is that something is blocking browser requests to that
internal web server. Most likely it's antivirus software. Try to configure
it so it lets through the requests to that port.
George.

"Asaf" <AG**@newsgroups.nospamwrote in message
news:20**********************************@microsof t.com...
Hi Peter,

Thanks for your answer.
I am confused now.
I don't want to use IIS for my ASP.NET applications so why VS.NET is using
http://localhost/ ?
When creating a new website I have set it to work on "File System" so it
is
going to look for localhost?
Where can I configure to use VS.NET 2008 built in web server please?

Thanks,
Asaf
"Peter Bromberg [C# MVP]" wrote:
>That ":49705" port number looks more like you are hitting the VS 2008 Web
Development built in webserver, not IIS. Make sure your project is
configured
to use IIS and that the /aaa/ folder is marked as an IIS application.
The resultand url would then resemble:
http://locahost/aaa/default.aspx
-- Peter
Site: http://www.eggheadcafe.com
UnBlog: http://petesbloggerama.blogspot.com
Short Urls & more: http://ittyurl.net
"Asaf" wrote:
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the
message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0. is "Allowed" in the ISAPI and CGI
Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them to
IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf

Mar 11 '08 #5
Hi,

I have disabled Vista Firewall and NOD32 Anti-Virus but still I can't load
my website pages to IE7 from VS.NET 2008.

Does the internal VS.NET 2008 web server is using http://localhost or
something else?

Is there some kind of a log that I can see what exactly it’s happening with
the IE7 when I try to debug?

Asaf
"George Ter-Saakov" wrote:
It looks like you hitting the internal web server in Visual studio. And not
IIS.

Also seems to be firewall/antivirus is blocking the request to
localhost:79705

Either allow it on firwall or use http and not local file system for your
project.

George.
"Asaf" <AG**@newsgroups.nospamwrote in message
news:F3**********************************@microsof t.com...
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the
message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0. is "Allowed" in the ISAPI and CGI
Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them to
IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf


Mar 11 '08 #6
Hi,

I have found that instead of http://localhost:49705/aaa/Default.aspx if I
change the localhost to 127.0.0.1 like this
http://127.0.0.1:49705/aaa/Default.aspx then it is working.

Is there a way to configure VS.NET to user 127.0.0.1 instead of localhost?

Asaf
"George Ter-Saakov" wrote:
It looks like you hitting the internal web server in Visual studio. And not
IIS.

Also seems to be firewall/antivirus is blocking the request to
localhost:79705

Either allow it on firwall or use http and not local file system for your
project.

George.
"Asaf" <AG**@newsgroups.nospamwrote in message
news:F3**********************************@microsof t.com...
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the
message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0. is "Allowed" in the ISAPI and CGI
Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them to
IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf


Mar 11 '08 #7
Hi Asaf,

Yes, the url indicate that you're using the built-in ASP.NET server rather
than IIS server. The error you saw in IE is a general one, here is a kb
article which provided some suggestion about troubleshooting this error:

http://support.microsoft.com/kb/926431

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
Delighting our customers is our #1 priority. We welcome your comments and
suggestions about how we

can improve the support we provide to you. Please feel free to let my
manager know what you think of

the level of service provided. You can send feedback directly to my manager
at: ms****@microsoft.com.

==================================================

This posting is provided "AS IS" with no warranties, and confers no rights.

--------------------
>From: =?Utf-8?B?QXNhZg==?= <AG**@newsgroups.nospam>
References: <F3**********************************@microsoft.co m>
<A5**********************************@microsoft.co m>
>Subject: RE: VS.NET 2008 Debug ASP.NET on VISTA with IIS7?
Date: Tue, 11 Mar 2008 12:59:11 -0700
>
Hi Peter,

Thanks for your answer.
I am confused now.
I don't want to use IIS for my ASP.NET applications so why VS.NET is using
http://localhost/ ?
When creating a new website I have set it to work on "File System" so it
is
>going to look for localhost?
Where can I configure to use VS.NET 2008 built in web server please?

Thanks,
Asaf
"Peter Bromberg [C# MVP]" wrote:
>That ":49705" port number looks more like you are hitting the VS 2008
Web
>Development built in webserver, not IIS. Make sure your project is
configured
>to use IIS and that the /aaa/ folder is marked as an IIS application.
The resultand url would then resemble:
http://locahost/aaa/default.aspx
-- Peter
Site: http://www.eggheadcafe.com
UnBlog: http://petesbloggerama.blogspot.com
Short Urls & more: http://ittyurl.net
"Asaf" wrote:
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the
message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0?is "Allowed" in the ISAPI and CGI
Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them
to IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf
Mar 12 '08 #8
Hi Asaf,

It seem that your Vista system has some problem with the "localhost" name's
resolving. I think you should fix this problem first. Here is a web thread
discussing on the same problem(localhost not work):

http://forums.vnunet.com/message.jspa?messageID=1023002

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
Delighting our customers is our #1 priority. We welcome your comments and
suggestions about how we

can improve the support we provide to you. Please feel free to let my
manager know what you think of

the level of service provided. You can send feedback directly to my manager
at: ms****@microsoft.com.

==================================================
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
>From: =?Utf-8?B?QXNhZg==?= <AG**@newsgroups.nospam>
References: <F3**********************************@microsoft.co m>
<u0**************@TK2MSFTNGP03.phx.gbl>
>Subject: Re: VS.NET 2008 Debug ASP.NET on VISTA with IIS7?
Date: Tue, 11 Mar 2008 16:05:00 -0700
>
Hi,

I have found that instead of http://localhost:49705/aaa/Default.aspx if I
change the localhost to 127.0.0.1 like this
http://127.0.0.1:49705/aaa/Default.aspx then it is working.

Is there a way to configure VS.NET to user 127.0.0.1 instead of localhost?

Asaf
"George Ter-Saakov" wrote:
>It looks like you hitting the internal web server in Visual studio. And
not
>IIS.

Also seems to be firewall/antivirus is blocking the request to
localhost:79705

Either allow it on firwall or use http and not local file system for
your
>project.

George.
"Asaf" <AG**@newsgroups.nospamwrote in message
news:F3**********************************@microso ft.com...
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the
message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0. is "Allowed" in the ISAPI and CGI
Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them
to
IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf


Mar 12 '08 #9
Hi,

I have found the solution.
Looking at hosts file I have found a second line like this:

::1 localhost

I have deleted this line and now every things works!

Thanks you all for your time and support.

Asaf

""Steven Cheng"" wrote:
Hi Asaf,

It seem that your Vista system has some problem with the "localhost" name's
resolving. I think you should fix this problem first. Here is a web thread
discussing on the same problem(localhost not work):

http://forums.vnunet.com/message.jspa?messageID=1023002

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
Delighting our customers is our #1 priority. We welcome your comments and
suggestions about how we

can improve the support we provide to you. Please feel free to let my
manager know what you think of

the level of service provided. You can send feedback directly to my manager
at: ms****@microsoft.com.

==================================================
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
From: =?Utf-8?B?QXNhZg==?= <AG**@newsgroups.nospam>
References: <F3**********************************@microsoft.co m>
<u0**************@TK2MSFTNGP03.phx.gbl>
Subject: Re: VS.NET 2008 Debug ASP.NET on VISTA with IIS7?
Date: Tue, 11 Mar 2008 16:05:00 -0700

Hi,

I have found that instead of http://localhost:49705/aaa/Default.aspx if I
change the localhost to 127.0.0.1 like this
http://127.0.0.1:49705/aaa/Default.aspx then it is working.

Is there a way to configure VS.NET to user 127.0.0.1 instead of localhost?

Asaf
"George Ter-Saakov" wrote:
It looks like you hitting the internal web server in Visual studio. And
not
IIS.

Also seems to be firewall/antivirus is blocking the request to
localhost:79705

Either allow it on firwall or use http and not local file system for
your
project.

George.
"Asaf" <AG**@newsgroups.nospamwrote in message
news:F3**********************************@microsof t.com...
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the
message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0. is "Allowed" in the ISAPI and CGI
Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert them
to
IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf


Mar 12 '08 #10
Thanks for your followup.

Glad that you've got it working.

Have a nice day!

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
Delighting our customers is our #1 priority. We welcome your comments and
suggestions about how we can improve the support we provide to you. Please
feel free to let my manager know what you think of the level of service
provided. You can send feedback directly to my manager at:
ms****@microsoft.com.

==================================================
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
>From: =?Utf-8?B?QXNhZg==?= <AG**@newsgroups.nospam>
References: <F3**********************************@microsoft.co m>
<u0**************@TK2MSFTNGP03.phx.gbl>
<C3**********************************@microsoft.co m>
<a1*************@TK2MSFTNGHUB02.phx.gbl>
>Subject: Re: VS.NET 2008 Debug ASP.NET on VISTA with IIS7?
Date: Wed, 12 Mar 2008 04:12:02 -0700
>
Hi,

I have found the solution.
Looking at hosts file I have found a second line like this:

::1 localhost

I have deleted this line and now every things works!

Thanks you all for your time and support.

Asaf

""Steven Cheng"" wrote:
>Hi Asaf,

It seem that your Vista system has some problem with the "localhost"
name's
>resolving. I think you should fix this problem first. Here is a web
thread
>discussing on the same problem(localhost not work):

http://forums.vnunet.com/message.jspa?messageID=1023002

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
Delighting our customers is our #1 priority. We welcome your comments
and
>suggestions about how we

can improve the support we provide to you. Please feel free to let my
manager know what you think of

the level of service provided. You can send feedback directly to my
manager
>at: ms****@microsoft.com.

================================================= =
This posting is provided "AS IS" with no warranties, and confers no
rights.
>>

--------------------
>From: =?Utf-8?B?QXNhZg==?= <AG**@newsgroups.nospam>
References: <F3**********************************@microsoft.co m>
<u0**************@TK2MSFTNGP03.phx.gbl>
>Subject: Re: VS.NET 2008 Debug ASP.NET on VISTA with IIS7?
Date: Tue, 11 Mar 2008 16:05:00 -0700
>
Hi,

I have found that instead of http://localhost:49705/aaa/Default.aspx if
I
>change the localhost to 127.0.0.1 like this
http://127.0.0.1:49705/aaa/Default.aspx then it is working.

Is there a way to configure VS.NET to user 127.0.0.1 instead of
localhost?
>
Asaf
"George Ter-Saakov" wrote:

It looks like you hitting the internal web server in Visual studio.
And
>not
>IIS.

Also seems to be firewall/antivirus is blocking the request to
localhost:79705

Either allow it on firwall or use http and not local file system for
your
>project.

George.
"Asaf" <AG**@newsgroups.nospamwrote in message
news:F3**********************************@microso ft.com...
Hello,

I have just installed VISTA Enterprise and VS.NET 2008.
When pressing F5 to debug my test ASP.NET website, IE 7 display the
message
"Internet Explorer cannot display the webpage".
The local URL that VS.NET 2008 generates is
http://localhost:49705/aaa/Default.aspx.
In IIS7 Manager, ASP.NET V2.0. is "Allowed" in the ISAPI and CGI
Restrictions.
Also IIS7 is working and display ASP.NET web sites if I convert
them
>to
IIS7
"Application" but I would like to use the Debug option.

Thanks in advanced for any help,
Asasf



Mar 13 '08 #11
I ran into the same issue after the Vista SP1 install in the 64 bit
version. The address "::1" is the IPv6 version of localhost or
127.0.0.1. It should NOT be removed from the hosts file if you're
running IPv6.

The fact that IE fails to dereference it properly looks like a bug.
Anyway, you're right, removing the entry will fix the problem for IPv4
just fine.

*** Sent via Developersdex http://www.developersdex.com ***
Mar 23 '08 #12

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

1
by: Torben Laursen | last post by:
Hi I have a website that I can debug just fine in VS2005 on WinXp. But when I move the website to a Vista computer and hit F5 inside VS2005 the website starts but I cannot debug it. I have...
2
by: nospam | last post by:
Hi, dont know if this is the correct group, but tried on vista.general and got no help. ive installed VS2005 on RC2 version of Vista and when i try to create a new website project it shows an...
3
by: Brad | last post by:
In a Vista/IIS7 asp.net app, a coded crystal report export is crashing IIS7....but it works just fine in visual studio's cassini web server. And if I create a web form and use the crystal...
8
by: Darwiniv | last post by:
1. Does anyone run ASAPI and mysql succesfully on Vista /IIS7? 2. Does anyone run CGI and display all SESSION errors on Vista /IIS7? php ASAPI doesn't works with MYSQL. And CGI doesn't show...
9
by: Mark Rae | last post by:
Hi, Now that the VS.NET 2005 SP1 update patch is with us, I'm in the process of moving my main development environment onto 64-bit Vista Business Edition - so far, so good... However, there...
5
by: =?Utf-8?B?bXVzb3NkZXY=?= | last post by:
Hi, I wonder if someone could shed some light on this one for me. I have developed a web app in VS2005 with the built in server. It uses an sql database, everytihng works. I need to test it...
4
by: PW | last post by:
Has anyone used the traditional Classic ASP / Access DB / IIS configuration on Vista yet? I haven't, but before I upgrade to Vista I would like to ensure all my websites will work once I do. ...
6
by: ma | last post by:
Hello, I am new to IIS and ASP.NET. I wrote my first ASP.NET and I want to deploy in to a system which has Vista Business and IIS7. I copied my files to the target computer and created a virtual...
3
by: =?Utf-8?B?T2xpdmllciBNQVRST1Q=?= | last post by:
I'm trying to run an ASP.NET 2.0 web site on Windows Server 2008 RC1. I encounter a server error : HTTP 500.19 - Configuration data is invalid IIS7 claims that the <appSettingssection in web.config...
0
by: lllomh | last post by:
Define the method first this.state = { buttonBackgroundColor: 'green', isBlinking: false, // A new status is added to identify whether the button is blinking or not } autoStart=()=>{
2
by: DJRhino | last post by:
Was curious if anyone else was having this same issue or not.... I was just Up/Down graded to windows 11 and now my access combo boxes are not acting right. With win 10 I could start typing...
2
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 4 Oct 2023 starting at 18:00 UK time (6PM UTC+1) and finishing at about 19:15 (7.15PM) The start time is equivalent to 19:00 (7PM) in Central...
0
by: Aliciasmith | last post by:
In an age dominated by smartphones, having a mobile app for your business is no longer an option; it's a necessity. Whether you're a startup or an established enterprise, finding the right mobile app...
0
tracyyun
by: tracyyun | last post by:
Hello everyone, I have a question and would like some advice on network connectivity. I have one computer connected to my router via WiFi, but I have two other computers that I want to be able to...
1
by: Teri B | last post by:
Hi, I have created a sub-form Roles. In my course form the user selects the roles assigned to the course. 0ne-to-many. One course many roles. Then I created a report based on the Course form and...
3
by: nia12 | last post by:
Hi there, I am very new to Access so apologies if any of this is obvious/not clear. I am creating a data collection tool for health care employees to complete. It consists of a number of...
0
NeoPa
by: NeoPa | last post by:
Introduction For this article I'll be focusing on the Report (clsReport) class. This simply handles making the calling Form invisible until all of the Reports opened by it have been closed, when it...
0
isladogs
by: isladogs | last post by:
The next online meeting of the Access Europe User Group will be on Wednesday 6 Dec 2023 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). In this month's session, Mike...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.