By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,247 Members | 1,427 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,247 IT Pros & Developers. It's quick & easy.

Frustrated setting up write permission to a folder

P: n/a
OK, I know this sounds stupid, but I have been playing with this for
hours, and could not get a clue.

In my asp.net 2.0 web application, I generate charts on the fly. I
would like to save the charts png images in a particular folder. So,
I created a folder ChartImages under the root of my web application.

Whenever I run the web application, I get a folder access is denied
error.

Well, if I choose to save the png images directly under the root of
the web application, though organizationally messy, I don't run into
problems at all.

I have added the ASPNET account to this ChartImages folder, and let it
have full control, but it still doesn't work. It makes no difference
whether or not I inherit the permission from the parent folder.

I see people making the same manipulation and it works. For example,
at

http://forums.asp.net/t/1185795.aspx , Mike offered the same solution:

<quote>
When you right click on a folder, you should have an option in the
context menu which says something like Security and Permission..., or
if you select Properties, you should see a Security tab. If you can't
see these, you will have to uncheck Use Simple File Sharing in Folder
Options.

Once you've done that, you should get the Security option. Within
that, Click Add, then Advanced, then Find Now. ASPNET should appear
somewhere in the list. Select it, click OK, then click OK again.
Select it in the Group or User names, then click Modify. Apply, and
that's it.
</quote>

How come I cannot make it work? Am I missing anything critical?
Thank you very much!
Feb 26 '08 #1
Share this Question
Share on Google+
1 Reply


P: n/a
"gnewsgroup" <gn********@gmail.comwrote in message
news:b9**********************************@b1g2000h sg.googlegroups.com...
I have added the ASPNET account to this ChartImages folder,
Are you absolutely certain that your web app is running under the ASPNET
account...?
--
Mark Rae
ASP.NET MVP
http://www.markrae.net

Feb 26 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.