By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,306 Members | 1,657 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,306 IT Pros & Developers. It's quick & easy.

problems with visual studio 2008 on vista

P: n/a
Hi, anyone using VS2008 (final) on windows Vista?
I have a problem. The ASP.NET web site administration tool on any site
created by VS2008, running on Vista, is not working as it should. I
can configure users, roles, but when I try the option 'Select a single
provider for all site management data' AspNetSqlProvider test, I
receive the message:
'Could not establish a connection to the database.
If you have not yet created the SQL Server database, exit the Web Site
Administration tool, use the aspnet_regsql command-line utility to
create and configure the database, and then return to this tool to set
the provider.'
I tried the aspnet_regsql tool, tried to run VS as admin, and still
the same.
Any ideas?
TIA

__________________________________________________ __
Claudio M. E. Bastos Iorio
http://www.blumer.com.ar
Dec 4 '07 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Here are the command-line switches available for ASPNET_REGSQL.EXE:

Administrative utility to install and uninstall ASP.NET features on a SQL
server.
Copyright (C) Microsoft Corporation. All rights reserved.

-- GENERAL OPTIONS --

-? Display this help text.

-W Wizard mode. (Default if no other parameters are specified.)
-- SQL CONNECTION OPTIONS --

-S <server SQL Server instance (SQL Server 7.0 and above) to work with.

-U <login id SQL Server user name to authenticate with; requires -P
option.

-P <password SQL Server password to authenticate with; requires -U
option.

-E Authenticate with current Windows credentials.

-C <connection string>
Connection string. Instead of specifying a user name,
password, and server name, specify a SQL Server connection
string. The string must not contain a database name unless
otherwise specified.

-sqlexportonly <filename>
Generate the SQL script file for adding or removing the
specified features and do not carry out the actual
operation.
Can be used with the following options: -A, -R, -ssadd, and
-ssremove.
-- APPLICATION SERVICES OPTIONS --

-A all|m|r|p|c|w Add support for a feature. Multiple values can be specified
together. For example:

-A mp
-A m -A p

all: All features
m: Membership
r: Role manager
p: Profiles
c: Personalization
w: SQL Web event provider

-R all|m|r|p|c|w Remove support for a feature. Multiple values can be
specified together. For example:

-R mp
-R m -R p

all : All features plus all common tables and stored
procedures shared by the features
m: Membership
r: Role manager
p: Profiles
c: Personalization
w: SQL Web event provider

-d <database Database name for use with application services. If no
database name is specified, the default database "aspnetdb"
is used.

-Q Quiet mode; do not display confirmation to remove a feature.

-- SQL CACHE DEPENDENCY OPTIONS (FOR SQL 7.0 AND 2000) --

-d <database Database name for use with SQL cache dependency in SQL 7.0
and SQL 2000. The database can optionally be specified using
the connection string with the -C option instead. (Required)

-ed Enable a database for SQL cache dependency.

-dd Disable a database for SQL cache dependency.

-et Enable a table for SQL cache dependency. Requires -t option.

-dt Disable a table for SQL cache dependency. Requires -t
option.

-t <table Name of the table to enable or disable for SQL cache
dependency. Requires -et or -dt option.

-lt List all tables enabled for SQL cache dependency.
-- SESSION STATE OPTIONS --

-ssadd Add support for SQLServer mode session state.

-ssremove Remove support for SQLServer mode session state.

-sstype t|p|c Type of session state support:

t: temporary. Session state data is stored in the "tempdb"
database. Stored procedures for managing session are
installed in the "ASPState" database. Data is not persisted
if you restart SQL. (Default)

p: persisted. Both session state data and the stored
procedures are stored in the "ASPState" database.

c: custom. Both session state data and the stored procedures
are stored in a custom database. The database name must be
specified.

-d <database The name of the custom database to use if -sstype is "c".

----------- Note that if you do not have SQLEXPRESS Installed you need to
specify a database and ensure that the web.config file is modified
accordingly. I generally advise against having SQLEXPRESS user-instances for
configuration of Membership etc. since in a production environment you will
need a normally "attached" database file to the SQL Server and a working
connection string that does *Not* specify a user instance.

--Peter
"Inside every large program, there is a small program trying to get out."
http://www.eggheadcafe.com
http://petesbloggerama.blogspot.com
http://www.blogmetafinder.com

"Claudio M. E. Bastos Iorio" wrote:
Hi, anyone using VS2008 (final) on windows Vista?
I have a problem. The ASP.NET web site administration tool on any site
created by VS2008, running on Vista, is not working as it should. I
can configure users, roles, but when I try the option 'Select a single
provider for all site management data' AspNetSqlProvider test, I
receive the message:
'Could not establish a connection to the database.
If you have not yet created the SQL Server database, exit the Web Site
Administration tool, use the aspnet_regsql command-line utility to
create and configure the database, and then return to this tool to set
the provider.'
I tried the aspnet_regsql tool, tried to run VS as admin, and still
the same.
Any ideas?
TIA

__________________________________________________ __
Claudio M. E. Bastos Iorio
http://www.blumer.com.ar
Dec 4 '07 #2

P: n/a
P.S. - at a minimum, to get the Admin app to work, you are going to need
something like this in your web.config to start out:

<connectionStrings>
<remove name="localSqlServer" />
<add name="localSqlServer"
connectionString="server=(local);database=test;uid =youruserid;pwd=yourpassword" providerName="SqlClient" />
</connectionStrings>
--
--Peter
"Inside every large program, there is a small program trying to get out."
http://www.eggheadcafe.com
http://petesbloggerama.blogspot.com
http://www.blogmetafinder.com

"Claudio M. E. Bastos Iorio" wrote:
Hi, anyone using VS2008 (final) on windows Vista?
I have a problem. The ASP.NET web site administration tool on any site
created by VS2008, running on Vista, is not working as it should. I
can configure users, roles, but when I try the option 'Select a single
provider for all site management data' AspNetSqlProvider test, I
receive the message:
'Could not establish a connection to the database.
If you have not yet created the SQL Server database, exit the Web Site
Administration tool, use the aspnet_regsql command-line utility to
create and configure the database, and then return to this tool to set
the provider.'
I tried the aspnet_regsql tool, tried to run VS as admin, and still
the same.
Any ideas?
TIA

__________________________________________________ __
Claudio M. E. Bastos Iorio
http://www.blumer.com.ar
Dec 4 '07 #3

P: n/a
On Dec 4, 6:23 pm, Peter Bromberg [C# MVP]
<pbromb...@yahoo.NoSpamMaam.comwrote:
P.S. - at a minimum, to get the Admin app to work, you are going to need
something like this in your web.config to start out:

<connectionStrings>
<remove name="localSqlServer" />
<add name="localSqlServer"
connectionString="server=(local);database=test;uid =youruserid;pwd=yourpassw-ord" providerName="SqlClient" />
</connectionStrings>

--
--Peter
"Inside every large program, there is a small program trying to get out."http://www.eggheadcafe.comhttp://petesbloggerama.blogspot.comhttp://www.blogmetafinder.com

"Claudio M. E. Bastos Iorio" wrote:
Hi, anyone using VS2008 (final) on windows Vista?
I have a problem. The ASP.NET web site administration tool on any site
created by VS2008, running on Vista, is not working as it should. I
can configure users, roles, but when I try the option 'Select a single
provider for all site management data' AspNetSqlProvider test, I
receive the message:
'Could not establish a connection to the database.
If you have not yet created the SQL Server database, exit the Web Site
Administration tool, use the aspnet_regsql command-line utility to
create and configure the database, and then return to this tool to set
the provider.'
I tried the aspnet_regsql tool, tried to run VS as admin, and still
the same.
Any ideas?
TIA
__________________________________________________ __
Claudio M. E. Bastos Iorio
http://www.blumer.com.ar- Hide quoted text -

- Show quoted text -
Thanks for all your responses guys. I tried the aspnet_regsql tool.
What is not working for me now is something that in VS2005 used to
work with no problem. For example, in VS2005, in a blank website
project or web application project, just adding a login control to a
page automatically adds the aspnetdb.mdf file to App_Data folder
needed. And then, accessing the 'web site admin tool' I used to edit
user, roles, whatever. That's not working in VS2008 for me. The file
seems to be added, but not copied when I try to publish site (no
errors publishing), and when I try to use the 'web site admin tool', I
receive the error 'Could not establish a connection to the
database.....'
What's wrong?

__________________________________________________ __
Claudio M. E. Bastos Iorio
http://www.blumer.com.ar
Dec 4 '07 #4

P: n/a

"Claudio M. E. Bastos Iorio" <se*********@gmail.comwrote in message
news:9a**********************************@e25g2000 prg.googlegroups.com...
Hi, anyone using VS2008 (final) on windows Vista?
I have a problem. The ASP.NET web site administration tool on any site
created by VS2008, running on Vista, is not working as it should. I
can configure users, roles, but when I try the option 'Select a single
provider for all site management data' AspNetSqlProvider test, I
receive the message:
'Could not establish a connection to the database.
If you have not yet created the SQL Server database, exit the Web Site
Administration tool, use the aspnet_regsql command-line utility to
create and configure the database, and then return to this tool to set
the provider.'
I tried the aspnet_regsql tool, tried to run VS as admin, and still
the same.
you tried it? what happened? have we established that you have an active
database instance running with the aspnetdb DB created?

Dec 5 '07 #5

P: n/a
On Dec 4, 11:30 pm, "Barrie Wilson" <bwil...@nowhere.comwrote:
"Claudio M. E. Bastos Iorio" <selecter...@gmail.comwrote in messagenews:9a**********************************@e 25g2000prg.googlegroups.com...
Hi, anyone using VS2008 (final) on windows Vista?
I have a problem. The ASP.NET web site administration tool on any site
created by VS2008, running on Vista, is not working as it should. I
can configure users, roles, but when I try the option 'Select a single
provider for all site management data' AspNetSqlProvider test, I
receive the message:
'Could not establish a connection to the database.
If you have not yet created the SQL Server database, exit the Web Site
Administration tool, use the aspnet_regsql command-line utility to
create and configure the database, and then return to this tool to set
the provider.'
I tried the aspnet_regsql tool, tried to run VS as admin, and still
the same.

you tried it? what happened? have we established that you have an active
database instance running with the aspnetdb DB created?
I tried (aspnet_regsql). It creates the aspnetdb.mdf file with proper
tables for roles and users. Changing permissions on App_Data (add
NETWORK SERVICE) allowed me to publish the database to the test
server. That's working now. The error in asp.net config tool is still
there.
I mean, with some workarounds it worked. But not so simple like
VS2005 (add a login control, run asp.net admin tool, add users-roles,
publish to test server, everything is working fine in first try).

__________________________________________________ __
Claudio M. E. Bastos Iorio
http://www.blumer.com.ar
Dec 5 '07 #6

This discussion thread is closed

Replies have been disabled for this discussion.