By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,862 Members | 1,767 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,862 IT Pros & Developers. It's quick & easy.

vs2008 deploy to localhost

P: n/a
hey all,
i created a basic web app in vs2008 and deployed it to my localhost. when i
tried to browse the site, i get the iis message "page cannot be displayed."

any iideas?
thanks,
rodchar
Nov 7 '07 #1
Share this Question
Share on Google+
13 Replies


P: n/a
LVP
http://support.microsoft.com/kb/241344
"rodchar" <ro*****@discussions.microsoft.comwrote in message
news:06**********************************@microsof t.com...
hey all,
i created a basic web app in vs2008 and deployed it to my localhost. when
i
tried to browse the site, i get the iis message "page cannot be
displayed."

any iideas?
thanks,
rodchar

Nov 7 '07 #2

P: n/a
On Nov 7, 8:38 pm, rodchar <rodc...@discussions.microsoft.comwrote:
hey all,
i created a basic web app in vs2008 and deployed it to my localhost. when i
tried to browse the site, i get the iis message "page cannot be displayed."

any iideas?
thanks,
rodchar
try to disable IE friendly error messages (Tools - Internet Options -
Advanced...)

Nov 7 '07 #3

P: n/a
see what i'm talking about here:

http://www25.brinkster.com/rodchar/medtest.htm
"LVP" wrote:
http://support.microsoft.com/kb/241344
"rodchar" <ro*****@discussions.microsoft.comwrote in message
news:06**********************************@microsof t.com...
hey all,
i created a basic web app in vs2008 and deployed it to my localhost. when
i
tried to browse the site, i get the iis message "page cannot be
displayed."

any iideas?
thanks,
rodchar


Nov 7 '07 #4

P: n/a
Try browsing to an HTML page not ASPX page if that works then you need to
configure ASP.Net on IIS.
Also check the ASP.Net version, wouldn't hurt to run
C:\WINDOWS\Microsoft.Net\Framework\v2.0.50727\aspn et_regiis.exe -i
You can also check the weblog to see if the page is actualy being hit, can
usualy be found at C:\WINDOWS\system32\LogFiles\W3SVC1.

Regards,
Brian K. Williams


"rodchar" <ro*****@discussions.microsoft.comwrote in message
news:06**********************************@microsof t.com...
hey all,
i created a basic web app in vs2008 and deployed it to my localhost. when
i
tried to browse the site, i get the iis message "page cannot be
displayed."

any iideas?
thanks,
rodchar

Nov 7 '07 #5

P: n/a
On Nov 7, 9:44 pm, rodchar <rodc...@discussions.microsoft.comwrote:
see what i'm talking about here:

http://www25.brinkster.com/rodchar/medtest.htm

Is Asp.net enabled in IIS? Check the web service extensions node
Nov 7 '07 #6

P: n/a
LVP
Have you tried to make sure that you web app is an application.
right click on the test2
Under Application Settings
next to Application name hit Remove then Create.
"LVP" <sq**********@hotmail.comwrote in message
news:eN*************@TK2MSFTNGP03.phx.gbl...
http://support.microsoft.com/kb/241344
"rodchar" <ro*****@discussions.microsoft.comwrote in message
news:06**********************************@microsof t.com...
>hey all,
i created a basic web app in vs2008 and deployed it to my localhost. when
i
tried to browse the site, i get the iis message "page cannot be
displayed."

any iideas?
thanks,
rodchar


Nov 7 '07 #7

P: n/a
That's a client issue.

He needs to reconfigure IE to enable enhanced security configuration.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Alexey Smirnov" <al************@gmail.comwrote in message
news:11**********************@o38g2000hse.googlegr oups.com...
On Nov 7, 9:44 pm, rodchar <rodc...@discussions.microsoft.comwrote:
>see what i'm talking about here:

http://www25.brinkster.com/rodchar/medtest.htm


Is Asp.net enabled in IIS? Check the web service extensions node


Nov 7 '07 #8

P: n/a
On Nov 7, 11:03 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
That's a client issue.

He needs to reconfigure IE to enable enhanced security configuration.

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Alexey Smirnov" <alexey.smir...@gmail.comwrote in message

news:11**********************@o38g2000hse.googlegr oups.com...
On Nov 7, 9:44 pm, rodchar <rodc...@discussions.microsoft.comwrote:
see what i'm talking about here:
>http://www25.brinkster.com/rodchar/medtest.htm
Is Asp.net enabled in IIS? Check the web service extensions node- Hide quoted text -

- Show quoted text -
HTTP 404 is a very common problem with IIS 6, because ASP.NET is
disabled by default.

Nov 7 '07 #9

P: n/a
re:
!HTTP 404 is a very common problem with IIS 6, because ASP.NET is disabled by default.

Check the screen previous to the 404...


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Alexey Smirnov" <al************@gmail.comwrote in message
news:11**********************@k79g2000hse.googlegr oups.com...
On Nov 7, 11:03 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
That's a client issue.

He needs to reconfigure IE to enable enhanced security configuration.

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Alexey Smirnov" <alexey.smir...@gmail.comwrote in message

news:11**********************@o38g2000hse.googlegr oups.com...
On Nov 7, 9:44 pm, rodchar <rodc...@discussions.microsoft.comwrote:
see what i'm talking about here:
>http://www25.brinkster.com/rodchar/medtest.htm
Is Asp.net enabled in IIS? Check the web service extensions node- Hide quoted text -

- Show quoted text -
HTTP 404 is a very common problem with IIS 6, because ASP.NET is
disabled by default.
Nov 7 '07 #10

P: n/a
On Nov 8, 12:08 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!HTTP 404 is a very common problem with IIS 6, because ASP.NET is disabled by default.

Check the screen previous to the 404...

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Alexey Smirnov" <alexey.smir...@gmail.comwrote in message

news:11**********************@k79g2000hse.googlegr oups.com...
On Nov 7, 11:03 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:


That's a client issue.
He needs to reconfigure IE to enable enhanced security configuration.
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Alexey Smirnov" <alexey.smir....@gmail.comwrote in message
news:11**********************@o38g2000hse.googlegr oups.com...
On Nov 7, 9:44 pm, rodchar <rodc...@discussions.microsoft.comwrote:
>see what i'm talking about here:
>>http://www25.brinkster.com/rodchar/medtest.htm
Is Asp.net enabled in IIS? Check the web service extensions node- Hide quoted text -
- Show quoted text -

HTTP 404 is a very common problem with IIS 6, because ASP.NET is
disabled by default.- Hide quoted text -

- Show quoted text -
Hi Juan,

I made a test on my Win2003 server. I created a test website with
default.aspx in the root directory. First, I enabled Internet Explorer
Enhanced Security Configuration (IE ESC) by adding this component in
Add or Remove Programs. When starting Internet Explorer, I now had a
page from res://shdoclc.dll/hardAdmin.htm that is about "Internet
Explorer Enhanced Security Configuration is enabled". Then I disabled
IE ESC and on starting Internet Explorer, I got the page from
res://shdoclc.dll/softAdmin.htm (as per screen) telling me that
"Internet Explorer Enhanced Security Configuration is not enabled".
Now, when I typing http://localhost I see the test page.

Nov 8 '07 #11

P: n/a
re:
!Then I disabled IE ESC and on starting Internet Explorer, I got the page
! from res://shdoclc.dll/softAdmin.htm (as per screen) telling me that
!"Internet Explorer Enhanced Security Configuration is not enabled".
!Now, when I typing http://localhost I see the test page.

You could, also, have left it enabled, and configured localhost as a Trusted site.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Alexey Smirnov" <al************@gmail.comwrote in message
news:11**********************@q5g2000prf.googlegro ups.com...
On Nov 8, 12:08 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!HTTP 404 is a very common problem with IIS 6, because ASP.NET is disabled by default.

Check the screen previous to the 404...

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Alexey Smirnov" <alexey.smir...@gmail.comwrote in message

news:11**********************@k79g2000hse.googlegr oups.com...
On Nov 7, 11:03 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:


That's a client issue.
He needs to reconfigure IE to enable enhanced security configuration.
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Alexey Smirnov" <alexey.smir...@gmail.comwrote in message
news:11**********************@o38g2000hse.googlegr oups.com...
On Nov 7, 9:44 pm, rodchar <rodc...@discussions.microsoft.comwrote:
>see what i'm talking about here:
>>http://www25.brinkster.com/rodchar/medtest.htm
Is Asp.net enabled in IIS? Check the web service extensions node- Hide quoted text -
- Show quoted text -

HTTP 404 is a very common problem with IIS 6, because ASP.NET is
disabled by default.- Hide quoted text -

- Show quoted text -
Hi Juan,

I made a test on my Win2003 server. I created a test website with
default.aspx in the root directory. First, I enabled Internet Explorer
Enhanced Security Configuration (IE ESC) by adding this component in
Add or Remove Programs. When starting Internet Explorer, I now had a
page from res://shdoclc.dll/hardAdmin.htm that is about "Internet
Explorer Enhanced Security Configuration is enabled". Then I disabled
IE ESC and on starting Internet Explorer, I got the page from
res://shdoclc.dll/softAdmin.htm (as per screen) telling me that
"Internet Explorer Enhanced Security Configuration is not enabled".
Now, when I typing http://localhost I see the test page.
Nov 8 '07 #12

P: n/a
thanks everyone for a plethora of replies. this is always helpful. it turned
out to be that ASP.NET was not enabled on the server. i had to go to
Add/Remove Programs and enable it from there.

thanks again to everyone. wow!!

"rodchar" wrote:
hey all,
i created a basic web app in vs2008 and deployed it to my localhost. when i
tried to browse the site, i get the iis message "page cannot be displayed."

any iideas?
thanks,
rodchar
Nov 8 '07 #13

P: n/a
That's fine, but what you did was *install* it
from Add/Remove Programs, not "enable" it.

In W2K3, for example, you have to enable it *after* you install it.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"rodchar" <ro*****@discussions.microsoft.comwrote in message
news:2A**********************************@microsof t.com...
thanks everyone for a plethora of replies. this is always helpful. it turned
out to be that ASP.NET was not enabled on the server. i had to go to
Add/Remove Programs and enable it from there.

thanks again to everyone. wow!!

"rodchar" wrote:
>hey all,
i created a basic web app in vs2008 and deployed it to my localhost. when i
tried to browse the site, i get the iis message "page cannot be displayed."

any iideas?
thanks,
rodchar

Nov 8 '07 #14

This discussion thread is closed

Replies have been disabled for this discussion.