469,568 Members | 1,350 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,568 developers. It's quick & easy.

IIS Security w/ASP.NET 2.0

I have changed the "My Project" setting in VS 2005 from "Use VS Dev. Server" to "Use IIS Web Server" and I've clicked the "Create Virtual Directory" button. When I attempt to run (with debugging), I get a generic error messagebox (doesn't even get to the browser) that says to ensure the server is operating correctly and that there are no errors in my code. When I try to start without debugging, I get a standard error page in my browser saying:
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
When I check the permissions of the VD, it looks ok, execute permissions are set to "scripts only" and the directory security is set to use the IUSER account.

What am I missing here?

Thanks,

Scott
Oct 18 '07 #1
4 1193
You must make the virtual directiory an application. Have you done that?

"Scott M." <s-***@nospam.nospamwrote in message
news:OC**************@TK2MSFTNGP05.phx.gbl...
I have changed the "My Project" setting in VS 2005 from "Use VS Dev. Server"
to "Use IIS Web Server" and I've clicked the "Create Virtual Directory"
button. When I attempt to run (with debugging), I get a generic error
messagebox (doesn't even get to the browser) that says to ensure the server
is operating correctly and that there are no errors in my code. When I try
to start without debugging, I get a standard error page in my browser
saying:
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
When I check the permissions of the VD, it looks ok, execute permissions are
set to "scripts only" and the directory security is set to use the IUSER
account.

What am I missing here?

Thanks,

Scott

Oct 18 '07 #2
When you hit the "Create Virtual Directory" button in VS's "My Project -
Web" tab, it not only creates the virtual directory, but makes it an
application as well - I have confirmed that within the MMC for IIS.
"Norman Yuan" <No*******@NoEmail.fakewrote in message
news:uC**************@TK2MSFTNGP06.phx.gbl...
You must make the virtual directiory an application. Have you done that?

"Scott M." <s-***@nospam.nospamwrote in message
news:OC**************@TK2MSFTNGP05.phx.gbl...
I have changed the "My Project" setting in VS 2005 from "Use VS Dev.
Server" to "Use IIS Web Server" and I've clicked the "Create Virtual
Directory" button. When I attempt to run (with debugging), I get a
generic error messagebox (doesn't even get to the browser) that says to
ensure the server is operating correctly and that there are no errors in
my code. When I try to start without debugging, I get a standard error
page in my browser saying:
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
When I check the permissions of the VD, it looks ok, execute permissions
are set to "scripts only" and the directory security is set to use the
IUSER account.

What am I missing here?

Thanks,

Scott

Oct 18 '07 #3
Curiosly, if I change the permissions on the application root folder to
"Scripts and Executables" (which I know I don't want to do in real life), I
get past the "Forbidden Access" error and now get a 404 error, yet the page
I'm trying to bring up does exist in the location that the browser its
trying to get it from (virtual directory wise, that is).
"Norman Yuan" <No*******@NoEmail.fakewrote in message
news:uC**************@TK2MSFTNGP06.phx.gbl...
You must make the virtual directiory an application. Have you done that?

"Scott M." <s-***@nospam.nospamwrote in message
news:OC**************@TK2MSFTNGP05.phx.gbl...
I have changed the "My Project" setting in VS 2005 from "Use VS Dev.
Server" to "Use IIS Web Server" and I've clicked the "Create Virtual
Directory" button. When I attempt to run (with debugging), I get a
generic error messagebox (doesn't even get to the browser) that says to
ensure the server is operating correctly and that there are no errors in
my code. When I try to start without debugging, I get a standard error
page in my browser saying:
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
When I check the permissions of the VD, it looks ok, execute permissions
are set to "scripts only" and the directory security is set to use the
IUSER account.

What am I missing here?

Thanks,

Scott

Oct 18 '07 #4
That must have been the missing piece .... I think most do the "Set Start Up Page", and somehow yours didn't get set.

The other issue I run into is

"Windows Integrated Security" on the IIS Security Tab.

...

And the last "Make sure" .. is the last tab of IIS property window, which sets the 1.1 or 2.0 version.
(Rare, but sometimes it'll get out of whack)
"Scott M." <s-***@nospam.nospamwrote in message news:OC**************@TK2MSFTNGP05.phx.gbl...
I have changed the "My Project" setting in VS 2005 from "Use VS Dev. Server" to "Use IIS Web Server" and I've clicked the "Create Virtual Directory" button. When I attempt to run (with debugging), I get a generic error messagebox (doesn't even get to the browser) that says to ensure the server is operating correctly and that there are no errors in my code. When I try to start without debugging, I get a standard error page in my browser saying:
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
When I check the permissions of the VD, it looks ok, execute permissions are set to "scripts only" and the directory security is set to use the IUSER account.

What am I missing here?

Thanks,

Scott
Oct 19 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by robert | last post: by
116 posts views Thread by Mike MacSween | last post: by
4 posts views Thread by Ashish | last post: by
reply views Thread by prithvi g via .NET 247 | last post: by
7 posts views Thread by Magdelin | last post: by
3 posts views Thread by Velvet | last post: by
1 post views Thread by Jeremy S. | last post: by
2 posts views Thread by Budhi Saputra Prasetya | last post: by
4 posts views Thread by guiromero | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.