By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,608 Members | 3,801 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,608 IT Pros & Developers. It's quick & easy.

Web Deployment Project and Localhost

P: n/a
I have an asp.net project with an WebDeployment Project.

At the end of the msbuild file I put:

<Target Name="AfterBuild">
<Exec WorkingDirectory="$(OutputPath)"
Command="$(MSBuildBinPath)\aspnet_regiis.exe -pef connectionStrings
$(OutputPath) -prov HrCustomProvider" />
<RemoveDir Directories="$(OutputPath)/ConfigFiles" />
</Target>

This works fine if the webserver is the built in server.
However if I am using the localhost IIS server I get an error.
From the Output window:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspn et_regiis.exe -pef
connectionStrings .\Debug\ -prov HrCustomProvider
Encrypting configuration section...
The configuration for physical path
'D:\DotNet2005\WebAuthentication_Solution\Hr-Auth_deploy\Debug\.\Debug\'
cannot be opened.

So I looked in my WebDeployment Project Property Pages
Configuration Properties: Compilation
Output Folder

It was set to .\Debug\

I am a little scared about changing the output directory to . because I
certainly don't want the source files to get deleted.

What should I do to get this to work.


Sep 4 '07 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Hi Chuck,

As for the Webdeployment project issue, how did you move the original VS
2005 TEST server based project to IIS hosted? Are you still using the same
solution(with the WEB deployment project) after you move the web project to
IIS?

If possible, you can tell me the detailed steps to create a web
project(with web deployment project) that can report the issue, I'd like to
perform some local test also.

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
>From: =?Utf-8?B?Q2h1Y2sgUA==?= <Ch***@newsgroup.nospam>
Subject: Web Deployment Project and Localhost
Date: Tue, 4 Sep 2007 15:00:01 -0700
>
I have an asp.net project with an WebDeployment Project.

At the end of the msbuild file I put:

<Target Name="AfterBuild">
<Exec WorkingDirectory="$(OutputPath)"
Command="$(MSBuildBinPath)\aspnet_regiis.exe -pef connectionStrings
$(OutputPath) -prov HrCustomProvider" />
<RemoveDir Directories="$(OutputPath)/ConfigFiles" />
</Target>

This works fine if the webserver is the built in server.
However if I am using the localhost IIS server I get an error.
From the Output window:
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\asp net_regiis.exe -pef
connectionStrings .\Debug\ -prov HrCustomProvider
Encrypting configuration section...
The configuration for physical path
'D:\DotNet2005\WebAuthentication_Solution\Hr-Auth_deploy\Debug\.\Debug\'
cannot be opened.

So I looked in my WebDeployment Project Property Pages
Configuration Properties: Compilation
Output Folder

It was set to .\Debug\

I am a little scared about changing the output directory to . because I
certainly don't want the source files to get deleted.

What should I do to get this to work.


Sep 5 '07 #2

P: n/a
Steven,

Here is the solution somehow in the solution properties under Configuration
Properties the Build check box for the deployment project was checked.
Sep 6 '07 #3

P: n/a
Thanks for the followup Chuck,

Sorry for the delayed response as I was on sick previously. Anyway, glad
that you've found a way to workaround the problem. If you need any further
help later, welcome to post here.

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
This posting is provided "AS IS" with no warranties, and confers no rights.


--------------------
>From: =?Utf-8?B?Q2h1Y2sgUA==?= <Ch***@newsgroup.nospam>
References: <76**********************************@microsoft.co m>
<qo*************@TK2MSFTNGHUB02.phx.gbl>
>Subject: RE: Web Deployment Project and Localhost
Date: Thu, 6 Sep 2007 10:18:03 -0700
>>
Steven,

Here is the solution somehow in the solution properties under
Configuration
>Properties the Build check box for the deployment project was checked.
Sep 11 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.