469,358 Members | 1,518 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,358 developers. It's quick & easy.

web.config error in cassini 2.0

Hello all,

I have a web application, which I had developed few years ago with
ASP .NET 1.1

Today, I would like to deploy the web application to client, using
ASP .NET 2.0 + UltiDev Cassini 2.0

I locate my whole project in a folder named C:\website\GOWatch

My setting in UltiDev Cassini 2.0 is as follow :

Application = GoWatch
Port Number = 2040
Physical Path = C:\website\GOWatch

When I try to access an URL http://localhost:2040/DesktopPC/login/Login.aspx
(The login.aspx is located physically at C:\website\GOWatch\DesktopPC
\login\Login.aspx), I get the following error :


Configuration Error
Description: An error occurred during the processing of a
configuration file required to service this request. Please review the
specific error details below and modify your configuration file
appropriately.

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS.

Source Error:
Line 7:
Line 8: <system.web>
Line 9: <authentication mode="Forms">
Line 10: <forms name=".ASPXUSERDEMO" loginUrl="http://
10.0.38.4/GoWatch/DesktopPC/login/login.aspx" protection="All"
timeout="5" />
Line 11: </authentication>

Source File: C:\website\GOWatch\desktoppc\login\web.config Line:
9

In my entire application, any sub folder with web.config will have the
similar error.

Please take note that, there are NO web.config in C:\website\GOWatch,
is this the root cause of the error?

Here is the content of my web.config in C:\website\GOWatch\desktoppc
\login\web.config
<configuration>
<appSettings>
<add key="ConnectionString" value="server=GOWATCHSERVER
\NetSDK; trusted_connection=true; Database=Gowatch" />
<add key="mailserver" value="GowatchServer" />
</appSettings>

<system.web>
<authentication mode="Forms">
<forms name=".ASPXUSERDEMO" loginUrl="http://10.0.38.4/GoWatch/
PocketPC/login/login.aspx" protection="All" timeout="5" />
</authentication>
<globalization requestEncoding="UTF-8" responseEncoding="UTF-8" /
>
<deviceFilters>
<filter name="supportsJavaScript" compare="Javascript"
argument="true"/>
</deviceFilters>

</system.web>

<location path="protected">
<system.web>
<authorization>
<deny users="?" />
</authorization>
</system.web>
</location>
</configuration>

Help are very much appreciated! Thank you.

cheok

Aug 25 '07 #1
4 2761
Since that's an UltiDev issue, you should post your question to the UltiDev Forums :

http://ultidev.com/Forums/default.aspx


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
<ya************@gmail.comwrote in message news:11**********************@i38g2000prf.googlegr oups.com...
Hello all,

I have a web application, which I had developed few years ago with
ASP .NET 1.1

Today, I would like to deploy the web application to client, using
ASP .NET 2.0 + UltiDev Cassini 2.0

I locate my whole project in a folder named C:\website\GOWatch

My setting in UltiDev Cassini 2.0 is as follow :

Application = GoWatch
Port Number = 2040
Physical Path = C:\website\GOWatch

When I try to access an URL http://localhost:2040/DesktopPC/login/Login.aspx
(The login.aspx is located physically at C:\website\GOWatch\DesktopPC
\login\Login.aspx), I get the following error :


Configuration Error
Description: An error occurred during the processing of a
configuration file required to service this request. Please review the
specific error details below and modify your configuration file
appropriately.

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS.

Source Error:
Line 7:
Line 8: <system.web>
Line 9: <authentication mode="Forms">
Line 10: <forms name=".ASPXUSERDEMO" loginUrl="http://
10.0.38.4/GoWatch/DesktopPC/login/login.aspx" protection="All"
timeout="5" />
Line 11: </authentication>

Source File: C:\website\GOWatch\desktoppc\login\web.config Line:
9

In my entire application, any sub folder with web.config will have the
similar error.

Please take note that, there are NO web.config in C:\website\GOWatch,
is this the root cause of the error?

Here is the content of my web.config in C:\website\GOWatch\desktoppc
\login\web.config
<configuration>
<appSettings>
<add key="ConnectionString" value="server=GOWATCHSERVER
\NetSDK; trusted_connection=true; Database=Gowatch" />
<add key="mailserver" value="GowatchServer" />
</appSettings>

<system.web>
<authentication mode="Forms">
<forms name=".ASPXUSERDEMO" loginUrl="http://10.0.38.4/GoWatch/
PocketPC/login/login.aspx" protection="All" timeout="5" />
</authentication>
<globalization requestEncoding="UTF-8" responseEncoding="UTF-8" /
>>
<deviceFilters>
<filter name="supportsJavaScript" compare="Javascript"
argument="true"/>
</deviceFilters>

</system.web>

<location path="protected">
<system.web>
<authorization>
<deny users="?" />
</authorization>
</system.web>
</location>
</configuration>

Help are very much appreciated! Thank you.

cheok

Aug 25 '07 #2
That said, the problem seems to be that the GOWatch directory is not marked as an application.

UltiDev Cassini is *not* Cassini, btw.
It's a propietary server version based on the Cassini source and owned by UltiDev LLC.

Are you using UltiDev Cassini 1.1 or UltiDev Cassini 2.0 ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Juan T. Llibre" <no***********@nowhere.comwrote in message news:eD**************@TK2MSFTNGP03.phx.gbl...
Since that's an UltiDev issue, you should post your question to the UltiDev Forums :

http://ultidev.com/Forums/default.aspx


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
<ya************@gmail.comwrote in message news:11**********************@i38g2000prf.googlegr oups.com...
>Hello all,

I have a web application, which I had developed few years ago with
ASP .NET 1.1

Today, I would like to deploy the web application to client, using
ASP .NET 2.0 + UltiDev Cassini 2.0

I locate my whole project in a folder named C:\website\GOWatch

My setting in UltiDev Cassini 2.0 is as follow :

Application = GoWatch
Port Number = 2040
Physical Path = C:\website\GOWatch

When I try to access an URL http://localhost:2040/DesktopPC/login/Login.aspx
(The login.aspx is located physically at C:\website\GOWatch\DesktopPC
\login\Login.aspx), I get the following error :


Configuration Error
Description: An error occurred during the processing of a
configuration file required to service this request. Please review the
specific error details below and modify your configuration file
appropriately.

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS.

Source Error:
Line 7:
Line 8: <system.web>
Line 9: <authentication mode="Forms">
Line 10: <forms name=".ASPXUSERDEMO" loginUrl="http://
10.0.38.4/GoWatch/DesktopPC/login/login.aspx" protection="All"
timeout="5" />
Line 11: </authentication>

Source File: C:\website\GOWatch\desktoppc\login\web.config Line:
9

In my entire application, any sub folder with web.config will have the
similar error.

Please take note that, there are NO web.config in C:\website\GOWatch,
is this the root cause of the error?

Here is the content of my web.config in C:\website\GOWatch\desktoppc
\login\web.config
<configuration>
<appSettings>
<add key="ConnectionString" value="server=GOWATCHSERVER
\NetSDK; trusted_connection=true; Database=Gowatch" />
<add key="mailserver" value="GowatchServer" />
</appSettings>

<system.web>
<authentication mode="Forms">
<forms name=".ASPXUSERDEMO" loginUrl="http://10.0.38.4/GoWatch/
PocketPC/login/login.aspx" protection="All" timeout="5" />
</authentication>
<globalization requestEncoding="UTF-8" responseEncoding="UTF-8" /
>>>
<deviceFilters>
<filter name="supportsJavaScript" compare="Javascript"
argument="true"/>
</deviceFilters>

</system.web>

<location path="protected">
<system.web>
<authorization>
<deny users="?" />
</authorization>
</system.web>
</location>
</configuration>

Help are very much appreciated! Thank you.

cheok


Aug 25 '07 #3
Here's the reply from the UltiDev Forums :

---000---
If your application is located entirely in the "DesktopPC" sub-folder, you need to register
the application with the physical location of "C:\website\GOWatch\DesktopPC".

If not, please be sure that your application root folder "C:\website\GOWatch"
contains a web.config if you want to specify root-level settings, like Authentication type.

In general, application root folder does not necessarily need to contain a web.config,
but some web.config settings seem be required to be in the root-level web.config.
---000---

Good luck...

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Juan T. Llibre" <no***********@nowhere.comwrote in message news:eD**************@TK2MSFTNGP03.phx.gbl...
Since that's an UltiDev issue, you should post your question to the UltiDev Forums :

http://ultidev.com/Forums/default.aspx


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
<ya************@gmail.comwrote in message news:11**********************@i38g2000prf.googlegr oups.com...
>Hello all,

I have a web application, which I had developed few years ago with
ASP .NET 1.1

Today, I would like to deploy the web application to client, using
ASP .NET 2.0 + UltiDev Cassini 2.0

I locate my whole project in a folder named C:\website\GOWatch

My setting in UltiDev Cassini 2.0 is as follow :

Application = GoWatch
Port Number = 2040
Physical Path = C:\website\GOWatch

When I try to access an URL http://localhost:2040/DesktopPC/login/Login.aspx
(The login.aspx is located physically at C:\website\GOWatch\DesktopPC
\login\Login.aspx), I get the following error :


Configuration Error
Description: An error occurred during the processing of a
configuration file required to service this request. Please review the
specific error details below and modify your configuration file
appropriately.

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS.

Source Error:
Line 7:
Line 8: <system.web>
Line 9: <authentication mode="Forms">
Line 10: <forms name=".ASPXUSERDEMO" loginUrl="http://
10.0.38.4/GoWatch/DesktopPC/login/login.aspx" protection="All"
timeout="5" />
Line 11: </authentication>

Source File: C:\website\GOWatch\desktoppc\login\web.config Line:
9

In my entire application, any sub folder with web.config will have the
similar error.

Please take note that, there are NO web.config in C:\website\GOWatch,
is this the root cause of the error?

Here is the content of my web.config in C:\website\GOWatch\desktoppc
\login\web.config
<configuration>
<appSettings>
<add key="ConnectionString" value="server=GOWATCHSERVER
\NetSDK; trusted_connection=true; Database=Gowatch" />
<add key="mailserver" value="GowatchServer" />
</appSettings>

<system.web>
<authentication mode="Forms">
<forms name=".ASPXUSERDEMO" loginUrl="http://10.0.38.4/GoWatch/
PocketPC/login/login.aspx" protection="All" timeout="5" />
</authentication>
<globalization requestEncoding="UTF-8" responseEncoding="UTF-8" /
>>>
<deviceFilters>
<filter name="supportsJavaScript" compare="Javascript"
argument="true"/>
</deviceFilters>

</system.web>

<location path="protected">
<system.web>
<authorization>
<deny users="?" />
</authorization>
</system.web>
</location>
</configuration>

Help are very much appreciated! Thank you.

cheok


Aug 25 '07 #4
Thanks! I just do a quick hacking by removing all the web.config and
move them to the root folder. Anyway, this just suit to my
requirement :)
Aug 26 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by J. Muenchbourg | last post: by
3 posts views Thread by Daniel Wang | last post: by
2 posts views Thread by jai hanuman | last post: by
5 posts views Thread by clintonG | last post: by
5 posts views Thread by Randall Parker | last post: by
5 posts views Thread by NonNB | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.