By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,829 Members | 1,828 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,829 IT Pros & Developers. It's quick & easy.

Enable session state

P: n/a
I test asp.net 2.0 application on virtual PC for studio Orcas 2.0. When I
start application I get error in line
session("aa")="bb"
Error tells that I need to enable session state. I found in @page directive
option
enableSessionState which has values false, readonly and true. I put this
value true, however it did not help. it is possible to put this value into
web.config, but i did not find where. Also i need to add appropriate module
in http module list.
Whatever I do, nothing works,
Aug 20 '07 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Is this a web form? It sounds like it is not. Have you tried a web form.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET - MS Press
Professional VSTO 2005 - Wrox/Wiley
OWC Black Book www.lulu.com/owc

"Aleks Kleyn" <Al********@discussions.microsoft.comwrote in message
news:6F**********************************@microsof t.com...
>I test asp.net 2.0 application on virtual PC for studio Orcas 2.0. When I
start application I get error in line
session("aa")="bb"
Error tells that I need to enable session state. I found in @page
directive
option
enableSessionState which has values false, readonly and true. I put this
value true, however it did not help. it is possible to put this value
into
web.config, but i did not find where. Also i need to add appropriate
module
in http module list.
Whatever I do, nothing works,

Aug 21 '07 #2

P: n/a
This is regular web form asp.net 2.0. in onLoad event i wrote
session("aa")="bb". It works in regular case. But I test it in win 2003 and
studio Orcas. I need to understand what I need to enable session.

"Alvin Bruney [MVP]" wrote:
Is this a web form? It sounds like it is not. Have you tried a web form.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET - MS Press
Professional VSTO 2005 - Wrox/Wiley
OWC Black Book www.lulu.com/owc

"Aleks Kleyn" <Al********@discussions.microsoft.comwrote in message
news:6F**********************************@microsof t.com...
I test asp.net 2.0 application on virtual PC for studio Orcas 2.0. When I
start application I get error in line
session("aa")="bb"
Error tells that I need to enable session state. I found in @page
directive
option
enableSessionState which has values false, readonly and true. I put this
value true, however it did not help. it is possible to put this value
into
web.config, but i did not find where. Also i need to add appropriate
module
in http module list.
Whatever I do, nothing works,


Aug 21 '07 #3

P: n/a
Hi,
Maybe at your machine.config session closed.
Try to check maching.config, web.config (in the same directory) or
web.config (int wwwroot directory)

I am not sure but in my opinion because of win2k3's security options it is
not allowed by default.

"Aleks Kleyn" <Al********@discussions.microsoft.com>, iletisinde şunu yazdı,
news:0D**********************************@microsof t.com...
This is regular web form asp.net 2.0. in onLoad event i wrote
session("aa")="bb". It works in regular case. But I test it in win 2003
and
studio Orcas. I need to understand what I need to enable session.

"Alvin Bruney [MVP]" wrote:
>Is this a web form? It sounds like it is not. Have you tried a web form.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET - MS Press
Professional VSTO 2005 - Wrox/Wiley
OWC Black Book www.lulu.com/owc

"Aleks Kleyn" <Al********@discussions.microsoft.comwrote in message
news:6F**********************************@microso ft.com...
>I test asp.net 2.0 application on virtual PC for studio Orcas 2.0. When
I
start application I get error in line
session("aa")="bb"
Error tells that I need to enable session state. I found in @page
directive
option
enableSessionState which has values false, readonly and true. I put
this
value true, however it did not help. it is possible to put this value
into
web.config, but i did not find where. Also i need to add appropriate
module
in http module list.
Whatever I do, nothing works,


Aug 22 '07 #4

P: n/a
re:
!in my opinion because of win2k3's security options it is not allowed by default

The default setting for session state is "InProc",
which means that sessions are allowed no matter which OS is used.

If you don't want sessions, you have to set sessionstate to "Off",
either in the <sessionstate mode...or the <pages sessionstate...elements in web.config
..
That disables the use of sessions.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaol : http://asp.net.do/foros/
======================================
"Bahadir ARSLAN" <ba************@netron.com.trwrote in message
news:9E**********************************@microsof t.com...
Hi,
Maybe at your machine.config session closed.
Try to check maching.config, web.config (in the same directory) or web.config (int wwwroot directory)

I am not sure but in my opinion because of win2k3's security options it is not allowed by default.

"Aleks Kleyn" <Al********@discussions.microsoft.com>, iletisinde sunu yazdi,
news:0D**********************************@microsof t.com...
>This is regular web form asp.net 2.0. in onLoad event i wrote
session("aa")="bb". It works in regular case. But I test it in win 2003 and
studio Orcas. I need to understand what I need to enable session.

"Alvin Bruney [MVP]" wrote:
>>Is this a web form? It sounds like it is not. Have you tried a web form.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET - MS Press
Professional VSTO 2005 - Wrox/Wiley
OWC Black Book www.lulu.com/owc

"Aleks Kleyn" <Al********@discussions.microsoft.comwrote in message
news:6F**********************************@micros oft.com...
I test asp.net 2.0 application on virtual PC for studio Orcas 2.0. When I
start application I get error in line
session("aa")="bb"
Error tells that I need to enable session state. I found in @page
directive
option
enableSessionState which has values false, readonly and true. I put this
value true, however it did not help. it is possible to put this value
into
web.config, but i did not find where. Also i need to add appropriate
module
in http module list.
Whatever I do, nothing works,

Aug 22 '07 #5

P: n/a
you catched the point. I do not know about machine.config and I decided to
look to webroot. I did not find machine.config, but in the main folder there
is web.config as well. There reference to http module for sessionState was
commented (I need to find answer why; this is team foundation server). When I
uncommented this reference everything works fine

"Bahadır ARSLAN" wrote:
Hi,
Maybe at your machine.config session closed.
Try to check maching.config, web.config (in the same directory) or
web.config (int wwwroot directory)

I am not sure but in my opinion because of win2k3's security options it is
not allowed by default.

"Aleks Kleyn" <Al********@discussions.microsoft.com>, iletisinde şunu yazdı,
news:0D**********************************@microsof t.com...
This is regular web form asp.net 2.0. in onLoad event i wrote
session("aa")="bb". It works in regular case. But I test it in win 2003
and
studio Orcas. I need to understand what I need to enable session.

"Alvin Bruney [MVP]" wrote:
Is this a web form? It sounds like it is not. Have you tried a web form.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET - MS Press
Professional VSTO 2005 - Wrox/Wiley
OWC Black Book www.lulu.com/owc

"Aleks Kleyn" <Al********@discussions.microsoft.comwrote in message
news:6F**********************************@microsof t.com...
I test asp.net 2.0 application on virtual PC for studio Orcas 2.0. When
I
start application I get error in line
session("aa")="bb"
Error tells that I need to enable session state. I found in @page
directive
option
enableSessionState which has values false, readonly and true. I put
this
value true, however it did not help. it is possible to put this value
into
web.config, but i did not find where. Also i need to add appropriate
module
in http module list.
Whatever I do, nothing works,
Aug 22 '07 #6

This discussion thread is closed

Replies have been disabled for this discussion.