By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,997 Members | 1,260 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,997 IT Pros & Developers. It's quick & easy.

release mode Compile error BC2014

P: n/a
I have an asp.net 2.0 project that when I change the build configuration to
release I get the following error:

Command line error BC2014: the value 'None' is invalid for option
'debug'.

If I go into the projects Advanced Compile Options and change the Generate
Debug Info dropdown from None to PDB-Only the error goes away. Can anyone
explain why I have to do this and what can I do to get the one option to
work on a asp.net project? It is causing problems because the common
project is shared with a VB project that gets an error on release mode
compile if it is set to pdb-only.

Thanks for your help.
Jul 13 '07 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Just add this entry to the web.config file :
<compilation debug="true" />

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"news.microsoft.com" <tw***********@hotmail.comwrote in message news:e4*************@TK2MSFTNGP06.phx.gbl...
>I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:

Command line error BC2014: the value 'None' is invalid for option 'debug'.

If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
asp.net project? It is causing problems because the common project is shared with a VB project that gets an error on
release mode compile if it is set to pdb-only.

Thanks for your help.

Jul 13 '07 #2

P: n/a
On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
Just add this entry to the web.config file :

<compilation debug="true" />

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================

"news.microsoft.com" <twsilentde...@hotmail.comwrote in messagenews:e4*************@TK2MSFTNGP06.phx.gbl.. .
I have an asp.net 2.0 project that when I change the build configurationto release I get the following error:
Command line error BC2014: the value 'None' is invalid for option 'debug'.
If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
the error goes away. Can anyone explain why I have to do this and whatcan I do to get the one option to work on a
asp.net project? It is causing problems because the common project is shared with a VB project that gets an error on
release mode compile if it is set to pdb-only.
Thanks for your help.- Hide quoted text -

- Show quoted text -
hai,
he try build in release mode better set
<compilation debug="false" />

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd

Jul 13 '07 #3

P: n/a
re:
!he try build in release mode better set
!<compilation debug="false" />

No. He said that when :

!I change the build configuration to release

....the error occurs, therefore setting it to debug="true" should fix it.

Your suggestion, debug="false", is the same as setting the application
to release mode, so he would likely continue to get the same error as
whenhe manually sets it to "release" mode.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"nahid" <na******@gmail.comwrote in message news:11**********************@k79g2000hse.googlegr oups.com...
On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
Just add this entry to the web.config file :

<compilation debug="true" />

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================

"news.microsoft.com" <twsilentde...@hotmail.comwrote in messagenews:e4*************@TK2MSFTNGP06.phx.gbl.. .
I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:
Command line error BC2014: the value 'None' is invalid for option 'debug'.
If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
on
release mode compile if it is set to pdb-only.
Thanks for your help.- Hide quoted text -

- Show quoted text -
hai,
he try build in release mode better set
<compilation debug="false" />

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd
Jul 13 '07 #4

P: n/a
On Jul 14, 12:53 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!he try build in release mode better set
!<compilation debug="false" />

No. He said that when :

!I change the build configuration to release

...the error occurs, therefore setting it to debug="true" should fix it.

Your suggestion, debug="false", is the same as setting the application
to release mode, so he would likely continue to get the same error as
whenhe manually sets it to "release" mode.

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"nahid" <nahid...@gmail.comwrote in messagenews:11**********************@k79g2000hse.g ooglegroups.com...

On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:


Just add this entry to the web.config file :
<compilation debug="true" />
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================
"news.microsoft.com" <twsilentde...@hotmail.comwrote in messagenews:e4*************@TK2MSFTNGP06.phx.gbl.. .
>I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:
Command line error BC2014: the value 'None' is invalid for option 'debug'.
If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to PDB-Only
the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on a
asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
on
release mode compile if it is set to pdb-only.
Thanks for your help.- Hide quoted text -
- Show quoted text -

hai,
he try build in release mode better set
<compilation debug="false" />

nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quotedtext -

- Show quoted text -
well so what is basically main problem, say i'm not prefer set
<compilation debug="true" /because of loss some performance

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd

Jul 13 '07 #5

P: n/a
re:
!well so what is basically main problem, say i'm not prefer set
!<compilation debug="true" /because of loss some performance

True enough, but to resolve the *current* problem ( that the app won't run ),
the solution is get get the app working *first* and then *later* we worry about performance.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"nahid" <na******@gmail.comwrote in message news:11**********************@q75g2000hsh.googlegr oups.com...
On Jul 14, 12:53 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!he try build in release mode better set
!<compilation debug="false" />

No. He said that when :

!I change the build configuration to release

...the error occurs, therefore setting it to debug="true" should fix it.

Your suggestion, debug="false", is the same as setting the application
to release mode, so he would likely continue to get the same error as
whenhe manually sets it to "release" mode.

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"nahid" <nahid...@gmail.comwrote in
messagenews:11**********************@k79g2000hse.g ooglegroups.com...

On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:


Just add this entry to the web.config file :
<compilation debug="true" />
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================
"news.microsoft.com" <twsilentde...@hotmail.comwrote in messagenews:e4*************@TK2MSFTNGP06.phx.gbl.. .
>I have an asp.net 2.0 project that when I change the build configuration to release I get the following error:
Command line error BC2014: the value 'None' is invalid for option 'debug'.
If I go into the projects Advanced Compile Options and change the Generate Debug Info dropdown from None to
PDB-Only
the error goes away. Can anyone explain why I have to do this and what can I do to get the one option to work on
a
asp.net project? It is causing problems because the common project is shared with a VB project that gets an error
on
release mode compile if it is set to pdb-only.
Thanks for your help.- Hide quoted text -
- Show quoted text -

hai,
he try build in release mode better set
<compilation debug="false" />

nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted text -

- Show quoted text -
well so what is basically main problem, say i'm not prefer set
<compilation debug="true" /because of loss some performance

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd
Jul 13 '07 #6

P: n/a
I already have in my web config file <compilation defaultLanguage="vb"
debug="true"/>
and I am getting this message if the debug is set to true or false in the
web.config file.

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2****************@TK2MSFTNGP06.phx.gbl...
re:
!well so what is basically main problem, say i'm not prefer set
!<compilation debug="true" /because of loss some performance

True enough, but to resolve the *current* problem ( that the app won't
run ),
the solution is get get the app working *first* and then *later* we worry
about performance.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"nahid" <na******@gmail.comwrote in message
news:11**********************@q75g2000hsh.googlegr oups.com...
On Jul 14, 12:53 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
>re:
!he try build in release mode better set
!<compilation debug="false" />

No. He said that when :

!I change the build configuration to release

...the error occurs, therefore setting it to debug="true" should fix it.

Your suggestion, debug="false", is the same as setting the application
to release mode, so he would likely continue to get the same error as
whenhe manually sets it to "release" mode.

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"nahid" <nahid...@gmail.comwrote
in messagenews:11**********************@k79g2000hse.g ooglegroups.com...

On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:


Just add this entry to the web.config file :
<compilation debug="true" />
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================
"news.microsoft.com" <twsilentde...@hotmail.comwrote in
messagenews:e4*************@TK2MSFTNGP06.phx.gbl.. .
I have an asp.net 2.0 project that when I change the build
configuration to release I get the following error:
Command line error BC2014: the value 'None' is invalid for option
'debug'.
If I go into the projects Advanced Compile Options and change the
Generate Debug Info dropdown from None to PDB-Only
the error goes away. Can anyone explain why I have to do this and
what can I do to get the one option to work on a
asp.net project? It is causing problems because the common project
is shared with a VB project that gets an error
on
release mode compile if it is set to pdb-only.
Thanks for your help.- Hide quoted text -
- Show quoted text -

hai,
he try build in release mode better set
<compilation debug="false" />

nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide quoted
text -

- Show quoted text -

well so what is basically main problem, say i'm not prefer set
<compilation debug="true" /because of loss some performance

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd


Jul 13 '07 #7

P: n/a
I already have in my web config file <compilation defaultLanguage="vb"
debug="true"/>
and I am getting this message if the debug is set to true or false in the
web.config file if I am trying to compile in release mode with the Generate
Debug Info dropdown set to None. If I change the Generate Debug Info
dropdown set to PDB-Only or Full then the project compiles fine reguardless
of release or debug mode. I hope this clarifies the problem I am having.
"news.microsoft.com" <tw***********@hotmail.comwrote in message
news:Od*************@TK2MSFTNGP06.phx.gbl...
>I already have in my web config file <compilation defaultLanguage="vb"
debug="true"/>
and I am getting this message if the debug is set to true or false in the
web.config file.

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2****************@TK2MSFTNGP06.phx.gbl...
>re:
!well so what is basically main problem, say i'm not prefer set
!<compilation debug="true" /because of loss some performance

True enough, but to resolve the *current* problem ( that the app won't
run ),
the solution is get get the app working *first* and then *later* we worry
about performance.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"nahid" <na******@gmail.comwrote in message
news:11**********************@q75g2000hsh.googleg roups.com...
On Jul 14, 12:53 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
>>re:
!he try build in release mode better set
!<compilation debug="false" />

No. He said that when :

!I change the build configuration to release

...the error occurs, therefore setting it to debug="true" should fix it.

Your suggestion, debug="false", is the same as setting the application
to release mode, so he would likely continue to get the same error as
whenhe manually sets it to "release" mode.

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"nahid" <nahid...@gmail.comwrote
in messagenews:11**********************@k79g2000hse.g ooglegroups.com...

On Jul 14, 12:20 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:

Just add this entry to the web.config file :

<compilation debug="true" />

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================

"news.microsoft.com" <twsilentde...@hotmail.comwrote in
messagenews:e4*************@TK2MSFTNGP06.phx.gbl. ..
I have an asp.net 2.0 project that when I change the build
configuration to release I get the following error:

Command line error BC2014: the value 'None' is invalid for option
'debug'.

If I go into the projects Advanced Compile Options and change the
Generate Debug Info dropdown from None to PDB-Only
the error goes away. Can anyone explain why I have to do this and
what can I do to get the one option to work on a
asp.net project? It is causing problems because the common project
is shared with a VB project that gets an error
on
release mode compile if it is set to pdb-only.

Thanks for your help.- Hide quoted text -

- Show quoted text -

hai,
he try build in release mode better set
<compilation debug="false" />

nahidhttp://nahidulkibria.blogspot.com/http://www.kaz.com.bd- Hide
quoted text -

- Show quoted text -

well so what is basically main problem, say i'm not prefer set
<compilation debug="true" /because of loss some performance

nahid
http://nahidulkibria.blogspot.com/
http://www.kaz.com.bd



Jul 13 '07 #8

This discussion thread is closed

Replies have been disabled for this discussion.