By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,187 Members | 1,038 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,187 IT Pros & Developers. It's quick & easy.

Errors locating WebResource.axd

P: n/a
We are getting WebForm_DoPostBackWithOptions is not defined and other Java
script errors related to WebResource.axd file. I narrowed down the problem
and found out the cause but can't come up with a solution based on our
application setup. Here is is how our web sites configured on IIS.
Multiple web sites points to the same IP address and some of these web sites
has sub-virtual directories, for example mystore.com is a web site that has
one or more virtuals configured store1, store2, etc... so mystore.com/store1
and mystore.com are two different URLs.

Website:somestore.com
website: newstore.com
website: Mystore.com
virtual:store1
virtual:store2
virtual:test1

Now, mystore.com is working fine with no errors because it is locating
WebResource file via this path "/WebResource.axd/...." whereas
mystore.com/store1 causes Javascript errors because it is trying to locate
javascripts built-in through this path "/store1/WebResource.asd/...."

<script
src="/store1/WebResource.axd?d=GDH9bwi9ljRPaO1zUbDGCA2&t=633165 740660873260"
type="text/javascript"></script>
Which doesn't exist. I checked the mappings of both website and its virtual
and .axd is mapped to
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspn et_isapi.dll
Is there is a way to control the path to WebResource.axd page so it doesn't
add the virtual name to the path? Or do I need to change some parameters in
IIS?

Note: we are getting these errors now because we recently upgraded our
application to VS2005.
Jul 5 '07 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I am still researching this problem and found out that the src to
webResource.axd on the html page source for mystore.com/store1 is correct but
still can't locate the file if I paste the path
="/store1/WebResource.axd?d=GDH9bwi9ljRPaO1zUbDGCA2&t=633165 740660873260 to
the URL I get page can't be displayed error. Is it because we have multiple
websites points to the same IP address and under these web sites we have
another level of virtuals, web site without any virtuals works fine
(newsite.com) the problem is when a store has multiple virtuals
"mystore.com/store1, mystore.com.store2, etc..."

any idea can help, thanks...

"May" wrote:
We are getting WebForm_DoPostBackWithOptions is not defined and other Java
script errors related to WebResource.axd file. I narrowed down the problem
and found out the cause but can't come up with a solution based on our
application setup. Here is is how our web sites configured on IIS.
Multiple web sites points to the same IP address and some of these web sites
has sub-virtual directories, for example mystore.com is a web site that has
one or more virtuals configured store1, store2, etc... so mystore.com/store1
and mystore.com are two different URLs.

Website:somestore.com
website: newstore.com
website: Mystore.com
virtual:store1
virtual:store2
virtual:test1

Now, mystore.com is working fine with no errors because it is locating
WebResource file via this path "/WebResource.axd/...." whereas
mystore.com/store1 causes Javascript errors because it is trying to locate
javascripts built-in through this path "/store1/WebResource.asd/...."

<script
src="/store1/WebResource.axd?d=GDH9bwi9ljRPaO1zUbDGCA2&t=633165 740660873260"
type="text/javascript"></script>
Which doesn't exist. I checked the mappings of both website and its virtual
and .axd is mapped to
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspn et_isapi.dll
Is there is a way to control the path to WebResource.axd page so it doesn't
add the virtual name to the path? Or do I need to change some parameters in
IIS?

Note: we are getting these errors now because we recently upgraded our
application to VS2005.

Jul 8 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.