By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,684 Members | 1,439 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,684 IT Pros & Developers. It's quick & easy.

Unable to redirect when using custom 'Login' with custom 'Membership provider'

P: n/a
After logging in, I am not able to redirect to the target url; and
this happens only when I connect to the website using "http://machine-
name:portname"; but not if I connect using either "http://IP:portname"
or "http://localhost:portname"

Web site has custom 'Login control' and custom 'Membership provider';
and I do not have access to 'Login control' control code.
MembershipProvider::Validateuser() is returning true irrespective of
URL. Webserver is not part of any AD domain and is just a workgroup.
When it fails to redirect, it does not display any error but just a
blank page.

Login.aspx.cs
----------------------
<%@ Register Assembly="MyControlLibrary" Namespace="MyControlLibrary"
TagPrefix="cc1" %>
....
....
<form id="form1" runat="server">
<div style="text-align: center;">
<cc1:MyLogin ID="MyLogin1" runat="server" BrandName="abc"
ProductName="Abc" DestinationPageUrl="~/target.aspx">
</cc1:MyLogin>
</div>
</form>
Web.config
------------------
<authentication mode="Forms">
<forms name="Web_GUI" loginUrl="login.aspx"/>
</authentication>

<membership defaultProvider="MyMembershipProvider">
<providers>
<add enablePasswordRetrieval="false" enablePasswordReset="false"
requiresQuestionAndAnswer="false"
applicationName="MyMembershipProvider" requiresUniqueEmail="true"
passwordFormat="Hashed"
maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7"
minRequiredNonalphanumericCharacters="1"
passwordAttemptWindow="10"
passwordStrengthRegularExpression="" name="MyMembershipProvider"
type="MyMembershipProvider"/>
</providers>
</membership>
Is this because I have not configured the trusted-site correctly in
IE?

Thanks
Ramesh

Jun 5 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.