By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,214 Members | 2,066 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,214 IT Pros & Developers. It's quick & easy.

GZip output compression with AJAX

P: n/a
Hi. To make page downloading quicker, I added GZipStream into the
Response filter. My (shortened VB) code snippet from Global.asax looks
like this:
............................................

Sub Application_BeginRequest(...)

If Request.RawUrl.Contains(".aspx") And _
Not Request.Headers("Accept-Encoding") Is Nothing Then

If Request.Headers("Accept-
encoding").ToLower().Contains("gzip") Then

Response.Filter = New GZipStream(Response.Filter,
CompressionMode.Compress, True)
Response.AppendHeader("Content-encoding", "gzip")

' Else...try deflate

End If

End If

End Sub
............................................

I added the check for .aspx in the request because it was messing up
images. Now that I'm using AJAX, it's giving me problems again. When
AJAX (I mean ASP's AJAX thing, but I'm not using Atlas) tries to
communicate with the server, it (JS) alert()s me that it could not
parse the server's response, and is probably because of a filter
(meaning this simple GZip stream).

How can I more efficiently check whether or not it is appropriate to
compress the output? And, by the way, is there a better way of
compressing output that won't mess up with images and could possibly
compress AJAX also?

-Mike PII

Jun 4 '07 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Did you ever find a solution to this? I am having the same problem. If I
enable compression on our ISA server, it works fine. Just when using an
HTTPModule is when I have this problem. Very frustrating.

"Mike P2" wrote:
Hi. To make page downloading quicker, I added GZipStream into the
Response filter. My (shortened VB) code snippet from Global.asax looks
like this:
............................................

Sub Application_BeginRequest(...)

If Request.RawUrl.Contains(".aspx") And _
Not Request.Headers("Accept-Encoding") Is Nothing Then

If Request.Headers("Accept-
encoding").ToLower().Contains("gzip") Then

Response.Filter = New GZipStream(Response.Filter,
CompressionMode.Compress, True)
Response.AppendHeader("Content-encoding", "gzip")

' Else...try deflate

End If

End If

End Sub
............................................

I added the check for .aspx in the request because it was messing up
images. Now that I'm using AJAX, it's giving me problems again. When
AJAX (I mean ASP's AJAX thing, but I'm not using Atlas) tries to
communicate with the server, it (JS) alert()s me that it could not
parse the server's response, and is probably because of a filter
(meaning this simple GZip stream).

How can I more efficiently check whether or not it is appropriate to
compress the output? And, by the way, is there a better way of
compressing output that won't mess up with images and could possibly
compress AJAX also?

-Mike PII

Jun 6 '07 #2

P: n/a
On Jun 6, 8:50 am, bikemike <bikem...@discussions.microsoft.com>
wrote:
Did you ever find a solution to this? I am having the same problem. If I
enable compression on our ISA server, it works fine. Just when using an
HTTPModule is when I have this problem. Very frustrating.
No, I haven't found a solution yet. This is frustrating me too. GZip
compression is a pretty common thing, I'm sure it's been done
successfully in ASP.net and there are people in this newsgroup who
have the solution.

-Mike PII

Jun 6 '07 #3

P: n/a
Ok, I tried using

If Request.Headers("Accept").Contains("html") Or
Request.Headers("Accept").Contains("xml")) Then

instead to decide whether or not to compress the output with GZ and my
other filter that takes out some whitespace, but that's not helping
either. I guess ASP.net AJAX is served by the same page it's on
instead of ScriptResource.axd or whatever. So what can I do?

-Mike PII

Jun 11 '07 #4

P: n/a
I did find a solution to this problem that is not resolved with GZip in .NET,
but in IIS. Basically all I did was enable compression for only my virtual
directory in IIS. For whatever reason, the AJAX code does not have any
problems with this and it works great. I am getting nearly 90% compression
on my returned code now. After spending a day trying to make the .NET
solution work, I gave up and looked for alternative solutions. Fortunately,
the built-in IIS compression did the trick. If you need help on how to
enable it for just a single web or virtual, let me know.

"Mike P2" wrote:
Ok, I tried using

If Request.Headers("Accept").Contains("html") Or
Request.Headers("Accept").Contains("xml")) Then

instead to decide whether or not to compress the output with GZ and my
other filter that takes out some whitespace, but that's not helping
either. I guess ASP.net AJAX is served by the same page it's on
instead of ScriptResource.axd or whatever. So what can I do?

-Mike PII

Jun 12 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.