By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,684 Members | 1,439 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,684 IT Pros & Developers. It's quick & easy.

web.config ignored - Solved

P: n/a
I recently posted the following problem description:

----Snip---------------------
I have a ASP.Net 2.0 web application that I am trying to debug. Problem is
that I can't get the error message to show in the browser. It always returns
the generic error message telling me to set customErrors="Off". Problem is I
have already done that.

I have tried to activate tracing as well, by setting trace enabled="true",
but accessing the trace.axd page returns a message instructing me to do just
that.
-----------------------------

Since no solution was found in the newsgroup I had to investigate the cause myself, and it turns out that the problem was related to a setting in the machine.config file.

configuration>

....

<system.web>

....

<deployment retail="false" />

....

</system.web>

</configuration>

According to the documentation, setting retail="true" gives exactly the problem I was having:

When retail is set to true, ASP.NET disables certain configuration settings such as trace output, custom errors, and debug capabilities.
Problem solved!

Regards;
/jb
Jun 1 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.