By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,829 Members | 1,798 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,829 IT Pros & Developers. It's quick & easy.

Session Timeout Problem

P: n/a
The web.config in my asp.net application, running on Server2003, has this
entry: <sessionState mode="InProc" timeout="40".
In IIS the asp.net State Management timeout setting is 40 for my website.
In IIS the virtual directory configuration setting is set to 40.

The application still timesout at 20 minutes.

What else can I do?

--
Regards,
Gary Blakely
May 31 '07 #1
Share this Question
Share on Google+
14 Replies


P: n/a
set the timeout on page load, see if that helps.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET is coming...
https://www.microsoft.com/MSPress/books/10933.aspx
OWC Black Book www.lulu.com/owc
Professional VSTO 2005 - Wrox/Wiley
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:eG**************@TK2MSFTNGP03.phx.gbl...
The web.config in my asp.net application, running on Server2003, has this
entry: <sessionState mode="InProc" timeout="40".
In IIS the asp.net State Management timeout setting is 40 for my website.
In IIS the virtual directory configuration setting is set to 40.

The application still timesout at 20 minutes.

What else can I do?

--
Regards,
Gary Blakely


May 31 '07 #2

P: n/a
you probably have asp.net configured to shutdown after 20 mins of idle.
this causes a recycle which loses all session data.

if you use inproc session, you will sometimes lose session data due to a
recycle, so your site should be coded to handle this case.

-- bruce (sqlwork.com)

GaryDean wrote:
The web.config in my asp.net application, running on Server2003, has this
entry: <sessionState mode="InProc" timeout="40".
In IIS the asp.net State Management timeout setting is 40 for my website.
In IIS the virtual directory configuration setting is set to 40.

The application still timesout at 20 minutes.

What else can I do?
May 31 '07 #3

P: n/a
Hi Gary,

As you mentioned that you've used three session setting, then what's the
actual session mode you use now, inproc one? I suggeset you create a
simplified application and use inproc session to verify the behavior.

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
This posting is provided "AS IS" with no warranties, and confers no rights.

May 31 '07 #4

P: n/a
Could you be a little more specific?
I have asp.net configured to shutdown after 20 mins? where? how?
"site should be coded to handle this case? how?

--
Regards,
Gary Blakely
"bruce barker" <no****@nospam.comwrote in message
news:uu**************@TK2MSFTNGP06.phx.gbl...
you probably have asp.net configured to shutdown after 20 mins of idle.
this causes a recycle which loses all session data.

if you use inproc session, you will sometimes lose session data due to a
recycle, so your site should be coded to handle this case.

-- bruce (sqlwork.com)

GaryDean wrote:
>The web.config in my asp.net application, running on Server2003, has this
entry: <sessionState mode="InProc" timeout="40".
In IIS the asp.net State Management timeout setting is 40 for my website.
In IIS the virtual directory configuration setting is set to 40.

The application still timesout at 20 minutes.

What else can I do?

May 31 '07 #5

P: n/a
Steven,
you ask "what's the actual session mode you use now" not sure I understand
your question. In my original post I stated the session settings in my
web.config and the setting is IIS. every conceivable setting I know of says
40 minutes but the application timesout after 20 minutes.

--
Regards,
Gary Blakely
"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
news:MZ**************@TK2MSFTNGHUB02.phx.gbl...
Hi Gary,

As you mentioned that you've used three session setting, then what's the
actual session mode you use now, inproc one? I suggeset you create a
simplified application and use inproc session to verify the behavior.

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
This posting is provided "AS IS" with no warranties, and confers no
rights.

May 31 '07 #6

P: n/a
re:
!every conceivable setting I know of says
!40 minutes but the application timesout after 20 minutes.

Including the Forms Authentication timeout ( if you're using that ? ).
*That* defaults to 20 minutes, too.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:O$**************@TK2MSFTNGP04.phx.gbl...
Steven,
you ask "what's the actual session mode you use now" not sure I understand your question. In my
original post I stated the session settings in my web.config and the setting is IIS. every
conceivable setting I know of says 40 minutes but the application timesout after 20 minutes.

--
Regards,
Gary Blakely
"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
news:MZ**************@TK2MSFTNGHUB02.phx.gbl...
>Hi Gary,

As you mentioned that you've used three session setting, then what's the
actual session mode you use now, inproc one? I suggeset you create a
simplified application and use inproc session to verify the behavior.

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
This posting is provided "AS IS" with no warranties, and confers no rights.


May 31 '07 #7

P: n/a
re:
!I have asp.net configured to shutdown after 20 mins? where? how?

20 minutes is the default.
If you don't have a timeout configured...you'll get a 20 minute timeout.

To get back to the problem, are you using Forms Authentication ?
Could *that* be set to 20 minutes ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
Could you be a little more specific?
I have asp.net configured to shutdown after 20 mins? where? how?
"site should be coded to handle this case? how?

--
Regards,
Gary Blakely
"bruce barker" <no****@nospam.comwrote in message news:uu**************@TK2MSFTNGP06.phx.gbl...
>you probably have asp.net configured to shutdown after 20 mins of idle. this causes a recycle
which loses all session data.

if you use inproc session, you will sometimes lose session data due to a recycle, so your site
should be coded to handle this case.

-- bruce (sqlwork.com)

GaryDean wrote:
>>The web.config in my asp.net application, running on Server2003, has this entry: <sessionState
mode="InProc" timeout="40".
In IIS the asp.net State Management timeout setting is 40 for my website.
In IIS the virtual directory configuration setting is set to 40.

The application still timesout at 20 minutes.

What else can I do?


May 31 '07 #8

P: n/a
I believe that timeout default is 30, but yes I also set the Forms
Authentication timout to 40.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2***************@TK2MSFTNGP05.phx.gbl...
re:
!every conceivable setting I know of says
!40 minutes but the application timesout after 20 minutes.

Including the Forms Authentication timeout ( if you're using that ? ).
*That* defaults to 20 minutes, too.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:O$**************@TK2MSFTNGP04.phx.gbl...
>Steven,
you ask "what's the actual session mode you use now" not sure I
understand your question. In my original post I stated the session
settings in my web.config and the setting is IIS. every conceivable
setting I know of says 40 minutes but the application timesout after 20
minutes.

--
Regards,
Gary Blakely
"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
news:MZ**************@TK2MSFTNGHUB02.phx.gbl...
>>Hi Gary,

As you mentioned that you've used three session setting, then what's the
actual session mode you use now, inproc one? I suggeset you create a
simplified application and use inproc session to verify the behavior.

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
This posting is provided "AS IS" with no warranties, and confers no
rights.



Jun 1 '07 #9

P: n/a
If you have set all the timeouts to 40, and the app is still losing the session variables
at 20, then either the app is recycling at 20 or the application pool is recycling at 20.

Have you attempted to set a different recycling threshold in the IIS Manager ?

Also, have you tried to use State Server, instead of InProc ?

State Server, as does SQL Server, gets around the loss of
session variables due to Application/App Pool recycling.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:eb****************@TK2MSFTNGP05.phx.gbl...
>I believe that timeout default is 30, but yes I also set the Forms Authentication timout to 40.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2***************@TK2MSFTNGP05.phx.gbl...
>re:
!every conceivable setting I know of says
!40 minutes but the application timesout after 20 minutes.

Including the Forms Authentication timeout ( if you're using that ? ).
*That* defaults to 20 minutes, too.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:O$**************@TK2MSFTNGP04.phx.gbl...
>>Steven,
you ask "what's the actual session mode you use now" not sure I understand your question. In
my original post I stated the session settings in my web.config and the setting is IIS. every
conceivable setting I know of says 40 minutes but the application timesout after 20 minutes.

--
Regards,
Gary Blakely
"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
news:MZ**************@TK2MSFTNGHUB02.phx.gbl.. .
Hi Gary,

As you mentioned that you've used three session setting, then what's the
actual session mode you use now, inproc one? I suggeset you create a
simplified application and use inproc session to verify the behavior.

Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead
This posting is provided "AS IS" with no warranties, and confers no rights.



Jun 1 '07 #10

P: n/a
I've goolged and looked everywhere I can and I can't find anything on
"recycling threshold settings" in IIS. My original question at the
beginning of this thread stands.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OO****************@TK2MSFTNGP03.phx.gbl...
If you have set all the timeouts to 40, and the app is still losing the
session variables
at 20, then either the app is recycling at 20 or the application pool is
recycling at 20.

Have you attempted to set a different recycling threshold in the IIS
Manager ?

Also, have you tried to use State Server, instead of InProc ?

State Server, as does SQL Server, gets around the loss of
session variables due to Application/App Pool recycling.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:eb****************@TK2MSFTNGP05.phx.gbl...
>>I believe that timeout default is 30, but yes I also set the Forms
Authentication timout to 40.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2***************@TK2MSFTNGP05.phx.gbl...
>>re:
!every conceivable setting I know of says
!40 minutes but the application timesout after 20 minutes.

Including the Forms Authentication timeout ( if you're using that ? ).
*That* defaults to 20 minutes, too.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:O$**************@TK2MSFTNGP04.phx.gbl...
Steven,
you ask "what's the actual session mode you use now" not sure I
understand your question. In my original post I stated the session
settings in my web.config and the setting is IIS. every conceivable
setting I know of says 40 minutes but the application timesout after 20
minutes.

--
Regards,
Gary Blakely
"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
news:MZ**************@TK2MSFTNGHUB02.phx.gbl. ..
Hi Gary,
>
As you mentioned that you've used three session setting, then what's
the
actual session mode you use now, inproc one? I suggeset you create a
simplified application and use inproc session to verify the behavior.
>
Sincerely,
>
Steven Cheng
>
Microsoft MSDN Online Support Lead
>
>
This posting is provided "AS IS" with no warranties, and confers no
rights.
>




Jun 1 '07 #11

P: n/a
no, it's set to 40. Everythingis set to 40.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
re:
!I have asp.net configured to shutdown after 20 mins? where? how?

20 minutes is the default.
If you don't have a timeout configured...you'll get a 20 minute timeout.

To get back to the problem, are you using Forms Authentication ?
Could *that* be set to 20 minutes ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
>Could you be a little more specific?
I have asp.net configured to shutdown after 20 mins? where? how?
"site should be coded to handle this case? how?

--
Regards,
Gary Blakely
"bruce barker" <no****@nospam.comwrote in message
news:uu**************@TK2MSFTNGP06.phx.gbl...
>>you probably have asp.net configured to shutdown after 20 mins of idle.
this causes a recycle which loses all session data.

if you use inproc session, you will sometimes lose session data due to a
recycle, so your site should be coded to handle this case.

-- bruce (sqlwork.com)

GaryDean wrote:
The web.config in my asp.net application, running on Server2003, has
this entry: <sessionState mode="InProc" timeout="40".
In IIS the asp.net State Management timeout setting is 40 for my
website.
In IIS the virtual directory configuration setting is set to 40.

The application still timesout at 20 minutes.

What else can I do?



Jun 1 '07 #12

P: n/a
In Windows Server 2003, you can set the recycling threshhold
for the Application Pool in which an application runs.

In the IIS Manager, scroll down the left hand panel to "Application Pools",
and select the Application Pool in which your app runs.

Right-click the App Pool and select "Properties" from the context menu.

You'll see several options for setting the time/memory limit/number of requests
at which the application pool will be recycled.

Just make sure your time setting isn't set too low.
Leave the rest untouched until you are familiar with the settings.

You don't say whether you tried using State Server.

!Also, have you tried to use State Server, instead of InProc state management?

!State Server state management, as does SQL Server, gets around
!the loss of session variables due to Application/App Pool recycling.

Just configure it in web.config :

<sessionState
mode="StateServer"
stateConnectionString="tcpip=127.0.0.1:42424"
stateNetworkTimeout="10"
cookieless="false"
timeout="20"
/>

....and in the "Services" applet of the W2K3 Server, start the State Server service.

That usually works to prevent Session variable losses.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:eY**************@TK2MSFTNGP02.phx.gbl...
I've goolged and looked everywhere I can and I can't find anything on "recycling threshold
settings" in IIS. My original question at the beginning of this thread stands.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OO****************@TK2MSFTNGP03.phx.gbl...
>If you have set all the timeouts to 40, and the app is still losing the session variables
at 20, then either the app is recycling at 20 or the application pool is recycling at 20.

Have you attempted to set a different recycling threshold in the IIS Manager ?

Also, have you tried to use State Server, instead of InProc ?

State Server, as does SQL Server, gets around the loss of
session variables due to Application/App Pool recycling.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:eb****************@TK2MSFTNGP05.phx.gbl...
>>>I believe that timeout default is 30, but yes I also set the Forms Authentication timout to 40.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2***************@TK2MSFTNGP05.phx.gbl...
re:
!every conceivable setting I know of says
!40 minutes but the application timesout after 20 minutes.

Including the Forms Authentication timeout ( if you're using that ? ).
*That* defaults to 20 minutes, too.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:O$**************@TK2MSFTNGP04.phx.gbl...
Steven,
you ask "what's the actual session mode you use now" not sure I understand your question. In
my original post I stated the session settings in my web.config and the setting is IIS. every
conceivable setting I know of says 40 minutes but the application timesout after 20 minutes.
>
--
Regards,
Gary Blakely
"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
news:MZ**************@TK2MSFTNGHUB02.phx.gbl.. .
>Hi Gary,
>>
>As you mentioned that you've used three session setting, then what's the
>actual session mode you use now, inproc one? I suggeset you create a
>simplified application and use inproc session to verify the behavior.
>>
>Sincerely,
>>
>Steven Cheng
>>
>Microsoft MSDN Online Support Lead
>>
>>
>This posting is provided "AS IS" with no warranties, and confers no rights.
>>
>
>




Jun 2 '07 #13

P: n/a
Juan,
That was it. The other settings had already extended my Session.timeout but
then we were getting null session variables after 20 minutes. I didn't try
State Server because we just don't need it now for this low-arrival rate
app.

Thank you very much for your help on this issue.

Regards,
Gary Blakely

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:el**************@TK2MSFTNGP05.phx.gbl...
In Windows Server 2003, you can set the recycling threshhold
for the Application Pool in which an application runs.

In the IIS Manager, scroll down the left hand panel to "Application
Pools",
and select the Application Pool in which your app runs.

Right-click the App Pool and select "Properties" from the context menu.

You'll see several options for setting the time/memory limit/number of
requests
at which the application pool will be recycled.

Just make sure your time setting isn't set too low.
Leave the rest untouched until you are familiar with the settings.

You don't say whether you tried using State Server.

!Also, have you tried to use State Server, instead of InProc state
management?

!State Server state management, as does SQL Server, gets around
!the loss of session variables due to Application/App Pool recycling.

Just configure it in web.config :

<sessionState
mode="StateServer"
stateConnectionString="tcpip=127.0.0.1:42424"
stateNetworkTimeout="10"
cookieless="false"
timeout="20"
/>

...and in the "Services" applet of the W2K3 Server, start the State Server
service.

That usually works to prevent Session variable losses.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:eY**************@TK2MSFTNGP02.phx.gbl...
>I've goolged and looked everywhere I can and I can't find anything on
"recycling threshold settings" in IIS. My original question at the
beginning of this thread stands.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OO****************@TK2MSFTNGP03.phx.gbl...
>>If you have set all the timeouts to 40, and the app is still losing the
session variables
at 20, then either the app is recycling at 20 or the application pool is
recycling at 20.

Have you attempted to set a different recycling threshold in the IIS
Manager ?

Also, have you tried to use State Server, instead of InProc ?

State Server, as does SQL Server, gets around the loss of
session variables due to Application/App Pool recycling.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:eb****************@TK2MSFTNGP05.phx.gbl.. .
I believe that timeout default is 30, but yes I also set the Forms
Authentication timout to 40.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2***************@TK2MSFTNGP05.phx.gbl.. .
re:
!every conceivable setting I know of says
!40 minutes but the application timesout after 20 minutes.
>
Including the Forms Authentication timeout ( if you're using that ? ).
*That* defaults to 20 minutes, too.
>
>
>
Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:O$**************@TK2MSFTNGP04.phx.gbl.. .
>Steven,
>you ask "what's the actual session mode you use now" not sure I
>understand your question. In my original post I stated the session
>settings in my web.config and the setting is IIS. every conceivable
>setting I know of says 40 minutes but the application timesout after
>20 minutes.
>>
>--
>Regards,
>Gary Blakely
>"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
>news:MZ**************@TK2MSFTNGHUB02.phx.gbl. ..
>>Hi Gary,
>>>
>>As you mentioned that you've used three session setting, then what's
>>the
>>actual session mode you use now, inproc one? I suggeset you create
>>a
>>simplified application and use inproc session to verify the
>>behavior.
>>>
>>Sincerely,
>>>
>>Steven Cheng
>>>
>>Microsoft MSDN Online Support Lead
>>>
>>>
>>This posting is provided "AS IS" with no warranties, and confers no
>>rights.
>>>
>>
>>
>
>




Jun 3 '07 #14

P: n/a
re:
!Juan,
!That was it.

Glad to hear that!

re:
!Thank you very much for your help on this issue.

You're quite welcome. Glad to know you're up and running trouble-free again.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
Juan,
That was it. The other settings had already extended my Session.timeout but then we were getting
null session variables after 20 minutes. I didn't try State Server because we just don't need it
now for this low-arrival rate app.

Thank you very much for your help on this issue.

Regards,
Gary Blakely

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:el**************@TK2MSFTNGP05.phx.gbl...
>In Windows Server 2003, you can set the recycling threshhold
for the Application Pool in which an application runs.

In the IIS Manager, scroll down the left hand panel to "Application Pools",
and select the Application Pool in which your app runs.

Right-click the App Pool and select "Properties" from the context menu.

You'll see several options for setting the time/memory limit/number of requests
at which the application pool will be recycled.

Just make sure your time setting isn't set too low.
Leave the rest untouched until you are familiar with the settings.

You don't say whether you tried using State Server.

!Also, have you tried to use State Server, instead of InProc state management?

!State Server state management, as does SQL Server, gets around
!the loss of session variables due to Application/App Pool recycling.

Just configure it in web.config :

<sessionState
mode="StateServer"
stateConnectionString="tcpip=127.0.0.1:42424"
stateNetworkTimeout="10"
cookieless="false"
timeout="20"
/>

...and in the "Services" applet of the W2K3 Server, start the State Server service.

That usually works to prevent Session variable losses.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:eY**************@TK2MSFTNGP02.phx.gbl...
>>I've goolged and looked everywhere I can and I can't find anything on "recycling threshold
settings" in IIS. My original question at the beginning of this thread stands.

--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OO****************@TK2MSFTNGP03.phx.gbl.. .
If you have set all the timeouts to 40, and the app is still losing the session variables
at 20, then either the app is recycling at 20 or the application pool is recycling at 20.

Have you attempted to set a different recycling threshold in the IIS Manager ?

Also, have you tried to use State Server, instead of InProc ?

State Server, as does SQL Server, gets around the loss of
session variables due to Application/App Pool recycling.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"GaryDean" <Ga******@newsgroups.nospamwrote in message
news:eb****************@TK2MSFTNGP05.phx.gbl. ..
>I believe that timeout default is 30, but yes I also set the Forms Authentication timout to 40.
>
--
Regards,
Gary Blakely
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2***************@TK2MSFTNGP05.phx.gbl. ..
>re:
>!every conceivable setting I know of says
>!40 minutes but the application timesout after 20 minutes.
>>
>Including the Forms Authentication timeout ( if you're using that ? ).
>*That* defaults to 20 minutes, too.
>>
>>
>>
>Juan T. Llibre, asp.net MVP
>asp.net faq : http://asp.net.do/faq/
>foros de asp.net, en español : http://asp.net.do/foros/
>======================================
>"GaryDean" <Ga******@newsgroups.nospamwrote in message
>news:O$**************@TK2MSFTNGP04.phx.gbl. ..
>>Steven,
>>you ask "what's the actual session mode you use now" not sure I understand your question.
>>In my original post I stated the session settings in my web.config and the setting is IIS.
>>every conceivable setting I know of says 40 minutes but the application timesout after 20
>>minutes.
>>>
>>--
>>Regards,
>>Gary Blakely
>>"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
>>news:MZ**************@TK2MSFTNGHUB02.phx.gbl ...
>>>Hi Gary,
>>>>
>>>As you mentioned that you've used three session setting, then what's the
>>>actual session mode you use now, inproc one? I suggeset you create a
>>>simplified application and use inproc session to verify the behavior.
>>>>
>>>Sincerely,
>>>>
>>>Steven Cheng
>>>>
>>>Microsoft MSDN Online Support Lead
>>>>
>>>>
>>>This posting is provided "AS IS" with no warranties, and confers no rights.
>>>>
>>>
>>>
>>
>>
>
>




Jun 3 '07 #15

This discussion thread is closed

Replies have been disabled for this discussion.