By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,214 Members | 2,038 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,214 IT Pros & Developers. It's quick & easy.

*.aspx = 404

P: n/a
We have our application installed at a client site on a Win2k3 box. IIS
will serve *.html or *.txt, but when ever we try to get to any aspx
files via IIS, we get a 404.
We have deployed this app many times and it's always worked pretty well
and I have never seen this scenario before.
It's .Net 1.1 and we have given "Network Service" read and execute
permissions to the virtual directory. We've also done a aspnet_regiis -i
and iisreset with no change.
Any ideas? Thanks!

Matt
May 30 '07 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Have you *enabled* ASP.NET 1.1 ?

In W2K3, you must, specifically, enable the .Net Framework version you use.

Open the IIS Manager, scroll down on the left to "Web Service Extensions",
and select it; move to the right pane and select ASP.NET 1.1, and click the "Allow" button.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================

"MattB" <so********@yahoo.comwrote in message news:5c*************@mid.individual.net...
We have our application installed at a client site on a Win2k3 box. IIS will serve *.html or
*.txt, but when ever we try to get to any aspx files via IIS, we get a 404.
We have deployed this app many times and it's always worked pretty well and I have never seen this
scenario before.
It's .Net 1.1 and we have given "Network Service" read and execute permissions to the virtual
directory. We've also done a aspnet_regiis -i and iisreset with no change.
Any ideas? Thanks!

Matt


May 30 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.