By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,786 Members | 1,143 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,786 IT Pros & Developers. It's quick & easy.

HttpHandler not working

P: n/a
I have created a HttpHandler to intercept *.zip requests, authenticate
and authorize user before allowing user to download the file. This
works perfectly when I run it from ASP.NET development server (from VS
2005).

But when I run it from our web app server (Windows Server 2003-R2, IIS
6.0) it gives me a 404 Page not found error from IIS. I have
mapped .zip to aspnet_isapi.dll in IIS. And I have this added to my
web.config

<httpHandlers>
<add verb="*" path="datafeed/*.zip"
type="XXX.Web.DataFeedHttpHandler.DataFeedHttpHand ler" />
</httpHandlers>

Another thing different from my development environment is that the
Website on the app server is on Port 82 and not Port 80. Is this
causing the problem? Also is there any way I can debug and find out
where the error is occuring and get some more info on the error? (I
dont have VS 2005 on the app server)

Any help is highly appreciated.

Thanks,
Deepa

May 17 '07 #1
Share this Question
Share on Google+
4 Replies


P: n/a
re:
!But when I run it from our web app server (Windows Server 2003-R2, IIS
!6.0) it gives me a 404 Page not found error from IIS.

Does the account : NT AUTHORITY\NETWORK SERVICE
have read rights to the datafeed directory on the W2K3 server ?

The ASP.NET Development Server runs as MachineName\Administrator,
and automatically has read rights to the datafeed directory in your development box..

ASP.NET runs as NT AUTHORITY\NETWORK SERVICE on Windows Server 2003.
You have to, specifically, assign rights to the datafeed directory to that account on the server.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
<de*************@gmail.comwrote in message
news:11**********************@h2g2000hsg.googlegro ups.com...
>I have created a HttpHandler to intercept *.zip requests, authenticate
and authorize user before allowing user to download the file. This
works perfectly when I run it from ASP.NET development server (from VS
2005).

But when I run it from our web app server (Windows Server 2003-R2, IIS
6.0) it gives me a 404 Page not found error from IIS. I have
mapped .zip to aspnet_isapi.dll in IIS. And I have this added to my
web.config

<httpHandlers>
<add verb="*" path="datafeed/*.zip"
type="XXX.Web.DataFeedHttpHandler.DataFeedHttpHand ler" />
</httpHandlers>

Another thing different from my development environment is that the
Website on the app server is on Port 82 and not Port 80. Is this
causing the problem? Also is there any way I can debug and find out
where the error is occuring and get some more info on the error? (I
dont have VS 2005 on the app server)

Any help is highly appreciated.

Thanks,
Deepa

May 17 '07 #2

P: n/a
Thanks for your reply. I have assigned read rights to the Datafeed
directory to the Network service account. I still get the 404 message.
I am not sure if it even comes to the aspnet_isapi.dll since the "Page
not found" message is from IIS. Does it have anything to do with the
non default port that I am using (port 82)??
Thanks.
On May 17, 4:40 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!But when I run it from our web app server (Windows Server 2003-R2, IIS
!6.0) it gives me a 404 Page not found error from IIS.

Does the account : NT AUTHORITY\NETWORK SERVICE
have read rights to the datafeed directory on the W2K3 server ?

The ASP.NET Development Server runs as MachineName\Administrator,
and automatically has read rights to the datafeed directory in your development box..

ASP.NET runs as NT AUTHORITY\NETWORK SERVICE on Windows Server 2003.
You have to, specifically, assign rights to the datafeed directory to that account on the server.

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en espaņol :http://asp.net.do/foros/
======================================<deepa.ravik i...@gmail.comwrotein message

news:11**********************@h2g2000hsg.googlegro ups.com...
I have created a HttpHandler to intercept *.zip requests, authenticate
and authorize user before allowing user to download the file. This
works perfectly when I run it from ASP.NET development server (from VS
2005).
But when I run it from our web app server (Windows Server 2003-R2, IIS
6.0) it gives me a 404 Page not found error from IIS. I have
mapped .zip to aspnet_isapi.dll in IIS. And I have this added to my
web.config
<httpHandlers>
<add verb="*" path="datafeed/*.zip"
type="XXX.Web.DataFeedHttpHandler.DataFeedHttpHand ler" />
</httpHandlers>
Another thing different from my development environment is that the
Website on the app server is on Port 82 and not Port 80. Is this
causing the problem? Also is there any way I can debug and find out
where the error is occuring and get some more info on the error? (I
dont have VS 2005 on the app server)
Any help is highly appreciated.
Thanks,
Deepa

May 18 '07 #3

P: n/a
re:
!>have anything to do with the non default port that I am using (port 82)??

No. The 404 Page not found error from IIS is typical error message for permission problems.

Make sure the NT AUTHORITY\NETWORK SERVICE
account has access rights to the directory and *.aspx files you execute.

You *did* enable ASP.NET on the W2K3 R2 server, right ?
You must, specifically, enable ASP.NET on W2K3.

And...you are *not* impersonating, are you ?
If you are, the account you're impersonating is the one which needs access permission.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
======================================
<de*************@gmail.comwrote in message
news:11**********************@e65g2000hsc.googlegr oups.com...
Thanks for your reply. I have assigned read rights to the Datafeed
directory to the Network service account. I still get the 404 message.
I am not sure if it even comes to the aspnet_isapi.dll since the "Page
not found" message is from IIS. Does it have anything to do with the
non default port that I am using (port 82)??
Thanks.
On May 17, 4:40 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!But when I run it from our web app server (Windows Server 2003-R2, IIS
!6.0) it gives me a 404 Page not found error from IIS.

Does the account : NT AUTHORITY\NETWORK SERVICE
have read rights to the datafeed directory on the W2K3 server ?

The ASP.NET Development Server runs as MachineName\Administrator,
and automatically has read rights to the datafeed directory in your development box..

ASP.NET runs as NT AUTHORITY\NETWORK SERVICE on Windows Server 2003.
You have to, specifically, assign rights to the datafeed directory to that account on the server.

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en espaņol :http://asp.net.do/foros/
======================================<deepa.ravik i...@gmail.comwrote in message

news:11**********************@h2g2000hsg.googlegro ups.com...
I have created a HttpHandler to intercept *.zip requests, authenticate
and authorize user before allowing user to download the file. This
works perfectly when I run it from ASP.NET development server (from VS
2005).
But when I run it from our web app server (Windows Server 2003-R2, IIS
6.0) it gives me a 404 Page not found error from IIS. I have
mapped .zip to aspnet_isapi.dll in IIS. And I have this added to my
web.config
<httpHandlers>
<add verb="*" path="datafeed/*.zip"
type="XXX.Web.DataFeedHttpHandler.DataFeedHttpHand ler" />
</httpHandlers>
Another thing different from my development environment is that the
Website on the app server is on Port 82 and not Port 80. Is this
causing the problem? Also is there any way I can debug and find out
where the error is occuring and get some more info on the error? (I
dont have VS 2005 on the app server)
Any help is highly appreciated.
Thanks,
Deepa


May 18 '07 #4

P: n/a
On May 17, 8:51 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!>have anything to do with the non default port that I am using (port 82)??

No. The 404 Page not found error from IIS is typical error message for permission problems.

Make sure the NT AUTHORITY\NETWORK SERVICE
account has access rights to the directory and *.aspx files you execute.

You *did* enable ASP.NET on the W2K3 R2 server, right ?
You must, specifically, enable ASP.NET on W2K3.

And...you are *not* impersonating, are you ?
If you are, the account you're impersonating is the one which needs access permission.

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en espaņol :http://asp.net.do/foros/
======================================<deepa.ravik i...@gmail.comwrotein message

news:11**********************@e65g2000hsc.googlegr oups.com...
Thanks for your reply. I have assigned read rights to the Datafeed
directory to the Network service account. I still get the 404 message.
I am not sure if it even comes to the aspnet_isapi.dll since the "Page
not found" message is from IIS. Does it have anything to do with the
non default port that I am using (port 82)??
Thanks.

On May 17, 4:40 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!But when I run it from our web app server (Windows Server 2003-R2, IIS
!6.0) it gives me a 404 Page not found error from IIS.
Does the account : NT AUTHORITY\NETWORK SERVICE
have read rights to the datafeed directory on the W2K3 server ?
The ASP.NET Development Server runs as MachineName\Administrator,
and automatically has read rights to the datafeed directory in your development box..
ASP.NET runs as NT AUTHORITY\NETWORK SERVICE on Windows Server 2003.
You have to, specifically, assign rights to the datafeed directory to that account on the server.
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en espaņol :http://asp.net.do/foros/
======================================<deepa.ravik i...@gmail.comwrote in message
news:11**********************@h2g2000hsg.googlegro ups.com...
>I have created a HttpHandler to intercept *.zip requests, authenticate
and authorize user before allowing user to download the file. This
works perfectly when I run it from ASP.NET development server (from VS
2005).
But when I run it from our web app server (Windows Server 2003-R2, IIS
6.0) it gives me a 404 Page not found error from IIS. I have
mapped .zip to aspnet_isapi.dll in IIS. And I have this added to my
web.config
<httpHandlers>
<add verb="*" path="datafeed/*.zip"
type="XXX.Web.DataFeedHttpHandler.DataFeedHttpHand ler" />
</httpHandlers>
Another thing different from my development environment is that the
Website on the app server is on Port 82 and not Port 80. Is this
causing the problem? Also is there any way I can debug and find out
where the error is occuring and get some more info on the error? (I
dont have VS 2005 on the app server)
Any help is highly appreciated.
Thanks,
Deepa

The NETWORK SERVICE account has read rights on all the directories and
*aspx files. In fact, I also tried adding NETWORK SERVICE to
Administrators group. It still gave me 404. I am not using
impersonation. And I did not understand what you meant by enabling
ASP.NET on Win 2003. All the other pages on the website ok. Only the
download zip file link gives an error. The link is
http://localhost:82/datafeed/abcd.zip
(.zip is mapped to aspnet_isapi.dll in IIS)

May 18 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.