By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,179 Members | 2,192 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,179 IT Pros & Developers. It's quick & easy.

asp.net debugging on local IIS

P: n/a
I can't get to debug on my local IIS using VStudio.net 2005 Prof. I can on
the development server. I get the msg 'the server does not support debugging
for asp.net...'
I have done the following as in 'How to: Enable Debugging for ASP.NET
Applications'

Under Debuggers ASP.NET box is selected
in web.config set compilation debug="true"

in virtual directory:
properties:
I have set execute permissions to 'scripts and executables'
application configuration, I have checked 'enable asp server-side
debugging' and 'client-side debugging'.

In the asp.net configuration tool I have checked 'enable debugging'.

In IE tools:

I have cleared 'disable script checking'

I think I need a hand here!
--
Apr 15 '07 #1
Share this Question
Share on Google+
5 Replies


P: n/a
See if the info in this KB helps :

http://support.microsoft.com/default...b/814717/en-us

For more info on debugging, see :

http://msdn2.microsoft.com/en-us/lib...f0(vs.71).aspx


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espańol : http://asp.net.do/foros/
===================================
"gadya" <ga***@discussions.microsoft.comwrote in message
news:01**********************************@microsof t.com...
>I can't get to debug on my local IIS using VStudio.net 2005 Prof. I can on
the development server. I get the msg 'the server does not support debugging
for asp.net...'
I have done the following as in 'How to: Enable Debugging for ASP.NET
Applications'

Under Debuggers ASP.NET box is selected
in web.config set compilation debug="true"

in virtual directory:
properties:
I have set execute permissions to 'scripts and executables'
application configuration, I have checked 'enable asp server-side
debugging' and 'client-side debugging'.

In the asp.net configuration tool I have checked 'enable debugging'.

In IE tools:

I have cleared 'disable script checking'

I think I need a hand here!
--

Apr 15 '07 #2

P: n/a
Juan,
Thanks for the links. Haven't found anything that seems to click though
apart from the fact that it says:
'You must still make sure that you have adequate permissions to debug. When
you install Visual Studio or Visual Studio server components on a computer,
it creates a Windows group called Debugger Users.'

I don't have such a group, but I am the sole user and administrator.

As to: BUG: Error while trying to run project: Unable to start debugging on
the web server. Could not start ASP.NET or ATL Server debugging. That's not
my error msg and it doesn't seem to tie up at all.
"Juan T. Llibre" wrote:
See if the info in this KB helps :

http://support.microsoft.com/default...b/814717/en-us

For more info on debugging, see :

http://msdn2.microsoft.com/en-us/lib...f0(vs.71).aspx


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaƱol : http://asp.net.do/foros/
===================================
"gadya" <ga***@discussions.microsoft.comwrote in message
news:01**********************************@microsof t.com...
I can't get to debug on my local IIS using VStudio.net 2005 Prof. I can on
the development server. I get the msg 'the server does not support debugging
for asp.net...'
I have done the following as in 'How to: Enable Debugging for ASP.NET
Applications'

Under Debuggers ASP.NET box is selected
in web.config set compilation debug="true"

in virtual directory:
properties:
I have set execute permissions to 'scripts and executables'
application configuration, I have checked 'enable asp server-side
debugging' and 'client-side debugging'.

In the asp.net configuration tool I have checked 'enable debugging'.

In IE tools:

I have cleared 'disable script checking'

I think I need a hand here!
--


Apr 15 '07 #3

P: n/a
1. Which OS are you using ?

2. Make sure your "Debugger Users" group includes the account you
use to login into Windows and the IWAM_MachineName accounts.

3. If you don't have that group, create it and add those accounts.

4. Also, if the ASP.NET worker process is running as the ASPNET account,
or as the NETWORK SERVICE account, you need Administrator privileges to debug it.

5. Are you impersonating the ASP.NET worker process ?
If so, the account you're using must be a member of the Administrators and Debugger Users groups.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espańol : http://asp.net.do/foros/
===================================
"gadya" <ga***@discussions.microsoft.comwrote in message
news:93**********************************@microsof t.com...
Juan,
Thanks for the links. Haven't found anything that seems to click though
apart from the fact that it says:
'You must still make sure that you have adequate permissions to debug. When
you install Visual Studio or Visual Studio server components on a computer,
it creates a Windows group called Debugger Users.'

I don't have such a group, but I am the sole user and administrator.

As to: BUG: Error while trying to run project: Unable to start debugging on
the web server. Could not start ASP.NET or ATL Server debugging. That's not
my error msg and it doesn't seem to tie up at all.
"Juan T. Llibre" wrote:
>See if the info in this KB helps :

http://support.microsoft.com/default...b/814717/en-us

For more info on debugging, see :

http://msdn2.microsoft.com/en-us/lib...f0(vs.71).aspx


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espańol : http://asp.net.do/foros/
===================================
"gadya" <ga***@discussions.microsoft.comwrote in message
news:01**********************************@microso ft.com...
>I can't get to debug on my local IIS using VStudio.net 2005 Prof. I can on
the development server. I get the msg 'the server does not support debugging
for asp.net...'
I have done the following as in 'How to: Enable Debugging for ASP.NET
Applications'

Under Debuggers ASP.NET box is selected
in web.config set compilation debug="true"

in virtual directory:
properties:
I have set execute permissions to 'scripts and executables'
application configuration, I have checked 'enable asp server-side
debugging' and 'client-side debugging'.

In the asp.net configuration tool I have checked 'enable debugging'.

In IE tools:

I have cleared 'disable script checking'

I think I need a hand here!
--




Apr 15 '07 #4

P: n/a
Thanks but I'll have to leave it at the moment as the system has begun to
play up and the development server is now also having problems.

Will get back when I'm sorted out!
--

"Juan T. Llibre" wrote:
1. Which OS are you using ?

2. Make sure your "Debugger Users" group includes the account you
use to login into Windows and the IWAM_MachineName accounts.

3. If you don't have that group, create it and add those accounts.

4. Also, if the ASP.NET worker process is running as the ASPNET account,
or as the NETWORK SERVICE account, you need Administrator privileges to debug it.

5. Are you impersonating the ASP.NET worker process ?
If so, the account you're using must be a member of the Administrators and Debugger Users groups.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaƱol : http://asp.net.do/foros/
===================================
"gadya" <ga***@discussions.microsoft.comwrote in message
news:93**********************************@microsof t.com...
Juan,
Thanks for the links. Haven't found anything that seems to click though
apart from the fact that it says:
'You must still make sure that you have adequate permissions to debug. When
you install Visual Studio or Visual Studio server components on a computer,
it creates a Windows group called Debugger Users.'

I don't have such a group, but I am the sole user and administrator.

As to: BUG: Error while trying to run project: Unable to start debugging on
the web server. Could not start ASP.NET or ATL Server debugging. That's not
my error msg and it doesn't seem to tie up at all.
"Juan T. Llibre" wrote:
See if the info in this KB helps :

http://support.microsoft.com/default...b/814717/en-us

For more info on debugging, see :

http://msdn2.microsoft.com/en-us/lib...f0(vs.71).aspx


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaƱol : http://asp.net.do/foros/
===================================
"gadya" <ga***@discussions.microsoft.comwrote in message
news:01**********************************@microsof t.com...
I can't get to debug on my local IIS using VStudio.net 2005 Prof. I can on
the development server. I get the msg 'the server does not support debugging
for asp.net...'
I have done the following as in 'How to: Enable Debugging for ASP.NET
Applications'

Under Debuggers ASP.NET box is selected
in web.config set compilation debug="true"

in virtual directory:
properties:
I have set execute permissions to 'scripts and executables'
application configuration, I have checked 'enable asp server-side
debugging' and 'client-side debugging'.

In the asp.net configuration tool I have checked 'enable debugging'.

In IE tools:

I have cleared 'disable script checking'

I think I need a hand here!
--

Apr 15 '07 #5

P: n/a
The system was corrupt. I have reinstalled and everything is now working.
thanks for help.
--
Victor
"gadya" wrote:
Thanks but I'll have to leave it at the moment as the system has begun to
play up and the development server is now also having problems.

Will get back when I'm sorted out!
--

"Juan T. Llibre" wrote:
1. Which OS are you using ?

2. Make sure your "Debugger Users" group includes the account you
use to login into Windows and the IWAM_MachineName accounts.

3. If you don't have that group, create it and add those accounts.

4. Also, if the ASP.NET worker process is running as the ASPNET account,
or as the NETWORK SERVICE account, you need Administrator privileges to debug it.

5. Are you impersonating the ASP.NET worker process ?
If so, the account you're using must be a member of the Administrators and Debugger Users groups.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaƱol : http://asp.net.do/foros/
===================================
"gadya" <ga***@discussions.microsoft.comwrote in message
news:93**********************************@microsof t.com...
Juan,
Thanks for the links. Haven't found anything that seems to click though
apart from the fact that it says:
'You must still make sure that you have adequate permissions to debug. When
you install Visual Studio or Visual Studio server components on a computer,
it creates a Windows group called Debugger Users.'
>
I don't have such a group, but I am the sole user and administrator.
>
As to: BUG: Error while trying to run project: Unable to start debugging on
the web server. Could not start ASP.NET or ATL Server debugging. That's not
my error msg and it doesn't seem to tie up at all.
>
>
"Juan T. Llibre" wrote:
>
>See if the info in this KB helps :
>>
>http://support.microsoft.com/default...b/814717/en-us
>>
>For more info on debugging, see :
>>
>http://msdn2.microsoft.com/en-us/lib...f0(vs.71).aspx
>>
>>
>>
>>
>Juan T. Llibre, asp.net MVP
>asp.net faq : http://asp.net.do/faq/
>foros de asp.net, en espaƱol : http://asp.net.do/foros/
>===================================
>"gadya" <ga***@discussions.microsoft.comwrote in message
>news:01**********************************@microso ft.com...
>I can't get to debug on my local IIS using VStudio.net 2005 Prof. I can on
the development server. I get the msg 'the server does not support debugging
for asp.net...'
I have done the following as in 'How to: Enable Debugging for ASP.NET
Applications'
>
Under Debuggers ASP.NET box is selected
in web.config set compilation debug="true"
>
in virtual directory:
properties:
I have set execute permissions to 'scripts and executables'
application configuration, I have checked 'enable asp server-side
debugging' and 'client-side debugging'.
>
In the asp.net configuration tool I have checked 'enable debugging'.
>
In IE tools:
>
I have cleared 'disable script checking'
>
I think I need a hand here!
--
>>
>>
>>

Apr 18 '07 #6

This discussion thread is closed

Replies have been disabled for this discussion.