By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,967 Members | 1,625 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,967 IT Pros & Developers. It's quick & easy.

how to create an ASPNET.mdf file?

P: n/a
Hi,

i'm building an web application for anonymous users. They can take a look in
the website, nothing more. In order to perform other actions, the anonymous
user must be logged. So i create an aspx page with the CreateUserWizard
control. The user can fill his username, password etc ....

My problem is: when an user fills everything and clicks on button "create an
account", nothing happens (no error, but no user account created).
I thought asp.net would create in App_Data an ASPNET.MDF file for storing
user and membership information and add automatically a new connection
string in web.config. But it doesn't happen.

I know i can go in design mode (n VWD) and click on "administer the site",
but all the users are anonymous, so i can't create user in advance.
Do i have to put some configuration code in web.config? Or something else?

Thanks for help
Mich
Apr 8 '07 #1
Share this Question
Share on Google+
16 Replies


P: n/a
Run aspnet_regsql.exe from a command window in your .Net Framework 2.0 directory.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Mich" <mi**@nm.dfwrote in message news:Og****************@TK2MSFTNGP03.phx.gbl...
Hi,

i'm building an web application for anonymous users. They can take a look in the website, nothing
more. In order to perform other actions, the anonymous user must be logged. So i create an aspx
page with the CreateUserWizard control. The user can fill his username, password etc ....

My problem is: when an user fills everything and clicks on button "create an account", nothing
happens (no error, but no user account created).
I thought asp.net would create in App_Data an ASPNET.MDF file for storing user and membership
information and add automatically a new connection string in web.config. But it doesn't happen.

I know i can go in design mode (n VWD) and click on "administer the site", but all the users are
anonymous, so i can't create user in advance.
Do i have to put some configuration code in web.config? Or something else?

Thanks for help
Mich

Apr 8 '07 #2

P: n/a
Hi Juan, thanks for replying..

I did this and an mdf file ASPNETDB.MDF was created in the sql server
directory.
So i copied both files (mdf and log) into APP_Data of my application.
I added a connection string in web.config like this:
<add name="aspnetdb" connectionString="Data
Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
Security=True;User Instance=True" providerName="System.Data.SqlClient"/>

Now, when starting the aspx page containing the createuserwizard and filling
all texboxes, again, nothing happens (user is not created). If i try it
within VWDev., the user is then created.
What do i forget or do wrong?
Thanks

"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
news:ut**************@TK2MSFTNGP05.phx.gbl...
Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
directory.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Mich" <mi**@nm.dfwrote in message
news:Og****************@TK2MSFTNGP03.phx.gbl...
>Hi,

i'm building an web application for anonymous users. They can take a look
in the website, nothing more. In order to perform other actions, the
anonymous user must be logged. So i create an aspx page with the
CreateUserWizard control. The user can fill his username, password etc
....

My problem is: when an user fills everything and clicks on button "create
an account", nothing happens (no error, but no user account created).
I thought asp.net would create in App_Data an ASPNET.MDF file for storing
user and membership information and add automatically a new connection
string in web.config. But it doesn't happen.

I know i can go in design mode (n VWD) and click on "administer the
site", but all the users are anonymous, so i can't create user in
advance.
Do i have to put some configuration code in web.config? Or something
else?

Thanks for help
Mich


Apr 8 '07 #3

P: n/a
I notice you ahve integrated security rather than user names and passwords.
I may be wrong but I think integrated security will require the current user
to have permission in the database. When you are doing it through VWDev, you
are probably carrying your username through, but when doing it from ASP.NET,
you are using the ASP.NET user account, which may not have permission.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:Ox****************@TK2MSFTNGP05.phx.gbl...
Hi Juan, thanks for replying..

I did this and an mdf file ASPNETDB.MDF was created in the sql server
directory.
So i copied both files (mdf and log) into APP_Data of my application.
I added a connection string in web.config like this:
<add name="aspnetdb" connectionString="Data
Source=.\SQLEXPRESS;AttachDbFilename=|DataDirector y|\ASPNETDB.MDF;Integrated
Security=True;User Instance=True" providerName="System.Data.SqlClient"/>

Now, when starting the aspx page containing the createuserwizard and
filling all texboxes, again, nothing happens (user is not created). If i
try it within VWDev., the user is then created.
What do i forget or do wrong?
Thanks

"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
news:ut**************@TK2MSFTNGP05.phx.gbl...
>Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
directory.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Mich" <mi**@nm.dfwrote in message
news:Og****************@TK2MSFTNGP03.phx.gbl...
>>Hi,

i'm building an web application for anonymous users. They can take a
look in the website, nothing more. In order to perform other actions,
the anonymous user must be logged. So i create an aspx page with the
CreateUserWizard control. The user can fill his username, password etc
....

My problem is: when an user fills everything and clicks on button
"create an account", nothing happens (no error, but no user account
created).
I thought asp.net would create in App_Data an ASPNET.MDF file for
storing user and membership information and add automatically a new
connection string in web.config. But it doesn't happen.

I know i can go in design mode (n VWD) and click on "administer the
site", but all the users are anonymous, so i can't create user in
advance.
Do i have to put some configuration code in web.config? Or something
else?

Thanks for help
Mich



Apr 9 '07 #4

P: n/a
Account ASPNET has R/W rights on the APP_Data dir.
And if it was not so, i would get an error, but here, no error, nothing
happens ...

"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:O8*************@TK2MSFTNGP02.phx.gbl...
>I notice you ahve integrated security rather than user names and passwords.
I may be wrong but I think integrated security will require the current
user to have permission in the database. When you are doing it through
VWDev, you are probably carrying your username through, but when doing it
from ASP.NET, you are using the ASP.NET user account, which may not have
permission.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:Ox****************@TK2MSFTNGP05.phx.gbl...
>Hi Juan, thanks for replying..

I did this and an mdf file ASPNETDB.MDF was created in the sql server
directory.
So i copied both files (mdf and log) into APP_Data of my application.
I added a connection string in web.config like this:
<add name="aspnetdb" connectionString="Data
Source=.\SQLEXPRESS;AttachDbFilename=|DataDirecto ry|\ASPNETDB.MDF;Integrated
Security=True;User Instance=True" providerName="System.Data.SqlClient"/>

Now, when starting the aspx page containing the createuserwizard and
filling all texboxes, again, nothing happens (user is not created). If i
try it within VWDev., the user is then created.
What do i forget or do wrong?
Thanks

"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
news:ut**************@TK2MSFTNGP05.phx.gbl...
>>Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
directory.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Mich" <mi**@nm.dfwrote in message
news:Og****************@TK2MSFTNGP03.phx.gbl.. .
Hi,

i'm building an web application for anonymous users. They can take a
look in the website, nothing more. In order to perform other actions,
the anonymous user must be logged. So i create an aspx page with the
CreateUserWizard control. The user can fill his username, password etc
....

My problem is: when an user fills everything and clicks on button
"create an account", nothing happens (no error, but no user account
created).
I thought asp.net would create in App_Data an ASPNET.MDF file for
storing user and membership information and add automatically a new
connection string in web.config. But it doesn't happen.

I know i can go in design mode (n VWD) and click on "administer the
site", but all the users are anonymous, so i can't create user in
advance.
Do i have to put some configuration code in web.config? Or something
else?

Thanks for help
Mich



Apr 9 '07 #5

P: n/a
but what about your database?

just having access to the directory does not give database permission.

Set up a user in your database. Give that user permission to see the table
you want to view. Put that users username/password into your connection
string.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:OF**************@TK2MSFTNGP02.phx.gbl...
Account ASPNET has R/W rights on the APP_Data dir.
And if it was not so, i would get an error, but here, no error, nothing
happens ...

"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:O8*************@TK2MSFTNGP02.phx.gbl...
>>I notice you ahve integrated security rather than user names and
passwords. I may be wrong but I think integrated security will require the
current user to have permission in the database. When you are doing it
through VWDev, you are probably carrying your username through, but when
doing it from ASP.NET, you are using the ASP.NET user account, which may
not have permission.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:Ox****************@TK2MSFTNGP05.phx.gbl...
>>Hi Juan, thanks for replying..

I did this and an mdf file ASPNETDB.MDF was created in the sql server
directory.
So i copied both files (mdf and log) into APP_Data of my application.
I added a connection string in web.config like this:
<add name="aspnetdb" connectionString="Data
Source=.\SQLEXPRESS;AttachDbFilename=|DataDirect ory|\ASPNETDB.MDF;Integrated
Security=True;User Instance=True" providerName="System.Data.SqlClient"/>

Now, when starting the aspx page containing the createuserwizard and
filling all texboxes, again, nothing happens (user is not created). If i
try it within VWDev., the user is then created.
What do i forget or do wrong?
Thanks

"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
news:ut**************@TK2MSFTNGP05.phx.gbl...
Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
directory.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Mich" <mi**@nm.dfwrote in message
news:Og****************@TK2MSFTNGP03.phx.gbl. ..
Hi,
>
i'm building an web application for anonymous users. They can take a
look in the website, nothing more. In order to perform other actions,
the anonymous user must be logged. So i create an aspx page with the
CreateUserWizard control. The user can fill his username, password etc
....
>
My problem is: when an user fills everything and clicks on button
"create an account", nothing happens (no error, but no user account
created).
I thought asp.net would create in App_Data an ASPNET.MDF file for
storing user and membership information and add automatically a new
connection string in web.config. But it doesn't happen.
>
I know i can go in design mode (n VWD) and click on "administer the
site", but all the users are anonymous, so i can't create user in
advance.
Do i have to put some configuration code in web.config? Or something
else?
>
Thanks for help
Mich
>




Apr 9 '07 #6

P: n/a
David, i did all those things but i found it:
the map security of the standard website in the IIS was set on Windows
Integrated Auth.
The map security of my website (one level lower in the IIS as all other
websites) is set on Anonymous.
This is the reason why login and createuserwizard doesn't work.
I changed the map security of the standard website into Anonymous and
everything works.
Amazing, no?
Do you have an explanation for that?
"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:e%****************@TK2MSFTNGP02.phx.gbl...
but what about your database?

just having access to the directory does not give database permission.

Set up a user in your database. Give that user permission to see the table
you want to view. Put that users username/password into your connection
string.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:OF**************@TK2MSFTNGP02.phx.gbl...
>Account ASPNET has R/W rights on the APP_Data dir.
And if it was not so, i would get an error, but here, no error, nothing
happens ...

"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:O8*************@TK2MSFTNGP02.phx.gbl...
>>>I notice you ahve integrated security rather than user names and
passwords. I may be wrong but I think integrated security will require
the current user to have permission in the database. When you are doing
it through VWDev, you are probably carrying your username through, but
when doing it from ASP.NET, you are using the ASP.NET user account, which
may not have permission.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:Ox****************@TK2MSFTNGP05.phx.gbl.. .
Hi Juan, thanks for replying..

I did this and an mdf file ASPNETDB.MDF was created in the sql server
directory.
So i copied both files (mdf and log) into APP_Data of my application.
I added a connection string in web.config like this:
<add name="aspnetdb" connectionString="Data
Source=.\SQLEXPRESS;AttachDbFilename=|DataDirec tory|\ASPNETDB.MDF;Integrated
Security=True;User Instance=True"
providerName="System.Data.SqlClient"/>

Now, when starting the aspx page containing the createuserwizard and
filling all texboxes, again, nothing happens (user is not created). If
i try it within VWDev., the user is then created.
What do i forget or do wrong?
Thanks

"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
news:ut**************@TK2MSFTNGP05.phx.gbl...
Run aspnet_regsql.exe from a command window in your .Net Framework 2.0
directory.
>
>
>
>
Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Mich" <mi**@nm.dfwrote in message
news:Og****************@TK2MSFTNGP03.phx.gbl.. .
>Hi,
>>
>i'm building an web application for anonymous users. They can take a
>look in the website, nothing more. In order to perform other actions,
>the anonymous user must be logged. So i create an aspx page with the
>CreateUserWizard control. The user can fill his username, password
>etc ....
>>
>My problem is: when an user fills everything and clicks on button
>"create an account", nothing happens (no error, but no user account
>created).
>I thought asp.net would create in App_Data an ASPNET.MDF file for
>storing user and membership information and add automatically a new
>connection string in web.config. But it doesn't happen.
>>
>I know i can go in design mode (n VWD) and click on "administer the
>site", but all the users are anonymous, so i can't create user in
>advance.
>Do i have to put some configuration code in web.config? Or something
>else?
>>
>Thanks for help
>Mich
>>
>
>




Apr 9 '07 #7

P: n/a
Hello Mich.

I'm trying to follow along in this thread beacuse i think i'm having the
same problem.

Can you explain where you went to change your "map security"?

Is it in the IIS Administration?

Any help would be gratefully appreciated.

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message
news:eZ****************@TK2MSFTNGP03.phx.gbl...
David, i did all those things but i found it:
the map security of the standard website in the IIS was set on Windows
Integrated Auth.
The map security of my website (one level lower in the IIS as all other
websites) is set on Anonymous.
This is the reason why login and createuserwizard doesn't work.
I changed the map security of the standard website into Anonymous and
everything works.
Amazing, no?
Do you have an explanation for that?
"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:e%****************@TK2MSFTNGP02.phx.gbl...
>but what about your database?

just having access to the directory does not give database permission.

Set up a user in your database. Give that user permission to see the
table you want to view. Put that users username/password into your
connection string.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:OF**************@TK2MSFTNGP02.phx.gbl...
>>Account ASPNET has R/W rights on the APP_Data dir.
And if it was not so, i would get an error, but here, no error, nothing
happens ...

"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:O8*************@TK2MSFTNGP02.phx.gbl...
I notice you ahve integrated security rather than user names and
passwords. I may be wrong but I think integrated security will require
the current user to have permission in the database. When you are doing
it through VWDev, you are probably carrying your username through, but
when doing it from ASP.NET, you are using the ASP.NET user account,
which may not have permission.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:Ox****************@TK2MSFTNGP05.phx.gbl. ..
Hi Juan, thanks for replying..
>
I did this and an mdf file ASPNETDB.MDF was created in the sql server
directory.
So i copied both files (mdf and log) into APP_Data of my application.
I added a connection string in web.config like this:
<add name="aspnetdb" connectionString="Data
Source=.\SQLEXPRESS;AttachDbFilename=|DataDire ctory|\ASPNETDB.MDF;Integrated
Security=True;User Instance=True"
providerName="System.Data.SqlClient"/>
>
Now, when starting the aspx page containing the createuserwizard and
filling all texboxes, again, nothing happens (user is not created). If
i try it within VWDev., the user is then created.
What do i forget or do wrong?
Thanks
>
>
>
"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
news:ut**************@TK2MSFTNGP05.phx.gbl.. .
>Run aspnet_regsql.exe from a command window in your .Net Framework
>2.0 directory.
>>
>>
>>
>>
>Juan T. Llibre, asp.net MVP
>asp.net faq : http://asp.net.do/faq/
>foros de asp.net, en espaņol : http://asp.net.do/foros/
>===================================
>"Mich" <mi**@nm.dfwrote in message
>news:Og****************@TK2MSFTNGP03.phx.gbl. ..
>>Hi,
>>>
>>i'm building an web application for anonymous users. They can take a
>>look in the website, nothing more. In order to perform other
>>actions, the anonymous user must be logged. So i create an aspx page
>>with the CreateUserWizard control. The user can fill his username,
>>password etc ....
>>>
>>My problem is: when an user fills everything and clicks on button
>>"create an account", nothing happens (no error, but no user account
>>created).
>>I thought asp.net would create in App_Data an ASPNET.MDF file for
>>storing user and membership information and add automatically a new
>>connection string in web.config. But it doesn't happen.
>>>
>>I know i can go in design mode (n VWD) and click on "administer the
>>site", but all the users are anonymous, so i can't create user in
>>advance.
>>Do i have to put some configuration code in web.config? Or something
>>else?
>>>
>>Thanks for help
>>Mich
>>>
>>
>>
>
>




Apr 9 '07 #8

P: n/a
re:
Can you explain where you went to change your "map security"?
He meant "the mapped security".

Use the IIS Manager for that.
Right-click and select "Properties"; then select the "Directory Security" tab.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:e3*************@TK2MSFTNGP05.phx.gbl...
Hello Mich.

I'm trying to follow along in this thread beacuse i think i'm having the same problem.

Can you explain where you went to change your "map security"?

Is it in the IIS Administration?

Any help would be gratefully appreciated.

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message news:eZ****************@TK2MSFTNGP03.phx.gbl...
>David, i did all those things but i found it:
the map security of the standard website in the IIS was set on Windows Integrated Auth.
The map security of my website (one level lower in the IIS as all other websites) is set on
Anonymous.
This is the reason why login and createuserwizard doesn't work.
I changed the map security of the standard website into Anonymous and everything works.
Amazing, no?
Do you have an explanation for that?
"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:e%****************@TK2MSFTNGP02.phx.gbl...
>>but what about your database?

just having access to the directory does not give database permission.

Set up a user in your database. Give that user permission to see the table you want to view. Put
that users username/password into your connection string.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message news:OF**************@TK2MSFTNGP02.phx.gbl...
Account ASPNET has R/W rights on the APP_Data dir.
And if it was not so, i would get an error, but here, no error, nothing happens ...

"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:O8*************@TK2MSFTNGP02.phx.gbl...
>I notice you ahve integrated security rather than user names and passwords. I may be wrong but
>I think integrated security will require the current user to have permission in the database.
>When you are doing it through VWDev, you are probably carrying your username through, but when
>doing it from ASP.NET, you are using the ASP.NET user account, which may not have permission.
>
--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
>
>
"Mich" <mi**@nm.dfwrote in message news:Ox****************@TK2MSFTNGP05.phx.gbl...
>Hi Juan, thanks for replying..
>>
>I did this and an mdf file ASPNETDB.MDF was created in the sql server directory.
>So i copied both files (mdf and log) into APP_Data of my application.
>I added a connection string in web.config like this:
> <add name="aspnetdb" connectionString="Data
>Source=.\SQLEXPRESS;AttachDbFilename=|DataDir ectory|\ASPNETDB.MDF;Integrated
>Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
>>
>Now, when starting the aspx page containing the createuserwizard and filling all texboxes,
>again, nothing happens (user is not created). If i try it within VWDev., the user is then
>created.
>What do i forget or do wrong?
>Thanks
>>
>>
>>
>"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
>news:ut**************@TK2MSFTNGP05.phx.gbl. ..
>>Run aspnet_regsql.exe from a command window in your .Net Framework 2.0 directory.
>>>
>>>
>>>
>>>
>>Juan T. Llibre, asp.net MVP
>>asp.net faq : http://asp.net.do/faq/
>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>===================================
>>"Mich" <mi**@nm.dfwrote in message news:Og****************@TK2MSFTNGP03.phx.gbl...
>>>Hi,
>>>>
>>>i'm building an web application for anonymous users. They can take a look in the website,
>>>nothing more. In order to perform other actions, the anonymous user must be logged. So i
>>>create an aspx page with the CreateUserWizard control. The user can fill his username,
>>>password etc ....
>>>>
>>>My problem is: when an user fills everything and clicks on button "create an account",
>>>nothing happens (no error, but no user account created).
>>>I thought asp.net would create in App_Data an ASPNET.MDF file for storing user and
>>>membership information and add automatically a new connection string in web.config. But it
>>>doesn't happen.
>>>>
>>>I know i can go in design mode (n VWD) and click on "administer the site", but all the
>>>users are anonymous, so i can't create user in advance.
>>>Do i have to put some configuration code in web.config? Or something else?
>>>>
>>>Thanks for help
>>>Mich
>>>>
>>>
>>>
>>
>>
>
>




Apr 9 '07 #9

P: n/a
Yes.

Rightclick on Standard website (maybe diffferent in windows 2003, i use xp
prof.), then take properties and then Map security. There you can choose
anonymous or win. int. auth.

"Tony Girgenti" <tony(nospam)@lakesideos.comschreef in bericht
news:e3*************@TK2MSFTNGP05.phx.gbl...
Hello Mich.

I'm trying to follow along in this thread beacuse i think i'm having the
same problem.

Can you explain where you went to change your "map security"?

Is it in the IIS Administration?

Any help would be gratefully appreciated.

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message
news:eZ****************@TK2MSFTNGP03.phx.gbl...
>David, i did all those things but i found it:
the map security of the standard website in the IIS was set on Windows
Integrated Auth.
The map security of my website (one level lower in the IIS as all other
websites) is set on Anonymous.
This is the reason why login and createuserwizard doesn't work.
I changed the map security of the standard website into Anonymous and
everything works.
Amazing, no?
Do you have an explanation for that?
"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:e%****************@TK2MSFTNGP02.phx.gbl...
>>but what about your database?

just having access to the directory does not give database permission.

Set up a user in your database. Give that user permission to see the
table you want to view. Put that users username/password into your
connection string.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:OF**************@TK2MSFTNGP02.phx.gbl...
Account ASPNET has R/W rights on the APP_Data dir.
And if it was not so, i would get an error, but here, no error, nothing
happens ...

"David" <da*****************@revilloc.REMOVETHIS.comschree f in
bericht news:O8*************@TK2MSFTNGP02.phx.gbl...
>I notice you ahve integrated security rather than user names and
>passwords. I may be wrong but I think integrated security will require
>the current user to have permission in the database. When you are doing
>it through VWDev, you are probably carrying your username through, but
>when doing it from ASP.NET, you are using the ASP.NET user account,
>which may not have permission.
>
--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
>
>
"Mich" <mi**@nm.dfwrote in message
news:Ox****************@TK2MSFTNGP05.phx.gbl.. .
>Hi Juan, thanks for replying..
>>
>I did this and an mdf file ASPNETDB.MDF was created in the sql server
>directory.
>So i copied both files (mdf and log) into APP_Data of my application.
>I added a connection string in web.config like this:
> <add name="aspnetdb" connectionString="Data
>Source=.\SQLEXPRESS;AttachDbFilename=|DataDir ectory|\ASPNETDB.MDF;Integrated
>Security=True;User Instance=True"
>providerName="System.Data.SqlClient"/>
>>
>Now, when starting the aspx page containing the createuserwizard and
>filling all texboxes, again, nothing happens (user is not created).
>If i try it within VWDev., the user is then created.
>What do i forget or do wrong?
>Thanks
>>
>>
>>
>"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
>news:ut**************@TK2MSFTNGP05.phx.gbl. ..
>>Run aspnet_regsql.exe from a command window in your .Net Framework
>>2.0 directory.
>>>
>>>
>>>
>>>
>>Juan T. Llibre, asp.net MVP
>>asp.net faq : http://asp.net.do/faq/
>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>===================================
>>"Mich" <mi**@nm.dfwrote in message
>>news:Og****************@TK2MSFTNGP03.phx.gbl ...
>>>Hi,
>>>>
>>>i'm building an web application for anonymous users. They can take
>>>a look in the website, nothing more. In order to perform other
>>>actions, the anonymous user must be logged. So i create an aspx
>>>page with the CreateUserWizard control. The user can fill his
>>>username, password etc ....
>>>>
>>>My problem is: when an user fills everything and clicks on button
>>>"create an account", nothing happens (no error, but no user account
>>>created).
>>>I thought asp.net would create in App_Data an ASPNET.MDF file for
>>>storing user and membership information and add automatically a new
>>>connection string in web.config. But it doesn't happen.
>>>>
>>>I know i can go in design mode (n VWD) and click on "administer the
>>>site", but all the users are anonymous, so i can't create user in
>>>advance.
>>>Do i have to put some configuration code in web.config? Or
>>>something else?
>>>>
>>>Thanks for help
>>>Mich
>>>>
>>>
>>>
>>
>>
>
>




Apr 9 '07 #10

P: n/a
Hello Mich.

I'm sorry for sounding so stupid but i'm not sure about where to go. By
"Standard website", do you mean "Default Web Site"? I have XP Pro, SP1
also.

Also, after right-clicking and selecting properties, do you mean the
"Directory Security" tab, then click "Edit" for the Authentication Methods
screen? I don't see a "Map secutiry".

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message
news:OO**************@TK2MSFTNGP06.phx.gbl...
Yes.

Rightclick on Standard website (maybe diffferent in windows 2003, i use xp
prof.), then take properties and then Map security. There you can choose
anonymous or win. int. auth.

"Tony Girgenti" <tony(nospam)@lakesideos.comschreef in bericht
news:e3*************@TK2MSFTNGP05.phx.gbl...
>Hello Mich.

I'm trying to follow along in this thread beacuse i think i'm having the
same problem.

Can you explain where you went to change your "map security"?

Is it in the IIS Administration?

Any help would be gratefully appreciated.

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message
news:eZ****************@TK2MSFTNGP03.phx.gbl...
>>David, i did all those things but i found it:
the map security of the standard website in the IIS was set on Windows
Integrated Auth.
The map security of my website (one level lower in the IIS as all other
websites) is set on Anonymous.
This is the reason why login and createuserwizard doesn't work.
I changed the map security of the standard website into Anonymous and
everything works.
Amazing, no?
Do you have an explanation for that?
"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:e%****************@TK2MSFTNGP02.phx.gbl.. .
but what about your database?

just having access to the directory does not give database permission.

Set up a user in your database. Give that user permission to see the
table you want to view. Put that users username/password into your
connection string.

--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
"Mich" <mi**@nm.dfwrote in message
news:OF**************@TK2MSFTNGP02.phx.gbl...
Account ASPNET has R/W rights on the APP_Data dir.
And if it was not so, i would get an error, but here, no error,
nothing happens ...
>
"David" <da*****************@revilloc.REMOVETHIS.comschree f in
bericht news:O8*************@TK2MSFTNGP02.phx.gbl...
>>I notice you ahve integrated security rather than user names and
>>passwords. I may be wrong but I think integrated security will require
>>the current user to have permission in the database. When you are
>>doing it through VWDev, you are probably carrying your username
>>through, but when doing it from ASP.NET, you are using the ASP.NET
>>user account, which may not have permission.
>>
>--
>Best regards,
>Dave Colliver.
>http://www.AshfieldFOCUS.com
>~~
>http://www.FOCUSPortals.com - Local franchises available
>>
>>
>"Mich" <mi**@nm.dfwrote in message
>news:Ox****************@TK2MSFTNGP05.phx.gbl. ..
>>Hi Juan, thanks for replying..
>>>
>>I did this and an mdf file ASPNETDB.MDF was created in the sql
>>server directory.
>>So i copied both files (mdf and log) into APP_Data of my
>>application.
>>I added a connection string in web.config like this:
>> <add name="aspnetdb" connectionString="Data
>>Source=.\SQLEXPRESS;AttachDbFilename=|DataDi rectory|\ASPNETDB.MDF;Integrated
>>Security=True;User Instance=True"
>>providerName="System.Data.SqlClient"/>
>>>
>>Now, when starting the aspx page containing the createuserwizard and
>>filling all texboxes, again, nothing happens (user is not created).
>>If i try it within VWDev., the user is then created.
>>What do i forget or do wrong?
>>Thanks
>>>
>>>
>>>
>>"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
>>news:ut**************@TK2MSFTNGP05.phx.gbl.. .
>>>Run aspnet_regsql.exe from a command window in your .Net Framework
>>>2.0 directory.
>>>>
>>>>
>>>>
>>>>
>>>Juan T. Llibre, asp.net MVP
>>>asp.net faq : http://asp.net.do/faq/
>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>===================================
>>>"Mich" <mi**@nm.dfwrote in message
>>>news:Og****************@TK2MSFTNGP03.phx.gb l...
>>>>Hi,
>>>>>
>>>>i'm building an web application for anonymous users. They can take
>>>>a look in the website, nothing more. In order to perform other
>>>>actions, the anonymous user must be logged. So i create an aspx
>>>>page with the CreateUserWizard control. The user can fill his
>>>>username, password etc ....
>>>>>
>>>>My problem is: when an user fills everything and clicks on button
>>>>"create an account", nothing happens (no error, but no user
>>>>account created).
>>>>I thought asp.net would create in App_Data an ASPNET.MDF file for
>>>>storing user and membership information and add automatically a
>>>>new connection string in web.config. But it doesn't happen.
>>>>>
>>>>I know i can go in design mode (n VWD) and click on "administer
>>>>the site", but all the users are anonymous, so i can't create user
>>>>in advance.
>>>>Do i have to put some configuration code in web.config? Or
>>>>something else?
>>>>>
>>>>Thanks for help
>>>>Mich
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>




Apr 9 '07 #11

P: n/a
re:
!Also, after right-clicking and selecting properties, do you mean the
!"Directory Security" tab, then click "Edit" for the Authentication Methods screen?

Yes, he means that.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:ek**************@TK2MSFTNGP03.phx.gbl...
Hello Mich.

I'm sorry for sounding so stupid but i'm not sure about where to go. By "Standard website", do
you mean "Default Web Site"? I have XP Pro, SP1 also.

Also, after right-clicking and selecting properties, do you mean the "Directory Security" tab,
then click "Edit" for the Authentication Methods screen? I don't see a "Map secutiry".

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message news:OO**************@TK2MSFTNGP06.phx.gbl...
>Yes.

Rightclick on Standard website (maybe diffferent in windows 2003, i use xp prof.), then take
properties and then Map security. There you can choose anonymous or win. int. auth.

"Tony Girgenti" <tony(nospam)@lakesideos.comschreef in bericht
news:e3*************@TK2MSFTNGP05.phx.gbl...
>>Hello Mich.

I'm trying to follow along in this thread beacuse i think i'm having the same problem.

Can you explain where you went to change your "map security"?

Is it in the IIS Administration?

Any help would be gratefully appreciated.

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message news:eZ****************@TK2MSFTNGP03.phx.gbl...
David, i did all those things but i found it:
the map security of the standard website in the IIS was set on Windows Integrated Auth.
The map security of my website (one level lower in the IIS as all other websites) is set on
Anonymous.
This is the reason why login and createuserwizard doesn't work.
I changed the map security of the standard website into Anonymous and everything works.
Amazing, no?
Do you have an explanation for that?
"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
news:e%****************@TK2MSFTNGP02.phx.gbl. ..
but what about your database?
>
just having access to the directory does not give database permission.
>
Set up a user in your database. Give that user permission to see the table you want to view.
Put that users username/password into your connection string.
>
--
Best regards,
Dave Colliver.
http://www.AshfieldFOCUS.com
~~
http://www.FOCUSPortals.com - Local franchises available
>
>
"Mich" <mi**@nm.dfwrote in message news:OF**************@TK2MSFTNGP02.phx.gbl...
>Account ASPNET has R/W rights on the APP_Data dir.
>And if it was not so, i would get an error, but here, no error, nothing happens ...
>>
>"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
>news:O8*************@TK2MSFTNGP02.phx.gbl.. .
>>>I notice you ahve integrated security rather than user names and passwords. I may be wrong
>>>but I think integrated security will require the current user to have permission in the
>>>database. When you are doing it through VWDev, you are probably carrying your username
>>>through, but when doing it from ASP.NET, you are using the ASP.NET user account, which may
>>>not have permission.
>>>
>>--
>>Best regards,
>>Dave Colliver.
>>http://www.AshfieldFOCUS.com
>>~~
>>http://www.FOCUSPortals.com - Local franchises available
>>>
>>>
>>"Mich" <mi**@nm.dfwrote in message news:Ox****************@TK2MSFTNGP05.phx.gbl...
>>>Hi Juan, thanks for replying..
>>>>
>>>I did this and an mdf file ASPNETDB.MDF was created in the sql server directory.
>>>So i copied both files (mdf and log) into APP_Data of my application.
>>>I added a connection string in web.config like this:
>>> <add name="aspnetdb" connectionString="Data
>>>Source=.\SQLEXPRESS;AttachDbFilename=|DataD irectory|\ASPNETDB.MDF;Integrated
>>>Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
>>>>
>>>Now, when starting the aspx page containing the createuserwizard and filling all texboxes,
>>>again, nothing happens (user is not created). If i try it within VWDev., the user is then
>>>created.
>>>What do i forget or do wrong?
>>>Thanks
>>>>
>>>>
>>>>
>>>"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
>>>news:ut**************@TK2MSFTNGP05.phx.gbl. ..
>>>>Run aspnet_regsql.exe from a command window in your .Net Framework 2.0 directory.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>Juan T. Llibre, asp.net MVP
>>>>asp.net faq : http://asp.net.do/faq/
>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>===================================
>>>>"Mich" <mi**@nm.dfwrote in message news:Og****************@TK2MSFTNGP03.phx.gbl...
>>>>>Hi,
>>>>>>
>>>>>i'm building an web application for anonymous users. They can take a look in the website,
>>>>>nothing more. In order to perform other actions, the anonymous user must be logged. So i
>>>>>create an aspx page with the CreateUserWizard control. The user can fill his username,
>>>>>password etc ....
>>>>>>
>>>>>My problem is: when an user fills everything and clicks on button "create an account",
>>>>>nothing happens (no error, but no user account created).
>>>>>I thought asp.net would create in App_Data an ASPNET.MDF file for storing user and
>>>>>membership information and add automatically a new connection string in web.config. But
>>>>>it doesn't happen.
>>>>>>
>>>>>I know i can go in design mode (n VWD) and click on "administer the site", but all the
>>>>>users are anonymous, so i can't create user in advance.
>>>>>Do i have to put some configuration code in web.config? Or something else?
>>>>>>
>>>>>Thanks for help
>>>>>Mich
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>




Apr 9 '07 #12

P: n/a
Hello Juan.

Well, changing that security settings didn't help me, but thanks for all
your help.

Tony

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OU**************@TK2MSFTNGP03.phx.gbl...
re:
!Also, after right-clicking and selecting properties, do you mean the
!"Directory Security" tab, then click "Edit" for the Authentication
Methods screen?

Yes, he means that.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:ek**************@TK2MSFTNGP03.phx.gbl...
>Hello Mich.

I'm sorry for sounding so stupid but i'm not sure about where to go. By
"Standard website", do you mean "Default Web Site"? I have XP Pro, SP1
also.

Also, after right-clicking and selecting properties, do you mean the
"Directory Security" tab, then click "Edit" for the Authentication
Methods screen? I don't see a "Map secutiry".

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message
news:OO**************@TK2MSFTNGP06.phx.gbl...
>>Yes.

Rightclick on Standard website (maybe diffferent in windows 2003, i use
xp prof.), then take properties and then Map security. There you can
choose anonymous or win. int. auth.

"Tony Girgenti" <tony(nospam)@lakesideos.comschreef in bericht
news:e3*************@TK2MSFTNGP05.phx.gbl...
Hello Mich.

I'm trying to follow along in this thread beacuse i think i'm having
the same problem.

Can you explain where you went to change your "map security"?

Is it in the IIS Administration?

Any help would be gratefully appreciated.

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message
news:eZ****************@TK2MSFTNGP03.phx.gbl. ..
David, i did all those things but i found it:
the map security of the standard website in the IIS was set on Windows
Integrated Auth.
The map security of my website (one level lower in the IIS as all
other websites) is set on Anonymous.
This is the reason why login and createuserwizard doesn't work.
I changed the map security of the standard website into Anonymous and
everything works.
Amazing, no?
Do you have an explanation for that?
>
>
"David" <da*****************@revilloc.REMOVETHIS.comschree f in
bericht news:e%****************@TK2MSFTNGP02.phx.gbl...
>but what about your database?
>>
>just having access to the directory does not give database
>permission.
>>
>Set up a user in your database. Give that user permission to see the
>table you want to view. Put that users username/password into your
>connection string.
>>
>--
>Best regards,
>Dave Colliver.
>http://www.AshfieldFOCUS.com
>~~
>http://www.FOCUSPortals.com - Local franchises available
>>
>>
>"Mich" <mi**@nm.dfwrote in message
>news:OF**************@TK2MSFTNGP02.phx.gbl. ..
>>Account ASPNET has R/W rights on the APP_Data dir.
>>And if it was not so, i would get an error, but here, no error,
>>nothing happens ...
>>>
>>"David" <da*****************@revilloc.REMOVETHIS.comschree f in
>>bericht news:O8*************@TK2MSFTNGP02.phx.gbl...
>>>>I notice you ahve integrated security rather than user names and
>>>>passwords. I may be wrong but I think integrated security will
>>>>require the current user to have permission in the database. When
>>>>you are doing it through VWDev, you are probably carrying your
>>>>username through, but when doing it from ASP.NET, you are using the
>>>>ASP.NET user account, which may not have permission.
>>>>
>>>--
>>>Best regards,
>>>Dave Colliver.
>>>http://www.AshfieldFOCUS.com
>>>~~
>>>http://www.FOCUSPortals.com - Local franchises available
>>>>
>>>>
>>>"Mich" <mi**@nm.dfwrote in message
>>>news:Ox****************@TK2MSFTNGP05.phx.gb l...
>>>>Hi Juan, thanks for replying..
>>>>>
>>>>I did this and an mdf file ASPNETDB.MDF was created in the sql
>>>>server directory.
>>>>So i copied both files (mdf and log) into APP_Data of my
>>>>application.
>>>>I added a connection string in web.config like this:
>>>> <add name="aspnetdb" connectionString="Data
>>>>Source=.\SQLEXPRESS;AttachDbFilename=|Data Directory|\ASPNETDB.MDF;Integrated
>>>>Security=True;User Instance=True"
>>>>providerName="System.Data.SqlClient"/>
>>>>>
>>>>Now, when starting the aspx page containing the createuserwizard
>>>>and filling all texboxes, again, nothing happens (user is not
>>>>created). If i try it within VWDev., the user is then created.
>>>>What do i forget or do wrong?
>>>>Thanks
>>>>>
>>>>>
>>>>>
>>>>"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
>>>>news:ut**************@TK2MSFTNGP05.phx.gbl ...
>>>>>Run aspnet_regsql.exe from a command window in your .Net
>>>>>Framework 2.0 directory.
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>Juan T. Llibre, asp.net MVP
>>>>>asp.net faq : http://asp.net.do/faq/
>>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>===================================
>>>>>"Mich" <mi**@nm.dfwrote in message
>>>>>news:Og****************@TK2MSFTNGP03.phx. gbl...
>>>>>>Hi,
>>>>>>>
>>>>>>i'm building an web application for anonymous users. They can
>>>>>>take a look in the website, nothing more. In order to perform
>>>>>>other actions, the anonymous user must be logged. So i create an
>>>>>>aspx page with the CreateUserWizard control. The user can fill
>>>>>>his username, password etc ....
>>>>>>>
>>>>>>My problem is: when an user fills everything and clicks on
>>>>>>button "create an account", nothing happens (no error, but no
>>>>>>user account created).
>>>>>>I thought asp.net would create in App_Data an ASPNET.MDF file
>>>>>>for storing user and membership information and add
>>>>>>automatically a new connection string in web.config. But it
>>>>>>doesn't happen.
>>>>>>>
>>>>>>I know i can go in design mode (n VWD) and click on "administer
>>>>>>the site", but all the users are anonymous, so i can't create
>>>>>>user in advance.
>>>>>>Do i have to put some configuration code in web.config? Or
>>>>>>something else?
>>>>>>>
>>>>>>Thanks for help
>>>>>>Mich
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>




Apr 9 '07 #13

P: n/a
re:
Well, changing that security settings didn't help me, but thanks for all your help.
1. What did you change...and to what ?
2. What happened after you changed it ?
3. Can you restate your problem ? ( Is it different than the OP's problem ? )


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:eo**************@TK2MSFTNGP06.phx.gbl...
Hello Juan.

Well, changing that security settings didn't help me, but thanks for all your help.

Tony

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OU**************@TK2MSFTNGP03.phx.gbl...
>re:
!Also, after right-clicking and selecting properties, do you mean the
!"Directory Security" tab, then click "Edit" for the Authentication Methods screen?

Yes, he means that.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:ek**************@TK2MSFTNGP03.phx.gbl...
>>Hello Mich.

I'm sorry for sounding so stupid but i'm not sure about where to go. By "Standard website", do
you mean "Default Web Site"? I have XP Pro, SP1 also.

Also, after right-clicking and selecting properties, do you mean the "Directory Security" tab,
then click "Edit" for the Authentication Methods screen? I don't see a "Map secutiry".

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message news:OO**************@TK2MSFTNGP06.phx.gbl...
Yes.

Rightclick on Standard website (maybe diffferent in windows 2003, i use xp prof.), then take
properties and then Map security. There you can choose anonymous or win. int. auth.

"Tony Girgenti" <tony(nospam)@lakesideos.comschreef in bericht
news:e3*************@TK2MSFTNGP05.phx.gbl...
Hello Mich.
>
I'm trying to follow along in this thread beacuse i think i'm having the same problem.
>
Can you explain where you went to change your "map security"?
>
Is it in the IIS Administration?
>
Any help would be gratefully appreciated.
>
Thanks,
Tony
>
"Mich" <mi**@nm.dfwrote in message news:eZ****************@TK2MSFTNGP03.phx.gbl...
>David, i did all those things but i found it:
>the map security of the standard website in the IIS was set on Windows Integrated Auth.
>The map security of my website (one level lower in the IIS as all other websites) is set on
>Anonymous.
>This is the reason why login and createuserwizard doesn't work.
>I changed the map security of the standard website into Anonymous and everything works.
>Amazing, no?
>Do you have an explanation for that?
>>
>>
>"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
>news:e%****************@TK2MSFTNGP02.phx.gbl. ..
>>but what about your database?
>>>
>>just having access to the directory does not give database permission.
>>>
>>Set up a user in your database. Give that user permission to see the table you want to view.
>>Put that users username/password into your connection string.
>>>
>>--
>>Best regards,
>>Dave Colliver.
>>http://www.AshfieldFOCUS.com
>>~~
>>http://www.FOCUSPortals.com - Local franchises available
>>>
>>>
>>"Mich" <mi**@nm.dfwrote in message news:OF**************@TK2MSFTNGP02.phx.gbl...
>>>Account ASPNET has R/W rights on the APP_Data dir.
>>>And if it was not so, i would get an error, but here, no error, nothing happens ...
>>>>
>>>"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
>>>news:O8*************@TK2MSFTNGP02.phx.gbl.. .
>>>>>I notice you ahve integrated security rather than user names and passwords. I may be wrong
>>>>>but I think integrated security will require the current user to have permission in the
>>>>>database. When you are doing it through VWDev, you are probably carrying your username
>>>>>through, but when doing it from ASP.NET, you are using the ASP.NET user account, which may
>>>>>not have permission.
>>>>>
>>>>--
>>>>Best regards,
>>>>Dave Colliver.
>>>>http://www.AshfieldFOCUS.com
>>>>~~
>>>>http://www.FOCUSPortals.com - Local franchises available
>>>>>
>>>>>
>>>>"Mich" <mi**@nm.dfwrote in message news:Ox****************@TK2MSFTNGP05.phx.gbl...
>>>>>Hi Juan, thanks for replying..
>>>>>>
>>>>>I did this and an mdf file ASPNETDB.MDF was created in the sql server directory.
>>>>>So i copied both files (mdf and log) into APP_Data of my application.
>>>>>I added a connection string in web.config like this:
>>>>> <add name="aspnetdb" connectionString="Data
>>>>>Source=.\SQLEXPRESS;AttachDbFilename=|Dat aDirectory|\ASPNETDB.MDF;Integrated
>>>>>Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
>>>>>>
>>>>>Now, when starting the aspx page containing the createuserwizard and filling all
>>>>>texboxes, again, nothing happens (user is not created). If i try it within VWDev., the
>>>>>user is then created.
>>>>>What do i forget or do wrong?
>>>>>Thanks
>>>>>>
>>>>>>
>>>>>>
>>>>>"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
>>>>>news:ut**************@TK2MSFTNGP05.phx.gb l...
>>>>>>Run aspnet_regsql.exe from a command window in your .Net Framework 2.0 directory.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>Juan T. Llibre, asp.net MVP
>>>>>>asp.net faq : http://asp.net.do/faq/
>>>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>===================================
>>>>>>"Mich" <mi**@nm.dfwrote in message news:Og****************@TK2MSFTNGP03.phx.gbl...
>>>>>>>Hi,
>>>>>>>>
>>>>>>>i'm building an web application for anonymous users. They can take a look in the
>>>>>>>website, nothing more. In order to perform other actions, the anonymous user must be
>>>>>>>logged. So i create an aspx page with the CreateUserWizard control. The user can fill
>>>>>>>his username, password etc ....
>>>>>>>>
>>>>>>>My problem is: when an user fills everything and clicks on button "create an account",
>>>>>>>nothing happens (no error, but no user account created).
>>>>>>>I thought asp.net would create in App_Data an ASPNET.MDF file for storing user and
>>>>>>>membership information and add automatically a new connection string in web.config. But
>>>>>>>it doesn't happen.
>>>>>>>>
>>>>>>>I know i can go in design mode (n VWD) and click on "administer the site", but all the
>>>>>>>users are anonymous, so i can't create user in advance.
>>>>>>>Do i have to put some configuration code in web.config? Or something else?
>>>>>>>>
>>>>>>>Thanks for help
>>>>>>>Mich

Apr 9 '07 #14

P: n/a
Hello Juan.

I unchecked the "Anonymous access" box on the Authentication Methods screen.
After doing so, nothing changed, so i just figured that it did not help.

My problem is outlined in the next post down.

Thanks,
Tony

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:e9**************@TK2MSFTNGP04.phx.gbl...
re:
>Well, changing that security settings didn't help me, but thanks for all
your help.

1. What did you change...and to what ?
2. What happened after you changed it ?
3. Can you restate your problem ? ( Is it different than the OP's problem
? )


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:eo**************@TK2MSFTNGP06.phx.gbl...
>Hello Juan.

Well, changing that security settings didn't help me, but thanks for all
your help.

Tony

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OU**************@TK2MSFTNGP03.phx.gbl...
>>re:
!Also, after right-clicking and selecting properties, do you mean the
!"Directory Security" tab, then click "Edit" for the Authentication
Methods screen?

Yes, he means that.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:ek**************@TK2MSFTNGP03.phx.gbl...
Hello Mich.

I'm sorry for sounding so stupid but i'm not sure about where to go.
By "Standard website", do you mean "Default Web Site"? I have XP Pro,
SP1 also.

Also, after right-clicking and selecting properties, do you mean the
"Directory Security" tab, then click "Edit" for the Authentication
Methods screen? I don't see a "Map secutiry".

Thanks,
Tony

"Mich" <mi**@nm.dfwrote in message
news:OO**************@TK2MSFTNGP06.phx.gbl...
Yes.
>
Rightclick on Standard website (maybe diffferent in windows 2003, i
use xp prof.), then take properties and then Map security. There you
can choose anonymous or win. int. auth.
>
"Tony Girgenti" <tony(nospam)@lakesideos.comschreef in bericht
news:e3*************@TK2MSFTNGP05.phx.gbl...
>Hello Mich.
>>
>I'm trying to follow along in this thread beacuse i think i'm having
>the same problem.
>>
>Can you explain where you went to change your "map security"?
>>
>Is it in the IIS Administration?
>>
>Any help would be gratefully appreciated.
>>
>Thanks,
>Tony
>>
>"Mich" <mi**@nm.dfwrote in message
>news:eZ****************@TK2MSFTNGP03.phx.gbl. ..
>>David, i did all those things but i found it:
>>the map security of the standard website in the IIS was set on
>>Windows Integrated Auth.
>>The map security of my website (one level lower in the IIS as all
>>other websites) is set on Anonymous.
>>This is the reason why login and createuserwizard doesn't work.
>>I changed the map security of the standard website into Anonymous
>>and everything works.
>>Amazing, no?
>>Do you have an explanation for that?
>>>
>>>
>>"David" <da*****************@revilloc.REMOVETHIS.comschree f in
>>bericht news:e%****************@TK2MSFTNGP02.phx.gbl...
>>>but what about your database?
>>>>
>>>just having access to the directory does not give database
>>>permission.
>>>>
>>>Set up a user in your database. Give that user permission to see
>>>the table you want to view. Put that users username/password into
>>>your connection string.
>>>>
>>>--
>>>Best regards,
>>>Dave Colliver.
>>>http://www.AshfieldFOCUS.com
>>>~~
>>>http://www.FOCUSPortals.com - Local franchises available
>>>>
>>>>
>>>"Mich" <mi**@nm.dfwrote in message
>>>news:OF**************@TK2MSFTNGP02.phx.gbl. ..
>>>>Account ASPNET has R/W rights on the APP_Data dir.
>>>>And if it was not so, i would get an error, but here, no error,
>>>>nothing happens ...
>>>>>
>>>>"David" <da*****************@revilloc.REMOVETHIS.comschree f in
>>>>bericht news:O8*************@TK2MSFTNGP02.phx.gbl...
>>>>>>I notice you ahve integrated security rather than user names and
>>>>>>passwords. I may be wrong but I think integrated security will
>>>>>>require the current user to have permission in the database. When
>>>>>>you are doing it through VWDev, you are probably carrying your
>>>>>>username through, but when doing it from ASP.NET, you are using
>>>>>>the ASP.NET user account, which may not have permission.
>>>>>>
>>>>>--
>>>>>Best regards,
>>>>>Dave Colliver.
>>>>>http://www.AshfieldFOCUS.com
>>>>>~~
>>>>>http://www.FOCUSPortals.com - Local franchises available
>>>>>>
>>>>>>
>>>>>"Mich" <mi**@nm.dfwrote in message
>>>>>news:Ox****************@TK2MSFTNGP05.phx. gbl...
>>>>>>Hi Juan, thanks for replying..
>>>>>>>
>>>>>>I did this and an mdf file ASPNETDB.MDF was created in the sql
>>>>>>server directory.
>>>>>>So i copied both files (mdf and log) into APP_Data of my
>>>>>>application.
>>>>>>I added a connection string in web.config like this:
>>>>>> <add name="aspnetdb" connectionString="Data
>>>>>>Source=.\SQLEXPRESS;AttachDbFilename=|Da taDirectory|\ASPNETDB.MDF;Integrated
>>>>>>Security=True;User Instance=True"
>>>>>>providerName="System.Data.SqlClient"/>
>>>>>>>
>>>>>>Now, when starting the aspx page containing the createuserwizard
>>>>>>and filling all texboxes, again, nothing happens (user is not
>>>>>>created). If i try it within VWDev., the user is then created.
>>>>>>What do i forget or do wrong?
>>>>>>Thanks
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
>>>>>>news:ut**************@TK2MSFTNGP05.phx.g bl...
>>>>>>>Run aspnet_regsql.exe from a command window in your .Net
>>>>>>>Framework 2.0 directory.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>Juan T. Llibre, asp.net MVP
>>>>>>>asp.net faq : http://asp.net.do/faq/
>>>>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>>===================================
>>>>>>>"Mich" <mi**@nm.dfwrote in message
>>>>>>>news:Og****************@TK2MSFTNGP03.ph x.gbl...
>>>>>>>>Hi,
>>>>>>>>>
>>>>>>>>i'm building an web application for anonymous users. They can
>>>>>>>>take a look in the website, nothing more. In order to perform
>>>>>>>>other actions, the anonymous user must be logged. So i create
>>>>>>>>an aspx page with the CreateUserWizard control. The user can
>>>>>>>>fill his username, password etc ....
>>>>>>>>>
>>>>>>>>My problem is: when an user fills everything and clicks on
>>>>>>>>button "create an account", nothing happens (no error, but no
>>>>>>>>user account created).
>>>>>>>>I thought asp.net would create in App_Data an ASPNET.MDF file
>>>>>>>>for storing user and membership information and add
>>>>>>>>automatically a new connection string in web.config. But it
>>>>>>>>doesn't happen.
>>>>>>>>>
>>>>>>>>I know i can go in design mode (n VWD) and click on
>>>>>>>>"administer the site", but all the users are anonymous, so i
>>>>>>>>can't create user in advance.
>>>>>>>>Do i have to put some configuration code in web.config? Or
>>>>>>>>something else?
>>>>>>>>>
>>>>>>>>Thanks for help
>>>>>>>>Mich


Apr 10 '07 #15

P: n/a
re:
!I unchecked the "Anonymous access" box on the Authentication Methods screen.

Hi, Tony.

The OP's problem was solved by *allowing* anonymous access,
not by requiring authentication.

When you *uncheck* the anonymous access box, you are -effectively- *requiring* authentication.

Let's see if we can do a little detective work and find out which account
ASP.NET is running as, so you can assign permissions to the correct account.

First of all, are you using impersonation ?
Knowing that will make a difference.

Secondly, can you save this page and run it from the root directory of your app ?

identity.aspx :
--------------------
<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = "ASP.NET is running as the account : " & tmp
End Sub
</script>
<html>
<head>
<title>What account is ASP.NET running as ?</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
---------------------

Whichever account is returned will be the account that needs access permission
to the App_Data directory and database, if you're using a trusted connection,
unless you are using a *specific* account to access your membership database.

Please read through Scott Mitchell's tutorial :

http://aspnet.4guysfromrolla.com/articles/120705-1.aspx

It has invaluable background info which will make your life easier
when trying to implement ASP.NET Membership.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:ex**************@TK2MSFTNGP04.phx.gbl...
Hello Juan.

I unchecked the "Anonymous access" box on the Authentication Methods screen. After doing so,
nothing changed, so i just figured that it did not help.

My problem is outlined in the next post down.

Thanks,
Tony

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:e9**************@TK2MSFTNGP04.phx.gbl...
>re:
>>Well, changing that security settings didn't help me, but thanks for all your help.

1. What did you change...and to what ?
2. What happened after you changed it ?
3. Can you restate your problem ? ( Is it different than the OP's problem ? )


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:eo**************@TK2MSFTNGP06.phx.gbl...
>>Hello Juan.

Well, changing that security settings didn't help me, but thanks for all your help.

Tony

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OU**************@TK2MSFTNGP03.phx.gbl...
re:
!Also, after right-clicking and selecting properties, do you mean the
!"Directory Security" tab, then click "Edit" for the Authentication Methods screen?

Yes, he means that.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:ek**************@TK2MSFTNGP03.phx.gbl...
Hello Mich.
>
I'm sorry for sounding so stupid but i'm not sure about where to go. By "Standard website", do
you mean "Default Web Site"? I have XP Pro, SP1 also.
>
Also, after right-clicking and selecting properties, do you mean the "Directory Security" tab,
then click "Edit" for the Authentication Methods screen? I don't see a "Map secutiry".
>
Thanks,
Tony
>
"Mich" <mi**@nm.dfwrote in message news:OO**************@TK2MSFTNGP06.phx.gbl...
>Yes.
>>
>Rightclick on Standard website (maybe diffferent in windows 2003, i use xp prof.), then take
>properties and then Map security. There you can choose anonymous or win. int. auth.
>>
>"Tony Girgenti" <tony(nospam)@lakesideos.comschreef in bericht
>news:e3*************@TK2MSFTNGP05.phx.gbl.. .
>>Hello Mich.
>>>
>>I'm trying to follow along in this thread beacuse i think i'm having the same problem.
>>>
>>Can you explain where you went to change your "map security"?
>>>
>>Is it in the IIS Administration?
>>>
>>Any help would be gratefully appreciated.
>>>
>>Thanks,
>>Tony
>>>
>>"Mich" <mi**@nm.dfwrote in message news:eZ****************@TK2MSFTNGP03.phx.gbl...
>>>David, i did all those things but i found it:
>>>the map security of the standard website in the IIS was set on Windows Integrated Auth.
>>>The map security of my website (one level lower in the IIS as all other websites) is set on
>>>Anonymous.
>>>This is the reason why login and createuserwizard doesn't work.
>>>I changed the map security of the standard website into Anonymous and everything works.
>>>Amazing, no?
>>>Do you have an explanation for that?
>>>>
>>>>
>>>"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
>>>news:e%****************@TK2MSFTNGP02.phx.gb l...
>>>>but what about your database?
>>>>>
>>>>just having access to the directory does not give database permission.
>>>>>
>>>>Set up a user in your database. Give that user permission to see the table you want to
>>>>view. Put that users username/password into your connection string.
>>>>>
>>>>--
>>>>Best regards,
>>>>Dave Colliver.
>>>>http://www.AshfieldFOCUS.com
>>>>~~
>>>>http://www.FOCUSPortals.com - Local franchises available
>>>>>
>>>>>
>>>>"Mich" <mi**@nm.dfwrote in message news:OF**************@TK2MSFTNGP02.phx.gbl...
>>>>>Account ASPNET has R/W rights on the APP_Data dir.
>>>>>And if it was not so, i would get an error, but here, no error, nothing happens ...
>>>>>>
>>>>>"David" <da*****************@revilloc.REMOVETHIS.comschree f in bericht
>>>>>news:O8*************@TK2MSFTNGP02.phx.gbl ...
>>>>>>>I notice you ahve integrated security rather than user names and passwords. I may be
>>>>>>>wrong but I think integrated security will require the current user to have permission in
>>>>>>>the database. When you are doing it through VWDev, you are probably carrying your
>>>>>>>username through, but when doing it from ASP.NET, you are using the ASP.NET user account,
>>>>>>>which may not have permission.
>>>>>>>
>>>>>>--
>>>>>>Best regards,
>>>>>>Dave Colliver.
>>>>>>http://www.AshfieldFOCUS.com
>>>>>>~~
>>>>>>http://www.FOCUSPortals.com - Local franchises available
>>>>>>>
>>>>>>>
>>>>>>"Mich" <mi**@nm.dfwrote in message news:Ox****************@TK2MSFTNGP05.phx.gbl...
>>>>>>>Hi Juan, thanks for replying..
>>>>>>>>
>>>>>>>I did this and an mdf file ASPNETDB.MDF was created in the sql server directory.
>>>>>>>So i copied both files (mdf and log) into APP_Data of my application.
>>>>>>>I added a connection string in web.config like this:
>>>>>>> <add name="aspnetdb" connectionString="Data
>>>>>>>Source=.\SQLEXPRESS;AttachDbFilename=|D ataDirectory|\ASPNETDB.MDF;Integrated
>>>>>>>Security=True;User Instance=True" providerName="System.Data.SqlClient"/>
>>>>>>>>
>>>>>>>Now, when starting the aspx page containing the createuserwizard and filling all
>>>>>>>texboxes, again, nothing happens (user is not created). If i try it within VWDev., the
>>>>>>>user is then created.
>>>>>>>What do i forget or do wrong?
>>>>>>>Thanks
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>"Juan T. Llibre" <no***********@nowhere.comschreef in bericht
>>>>>>>news:ut**************@TK2MSFTNGP05.phx. gbl...
>>>>>>>>Run aspnet_regsql.exe from a command window in your .Net Framework 2.0 directory.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>Juan T. Llibre, asp.net MVP
>>>>>>>>asp.net faq : http://asp.net.do/faq/
>>>>>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>>>===================================
>>>>>>>>"Mich" <mi**@nm.dfwrote in message news:Og****************@TK2MSFTNGP03.phx.gbl...
>>>>>>>>>Hi,
>>>>>>>>>>
>>>>>>>>>i'm building an web application for anonymous users. They can take a look in the
>>>>>>>>>website, nothing more. In order to perform other actions, the anonymous user must be
>>>>>>>>>logged. So i create an aspx page with the CreateUserWizard control. The user can fill
>>>>>>>>>his username, password etc ....
>>>>>>>>>>
>>>>>>>>>My problem is: when an user fills everything and clicks on button "create an
>>>>>>>>>account", nothing happens (no error, but no user account created).
>>>>>>>>>I thought asp.net would create in App_Data an ASPNET.MDF file for storing user and
>>>>>>>>>membership information and add automatically a new connection string in web.config.
>>>>>>>>>But it doesn't happen.
>>>>>>>>>>
>>>>>>>>>I know i can go in design mode (n VWD) and click on "administer the site", but all
>>>>>>>>>the users are anonymous, so i can't create user in advance.
>>>>>>>>>Do i have to put some configuration code in web.config? Or something else?
>>>>>>>>>>
>>>>>>>>>Thanks for help
>>>>>>>>>Mich

Apr 10 '07 #16

P: n/a
Hello Juan.

After posting my last rrply to you, i found an article on Google where a guy
said he deleted the login control from the form and recreated it. I tried
that and it worked for me.

I can't explain it but it resolved my problem. Maybe you know why?

Thanks again for all of your help.

Tony

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:%2****************@TK2MSFTNGP04.phx.gbl...
re:
!I unchecked the "Anonymous access" box on the Authentication Methods
screen.

Hi, Tony.

The OP's problem was solved by *allowing* anonymous access,
not by requiring authentication.

When you *uncheck* the anonymous access box, you are -effectively-
*requiring* authentication.

Let's see if we can do a little detective work and find out which account
ASP.NET is running as, so you can assign permissions to the correct
account.

First of all, are you using impersonation ?
Knowing that will make a difference.

Secondly, can you save this page and run it from the root directory of
your app ?

identity.aspx :
--------------------
<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = "ASP.NET is running as the account : " & tmp
End Sub
</script>
<html>
<head>
<title>What account is ASP.NET running as ?</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
---------------------

Whichever account is returned will be the account that needs access
permission
to the App_Data directory and database, if you're using a trusted
connection,
unless you are using a *specific* account to access your membership
database.

Please read through Scott Mitchell's tutorial :

http://aspnet.4guysfromrolla.com/articles/120705-1.aspx

It has invaluable background info which will make your life easier
when trying to implement ASP.NET Membership.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:ex**************@TK2MSFTNGP04.phx.gbl...
>Hello Juan.

I unchecked the "Anonymous access" box on the Authentication Methods
screen. After doing so, nothing changed, so i just figured that it did
not help.

My problem is outlined in the next post down.

Thanks,
Tony

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:e9**************@TK2MSFTNGP04.phx.gbl...
>>re:
Well, changing that security settings didn't help me, but thanks for
all your help.

1. What did you change...and to what ?
2. What happened after you changed it ?
3. Can you restate your problem ? ( Is it different than the OP's
problem ? )


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:eo**************@TK2MSFTNGP06.phx.gbl...
Hello Juan.

Well, changing that security settings didn't help me, but thanks for
all your help.

Tony

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OU**************@TK2MSFTNGP03.phx.gbl...
re:
!Also, after right-clicking and selecting properties, do you mean
the
!"Directory Security" tab, then click "Edit" for the Authentication
Methods screen?
>
Yes, he means that.
>
>
>
Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Tony Girgenti" <tony(nospam)@lakesideos.comwrote in message
news:ek**************@TK2MSFTNGP03.phx.gbl.. .
>Hello Mich.
>>
>I'm sorry for sounding so stupid but i'm not sure about where to go.
>By "Standard website", do you mean "Default Web Site"? I have XP
>Pro, SP1 also.
>>
>Also, after right-clicking and selecting properties, do you mean the
>"Directory Security" tab, then click "Edit" for the Authentication
>Methods screen? I don't see a "Map secutiry".
>>
>Thanks,
>Tony
>>
>"Mich" <mi**@nm.dfwrote in message
>news:OO**************@TK2MSFTNGP06.phx.gbl. ..
>>Yes.
>>>
>>Rightclick on Standard website (maybe diffferent in windows 2003, i
>>use xp prof.), then take properties and then Map security. There you
>>can choose anonymous or win. int. auth.
>>>
>>"Tony Girgenti" <tony(nospam)@lakesideos.comschreef in bericht
>>news:e3*************@TK2MSFTNGP05.phx.gbl. ..
>>>Hello Mich.
>>>>
>>>I'm trying to follow along in this thread beacuse i think i'm
>>>having the same problem.
>>>>
>>>Can you explain where you went to change your "map security"?
>>>>
>>>Is it in the IIS Administration?
>>>>
>>>Any help would be gratefully appreciated.
>>>>
>>>Thanks,
>>>Tony
>>>>
>>>"Mich" <mi**@nm.dfwrote in message
>>>news:eZ****************@TK2MSFTNGP03.phx.gb l...
>>>>David, i did all those things but i found it:
>>>>the map security of the standard website in the IIS was set on
>>>>Windows Integrated Auth.
>>>>The map security of my website (one level lower in the IIS as all
>>>>other websites) is set on Anonymous.
>>>>This is the reason why login and createuserwizard doesn't work.
>>>>I changed the map security of the standard website into Anonymous
>>>>and everything works.
>>>>Amazing, no?
>>>>Do you have an explanation for that?
>>>>>
>>>>>
>>>>"David" <da*****************@revilloc.REMOVETHIS.comschree f in
>>>>bericht news:e%****************@TK2MSFTNGP02.phx.gbl...
>>>>>but what about your database?
>>>>>>
>>>>>just having access to the directory does not give database
>>>>>permission.
>>>>>>
>>>>>Set up a user in your database. Give that user permission to see
>>>>>the table you want to view. Put that users username/password into
>>>>>your connection string.
>>>>>>
>>>>>--
>>>>>Best regards,
>>>>>Dave Colliver.
>>>>>http://www.AshfieldFOCUS.com
>>>>>~~
>>>>>http://www.FOCUSPortals.com - Local franchises available
>>>>>>
>>>>>>
>>>>>"Mich" <mi**@nm.dfwrote in message
>>>>>news:OF**************@TK2MSFTNGP02.phx.gb l...
>>>>>>Account ASPNET has R/W rights on the APP_Data dir.
>>>>>>And if it was not so, i would get an error, but here, no error,
>>>>>>nothing happens ...
>>>>>>>
>>>>>>"David" <da*****************@revilloc.REMOVETHIS.comschree f in
>>>>>>bericht news:O8*************@TK2MSFTNGP02.phx.gbl...
>>>>>>>>I notice you ahve integrated security rather than user names and
>>>>>>>>passwords. I may be wrong but I think integrated security will
>>>>>>>>require the current user to have permission in the database.
>>>>>>>>When you are doing it through VWDev, you are probably carrying
>>>>>>>>your username through, but when doing it from ASP.NET, you are
>>>>>>>>using the ASP.NET user account, which may not have permission.
>>>>>>>>
>>>>>>>--
>>>>>>>Best regards,
>>>>>>>Dave Colliver.
>>>>>>>http://www.AshfieldFOCUS.com
>>>>>>>~~
>>>>>>>http://www.FOCUSPortals.com - Local franchises available
>>>>>>>>
>>>>>>>>
>>>>>>>"Mich" <mi**@nm.dfwrote in message
>>>>>>>news:Ox****************@TK2MSFTNGP05.ph x.gbl...
>>>>>>>>Hi Juan, thanks for replying..
>>>>>>>>>
>>>>>>>>I did this and an mdf file ASPNETDB.MDF was created in the sql
>>>>>>>>server directory.
>>>>>>>>So i copied both files (mdf and log) into APP_Data of my
>>>>>>>>application.
>>>>>>>>I added a connection string in web.config like this:
>>>>>>>> <add name="aspnetdb" connectionString="Data
>>>>>>>>Source=.\SQLEXPRESS;AttachDbFilename=| DataDirectory|\ASPNETDB.MDF;Integrated
>>>>>>>>Security=True;User Instance=True"
>>>>>>>>providerName="System.Data.SqlClient"/>
>>>>>>>>>
>>>>>>>>Now, when starting the aspx page containing the
>>>>>>>>createuserwizard and filling all texboxes, again, nothing
>>>>>>>>happens (user is not created). If i try it within VWDev., the
>>>>>>>>user is then created.
>>>>>>>>What do i forget or do wrong?
>>>>>>>>Thanks
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>"Juan T. Llibre" <no***********@nowhere.comschreef in
>>>>>>>>bericht news:ut**************@TK2MSFTNGP05.phx.gbl...
>>>>>>>>>Run aspnet_regsql.exe from a command window in your .Net
>>>>>>>>>Framework 2.0 directory.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>Juan T. Llibre, asp.net MVP
>>>>>>>>>asp.net faq : http://asp.net.do/faq/
>>>>>>>>>foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>>>>===================================
>>>>>>>>>"Mich" <mi**@nm.dfwrote in message
>>>>>>>>>news:Og****************@TK2MSFTNGP03. phx.gbl...
>>>>>>>>>>Hi,
>>>>>>>>>>>
>>>>>>>>>>i'm building an web application for anonymous users. They
>>>>>>>>>>can take a look in the website, nothing more. In order to
>>>>>>>>>>perform other actions, the anonymous user must be logged. So
>>>>>>>>>>i create an aspx page with the CreateUserWizard control. The
>>>>>>>>>>user can fill his username, password etc ....
>>>>>>>>>>>
>>>>>>>>>>My problem is: when an user fills everything and clicks on
>>>>>>>>>>button "create an account", nothing happens (no error, but
>>>>>>>>>>no user account created).
>>>>>>>>>>I thought asp.net would create in App_Data an ASPNET.MDF
>>>>>>>>>>file for storing user and membership information and add
>>>>>>>>>>automatically a new connection string in web.config. But it
>>>>>>>>>>doesn't happen.
>>>>>>>>>>>
>>>>>>>>>>I know i can go in design mode (n VWD) and click on
>>>>>>>>>>"administer the site", but all the users are anonymous, so i
>>>>>>>>>>can't create user in advance.
>>>>>>>>>>Do i have to put some configuration code in web.config? Or
>>>>>>>>>>something else?
>>>>>>>>>>>
>>>>>>>>>>Thanks for help
>>>>>>>>>>Mich


Apr 10 '07 #17

This discussion thread is closed

Replies have been disabled for this discussion.