471,089 Members | 1,556 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,089 software developers and data experts.

Failed to access IIS metabase.

Hi:

I'm getting this error when I try to browse to a .aspx page that is located
on a virtual directory located on my Win XP Pro machine. There's more text in
the page that is displayed that says "the process account used to run ASP.NET
must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For
information on modifying metabase permissions, please see
http://support.microsoft.com/?kbid=267904"

I tried to execute the steps in that Knowledge Base article. However, when I
try to run "aspnet_regiis -ga aspnet" the command just comes back and
displays all its options (some help text).

Can someone please tell me what I'm doing wrong?

Thanks,

Jibey
Mar 28 '07 #1
2 26720
re:
>when I try to run "aspnet_regiis -ga aspnet"
You have to use a full name :

aspnet_regiis -ga DomainName\AccountName
....if you're using a domain account

or
aspnet_regiis -ga MachineName\AccountName
....if you're using a local account

Try :

aspnet_regiis -ga MachineName\ASPNET if you're running Windows XP.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Jibey Jacob" <Ji********@discussions.microsoft.comwrote in message
news:5B**********************************@microsof t.com...
Hi:

I'm getting this error when I try to browse to a .aspx page that is located
on a virtual directory located on my Win XP Pro machine. There's more text in
the page that is displayed that says "the process account used to run ASP.NET
must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For
information on modifying metabase permissions, please see
http://support.microsoft.com/?kbid=267904"

I tried to execute the steps in that Knowledge Base article. However, when I
try to run "aspnet_regiis -ga aspnet" the command just comes back and
displays all its options (some help text).

Can someone please tell me what I'm doing wrong?

Thanks,

Jibey

Mar 28 '07 #2
Well, depending on your OS, the Metabase is in
C:\WINDOWS\system32\inetsrv

Aside from reinstalling IIS and the framework you can try right-clicking on
the folder and granting read permission to the ASPNET account. Sounds like
you've hosed something.
Peter

--
Site: http://www.eggheadcafe.com
UnBlog: http://petesbloggerama.blogspot.com
Short urls & more: http://ittyurl.net


"Jibey Jacob" wrote:
Hi:

I'm getting this error when I try to browse to a .aspx page that is located
on a virtual directory located on my Win XP Pro machine. There's more text in
the page that is displayed that says "the process account used to run ASP.NET
must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For
information on modifying metabase permissions, please see
http://support.microsoft.com/?kbid=267904"

I tried to execute the steps in that Knowledge Base article. However, when I
try to run "aspnet_regiis -ga aspnet" the command just comes back and
displays all its options (some help text).

Can someone please tell me what I'm doing wrong?

Thanks,

Jibey
Mar 28 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by David | last post: by
3 posts views Thread by Microsoft | last post: by
5 posts views Thread by David Veeneman | last post: by
reply views Thread by Will Holley | last post: by
2 posts views Thread by Kivak Wolf | last post: by
2 posts views Thread by John | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.