By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,921 Members | 1,321 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,921 IT Pros & Developers. It's quick & easy.

Is the aspnet account called "aspnet" for all non-English versions of Windows and IIS?

P: n/a
Is the aspnet account called "aspnet" for all non-English versions of
Windows and IIS?

Mar 21 '07 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Yes, for Windows XP in all languages.

For Windows 2003 Server, the aspnet account is "network service".

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<to***@tpg.com.auwrote in message news:11*********************@y80g2000hsf.googlegro ups.com...
Is the aspnet account called "aspnet" for all non-English versions of
Windows and IIS?

Mar 22 '07 #2

P: n/a
On Mar 22, 11:17 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
Yes, for Windows XP in all languages.

For Windows 2003 Server, the aspnet account is "network service".

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
===================================

<t...@tpg.com.auwrote in messagenews:11*********************@y80g2000hsf.go oglegroups.com...
Is the aspnet account called "aspnet" for all non-English versions of
Windows and IIS?- Hide quoted text -

- Show quoted text -
Thanks for the response, Juan.

I am actually more confused than when I started, since the "Network
Service" account does not appear in the list of users configured on my
Win2003 Server (ie under Computer Management -Local Users and Groups
-Users). However, "Network Service" does appear in IIS's Application
Pool Identity dialog.

The reason for my post is that I have a web service. I need to deny
access to the "Users" group to enforce that web service users belong
to a group specific to my application. However I have found that if I
do not add the "aspnet" user, the web service will not operate. I need
to perform all configuration from an install script, and it must work
on English and international versions of Windows XP and Windows 2003.
Ideally the "aspnet" user would have a well-known SID, but it does not
appear to have one, hence the need to look up the SID using the
account name.

Mar 22 '07 #3

P: n/a
to***@tpg.com.au wrote:
On Mar 22, 11:17 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
>Yes, for Windows XP in all languages.

For Windows 2003 Server, the aspnet account is "network service".

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
===================================

<t...@tpg.com.auwrote in messagenews:11*********************@y80g2000hsf.go oglegroups.com...
>>Is the aspnet account called "aspnet" for all non-English versions of
Windows and IIS?- Hide quoted text -
- Show quoted text -

Thanks for the response, Juan.

I am actually more confused than when I started, since the "Network
Service" account does not appear in the list of users configured on my
Win2003 Server (ie under Computer Management -Local Users and Groups
-Users). However, "Network Service" does appear in IIS's Application
Pool Identity dialog.
The user name of the account is IIS_WPG.
The reason for my post is that I have a web service. I need to deny
access to the "Users" group to enforce that web service users belong
to a group specific to my application. However I have found that if I
do not add the "aspnet" user, the web service will not operate. I need
to perform all configuration from an install script, and it must work
on English and international versions of Windows XP and Windows 2003.
Ideally the "aspnet" user would have a well-known SID, but it does not
appear to have one, hence the need to look up the SID using the
account name.

--
Göran Andersson
_____
http://www.guffa.com
Mar 22 '07 #4

P: n/a
re:
!the "Network Service" account does not appear in the
!list of users configured on my Win2003 Server

That's because it's a local account.

re:
hence the need to look up the SID using the account name
You can do it manually, so you must be able to do it programmatically.

Manually, if you right-click the directory where your web service resides; select "Properties";
select the "Security" tab; click the "Add" button; click the "Advanced" button; and, finally,
click the "Find now" button, you'll see the "Network Service" account listed.

Double-click it, and it will be added to the list of accounts which can access
the directory. You must OK your way out of the dialogs, of course.

You can also write in the name after you click the "Add" button
and the Network Service account will be located and added.

Have you tried adding the Network Service account, even if it's not listed ?

Don't forget to give the Network Service account read/write permissions for the temp directory, too.
Webservices require permission to that directory.

See:
http://support.microsoft.com/default.aspx/kb/823196

You'll find more information at:
http://support.microsoft.com/kb/315736/EN-US/

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<to***@tpg.com.auwrote in message news:11**********************@p15g2000hsd.googlegr oups.com...
On Mar 22, 11:17 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
Yes, for Windows XP in all languages.

For Windows 2003 Server, the aspnet account is "network service".

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
===================================
<t...@tpg.com.auwrote in messagenews:11*********************@y80g2000hsf.go oglegroups.com...
Is the aspnet account called "aspnet" for all non-English versions of
Windows and IIS?- Hide quoted text -

- Show quoted text -
Thanks for the response, Juan.

I am actually more confused than when I started, since the "Network
Service" account does not appear in the list of users configured on my
Win2003 Server (ie under Computer Management -Local Users and Groups
-Users). However, "Network Service" does appear in IIS's Application
Pool Identity dialog.

The reason for my post is that I have a web service. I need to deny
access to the "Users" group to enforce that web service users belong
to a group specific to my application. However I have found that if I
do not add the "aspnet" user, the web service will not operate. I need
to perform all configuration from an install script, and it must work
on English and international versions of Windows XP and Windows 2003.
Ideally the "aspnet" user would have a well-known SID, but it does not
appear to have one, hence the need to look up the SID using the
account name.
Mar 22 '07 #5

P: n/a
re:
The user name of the account is IIS_WPG.
"Network Service" and "IIS_WPG" are different accounts.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Göran Andersson" <gu***@guffa.comwrote in message news:%2***************@TK2MSFTNGP06.phx.gbl...
to***@tpg.com.au wrote:
>On Mar 22, 11:17 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
>>Yes, for Windows XP in all languages.

For Windows 2003 Server, the aspnet account is "network service".

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
===================================
>><t...@tpg.com.auwrote in messagenews:11*********************@y80g2000hsf.go oglegroups.com...
Is the aspnet account called "aspnet" for all non-English versions of
Windows and IIS?- Hide quoted text -
- Show quoted text -

Thanks for the response, Juan.

I am actually more confused than when I started, since the "Network
Service" account does not appear in the list of users configured on my
Win2003 Server (ie under Computer Management -Local Users and Groups
-Users). However, "Network Service" does appear in IIS's Application
Pool Identity dialog.

The user name of the account is IIS_WPG.
>The reason for my post is that I have a web service. I need to deny
access to the "Users" group to enforce that web service users belong
to a group specific to my application. However I have found that if I
do not add the "aspnet" user, the web service will not operate. I need
to perform all configuration from an install script, and it must work
on English and international versions of Windows XP and Windows 2003.
Ideally the "aspnet" user would have a well-known SID, but it does not
appear to have one, hence the need to look up the SID using the
account name.


--
Göran Andersson
_____
http://www.guffa.com

Mar 22 '07 #6

P: n/a
On Mar 22, 10:33 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!the "Network Service" account does not appear in the
!list of users configured on my Win2003 Server

That's because it's a local account.

re:
hence the need to look up the SID using the account name

You can do it manually, so you must be able to do it programmatically.

Manually, if you right-click the directory where your web service resides; select "Properties";
select the "Security" tab; click the "Add" button; click the "Advanced" button; and, finally,
click the "Find now" button, you'll see the "Network Service" account listed.

Double-click it, and it will be added to the list of accounts which can access
the directory. You must OK your way out of the dialogs, of course.

You can also write in the name after you click the "Add" button
and the Network Service account will be located and added.

Have you tried adding the Network Service account, even if it's not listed ?

Don't forget to give the Network Service account read/write permissions for the temp directory, too.
Webservices require permission to that directory.

See:http://support.microsoft.com/default.aspx/kb/823196

You'll find more information at:http://support.microsoft.com/kb/315736/EN-US/

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
===================================<t...@tpg.com.a uwrote in messagenews:11**********************@p15g2000hsd.g ooglegroups.com...

On Mar 22, 11:17 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
Yes, for Windows XP in all languages.
For Windows 2003 Server, the aspnet account is "network service".
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
===================================
<t...@tpg.com.auwrote in messagenews:11*********************@y80g2000hsf.go oglegroups.com...
Is the aspnet account called "aspnet" for all non-English versions of
Windows and IIS?- Hide quoted text -
- Show quoted text -

Thanks for the response, Juan.

I am actually more confused than when I started, since the "Network
Service" account does not appear in the list of users configured on my
Win2003 Server (ie under Computer Management -Local Users and Groups
-Users). However, "Network Service" does appear in IIS's Application
Pool Identity dialog.

The reason for my post is that I have a web service. I need to deny
access to the "Users" group to enforce that web service users belong
to a group specific to my application. However I have found that if I
do not add the "aspnet" user, the web service will not operate. I need
to perform all configuration from an install script, and it must work
on English and international versions of Windows XP and Windows 2003.
Ideally the "aspnet" user would have a well-known SID, but it does not
appear to have one, hence the need to look up the SID using the
account name.
Thanks Juan,

I have modified my scripts to allow access to both "Network Service"
and ASPNET users, and have tested this on both WinXP and Win2003. My
web services work correctly. I suspect the "Network Service" user is
not called "Network Service" in all languages. This does not matter
since I used the well-known SID to reference this user rather than its
name.
Mar 23 '07 #7

P: n/a
re:
!I have modified my scripts to allow access to both "Network Service"
!and ASPNET users, and have tested this on both WinXP and Win2003.
!My web services work correctly.

Good news!

Glad to know you're up and running...


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
<to***@tpg.com.auwrote in message news:11**********************@l77g2000hsb.googlegr oups.com...
On Mar 22, 10:33 pm, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!the "Network Service" account does not appear in the
!list of users configured on my Win2003 Server

That's because it's a local account.

re:
hence the need to look up the SID using the account name

You can do it manually, so you must be able to do it programmatically.

Manually, if you right-click the directory where your web service resides; select "Properties";
select the "Security" tab; click the "Add" button; click the "Advanced" button; and, finally,
click the "Find now" button, you'll see the "Network Service" account listed.

Double-click it, and it will be added to the list of accounts which can access
the directory. You must OK your way out of the dialogs, of course.

You can also write in the name after you click the "Add" button
and the Network Service account will be located and added.

Have you tried adding the Network Service account, even if it's not listed ?

Don't forget to give the Network Service account read/write permissions for the temp directory,
too.
Webservices require permission to that directory.

See: http://support.microsoft.com/default.aspx/kb/823196

You'll find more information at: http://support.microsoft.com/kb/315736/EN-US/

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
===================================<t...@tpg.com.a uwrote in
messagenews:11**********************@p15g2000hsd.g ooglegroups.com...

On Mar 22, 11:17 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
Yes, for Windows XP in all languages.
For Windows 2003 Server, the aspnet account is "network service".
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
===================================
<t...@tpg.com.auwrote in messagenews:11*********************@y80g2000hsf.go oglegroups.com...
Is the aspnet account called "aspnet" for all non-English versions of
Windows and IIS?- Hide quoted text -
- Show quoted text -

Thanks for the response, Juan.

I am actually more confused than when I started, since the "Network
Service" account does not appear in the list of users configured on my
Win2003 Server (ie under Computer Management -Local Users and Groups
-Users). However, "Network Service" does appear in IIS's Application
Pool Identity dialog.

The reason for my post is that I have a web service. I need to deny
access to the "Users" group to enforce that web service users belong
to a group specific to my application. However I have found that if I
do not add the "aspnet" user, the web service will not operate. I need
to perform all configuration from an install script, and it must work
on English and international versions of Windows XP and Windows 2003.
Ideally the "aspnet" user would have a well-known SID, but it does not
appear to have one, hence the need to look up the SID using the
account name.
Thanks Juan,

I have modified my scripts to allow access to both "Network Service"
and ASPNET users, and have tested this on both WinXP and Win2003. My
web services work correctly. I suspect the "Network Service" user is
not called "Network Service" in all languages. This does not matter
since I used the well-known SID to reference this user rather than its
name.

Mar 23 '07 #8

This discussion thread is closed

Replies have been disabled for this discussion.