By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,722 Members | 1,350 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,722 IT Pros & Developers. It's quick & easy.

Session_start not firing in production server

P: n/a
Hello All,

I'm having a problem with global.asax file. The session_start method of
globals.asax.vb is not firing in my project when I copy the files to a
production server. It works OK in my development machine, which has VS2005
on Windows XP SP2.
The production server is a Windows 2000 Server SP4. (Almost a fresh install,
only with .NET FWK 2.0).
I configured a new site in IIS5. Then I compiled the application in the
development machine and copied ALL the files (including the /bin folder) to
the server.

I've checked the global.asax file by putting a breakpoint in the
session_start method and it get hit while debugging (always in MY comp).

Then I removed all the code for testing purposes and left only this:
Sub Session_Start(ByVal sender as object, ByVal e as EventArgs)
Throw New Exception("HEEEELLLOOOOOOO")
End Sub

The server doesn't stop at the exception, so no code is being called. (I
didn't use Diagnostics.EventLog since I had security permissions to
configure and this was a bit quicker to test)

My question is, are there any changes that need to be made in order for this
to work?
I tried these already:
. Changing the compile options of the global.asax (the default is
"Content", and I used "Embedded resource", then changed it back since it
didn't solve my problem).
. Restarting IIS after running
"%windir%\Microsoft.NET\Framework\v2.0.50727\aspne t_regiis.exe -i"
Any suggestions are welcome.
Thanks
__________________
Alejandro

+ Info: The development machine has also "Microsoft visual studio 2005 Web
Application Projects" installed.
Feb 1 '07 #1
Share this Question
Share on Google+
6 Replies


P: n/a
On Feb 1, 4:00 pm, "Alex" <alek...@hotmail.comwrote:
>
I've checked the global.asax file by putting a breakpoint in the
session_start method and it get hit while debugging (always in MY comp).

Sorry didn't get it, how do you debug remote server?

Feb 1 '07 #2

P: n/a
No no... I didn't debug the remote server... I debug in my development
computer. I did that just to be sure that the method was being called (at
least locally).

Now, I found something weird... if I move the Session_Start code from
global.asax.vb to Global.asax, enclosing it with the <scripttags like
this:
<script runat="server">
Sub Session_Start (....
....
End Sub
</script>

Then the method IS called. I don't know why this is behaving like the old
ASP way. Why does global.asax have a code behind file if it not being used?
"Alexey Smirnov" <al************@gmail.comescribió en el mensaje
news:11**********************@h3g2000cwc.googlegro ups.com...
On Feb 1, 4:00 pm, "Alex" <alek...@hotmail.comwrote:
>>
I've checked the global.asax file by putting a breakpoint in the
session_start method and it get hit while debugging (always in MY comp).


Sorry didn't get it, how do you debug remote server?

Feb 1 '07 #3

P: n/a
In order Global.asax to work you must create an application.
In IIS Managment console right click on your folder and you will see
"Create" next to "Application Name"

On your develoment machine VS does it automaticly when you creating project

George.

"Alex" <al*****@hotmail.comwrote in message
news:u5**************@TK2MSFTNGP03.phx.gbl...
Hello All,

I'm having a problem with global.asax file. The session_start method of
globals.asax.vb is not firing in my project when I copy the files to a
production server. It works OK in my development machine, which has VS2005
on Windows XP SP2.
The production server is a Windows 2000 Server SP4. (Almost a fresh
install, only with .NET FWK 2.0).
I configured a new site in IIS5. Then I compiled the application in the
development machine and copied ALL the files (including the /bin folder)
to the server.

I've checked the global.asax file by putting a breakpoint in the
session_start method and it get hit while debugging (always in MY comp).

Then I removed all the code for testing purposes and left only this:
Sub Session_Start(ByVal sender as object, ByVal e as EventArgs)
Throw New Exception("HEEEELLLOOOOOOO")
End Sub

The server doesn't stop at the exception, so no code is being called. (I
didn't use Diagnostics.EventLog since I had security permissions to
configure and this was a bit quicker to test)

My question is, are there any changes that need to be made in order for
this to work?
I tried these already:
. Changing the compile options of the global.asax (the default is
"Content", and I used "Embedded resource", then changed it back since it
didn't solve my problem).
. Restarting IIS after running
"%windir%\Microsoft.NET\Framework\v2.0.50727\aspne t_regiis.exe -i"
Any suggestions are welcome.
Thanks
__________________
Alejandro

+ Info: The development machine has also "Microsoft visual studio 2005 Web
Application Projects" installed.

Feb 1 '07 #4

P: n/a
Thanks for the tip, but I forgot to mention that I already made an
application in IIS, so that's not the source of the problem... =(

In order Global.asax to work you must create an application.
In IIS Managment console right click on your folder and you will see
"Create" next to "Application Name"

On your develoment machine VS does it automaticly when you creating
project

George.

"Alex" <al*****@hotmail.comwrote in message
news:u5**************@TK2MSFTNGP03.phx.gbl...
>Hello All,

I'm having a problem with global.asax file. The session_start method of
globals.asax.vb is not firing in my project when I copy the files to a
production server. It works OK in my development machine, which has
VS2005 on Windows XP SP2.
The production server is a Windows 2000 Server SP4. (Almost a fresh
install, only with .NET FWK 2.0).
I configured a new site in IIS5. Then I compiled the application in the
development machine and copied ALL the files (including the /bin folder)
to the server.

I've checked the global.asax file by putting a breakpoint in the
session_start method and it get hit while debugging (always in MY comp).

Then I removed all the code for testing purposes and left only this:
Sub Session_Start(ByVal sender as object, ByVal e as EventArgs)
Throw New Exception("HEEEELLLOOOOOOO")
End Sub

The server doesn't stop at the exception, so no code is being called. (I
didn't use Diagnostics.EventLog since I had security permissions to
configure and this was a bit quicker to test)

My question is, are there any changes that need to be made in order for
this to work?
I tried these already:
. Changing the compile options of the global.asax (the default is
"Content", and I used "Embedded resource", then changed it back since it
didn't solve my problem).
. Restarting IIS after running
"%windir%\Microsoft.NET\Framework\v2.0.50727\aspn et_regiis.exe -i"
Any suggestions are welcome.
Thanks
__________________
Alejandro

+ Info: The development machine has also "Microsoft visual studio 2005
Web Application Projects" installed.


Feb 1 '07 #5

P: n/a
I believe what may be happening here is that you have a Web Site project
instead of a Web Application Project. In the web site project model, you will
probably need to put your global.asax.vb file in the APP_CODE folder.
Peter

--
Site: http://www.eggheadcafe.com
UnBlog: http://petesbloggerama.blogspot.com
Short urls & more: http://ittyurl.net


"Alex" wrote:
Thanks for the tip, but I forgot to mention that I already made an
application in IIS, so that's not the source of the problem... =(

In order Global.asax to work you must create an application.
In IIS Managment console right click on your folder and you will see
"Create" next to "Application Name"

On your develoment machine VS does it automaticly when you creating
project

George.

"Alex" <al*****@hotmail.comwrote in message
news:u5**************@TK2MSFTNGP03.phx.gbl...
Hello All,

I'm having a problem with global.asax file. The session_start method of
globals.asax.vb is not firing in my project when I copy the files to a
production server. It works OK in my development machine, which has
VS2005 on Windows XP SP2.
The production server is a Windows 2000 Server SP4. (Almost a fresh
install, only with .NET FWK 2.0).
I configured a new site in IIS5. Then I compiled the application in the
development machine and copied ALL the files (including the /bin folder)
to the server.

I've checked the global.asax file by putting a breakpoint in the
session_start method and it get hit while debugging (always in MY comp).

Then I removed all the code for testing purposes and left only this:
Sub Session_Start(ByVal sender as object, ByVal e as EventArgs)
Throw New Exception("HEEEELLLOOOOOOO")
End Sub

The server doesn't stop at the exception, so no code is being called. (I
didn't use Diagnostics.EventLog since I had security permissions to
configure and this was a bit quicker to test)

My question is, are there any changes that need to be made in order for
this to work?
I tried these already:
. Changing the compile options of the global.asax (the default is
"Content", and I used "Embedded resource", then changed it back since it
didn't solve my problem).
. Restarting IIS after running
"%windir%\Microsoft.NET\Framework\v2.0.50727\aspne t_regiis.exe -i"
Any suggestions are welcome.
Thanks
__________________
Alejandro

+ Info: The development machine has also "Microsoft visual studio 2005
Web Application Projects" installed.


Feb 1 '07 #6

P: n/a
No, I created a Web Application Project. Besides, the strange thing is that
the same files work perfect in my development computer, but not in the
server.
That's the reason I think there might be something regarding IIS which
doesn't work with my app in the server.
Thanks for the tip anyway

"Peter Bromberg [C# MVP]" <pb*******@yahoo.yabbadabbadoo.comescribió en el
mensaje news:EB**********************************@microsof t.com...
>I believe what may be happening here is that you have a Web Site project
instead of a Web Application Project. In the web site project model, you
will
probably need to put your global.asax.vb file in the APP_CODE folder.
Peter

--
Site: http://www.eggheadcafe.com
UnBlog: http://petesbloggerama.blogspot.com
Short urls & more: http://ittyurl.net


"Alex" wrote:
>Thanks for the tip, but I forgot to mention that I already made an
application in IIS, so that's not the source of the problem... =(

In order Global.asax to work you must create an application.
In IIS Managment console right click on your folder and you will see
"Create" next to "Application Name"

On your develoment machine VS does it automaticly when you creating
project

George.

"Alex" <al*****@hotmail.comwrote in message
news:u5**************@TK2MSFTNGP03.phx.gbl...
Hello All,

I'm having a problem with global.asax file. The session_start method
of
globals.asax.vb is not firing in my project when I copy the files to a
production server. It works OK in my development machine, which has
VS2005 on Windows XP SP2.
The production server is a Windows 2000 Server SP4. (Almost a fresh
install, only with .NET FWK 2.0).
I configured a new site in IIS5. Then I compiled the application in
the
development machine and copied ALL the files (including the /bin
folder)
to the server.

I've checked the global.asax file by putting a breakpoint in the
session_start method and it get hit while debugging (always in MY
comp).

Then I removed all the code for testing purposes and left only this:
Sub Session_Start(ByVal sender as object, ByVal e as EventArgs)
Throw New Exception("HEEEELLLOOOOOOO")
End Sub

The server doesn't stop at the exception, so no code is being called.
(I
didn't use Diagnostics.EventLog since I had security permissions to
configure and this was a bit quicker to test)

My question is, are there any changes that need to be made in order
for
this to work?
I tried these already:
. Changing the compile options of the global.asax (the default is
"Content", and I used "Embedded resource", then changed it back since
it
didn't solve my problem).
. Restarting IIS after running
"%windir%\Microsoft.NET\Framework\v2.0.50727\aspn et_regiis.exe -i"
Any suggestions are welcome.
Thanks
__________________
Alejandro

+ Info: The development machine has also "Microsoft visual studio 2005
Web Application Projects" installed.



Feb 2 '07 #7

This discussion thread is closed

Replies have been disabled for this discussion.