468,103 Members | 1,225 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,103 developers. It's quick & easy.

Unable to start debugging on the webserver

This is happening on a WinXP Pro SP2 machine with Visual Studio 2005 & local
IIS as the debugger. Everything was working fine this morning (and had been
working for weeks/months prior). After a trip to windows update (where I
installed IE 7, .NET 3.0, VS 2005 SP1 and misc updates for XP such as
timezone changes & a new sound driver) I can no longer debug my web app on
IIS. I now receive this message:

"Unable to start debugging on the web server. The web server is not
configured correctly. See help for common configuration errors. Running the
web page outside of the debugger may provide further information."

I can visit the website without debugging directly at http://localhost/ in
IE 7 (or FireFox 2.0) and the website functions 100% as expected, no errors.
I have not changed any of the authentication methods for the website in IIS.
Windows Authentication is enabled. IIS shows framework version 2.0 on the
ASP.NET property tab of the website (as it always did) and the website code
itself is still referencing objects from the 2.0 framework (no change).
debug="true" in web.config (no change), VS 2005 still references a custom
webserver url of http://localhost/ (no change). I cannot figure out what
has changed but obviously something very critical has in fact changed.

It was not getting this error message this morning before the updates. Any
ideas?
Feb 1 '07 #1
3 2937
the problem is caused by installing ie 7.0

try adding localhost to the trusted sites, or upgrade to vista (the only
enviroment i use ie 7.0).

-- bruce (sqlwork.com)
1388-2/HB wrote:
This is happening on a WinXP Pro SP2 machine with Visual Studio 2005 & local
IIS as the debugger. Everything was working fine this morning (and had been
working for weeks/months prior). After a trip to windows update (where I
installed IE 7, .NET 3.0, VS 2005 SP1 and misc updates for XP such as
timezone changes & a new sound driver) I can no longer debug my web app on
IIS. I now receive this message:

"Unable to start debugging on the web server. The web server is not
configured correctly. See help for common configuration errors. Running the
web page outside of the debugger may provide further information."

I can visit the website without debugging directly at http://localhost/ in
IE 7 (or FireFox 2.0) and the website functions 100% as expected, no errors.
I have not changed any of the authentication methods for the website in IIS.
Windows Authentication is enabled. IIS shows framework version 2.0 on the
ASP.NET property tab of the website (as it always did) and the website code
itself is still referencing objects from the 2.0 framework (no change).
debug="true" in web.config (no change), VS 2005 still references a custom
webserver url of http://localhost/ (no change). I cannot figure out what
has changed but obviously something very critical has in fact changed.

It was not getting this error message this morning before the updates. Any
ideas?

Feb 1 '07 #2
After putting localhost in different zones (trusted, intranet) to no
success, I simply uninstalled IE 7.

I'm still getting the error when I try to debug the website. Was I wrong to
install the VS 2005 SP1 upgrade on an XP Pro / IIS5 machine, is it meant for
Vista / IIS 7 machines?

This certainly isn't helping me meet any project deadlines, that's for sure.

"bruce barker" <no****@nospam.comwrote in message
news:uv**************@TK2MSFTNGP04.phx.gbl...
the problem is caused by installing ie 7.0

try adding localhost to the trusted sites, or upgrade to vista (the only
enviroment i use ie 7.0).

-- bruce (sqlwork.com)

Feb 1 '07 #3
Ok this doesn't make much sense, but it's reproduceable and it fixes the
problem so who am I to argue. Turns out it doesn't have anything to do with
localhost being in a low security zone, I think it has something to do with
VS 2005's ability to attach to the aspnet worker process.

This error is indeed caused by installing IE 7. Studying the behavior on my
workstation, I can in fact get IE 7, VS 2005 and IIS 5.1 to all play nice
together, but only if VS 2005 is installed *after* IE 7 is installed. From
this I can only assume something in the IE 7 installation is modifying
something that VS 2005 needs in order to attach to the aspnet worker
process, because this is where it seems to be failing when it fails. And
whatever that modification is that IE 7 makes, the IE 7 uninstaller does not
"undo" it; meaning once IE 7 is installed, VS 2005's ability to debug on IIS
is "broken" thereafter.

But if I reinstall (or repair) VS 2005, this "fixes" whatever IE 7 "breaks".
So I can in fact install IE 7 and use it while debugging, so long as VS 2005
is installed or repaired "on top of" IE 7.

On my machine I can consistantly "break" VS 2005 / IIS web debugging by
re-installing IE 7, and in turn "fix" it by re-installing VS 2005. I never
touch IIS or modify IE 7's security settings, just install the programs in a
different order is all.

Installed VS 2005 SP1 & updates for IE 7 and everything's fine now.

"1388-2/HB" <1@1.netwrote in message
news:A2*******************@newssvr25.news.prodigy. net...
After putting localhost in different zones (trusted, intranet) to no
success, I simply uninstalled IE 7.

I'm still getting the error when I try to debug the website. Was I wrong
to install the VS 2005 SP1 upgrade on an XP Pro / IIS5 machine, is it
meant for Vista / IIS 7 machines?

This certainly isn't helping me meet any project deadlines, that's for
sure.

"bruce barker" <no****@nospam.comwrote in message
news:uv**************@TK2MSFTNGP04.phx.gbl...
>the problem is caused by installing ie 7.0

try adding localhost to the trusted sites, or upgrade to vista (the only
enviroment i use ie 7.0).

-- bruce (sqlwork.com)



Feb 5 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Andrew | last post: by
16 posts views Thread by Serdar Kalaycý | last post: by
1 post views Thread by Michael Turner | last post: by
1 post views Thread by Solo | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.