By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,244 Members | 1,772 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,244 IT Pros & Developers. It's quick & easy.

Timeout makes report fail

P: n/a
If setting
<sessionState mode="InProc" cookieless="true" timeout="60" />
in the webconfig, makes a report (in a ReportViewer) fail with a
session timeout.

If removing the timeout from webconfig, the report is shown without
error.

Any ideas?
--
http://www.dbconsult.dk
http://www.vinthervej2.dk [private]
Jan 31 '07 #1
Share this Question
Share on Google+
2 Replies


P: n/a
I've seen cases where you can actually set a value to be too large, causing
things to cancel early. You may try setting it to 20, which would be the
default anyway, and going up from there. Can you tell if the application is
also closing out as well or just the session? I'm wondering if the
application itself is closing down after 20 minutes of inactivity, which is
the normal for an application.
--

Hope this helps,
Mark Fitzpatrick
Former Microsoft FrontPage MVP 199?-2006

"Morten Snedker" <morten_spammenot_ATdbconsult.dkwrote in message
news:r6********************************@4ax.com...
If setting
<sessionState mode="InProc" cookieless="true" timeout="60" />
in the webconfig, makes a report (in a ReportViewer) fail with a
session timeout.

If removing the timeout from webconfig, the report is shown without
error.

Any ideas?
--
http://www.dbconsult.dk
http://www.vinthervej2.dk [private]

Jan 31 '07 #2

P: n/a
On Wed, 31 Jan 2007 07:57:05 -0600, "Mark Fitzpatrick"
<ma******@fitzme.comwrote:

I'm not sure what you mean by "application closing". The browser
application stays alive at all times. I've made no special closing
events.

I've set the timeout in webconfig and a 1 hour javascript timer client
side. That's it.

I've started moving the report to a crystal report, but I find it an
awkwad solution to the problem.

60 minutes timeout is a minimum. Users a experiencing problems with
not making it when entering data. And I'd like to keep it cookieless.

Thanks for your response!

/Snedker

>I've seen cases where you can actually set a value to be too large, causing
things to cancel early. You may try setting it to 20, which would be the
default anyway, and going up from there. Can you tell if the application is
also closing out as well or just the session? I'm wondering if the
application itself is closing down after 20 minutes of inactivity, which is
the normal for an application.
Feb 1 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.