468,242 Members | 1,638 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,242 developers. It's quick & easy.

not working: <customErrors mode="Off"/>

I made the above change to my web.config file so that errors would be
reported from a remote site as explained in the Server Error:
Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrorstag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrorstag should then have its "mode" attribute
set to "Off".

OK, this had no effect. I verifed the change to web.config did take place.

I can publish my project to my own localhost IIs, to another system
running its own XP IIS.

I can even publish a FP2003 (non- aspx) app to the server that has the
problem and it runs fine. I cannot get an error message from the server
indicating the problem. I am publishing using local file as in
\\servername\acqlib and attempting to run page using
http://servername/acqlib/default.aspx

OK - to make a long story short, I got the administrator to run the page
while logged onto the system and it gave an error at:
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

This indicates the server is not running dotnet 2.0 Admin is looking into
installing dotnet 2.0 on the server.

My question: Why didnt that error message show up where I could figure out
the problem myself?


--
================================================== =====================
Joseph "Beemer Biker" Stateson
http://ResearchRiders.org Ask about my 99'R1100RT
================================================== =====================
Jan 24 '07 #1
2 2591
The way it works, unless I am very much mistaken, is that the server side
code throws an exception, which you catch and deal with on your client.

Since your code could not even run - because .NET 2.0 is not present, it
would not be possible even to load the assembly, never mind create and throw
an exception.

That's my best guess anyway.
Peter
"Beemer Biker" <js*******@swri.eduwrote in message
news:12*************@corp.supernews.com...
>I made the above change to my web.config file so that errors would be
reported from a remote site as explained in the Server Error:
Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrorstag within a
"web.config" configuration file located in the root directory of the
current web application. This <customErrorstag should then have its
"mode" attribute set to "Off".

OK, this had no effect. I verifed the change to web.config did take
place.

I can publish my project to my own localhost IIs, to another system
running its own XP IIS.

I can even publish a FP2003 (non- aspx) app to the server that has the
problem and it runs fine. I cannot get an error message from the server
indicating the problem. I am publishing using local file as in
\\servername\acqlib and attempting to run page using
http://servername/acqlib/default.aspx

OK - to make a long story short, I got the administrator to run the page
while logged onto the system and it gave an error at:
<configuration
xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

This indicates the server is not running dotnet 2.0 Admin is looking into
installing dotnet 2.0 on the server.

My question: Why didnt that error message show up where I could figure
out the problem myself?


--
================================================== =====================
Joseph "Beemer Biker" Stateson
http://ResearchRiders.org Ask about my 99'R1100RT
================================================== =====================


Jan 24 '07 #2
well if the error is parsing the config file, then you can turn error
reporting on with the web config.

-- bruce (sqlwork.com)

Beemer Biker wrote:
I made the above change to my web.config file so that errors would be
reported from a remote site as explained in the Server Error:
Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrorstag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrorstag should then have its "mode" attribute
set to "Off".

OK, this had no effect. I verifed the change to web.config did take place.

I can publish my project to my own localhost IIs, to another system
running its own XP IIS.

I can even publish a FP2003 (non- aspx) app to the server that has the
problem and it runs fine. I cannot get an error message from the server
indicating the problem. I am publishing using local file as in
\\servername\acqlib and attempting to run page using
http://servername/acqlib/default.aspx

OK - to make a long story short, I got the administrator to run the page
while logged onto the system and it gave an error at:
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">

This indicates the server is not running dotnet 2.0 Admin is looking into
installing dotnet 2.0 on the server.

My question: Why didnt that error message show up where I could figure out
the problem myself?

Jan 24 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Han | last post: by
2 posts views Thread by Mary Kerrigan | last post: by
1 post views Thread by Menno Abbink | last post: by
1 post views Thread by Savas Ates | last post: by
5 posts views Thread by Savas Ates | last post: by
3 posts views Thread by =?Utf-8?B?bmt3?= | last post: by
reply views Thread by kermitthefrogpy | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.