By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,222 Members | 1,437 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,222 IT Pros & Developers. It's quick & easy.

Problem with Login Control and Custom Membership provider

P: n/a
Hello:

I have custom Membership and Role providers for an ASP.NET application,
the problem comes when the Authentication gets done ( and i'm using the
Login control, it finished properly ) but looks like the user is not
really logged in ( Verified using the LoginView control )

What could be the possible reasons for that problem ??

Thanks in advance !!!

P.S.: My web.config file for authenticaction and autorization looks like
this:

<!--
The <authenticationsection enables configuration
of the security authentication mode used by
ASP.NET to identify an incoming user.
-->
<authentication mode="Forms">
<forms loginUrl="Renovacion.aspx"
protection="All"
timeout="30"
name=".ASPXFORMSAUTH"
path="/FormsAuth"
requireSSL="false"
slidingExpiration="true"
defaultUrl="Acceso.aspx"
cookieless="UseCookies"
enableCrossAppRedirects="false"/>
</authentication>

<membership
defaultProvider="MembershipProvider"
userIsOnlineTimeWindow="15">
<providers>
<add
connectionStringName="ConnectionString"
applicationName="XXX"
minRequiredPasswordLength="5"
minRequiredNonalphanumericCharacters="0"
enablePasswordRetrieval="true"
passwordFormat="Clear"
name="MembershipProvider"
type="XXX.XXXMembershipProvider"
/>
</providers>
</membership>

<roleManager
enabled="true"
cacheRolesInCookie="true"
defaultProvider="RoleProvider"
cookieName=".ASPXROLES"
cookiePath="/"
cookieTimeout="30"
cookieRequireSSL="false"
cookieSlidingExpiration="true"
createPersistentCookie="false"
cookieProtection="All">

<providers>
<clear />
<add
connectionStringName="ConnectionString"
applicationName="CaixanovaRenovacion"
writeExceptionsToEventLog="false"
name="XXX"
type="XXX.XXXRenovacionRoleProvider"
/>
</providers>
</roleManager>

<authorization>
<allow users="*"/>
</authorization>
Jan 22 '07 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Hello:

Got it working yet, thanks !!!
Jan 22 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.