By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,515 Members | 1,339 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,515 IT Pros & Developers. It's quick & easy.

Error when publishing asp.net web

P: n/a
JC
Hi, I have a simple web application and It works well in my local computer..
When i upload it to my web server i get this error:
Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrorstag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrorstag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrorsconfiguration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
I already made the changes, the Bin folder and Web.config are under the /
but still get the same error... any ideas about whats going on. The server
is a Windows 2000 with .Net Framework 1.1
Thank you in advance for your help.
JC
Dec 19 '06 #1
Share this Question
Share on Google+
5 Replies


P: n/a
bpd
Typically, the application needs created under IIS.
-Run IIS.
-Find the folder/application - most likely under Default Web Site.
-Right click on the folder/application.
-Click on the create button.

JC wrote:
Hi, I have a simple web application and It works well in my local computer..
When i upload it to my web server i get this error:
Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrorstag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrorstag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrorsconfiguration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
I already made the changes, the Bin folder and Web.config are under the /
but still get the same error... any ideas about whats going on. The server
is a Windows 2000 with .Net Framework 1.1
Thank you in advance for your help.
JC
Dec 19 '06 #2

P: n/a
JC
Already did that and didn`t work, still getting the error message.
Thanks, JC

"bpd" <br*********@rollcoater.comescribió en el mensaje
news:11**********************@f1g2000cwa.googlegro ups.com...
Typically, the application needs created under IIS.
-Run IIS.
-Find the folder/application - most likely under Default Web Site.
-Right click on the folder/application.
-Click on the create button.

JC wrote:
>Hi, I have a simple web application and It works well in my local
computer..
When i upload it to my web server i get this error:
Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current
custom
error settings for this application prevent the details of the
application
error from being viewed remotely (for security reasons). It could,
however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable
on remote machines, please create a <customErrorstag within a
"web.config"
configuration file located in the root directory of the current web
application. This <customErrorstag should then have its "mode"
attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the
application's
<customErrorsconfiguration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"
defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
I already made the changes, the Bin folder and Web.config are under the /
but still get the same error... any ideas about whats going on. The
server
is a Windows 2000 with .Net Framework 1.1
Thank you in advance for your help.
JC

Dec 19 '06 #3

P: n/a
JC,

You say that the server is Windows 2000 with .Net 1.1, I take it that
the web site is also .Net 1.1? Sorry for the obvious question but you
don't mention this in your post.

Also are you able to get access to the server itself? Can you run the
application from the server, i.e. log on to the server and run a IE.
This will give you the real error message.

Steve

Dec 19 '06 #4

P: n/a
JC
Thank you Stephen. I already solved the problem.
The NT filesystem security was preventing the
application hosting ASP.NET from reading the ASP.NET pages. If you're
running
under W2K then the DACLs need to allow the local ASPNET account read access.

By design, in Microsoft Windows 2000 and in Microsoft Windows XP, ASP.NET
requires read, execute, and list access for the ASPNET account (the
Aspnet_wp.exe process account) on the root Web site or on any virtual
directory. Similarly, in Microsoft Windows Server 2003, ASP.NET requires
read, execute, and list access for the NETWORK SERVICE account (the W3wp.exe
process account) on the root Web site or on any virtual directory. This is
necessary so that ASP.NET can access the content files and can monitor file
changes.

RESOLUTION
To add read, execute, and list access for the ASPNET account on the root Web
site or on any virtual directory, follow these steps: 1. In Windows
Explorer, browse to the folder that contains the root Web site (which is
C:\Inetpub\Wwwroot by default) or the virtual directory.
2. Right-click the folder, and then click Properties.
3. On the Security tab, click Add.
4. Type ComputerName\ASPNET (for example, on a computer named Webdev,
type Webdev\ASPNET), and then click OK.
5. Allow the following permissions for the ASPNET account: . Read &
Execute
. List Folder Contents
. Read

6. Click OK to close the Properties dialog box and to save the
changes.
JC
If it's W2K3 then it's the Network Service account that requires read
access.
"Jester98x" <st**********@wdr.co.ukescribió en el mensaje
news:11*********************@f1g2000cwa.googlegrou ps.com...
JC,

You say that the server is Windows 2000 with .Net 1.1, I take it that
the web site is also .Net 1.1? Sorry for the obvious question but you
don't mention this in your post.

Also are you able to get access to the server itself? Can you run the
application from the server, i.e. log on to the server and run a IE.
This will give you the real error message.

Steve

Dec 20 '06 #5

P: n/a
JC,

Glad to hear you got it working.

Steve

Dec 20 '06 #6

This discussion thread is closed

Replies have been disabled for this discussion.