By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,824 Members | 1,213 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,824 IT Pros & Developers. It's quick & easy.

Creating a simple Windows Service .. can't find it??

P: n/a
Seems like I followed all steps but I can't find my service in the
service manager??

f:\windowsservice\EmptyService\EmptyService\bin\De bug>InstallUtil
EmptyS
ervice.exe
Microsoft (R) .NET Framework Installation utility Version 2.0.50727.42
Copyright (c) Microsoft Corporation. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
f:\windowsservice\EmptyService\
EmptyService\bin\Debug\EmptyService.exe assembly's progress.
The file is located at
f:\windowsservice\EmptyService\EmptyService\bin\D
ebug\EmptyService.InstallLog.
Installing assembly
'f:\windowsservice\EmptyService\EmptyService\bin\D eb
ug\EmptyService.exe'.
Affected parameters are:
logtoconsole =
assemblypath =
f:\windowsservice\EmptyService\EmptyService\bin\De bug\
EmptyService.exe
logfile =
f:\windowsservice\EmptyService\EmptyService\bin\De bug\Empty
Service.InstallLog

The Install phase completed successfully, and the Commit phase is
beginning.
See the contents of the log file for the
f:\windowsservice\EmptyService\
EmptyService\bin\Debug\EmptyService.exe assembly's progress.
The file is located at
f:\windowsservice\EmptyService\EmptyService\bin\D
ebug\EmptyService.InstallLog.
Committing assembly
'f:\windowsservice\EmptyService\EmptyService\bin\D eb
ug\EmptyService.exe'.
Affected parameters are:
logtoconsole =
assemblypath =
f:\windowsservice\EmptyService\EmptyService\bin\De bug\
EmptyService.exe
logfile =
f:\windowsservice\EmptyService\EmptyService\bin\De bug\Empty
Service.InstallLog

The Commit phase completed successfully.

The transacted install has completed.

f:\windowsservice\EmptyService\EmptyService\bin\De bug>

After I do this I get a popup window that says
Cannot start service from the command line or debugger.

The event log says:
Service cannot be started. The service process could not connect to the
service controller

Something strange in is when My Project, Start up object is set to
"Service1" which is NOT the name of my class or the service.. it's
should be EmptyService I think, but I can't seem to change this.

Also, when I right click on the installerproject, what should I enter
for CustomTool and CustomToolnamespace? I entered Emptyservice for
both.

I noticed when I click on add installer project again, it says service
name is empty, too long or has invalid characters.

Thanks for any help or information.

Nov 24 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
The service name needs to be set in the installer class.

Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com


"jobs" wrote:
Seems like I followed all steps but I can't find my service in the
service manager??

f:\windowsservice\EmptyService\EmptyService\bin\De bug>InstallUtil
EmptyS
ervice.exe
Microsoft (R) .NET Framework Installation utility Version 2.0.50727.42
Copyright (c) Microsoft Corporation. All rights reserved.
Running a transacted installation.

Beginning the Install phase of the installation.
See the contents of the log file for the
f:\windowsservice\EmptyService\
EmptyService\bin\Debug\EmptyService.exe assembly's progress.
The file is located at
f:\windowsservice\EmptyService\EmptyService\bin\D
ebug\EmptyService.InstallLog.
Installing assembly
'f:\windowsservice\EmptyService\EmptyService\bin\D eb
ug\EmptyService.exe'.
Affected parameters are:
logtoconsole =
assemblypath =
f:\windowsservice\EmptyService\EmptyService\bin\De bug\
EmptyService.exe
logfile =
f:\windowsservice\EmptyService\EmptyService\bin\De bug\Empty
Service.InstallLog

The Install phase completed successfully, and the Commit phase is
beginning.
See the contents of the log file for the
f:\windowsservice\EmptyService\
EmptyService\bin\Debug\EmptyService.exe assembly's progress.
The file is located at
f:\windowsservice\EmptyService\EmptyService\bin\D
ebug\EmptyService.InstallLog.
Committing assembly
'f:\windowsservice\EmptyService\EmptyService\bin\D eb
ug\EmptyService.exe'.
Affected parameters are:
logtoconsole =
assemblypath =
f:\windowsservice\EmptyService\EmptyService\bin\De bug\
EmptyService.exe
logfile =
f:\windowsservice\EmptyService\EmptyService\bin\De bug\Empty
Service.InstallLog

The Commit phase completed successfully.

The transacted install has completed.

f:\windowsservice\EmptyService\EmptyService\bin\De bug>

After I do this I get a popup window that says
Cannot start service from the command line or debugger.

The event log says:
Service cannot be started. The service process could not connect to the
service controller

Something strange in is when My Project, Start up object is set to
"Service1" which is NOT the name of my class or the service.. it's
should be EmptyService I think, but I can't seem to change this.

Also, when I right click on the installerproject, what should I enter
for CustomTool and CustomToolnamespace? I entered Emptyservice for
both.

I noticed when I click on add installer project again, it says service
name is empty, too long or has invalid characters.

Thanks for any help or information.

Nov 25 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.