By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,836 Members | 2,023 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,836 IT Pros & Developers. It's quick & easy.

Aspx is reading bad web.config

P: n/a
Hello!

On my server I have Sharepoint portal server as default web site
I create there a web application folder with form.aspx file.
When I'm trying to run aspx, i get an error.
Page is trying to read config from x:\inetpub\wwwroot\web.config.
Correct path is x:\inetpub\wwwroot\test\web.config.

How to force on application (or IIS or whatever) to use correct config?
Nov 22 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
the web.config file needs to be in the root of the web app. remove the
web.config under the inetpub\wwwroot. Why is that there anyway? I have
sharepoint portal on my box and the web.config is under the sharepoint
wwwroot\sharepoint folder
and that is also my default web site on my web server.

"marek zegarek" wrote:
Hello!

On my server I have Sharepoint portal server as default web site
I create there a web application folder with form.aspx file.
When I'm trying to run aspx, i get an error.
Page is trying to read config from x:\inetpub\wwwroot\web.config.
Correct path is x:\inetpub\wwwroot\test\web.config.

How to force on application (or IIS or whatever) to use correct config?
Nov 22 '06 #2

P: n/a
web.config is in root directory of web application.I cannot remove second
(from inetpub/wwwroot), because it is Sharepoint config. File is there,
because probably you install Sharepoint not on default web site
(wwwroot\sharepoint).

Anyone have any idea?
Użytkownik "igotyourdotnet" <ig************@nospam.nospamnapisał w
wiadomo¶ci news:81**********************************@microsof t.com...
the web.config file needs to be in the root of the web app. remove the
web.config under the inetpub\wwwroot. Why is that there anyway? I have
sharepoint portal on my box and the web.config is under the sharepoint
wwwroot\sharepoint folder
and that is also my default web site on my web server.

"marek zegarek" wrote:
>Hello!

On my server I have Sharepoint portal server as default web site
I create there a web application folder with form.aspx file.
When I'm trying to run aspx, i get an error.
Page is trying to read config from x:\inetpub\wwwroot\web.config.
Correct path is x:\inetpub\wwwroot\test\web.config.

How to force on application (or IIS or whatever) to use correct config?

Nov 23 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.