471,595 Members | 1,538 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,595 software developers and data experts.

URGENT: AJAX November CTP deployment problem

Hi,

I've just installed Ajax November CTP, changed app according to instructions
and I am (was) satisfied. Next step - deployment to server.

I'm receiving error:
--------------------------------------------------
Message......: Request for ConfigurationPermission failed while attempting
to access configuration section 'system.web/deployment'. To allow all
callers to access the data for this section, set section attribute
'requirePermission' equal 'false' in the configuration file where this
section is declared.

Source.......: System.Configuration

Stack trace....: at
System.Configuration.BaseConfigurationRecord.Check PermissionAllowed(String
configKey, Boolean requirePermission, Boolean isTrustedWithoutAptca) at
System.Configuration.BaseConfigurationRecord.GetSe ctionRecursive(String
configKey, Boolean getLkg, Boolean checkPermission, Boolean
getRuntimeObject, Boolean requestIsHere, Object& result, Object&
resultRuntimeObject) at
System.Configuration.BaseConfigurationRecord.GetSe ction(String configKey,
Boolean getLkg, Boolean checkPermission) at
System.Configuration.BaseConfigurationRecord.GetSe ction(String configKey) at
System.Web.Configuration.WebConfigurationManager.G etSection(String
sectionName) at
Microsoft.Web.UI.ScriptManager.GetDeploymentSectio nWithAssert() at
Microsoft.Web.UI.ScriptReference.IsDebuggingEnable d(ScriptManager
scriptManager) at
Microsoft.Web.UI.ScriptReference.ShouldUseDebugScr ipt(String releaseName,
Assembly assembly, ScriptManager scriptManager) at
Microsoft.Web.UI.ScriptReference.GetResourceName(S tring releaseName,
Assembly assembly, ScriptManager scriptManager) at
Microsoft.Web.UI.ScriptReference.GetUrlFromName(Sc riptManager scriptManager,
IControl scriptManagerControl, Boolean zip) at
Microsoft.Web.UI.ScriptReference.GetUrl(ScriptMana ger scriptManager,
IControl scriptManagerControl, Boolean zip) at
Microsoft.Web.UI.ScriptManager.RegisterScripts() at
Microsoft.Web.UI.ScriptManager.OnPreRender(EventAr gs e) at
System.Web.UI.Control.PreRenderRecursiveInternal() at
System.Web.UI.Control.PreRenderRecursiveInternal() at
System.Web.UI.Control.PreRenderRecursiveInternal() at
System.Web.UI.Control.PreRenderRecursiveInternal() at
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint,
Boolean includeStagesAfterAsyncPoint)

Inner exception: System.Security.SecurityException: Request for the
permission of type 'System.Configuration.ConfigurationPermission,
System.Configuration, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a' failed. at
System.Security.CodeAccessSecurityEngine.Check(Obj ect demand,
StackCrawlMark& stackMark, Boolean isPermSet) at
System.Security.CodeAccessPermission.Demand() at
System.Configuration.BaseConfigurationRecord.Check PermissionAllowed(String
configKey, Boolean requirePermission, Boolean isTrustedWithoutAptca) The
action that failed was: Demand The type of the first permission that failed
was: System.Configuration.ConfigurationPermission The Zone of the assembly
that failed was: MyComputer

Base exception.: Request for the permission of type
'System.Configuration.ConfigurationPermission, System.Configuration,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' failed.
---------------------------------------------------
I created new web app just to check have I done something wrong but I'm
still receiving error.

I cannot find useful info on web.

HELP! What shell I do now?

It looks like configuration problem so I believe my ISP will be willing to
do some tuning.

Thanks in advance,
Jevta
Nov 18 '06 #1
3 2973
Try removing "trust level="Medium" from your web.config. It worked on my computer ;-)

greetz Geert
Nov 28 '06 #2
mc
Geert van Raaij wrote:
Try removing "trust level="Medium" from your web.config. It worked on my computer ;-)

greetz Geert
I don't think that is a workable solution to this problem, Microsoft
have recently recommended that Shared hosts configure the servers at a
machine.config level to only support medium trust level sites.

I'm with brinkster, who have just applied this patch/config update after
identifying a security hole in the existing configuration. It is causing
significant problems to a large number of the hosts users.
MC
Nov 28 '06 #3
thanks Geert,

I've already tried that. No success. Moreover, I cannot override trust
level - lack of permissions.

MS wrote in specification that this version of Ajax's dll must be in GAC. I
asked my ISP to install it but they have policy "no custom products on
server because requests may be endless".

Therefore, I removed Atlas.

<Geert van Raaijwrote in message
news:%2****************@TK2MSFTNGP04.phx.gbl...
Try removing "trust level="Medium" from your web.config. It worked on my
computer ;-)

greetz Geert

Nov 29 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by =?Utf-8?B?UmljaCBBcm1zdHJvbmc=?= | last post: by
2 posts views Thread by =?Utf-8?B?UmljaCBBcm1zdHJvbmc=?= | last post: by
7 posts views Thread by =?Utf-8?B?V2FubmFiZQ==?= | last post: by
reply views Thread by XIAOLAOHU | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.