By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,550 Members | 1,733 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,550 IT Pros & Developers. It's quick & easy.

Reason: Not associated with a trusted SQL Server connection.

P: n/a
I posted this in another newsgroup but haven't received the answer, so
I am trying my luck here as well.

My database is running on a seperate machine and my connection string
is
"user id=cc;data source=Custom;initial catalog=Dev;password=cc". I
backed and restored the database on my local machine and changed the
connection string to this: "user id=cc;data source=(local);initial
catalog=Dev;password=cc".

But now when I run my asp.net application, I get this error:
Login failed for user 'cc'. Reason: Not associated with a trusted SQL
Server connection.
Can somebody please tell me what I need to do?
thanks

Nov 11 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Is the new box's Sql Server using Integrated Windows authentication ?

If it is, you'll have to change it to use both Windows and SQL Server authentication,
if you want SQL server users who are not Windows accounts to have access.

You could also create a"cc" user in the Windows box (and not change the authentication method).
I prefer to use SQL Server authentication, instead of Windows authentication, though.

To change the authentication mewthod, open the Enterprise Manager,
highlight your server, right-click and select "Properties".

Then, open the Security tab.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"Sehboo" <Ma*********@gmail.comwrote in message
news:11**********************@i42g2000cwa.googlegr oups.com...
>I posted this in another newsgroup but haven't received the answer, so
I am trying my luck here as well.

My database is running on a seperate machine and my connection string
is
"user id=cc;data source=Custom;initial catalog=Dev;password=cc". I
backed and restored the database on my local machine and changed the
connection string to this: "user id=cc;data source=(local);initial
catalog=Dev;password=cc".

But now when I run my asp.net application, I get this error:
Login failed for user 'cc'. Reason: Not associated with a trusted SQL
Server connection.
Can somebody please tell me what I need to do?
thanks

Nov 11 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Browse more ASP.NET Questions on Bytes