By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,509 Members | 1,194 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,509 IT Pros & Developers. It's quick & easy.

.Net 2.0 website is running on a different port?

P: n/a
TS
i just noticed the website i created in VS 2005 is running on a different
port than the default. I see that it is running on the local web server, and
also that the website i created isn't in IIS.

My crystal report looks weird because it is trying to show images from the
crystalreportviewers10 virtual directory based on the current website
running, which in this case is localhost:1169, but actuall the
crystalreportviewers10 virtual directory is off of just localhost.

What can I do in this situation to make my images to appear?

Can i change it to use port 80 and will it work?

thanks
Nov 6 '06 #1
Share this Question
Share on Google+
10 Replies


P: n/a
V
As far as I know, in VS 2005, the website projects are run on an
in-built web server and do not go to IIS till they are "Published".

I am not sure if you can send it to IIS while still developing it, I
guess you can keep publishing every so often to view it, its pretty
fast process. But I have a feeling that you can make some changes (by
downloading and installing some add-on to VS 2005 from MS) that will
allow you to do website development in VS2005 in VS2003 style. Try
googling for it (sorry, I couldn't be more specific).

Regards,
V

On Nov 7, 12:33 am, "TS" <manofstee...@nospam.nospamwrote:
i just noticed the website i created in VS 2005 is running on a different
port than the default. I see that it is running on the local web server, and
also that the website i created isn't in IIS.

My crystal report looks weird because it is trying to show images from the
crystalreportviewers10 virtual directory based on the current website
running, which in this case is localhost:1169, but actuall the
crystalreportviewers10 virtual directory is off of just localhost.

What can I do in this situation to make my images to appear?

Can i change it to use port 80 and will it work?

thanks
Nov 6 '06 #2

P: n/a
re:
Can i change it to use port 80 and will it work?

To specify the Web server for a Web site, open your local website and,
in the Solution Explorer, right-click the name of the Web site for which you
want to specify a Web server, and then click Property Pages.
In the Property Pages dialog box, click the Start Options tab.
Under Server, click Use custom server.
In the Base URL box, type the URL that Visual Web Developer / VS 2005
should start when running the current Web site. You can use localhost.
From that point on, the VS.NET IDE will not use the internal web server,
but will use IIS to open your pages, i.e., if you are working on default.aspx,
it will be opened as : http://localhost/default.aspx

That will use port 80 by default

That should get rid of *all* your URL referencing
problems without requiring workarounds.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================

"TS" <ma**********@nospam.nospamwrote in message news:OL****************@TK2MSFTNGP03.phx.gbl...
>i just noticed the website i created in VS 2005 is running on a different port than the default. I
see that it is running on the local web server, and also that the website i created isn't in IIS.

My crystal report looks weird because it is trying to show images from the crystalreportviewers10
virtual directory based on the current website running, which in this case is localhost:1169, but
actuall the crystalreportviewers10 virtual directory is off of just localhost.

What can I do in this situation to make my images to appear?

Can i change it to use port 80 and will it work?

thanks

Nov 6 '06 #3

P: n/a
Hi,

TS wrote:
i just noticed the website i created in VS 2005 is running on a different
port than the default. I see that it is running on the local web server, and
also that the website i created isn't in IIS.

My crystal report looks weird because it is trying to show images from the
crystalreportviewers10 virtual directory based on the current website
running, which in this case is localhost:1169, but actuall the
crystalreportviewers10 virtual directory is off of just localhost.

What can I do in this situation to make my images to appear?

Can i change it to use port 80 and will it work?

thanks
Studio 2005 comes with an integrated web server, which is used only
during development time. The web address becomes
http://localhost:<port>/<web application>. This is only for convenience,
to make development easier. If you require your application to run on
IIS also during development, you can use the project properties, tab
"Web" to select IIS as your server.

HTH,
Laurent
--
Laurent Bugnion, GalaSoft
Software engineering: http://www.galasoft-LB.ch
Private/Malaysia: http://mypage.bluewin.ch/lbugnion
Support children in Calcutta: http://www.calcutta-espoir.ch
Nov 6 '06 #4

P: n/a
TS
thanks, but when i set it to Http://localhost, it won't start in the
debugger and when i start without debugging, it doesn't find the site. i
guess i'd probably somehow do a publish which would publish my site to
IIS??? then it would work?

is it more efficient to run the site using the local dev server?

thanks

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OS**************@TK2MSFTNGP04.phx.gbl...
re:
>Can i change it to use port 80 and will it work?


To specify the Web server for a Web site, open your local website and,
in the Solution Explorer, right-click the name of the Web site for which
you
want to specify a Web server, and then click Property Pages.
In the Property Pages dialog box, click the Start Options tab.
Under Server, click Use custom server.
In the Base URL box, type the URL that Visual Web Developer / VS 2005
should start when running the current Web site. You can use localhost.
From that point on, the VS.NET IDE will not use the internal web server,
but will use IIS to open your pages, i.e., if you are working on
default.aspx,
it will be opened as : http://localhost/default.aspx

That will use port 80 by default

That should get rid of *all* your URL referencing
problems without requiring workarounds.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================

"TS" <ma**********@nospam.nospamwrote in message
news:OL****************@TK2MSFTNGP03.phx.gbl...
>>i just noticed the website i created in VS 2005 is running on a different
port than the default. I see that it is running on the local web server,
and also that the website i created isn't in IIS.

My crystal report looks weird because it is trying to show images from
the crystalreportviewers10 virtual directory based on the current website
running, which in this case is localhost:1169, but actuall the
crystalreportviewers10 virtual directory is off of just localhost.

What can I do in this situation to make my images to appear?

Can i change it to use port 80 and will it work?

thanks


Nov 6 '06 #5

P: n/a
Are you working from a subdirectory ?

If so, you should set the URL to http://localhost/yoursubdir/

You might also want to check Scott Guthrie's tip on running
a Root “/” Site with the VS/VWD 2005 Local Web Server :

http://weblogs.asp.net/scottgu/archi...21/431138.aspx


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"TS" <ma**********@nospam.nospamwrote in message news:O5**************@TK2MSFTNGP03.phx.gbl...
thanks, but when i set it to Http://localhost, it won't start in the debugger and when i start
without debugging, it doesn't find the site. i guess i'd probably somehow do a publish which would
publish my site to IIS??? then it would work?

is it more efficient to run the site using the local dev server?

thanks

"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:OS**************@TK2MSFTNGP04.phx.gbl...
>re:
>>Can i change it to use port 80 and will it work?


To specify the Web server for a Web site, open your local website and,
in the Solution Explorer, right-click the name of the Web site for which you
want to specify a Web server, and then click Property Pages.
In the Property Pages dialog box, click the Start Options tab.
Under Server, click Use custom server.
In the Base URL box, type the URL that Visual Web Developer / VS 2005
should start when running the current Web site. You can use localhost.
From that point on, the VS.NET IDE will not use the internal web server,
but will use IIS to open your pages, i.e., if you are working on default.aspx,
it will be opened as : http://localhost/default.aspx

That will use port 80 by default

That should get rid of *all* your URL referencing
problems without requiring workarounds.

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================

"TS" <ma**********@nospam.nospamwrote in message
news:OL****************@TK2MSFTNGP03.phx.gbl...
>>>i just noticed the website i created in VS 2005 is running on a different port than the default.
I see that it is running on the local web server, and also that the website i created isn't in
IIS.

My crystal report looks weird because it is trying to show images from the
crystalreportviewers10 virtual directory based on the current website running, which in this
case is localhost:1169, but actuall the crystalreportviewers10 virtual directory is off of just
localhost.

What can I do in this situation to make my images to appear?

Can i change it to use port 80 and will it work?

thanks



Nov 6 '06 #6

P: n/a
Hello TS,

As for the ASP.NET 2.0 web projects, you can create it through both IIS
hosted mode or TestServer(WebDev.WebServer.exe) mode. When using the
TestServer, it can only be accessed locally and VS IDE will assign the test
server instance a random local port by default, you can change this port.
If you want to develop the ASP.NET application in IIS directly, just simply
choose "http" when you create the web project and select the proper virtual
directory in IIS.

From your description, after you use "http"/IIS to create the web project
in VS 2005, you can not debug or even run(without debug) the application,
correct? If so, I think there may has some problem with the IIS server's
configuration. Have you checked the server to see whether the Application's
virtual directory has been configured to ASPNET 2.0 version and whether the
application pool(if use IIS6) is configured to the current service account(
BY default it is network service for IIS6, you can also change it to local
system for test). If you want to use F5 debugging in VS 2005, you need
make sure the website is configured as "Integrated windows" authentication.
In addition, as for the problem you met when running the web project in
IIS without debugging, would you provide us the detailed error message or
screenshot of the problem?

BTW, if you think use testserver ok, and just want to change it to listen
on 80 port, you can change the TEstServer's port in VS IDE by the following
steps:

*open website project(filesystem based) in VS 2005

*In solution explorer, select the web site project node

*In the property view/window, you will find there is a "Port number"
property and a "Use dynamic ports" property under "Develper Web Server"
category.

*Set "use dynamic ports" to false

*change the "Port number" to 80 as you want

Before start running, make sure you need to stop the IIS default site or
any other application or service which is already listening on the 80 TCP
port.

Hope this helps.
Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead

This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 7 '06 #7

P: n/a
My approach to creating websites in VS 2005 is to first create a virtual
directory in IIS on my local computer, make it an application, and to then
open that from Visual Studio and begin creating the pages. When I debug,
then, the debugging is done via IIS.

To publish the web to a remote server, I add a web deployment project (an
add-on to Visual studio from Microsoft) to the project. I then build the
project and copy the files in the web deployment project subfolder of the
project folder to the remote server.

That is what works for me.

"V" <va*************@gmail.comwrote in message
news:11**********************@f16g2000cwb.googlegr oups.com...
As far as I know, in VS 2005, the website projects are run on an
in-built web server and do not go to IIS till they are "Published".

I am not sure if you can send it to IIS while still developing it, I
guess you can keep publishing every so often to view it, its pretty
fast process. But I have a feeling that you can make some changes (by
downloading and installing some add-on to VS 2005 from MS) that will
allow you to do website development in VS2005 in VS2003 style. Try
googling for it (sorry, I couldn't be more specific).

Regards,
V

On Nov 7, 12:33 am, "TS" <manofstee...@nospam.nospamwrote:
>i just noticed the website i created in VS 2005 is running on a different
port than the default. I see that it is running on the local web server,
and
also that the website i created isn't in IIS.

My crystal report looks weird because it is trying to show images from
the
crystalreportviewers10 virtual directory based on the current website
running, which in this case is localhost:1169, but actuall the
crystalreportviewers10 virtual directory is off of just localhost.

What can I do in this situation to make my images to appear?

Can i change it to use port 80 and will it work?

thanks

Nov 7 '06 #8

P: n/a
TS
how do i move my website and solution from the test server to IIS so i can
continue developing thru IIS and so my website can be accessed from other
computers?

thanks

"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
news:Ts**************@TK2MSFTNGXA01.phx.gbl...
Hello TS,

As for the ASP.NET 2.0 web projects, you can create it through both IIS
hosted mode or TestServer(WebDev.WebServer.exe) mode. When using the
TestServer, it can only be accessed locally and VS IDE will assign the
test
server instance a random local port by default, you can change this port.
If you want to develop the ASP.NET application in IIS directly, just
simply
choose "http" when you create the web project and select the proper
virtual
directory in IIS.

From your description, after you use "http"/IIS to create the web project
in VS 2005, you can not debug or even run(without debug) the application,
correct? If so, I think there may has some problem with the IIS server's
configuration. Have you checked the server to see whether the
Application's
virtual directory has been configured to ASPNET 2.0 version and whether
the
application pool(if use IIS6) is configured to the current service
account(
BY default it is network service for IIS6, you can also change it to local
system for test). If you want to use F5 debugging in VS 2005, you need
make sure the website is configured as "Integrated windows"
authentication.
In addition, as for the problem you met when running the web project in
IIS without debugging, would you provide us the detailed error message or
screenshot of the problem?

BTW, if you think use testserver ok, and just want to change it to listen
on 80 port, you can change the TEstServer's port in VS IDE by the
following
steps:

*open website project(filesystem based) in VS 2005

*In solution explorer, select the web site project node

*In the property view/window, you will find there is a "Port number"
property and a "Use dynamic ports" property under "Develper Web Server"
category.

*Set "use dynamic ports" to false

*change the "Port number" to 80 as you want

Before start running, make sure you need to stop the IIS default site or
any other application or service which is already listening on the 80 TCP
port.

Hope this helps.
Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead

This posting is provided "AS IS" with no warranties, and confers no
rights.

Nov 9 '06 #9

P: n/a
Publish it.

The server won't care if the app was running through a different port in development.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
===================================
"TS" <ma**********@nospam.nospamwrote in message news:el**************@TK2MSFTNGP04.phx.gbl...
how do i move my website and solution from the test server to IIS so i can continue developing
thru IIS and so my website can be accessed from other computers?

thanks

"Steven Cheng[MSFT]" <st*****@online.microsoft.comwrote in message
news:Ts**************@TK2MSFTNGXA01.phx.gbl...
>Hello TS,

As for the ASP.NET 2.0 web projects, you can create it through both IIS
hosted mode or TestServer(WebDev.WebServer.exe) mode. When using the
TestServer, it can only be accessed locally and VS IDE will assign the test
server instance a random local port by default, you can change this port.
If you want to develop the ASP.NET application in IIS directly, just simply
choose "http" when you create the web project and select the proper virtual
directory in IIS.

From your description, after you use "http"/IIS to create the web project
in VS 2005, you can not debug or even run(without debug) the application,
correct? If so, I think there may has some problem with the IIS server's
configuration. Have you checked the server to see whether the Application's
virtual directory has been configured to ASPNET 2.0 version and whether the
application pool(if use IIS6) is configured to the current service account(
BY default it is network service for IIS6, you can also change it to local
system for test). If you want to use F5 debugging in VS 2005, you need
make sure the website is configured as "Integrated windows" authentication.
In addition, as for the problem you met when running the web project in
IIS without debugging, would you provide us the detailed error message or
screenshot of the problem?

BTW, if you think use testserver ok, and just want to change it to listen
on 80 port, you can change the TEstServer's port in VS IDE by the following
steps:

*open website project(filesystem based) in VS 2005

*In solution explorer, select the web site project node

*In the property view/window, you will find there is a "Port number"
property and a "Use dynamic ports" property under "Develper Web Server"
category.

*Set "use dynamic ports" to false

*change the "Port number" to 80 as you want

Before start running, make sure you need to stop the IIS default site or
any other application or service which is already listening on the 80 TCP
port.

Hope this helps.
Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead

This posting is provided "AS IS" with no warranties, and confers no rights.


Nov 9 '06 #10

P: n/a

Hello TS,

If you want both running and developing your ASP.NET application in IIS,
you can do it through the following approaches:
1. manually create a virtual directory (configured as application) and set
proper ASP.NET version and copy your original web site project folder's
content into that virtual directory.
After that, you can use VS 2005 to open it from IIS and develop upon it.

2. Use the VS IDE's copy site (WebSite --->copy Website... menu item) to
copy the current website project to a remote or local IIS or FTP server

You can choose either one as you like. I mostly use direct xcopy approach
since it is quite straight and simple.
Sincerely,

Steven Cheng

Microsoft MSDN Online Support Lead

This posting is provided "AS IS" with no warranties, and confers no rights.

Nov 10 '06 #11

This discussion thread is closed

Replies have been disabled for this discussion.